]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- rel. 3, /to build with gcc 3.2-7/
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment
2 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
3 Name:           gnome-panel
4 Version:        2.0.9
5 Release:        3
6 License:        LGPL
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/GNOME/2.0.1/sources/%{name}/%{name}-%{version}.tar.bz2
9 Patch0:         %{name}-clock-C_omf.patch
10 URL:            http://www.gnome.org/
11 BuildRequires:  ORBit2-devel >= 2.4.3
12 BuildRequires:  glib2-devel >= 2.0.6
13 BuildRequires:  gnome-desktop-devel >= 2.0.8
14 BuildRequires:  gtk-doc
15 BuildRequires:  gtk+2-devel >= 2.0.6
16 BuildRequires:  intltool >= 0.22
17 BuildRequires:  libglade2-devel >= 2.0.1
18 BuildRequires:  libgnomeui-devel >= 2.0.5
19 BuildRequires:  libwnck-devel >= 0.17
20 BuildRequires:  pkgconfig >= 0.12.0
21 BuildRequires:  scrollkeeper >= 0.3.11
22 Requires(post,postun): scrollkeeper
23 Requires(post,postun): /sbin/ldconfig
24 Requires(post): GConf2
25 Requires:       gnome-desktop >= 2.0.8
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _prefix         /usr/X11R6
29 %define         _mandir         %{_prefix}/man
30 %define         _sysconfdir     /etc/X11/GNOME2
31 %define         _gtkdocdir      %{_defaultdocdir}/gtk-doc/html
32 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
33
34 %description
35 GNOME (GNU Network Object Model Environment) is a user-friendly set of
36 applications and desktop tools to be used in conjunction with a window
37 manager for the X Window System. GNOME is similar in purpose and scope
38 to CDE and KDE, but GNOME is based completely on free software.
39
40 The GNOME panel packages provides the gnome panel, menus and some
41 basic applets for the panel.
42
43 %description -l pl
44 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
45 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
46 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
47 ca³kowicie na wolnym oprogramowaniu.
48
49 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
50 panelu GNOME2.
51
52 %package devel
53 Summary:        GNOME panel includes, and more
54 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
55 Group:          X11/Development/Libraries
56 Requires:       %{name} = %{version}
57 Requires:       gtk-doc-common
58
59 %description devel
60 Panel header files for creating GNOME panels.
61
62 %description devel -l pl
63 Pliki nag³ówkowe bibliotek panelu GNOME.
64
65 %package static
66 Summary:        GNOME panel static libraries
67 Summary(pl):    Statyczne biblioteki panelu GNOME
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-devel
70
71 %description static
72 Panel static libraries.
73
74 %description static -l pl
75 Statyczne biblioteki panelu GNOME.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80
81 %build
82 intltoolize --copy --force
83 %{__libtoolize}
84 glib-gettextize --copy --force
85 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --enable-gtk-doc \
90         --with-html-path=%{_gtkdocdir}
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT \
99         omf_dest_dir=%{_omf_dest_dir}/%{name} \
100         pkgconfigdir=%{_pkgconfigdir} \
101         HTML_DIR=%{_gtkdocdir}
102
103 mv ChangeLog main-ChangeLog
104 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
105
106 %find_lang %{name} --with-gnome --all-name
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 /sbin/ldconfig
113 scrollkeeper-update
114 GCONF_CONFIG_SOURCE="`%{_bindir}/gconftool-2 --get-default-source`" \
115 %{_bindir}/gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/*.schemas > /dev/null 
116
117 %postun 
118 /sbin/ldconfig
119 scrollkeeper-update
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS *ChangeLog NEWS README
124 %config %{_sysconfdir}/gconf/schemas/*
125 %config %{_sysconfdir}/sound/events/*
126 %attr(755,root,root) %{_bindir}/*
127 %attr(755,root,root) %{_libdir}/fish-applet-2
128 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
129 %attr(755,root,root) %{_libdir}/libgen_util_applet*.so
130 %attr(755,root,root) %{_libdir}/libgen_util_applet*.la
131 %{_libdir}/bonobo/servers/*
132 %{_datadir}/control-center-2.0/capplets/*
133 %{_datadir}/gen_util
134 %{_datadir}/gnome/panel
135 %{_datadir}/gnome-2.0/ui/*
136 %{_datadir}/gnome-panel*
137 %{_datadir}/idl/gnome-panel-2.0
138 %{_datadir}/pixmaps/*
139 %{_omf_dest_dir}/%{name}
140 %{_mandir}/man1/*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_libdir}/libpanel-applet*.??
145 %{_gtkdocdir}/panel-applet
146 %{_includedir}/panel-2.0
147 %{_pkgconfigdir}/*.pc
148
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/lib*.a
This page took 0.063133 seconds and 4 git commands to generate.