]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- added %%banner
[packages/gnome-panel.git] / gnome-panel.spec
1 #
2 # TODO
3 # - fix menu-stripe patch
4 #
5 # Conditional build:
6 %bcond_with     menu_stripe     # build with menu-stripe.patch
7 #
8 Summary:        The core programs for the GNOME GUI desktop environment
9 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
10 Name:           gnome-panel
11 Version:        2.10.0
12 Release:        3
13 License:        LGPL
14 Group:          X11/Applications
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.10/%{name}-%{version}.tar.bz2
16 # Source0-md5:  398e95097aeb7b8be2b6b47a0f9affe0
17 Source1:        pld-desktop-stripe.png
18 # Source1-md5:  4b8b299a8aa7b95a606e7c4d8debd60c
19 Patch0:         %{name}-no_launchers_on_panel.patch
20 Patch1:         %{name}-finalize-memleak.patch
21 %{?with_menu_stripe:Patch2:             %{name}-menu-stripe.patch}
22 Patch3:         %{name}-notification_area_applet.patch
23 URL:            http://www.gnome.org/
24 BuildRequires:  GConf2-devel >= 2.10.0
25 BuildRequires:  ORBit2-devel >= 1:2.12.1
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  evolution-data-server-devel >= 1.2.0
29 BuildRequires:  gnome-common >= 2.8.0-2
30 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
31 BuildRequires:  gnome-menus-devel >= 2.10.0
32 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
33 BuildRequires:  gtk+2-devel >= 2:2.6.2
34 BuildRequires:  gtk-doc >= 1.1
35 BuildRequires:  intltool >= 0.31
36 BuildRequires:  libart_lgpl-devel >= 2.3.15
37 BuildRequires:  libglade2-devel >= 1:2.5.0
38 BuildRequires:  libgnomeui-devel >= 2.10.0-2
39 BuildRequires:  libtool
40 BuildRequires:  libwnck-devel >= 2.10.0
41 BuildRequires:  pango-devel >= 1:1.8.0
42 BuildRequires:  perl-base
43 BuildRequires:  pkgconfig >= 1:0.15.0
44 BuildRequires:  rpm-build >= 4.1-10
45 BuildRequires:  rpmbuild(macros) >= 1.177
46 BuildRequires:  scrollkeeper >= 0.3.11
47 BuildConflicts: GConf-devel < 1.0.9-7
48 Requires(post,postun):  /sbin/ldconfig
49 Requires(post,postun):  scrollkeeper
50 Requires(post): GConf2 >= 2.10.0
51 Requires:       gnome-desktop >= 2.10.0-2
52 Requires:       gnome-icon-theme >= 2.10.0
53 Requires:       libgnomeui >= 2.10.0-2
54 Requires:       librsvg >= 1:2.9.5
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 GNOME (GNU Network Object Model Environment) is a user-friendly set of
59 applications and desktop tools to be used in conjunction with a window
60 manager for the X Window System. GNOME is similar in purpose and scope
61 to CDE and KDE, but GNOME is based completely on free software.
62
63 The gnome-panel packages provides the GNOME panel, menus and some
64 basic applets for the panel.
65
66 %description -l pl
67 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
68 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
69 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
70 ca³kowicie na wolnym oprogramowaniu.
71
72 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
73 panelu GNOME2.
74
75 %package devel
76 Summary:        GNOME panel includes, and more
77 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
78 Group:          X11/Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       gtk-doc-common
81 Requires:       libgnomeui-devel >= 2.10.0-2
82
83 %description devel
84 Panel header files for creating GNOME panels.
85
86 %description devel -l pl
87 Pliki nag³ówkowe bibliotek panelu GNOME.
88
89 %package static
90 Summary:        GNOME panel static libraries
91 Summary(pl):    Statyczne biblioteki panelu GNOME
92 Group:          X11/Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Panel static libraries.
97
98 %description static -l pl
99 Statyczne biblioteki panelu GNOME.
100
101 %prep
102 %setup -q
103 %patch0 -p1
104 %patch1 -p1
105 %{?with_menu_stripe:%patch2 -p1}
106 %patch3 -p1
107
108 %build
109 cp /usr/share/gnome-common/data/omf.make .
110 intltoolize --copy --force
111 %{__libtoolize}
112 glib-gettextize --copy --force
113 %{__aclocal}
114 %{__autoheader}
115 %{__autoconf}
116 %{__automake}
117 %configure \
118         --enable-gtk-doc \
119         --with-html-dir=%{_gtkdocdir} \
120         --enable-eds \
121         --disable-schemas-install
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT \
130         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
131
132 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
135
136 mv ChangeLog main-ChangeLog
137 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
138
139 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
140
141 %find_lang %{name} --with-gnome --all-name
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/ldconfig
148 scrollkeeper-update
149 %gconf_schema_install
150 %{_bindir}/gconftool-2 --direct \
151         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
152         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
153 %{_bindir}/gconftool-2 --direct \
154         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
155         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
156 %banner %{name} -e << EOF
157 For full functionality, you need to install gnome-utils.
158 EOF
159
160 %postun
161 /sbin/ldconfig
162 scrollkeeper-update
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS NEWS README *ChangeLog
167 %config %{_sysconfdir}/gconf/schemas/*
168 %attr(755,root,root) %{_bindir}/*
169 %attr(755,root,root) %{_libdir}/fish-applet-2
170 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
171 %attr(755,root,root) %{_libdir}/clock-applet
172 %attr(755,root,root) %{_libdir}/wnck-applet
173 %attr(755,root,root) %{_libdir}/notification-area-applet
174 %{_libdir}/bonobo/servers/*
175 %{_datadir}/gnome/panel
176 %{_datadir}/gnome-2.0/ui/*
177 %{_datadir}/gnome-panel
178 %{_datadir}/gnome-panelrc
179 %{_datadir}/idl/gnome-panel-2.0
180 %{_pixmapsdir}/*
181 %{_iconsdir}/*/*/apps/*.png
182 %{_omf_dest_dir}/%{name}
183 %{_mandir}/man1/*
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
188 %{_libdir}/*.la
189 %{_gtkdocdir}/panel-applet
190 %{_includedir}/panel-2.0
191 %{_pkgconfigdir}/*.pc
192
193 %files static
194 %defattr(644,root,root,755)
195 %{_libdir}/lib*.a
This page took 0.045836 seconds and 4 git commands to generate.