]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- R: xdg-menus, rel. 3
[packages/gnome-panel.git] / gnome-panel.spec
1 #
2 # TODO
3 # - fix menu-stripe patch
4 #
5 # Conditional build:
6 %bcond_with     menu_stripe     # build with menu-stripe.patch
7 #
8 Summary:        The core programs for the GNOME GUI desktop environment
9 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
10 Name:           gnome-panel
11 Version:        2.10.1
12 Release:        3
13 License:        LGPL
14 Group:          X11/Applications
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.10/%{name}-%{version}.tar.bz2
16 # Source0-md5:  a2719f5c79a9e48bca086f08a77a6889
17 Source1:        pld-desktop-stripe.png
18 # Source1-md5:  4b8b299a8aa7b95a606e7c4d8debd60c
19 Patch0:         %{name}-no_launchers_on_panel.patch
20 Patch1:         %{name}-finalize-memleak.patch
21 %{?with_menu_stripe:Patch2:     %{name}-menu-stripe.patch}
22 Patch3:         %{name}-notification_area_applet.patch
23 Patch4:         %{name}-no_mixer_applet.patch
24 URL:            http://www.gnome.org/
25 BuildRequires:  GConf2-devel >= 2.10.0
26 BuildRequires:  ORBit2-devel >= 1:2.12.1
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  evolution-data-server-devel >= 1.2.0
30 BuildRequires:  gnome-common >= 2.8.0-2
31 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
32 BuildRequires:  gnome-menus-devel >= 2.10.0
33 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
34 BuildRequires:  gtk+2-devel >= 2:2.6.2
35 BuildRequires:  gtk-doc >= 1.1
36 BuildRequires:  intltool >= 0.31
37 BuildRequires:  libart_lgpl-devel >= 2.3.15
38 BuildRequires:  libglade2-devel >= 1:2.5.0
39 BuildRequires:  libgnomeui-devel >= 2.10.0-2
40 BuildRequires:  libtool
41 BuildRequires:  libwnck-devel >= 2.10.0
42 BuildRequires:  pango-devel >= 1:1.8.0
43 BuildRequires:  perl-base
44 BuildRequires:  pkgconfig >= 1:0.15.0
45 BuildRequires:  rpm-build >= 4.1-10
46 BuildRequires:  rpmbuild(macros) >= 1.197
47 BuildRequires:  scrollkeeper >= 0.3.11
48 BuildConflicts: GConf-devel < 1.0.9-7
49 Requires(post,postun):  /sbin/ldconfig
50 Requires(post,preun):   GConf2 >= 2.10.0
51 Requires(post,postun):  scrollkeeper
52 Requires:       gnome-desktop >= 2.10.0-2
53 Requires:       gnome-icon-theme >= 2.10.0
54 Requires:       libgnomeui >= 2.10.0-2
55 Requires:       librsvg >= 1:2.9.5
56 Requires:       xdg-menus
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 GNOME (GNU Network Object Model Environment) is a user-friendly set of
61 applications and desktop tools to be used in conjunction with a window
62 manager for the X Window System. GNOME is similar in purpose and scope
63 to CDE and KDE, but GNOME is based completely on free software.
64
65 The gnome-panel packages provides the GNOME panel, menus and some
66 basic applets for the panel.
67
68 %description -l pl
69 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych dla
70 u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z zarz±dc±
71 okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje ca³kowicie
72 na wolnym oprogramowaniu.
73
74 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
75 panelu GNOME2.
76
77 %package devel
78 Summary:        GNOME panel includes, and more
79 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
80 Group:          X11/Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       gtk-doc-common
83 Requires:       libgnomeui-devel >= 2.10.0-2
84
85 %description devel
86 Panel header files for creating GNOME panels.
87
88 %description devel -l pl
89 Pliki nag³ówkowe bibliotek panelu GNOME.
90
91 %package static
92 Summary:        GNOME panel static libraries
93 Summary(pl):    Statyczne biblioteki panelu GNOME
94 Group:          X11/Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Panel static libraries.
99
100 %description static -l pl
101 Statyczne biblioteki panelu GNOME.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %{?with_menu_stripe:%patch2 -p1}
108 %patch3 -p1
109 %patch4 -p1
110
111 %build
112 cp /usr/share/gnome-common/data/omf.make .
113 %{__intltoolize}
114 %{__libtoolize}
115 %{__glib_gettextize}
116 %{__aclocal}
117 %{__autoheader}
118 %{__autoconf}
119 %{__automake}
120 %configure \
121         --enable-gtk-doc \
122         --with-html-dir=%{_gtkdocdir} \
123         --enable-eds \
124         --disable-schemas-install
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
134
135 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
136
137 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
138
139 mv ChangeLog main-ChangeLog
140 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
141
142 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
143
144 %find_lang %{name} --with-gnome --all-name
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %post
150 /sbin/ldconfig
151 %scrollkeeper_update_post
152 %gconf_schema_install clock.schemas
153 %gconf_schema_install fish.schemas
154 %gconf_schema_install panel-compatibility.schemas
155 %gconf_schema_install panel-general.schemas
156 %gconf_schema_install panel-global.schemas
157 %gconf_schema_install panel-object.schemas
158 %gconf_schema_install panel-toplevel.schemas
159 %gconf_schema_install window-list.schemas
160 %gconf_schema_install workspace-switcher.schemas
161 %{_bindir}/gconftool-2 --direct \
162         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
163         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
164 %{_bindir}/gconftool-2 --direct \
165         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
166         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
167 %banner %{name} -e << EOF
168 For full functionality, you need to install
169 gnome-utils-screenshot and gnome-utils-search-tool.
170 EOF
171
172 %preun
173 %gconf_schema_uninstall clock.schemas
174 %gconf_schema_uninstall fish.schemas
175 %gconf_schema_uninstall panel-compatibility.schemas
176 %gconf_schema_uninstall panel-general.schemas
177 %gconf_schema_uninstall panel-global.schemas
178 %gconf_schema_uninstall panel-object.schemas
179 %gconf_schema_uninstall panel-toplevel.schemas
180 %gconf_schema_uninstall window-list.schemas
181 %gconf_schema_uninstall workspace-switcher.schemas
182
183 %postun
184 /sbin/ldconfig
185 %scrollkeeper_update_postun
186
187 %files -f %{name}.lang
188 %defattr(644,root,root,755)
189 %doc AUTHORS NEWS README *ChangeLog
190 %config %{_sysconfdir}/gconf/schemas/*
191 %attr(755,root,root) %{_bindir}/*
192 %attr(755,root,root) %{_libdir}/fish-applet-2
193 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
194 %attr(755,root,root) %{_libdir}/clock-applet
195 %attr(755,root,root) %{_libdir}/wnck-applet
196 %attr(755,root,root) %{_libdir}/notification-area-applet
197 %{_libdir}/bonobo/servers/*
198 %{_datadir}/gnome/panel
199 %{_datadir}/gnome-2.0/ui/*
200 %{_datadir}/gnome-panel
201 %{_datadir}/gnome-panelrc
202 %{_datadir}/idl/gnome-panel-2.0
203 %{_pixmapsdir}/*
204 %{_iconsdir}/*/*/apps/*.png
205 %{_omf_dest_dir}/%{name}
206 %{_mandir}/man1/*
207
208 %files devel
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
211 %{_libdir}/*.la
212 %{_gtkdocdir}/panel-applet
213 %{_includedir}/panel-2.0
214 %{_pkgconfigdir}/*.pc
215
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/lib*.a
This page took 0.081094 seconds and 4 git commands to generate.