]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- 2.14.3, use rpm macros
[packages/gnome-panel.git] / gnome-panel.spec
1 Summary:        The core programs for the GNOME GUI desktop environment
2 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
3 Name:           gnome-panel
4 Version:        2.14.3
5 Release:        1
6 License:        LGPL
7 Group:          X11/Applications
8 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.14/%{name}-%{version}.tar.bz2
9 # Source0-md5:  14ab4c3d3ff3d0c1be397b6799a8626c
10 Patch0:         %{name}-finalize-memleak.patch
11 Patch1:         %{name}-no_launchers_on_panel.patch
12 URL:            http://www.gnome.org/
13 BuildRequires:  GConf2-devel >= 2.14.0
14 BuildRequires:  ORBit2-devel >= 1:2.14.0
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  evolution-data-server-devel >= 1.6.2
18 BuildRequires:  gnome-common >= 2.8.0-2
19 BuildRequires:  gnome-doc-utils >= 0.4.2
20 BuildRequires:  gnome-desktop-devel >= 2.14.2
21 BuildRequires:  gnome-menus-devel >= 2.14.0
22 BuildRequires:  gnome-vfs2-devel >= 2.14.2
23 BuildRequires:  gtk+2-devel >= 2:2.8.18
24 BuildRequires:  gtk-doc >= 1.4
25 BuildRequires:  intltool >= 0.35
26 BuildRequires:  libart_lgpl-devel >= 2.3.15
27 BuildRequires:  libglade2-devel >= 1:2.5.1
28 BuildRequires:  libgnomeui-devel >= 2.14.1
29 BuildRequires:  libtool
30 BuildRequires:  libwnck-devel >= 2.14.2
31 BuildRequires:  pango-devel >= 1:1.12.3
32 BuildRequires:  perl-base
33 BuildRequires:  pkgconfig >= 1:0.15.0
34 BuildRequires:  python-libxml2
35 BuildRequires:  rpm-build >= 4.1-10
36 BuildRequires:  rpmbuild(macros) >= 1.311
37 BuildRequires:  scrollkeeper >= 0.3.11
38 BuildConflicts: GConf-devel < 1.0.9-7
39 Requires(post,preun):   GConf2 >= 2.14.0
40 Requires(post,postun):  scrollkeeper
41 Requires:       %{name}-libs = %{version}-%{release}
42 Requires:       hicolor-icon-theme
43 Requires:       gnome-desktop >= 2.14.2
44 Requires:       gnome-icon-theme >= 2.14.0
45 Requires:       xdg-menus
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 GNOME (GNU Network Object Model Environment) is a user-friendly set of
50 applications and desktop tools to be used in conjunction with a window
51 manager for the X Window System. GNOME is similar in purpose and scope
52 to CDE and KDE, but GNOME is based completely on free software.
53
54 The gnome-panel packages provides the GNOME panel, menus and some
55 basic applets for the panel.
56
57 %description -l pl
58 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych dla
59 u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z zarz±dc±
60 okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje ca³kowicie
61 na wolnym oprogramowaniu.
62
63 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
64 panelu GNOME2.
65
66 %package devel
67 Summary:        GNOME panel includes, and more
68 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-libs = %{version}-%{release}
71 Requires:       gtk-doc-common
72 Requires:       libgnomeui-devel >= 2.14.1
73
74 %description devel
75 Panel header files for creating GNOME panels.
76
77 %description devel -l pl
78 Pliki nag³ówkowe bibliotek panelu GNOME.
79
80 %package static
81 Summary:        GNOME panel static libraries
82 Summary(pl):    Statyczne biblioteki panelu GNOME
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Panel static libraries.
88
89 %description static -l pl
90 Statyczne biblioteki panelu GNOME.
91
92 %package libs
93 Summary:        GNOME panel library
94 Summary(pl):    Biblioteka panelu GNOME
95 Group:          X11/Libraries
96 Requires:       libgnomeui >= 2.14.0
97 Requires:       librsvg >= 1:2.14.0
98
99 %description libs
100 GNOME panel library.
101
102 %description libs -l pl
103 Biblioteka panelu GNOME.
104
105 %prep
106 %setup -q
107 %patch0 -p1
108 %patch1 -p1
109
110 %build
111 %{__gnome_doc_prepare}
112 %{__gnome_doc_common}
113 %{__intltoolize}
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --disable-schemas-install \
121         --enable-eds \
122         --enable-gtk-doc \
123         --with-html-dir=%{_gtkdocdir}
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
133
134 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
135
136 # short circuit stopper (fix me!)
137 mv ChangeLog main-ChangeLog
138 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
139
140 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas/panel-default-setup.entries
141
142 %find_lang %{name} --with-gnome --all-name
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %scrollkeeper_update_post
149 %gconf_schema_install clock.schemas
150 %gconf_schema_install fish.schemas
151 %gconf_schema_install panel-compatibility.schemas
152 %gconf_schema_install panel-general.schemas
153 %gconf_schema_install panel-global.schemas
154 %gconf_schema_install panel-object.schemas
155 %gconf_schema_install panel-toplevel.schemas
156 %gconf_schema_install window-list.schemas
157 %gconf_schema_install workspace-switcher.schemas
158 %update_icon_cache hicolor
159 %{_bindir}/gconftool-2 --direct \
160         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
161         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
162 %{_bindir}/gconftool-2 --direct \
163         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
164         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
165 %banner %{name} -e << EOF
166 For full functionality, you need to install
167 gnome-utils-screenshot and gnome-utils-search-tool.
168 EOF
169
170 %preun
171 %gconf_schema_uninstall clock.schemas
172 %gconf_schema_uninstall fish.schemas
173 %gconf_schema_uninstall panel-compatibility.schemas
174 %gconf_schema_uninstall panel-general.schemas
175 %gconf_schema_uninstall panel-global.schemas
176 %gconf_schema_uninstall panel-object.schemas
177 %gconf_schema_uninstall panel-toplevel.schemas
178 %gconf_schema_uninstall window-list.schemas
179 %gconf_schema_uninstall workspace-switcher.schemas
180
181 %postun
182 %scrollkeeper_update_postun
183 %update_icon_cache hicolor
184
185 %post   libs -p /sbin/ldconfig
186 %postun libs -p /sbin/ldconfig
187
188 %files -f %{name}.lang
189 %defattr(644,root,root,755)
190 %doc AUTHORS NEWS README *ChangeLog
191 %attr(755,root,root) %{_bindir}/*
192 %attr(755,root,root) %{_libdir}/clock-applet
193 %attr(755,root,root) %{_libdir}/fish-applet-2
194 %attr(755,root,root) %{_libdir}/notification-area-applet
195 %attr(755,root,root) %{_libdir}/wnck-applet
196 %{_datadir}/gnome-2.0/ui/*
197 %{_datadir}/gnome-panel
198 %{_datadir}/gnome/panel
199 %{_datadir}/gnome-panelrc
200 %{_datadir}/idl/gnome-panel-2.0
201 %{_iconsdir}/*/*/apps/*.png
202 %{_libdir}/bonobo/servers/*
203 %{_mandir}/man1/*
204 %{_omf_dest_dir}/clock
205 %{_omf_dest_dir}/fish
206 %{_omf_dest_dir}/%{name}
207 %{_omf_dest_dir}/window-list
208 %{_omf_dest_dir}/workspace-switcher
209 %{_sysconfdir}/gconf/schemas/clock.schemas
210 %{_sysconfdir}/gconf/schemas/fish.schemas
211 %{_sysconfdir}/gconf/schemas/panel-compatibility.schemas
212 %{_sysconfdir}/gconf/schemas/panel-general.schemas
213 %{_sysconfdir}/gconf/schemas/panel-global.schemas
214 %{_sysconfdir}/gconf/schemas/panel-object.schemas
215 %{_sysconfdir}/gconf/schemas/panel-toplevel.schemas
216 %{_sysconfdir}/gconf/schemas/window-list.schemas
217 %{_sysconfdir}/gconf/schemas/workspace-switcher.schemas
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
222 %{_libdir}/*.la
223 %{_gtkdocdir}/panel-applet
224 %{_includedir}/panel-2.0
225 %{_pkgconfigdir}/*.pc
226
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/lib*.a
230
231 %files libs
232 %defattr(644,root,root,755)
233 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
This page took 0.166908 seconds and 3 git commands to generate.