]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- rebuild with howl 0.9.10, release 2
[packages/gnome-panel.git] / gnome-panel.spec
1 #
2 # TODO
3 # - fix menu-stripe patch
4 #
5 # Conditional build:
6 %bcond_with     menu_stripe     # build with menu-stripe.patch
7 #
8 Summary:        The core programs for the GNOME GUI desktop environment
9 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
10 Name:           gnome-panel
11 Version:        2.10.0
12 Release:        2
13 License:        LGPL
14 Group:          X11/Applications
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.10/%{name}-%{version}.tar.bz2
16 # Source0-md5:  398e95097aeb7b8be2b6b47a0f9affe0
17 Source1:        pld-desktop-stripe.png
18 # Source1-md5:  4b8b299a8aa7b95a606e7c4d8debd60c
19 Patch0:         %{name}-no_launchers_on_panel.patch
20 Patch1:         %{name}-finalize-memleak.patch
21 %{?with_menu_stripe:Patch2:             %{name}-menu-stripe.patch}
22 Patch3:         %{name}-notification_area_applet.patch
23 URL:            http://www.gnome.org/
24 BuildRequires:  GConf2-devel >= 2.10.0
25 BuildRequires:  ORBit2-devel >= 1:2.12.1
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  evolution-data-server-devel >= 1.2.0
29 BuildRequires:  gnome-common >= 2.8.0-2
30 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
31 BuildRequires:  gnome-menus-devel >= 2.10.0
32 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
33 BuildRequires:  gtk+2-devel >= 2:2.6.2
34 BuildRequires:  gtk-doc >= 1.1
35 BuildRequires:  intltool >= 0.31
36 BuildRequires:  libart_lgpl-devel >= 2.3.15
37 BuildRequires:  libglade2-devel >= 1:2.5.0
38 BuildRequires:  libgnomeui-devel >= 2.10.0-2
39 BuildRequires:  libtool
40 BuildRequires:  libwnck-devel >= 2.10.0
41 BuildRequires:  pango-devel >= 1:1.8.0
42 BuildRequires:  perl-base
43 BuildRequires:  pkgconfig >= 1:0.15.0
44 BuildRequires:  rpm-build >= 4.1-10
45 BuildRequires:  scrollkeeper >= 0.3.11
46 BuildConflicts: GConf-devel < 1.0.9-7
47 Requires(post,postun):  /sbin/ldconfig
48 Requires(post,postun):  scrollkeeper
49 Requires(post): GConf2 >= 2.10.0
50 Requires:       gnome-desktop >= 2.10.0-2
51 Requires:       gnome-icon-theme >= 2.10.0
52 Requires:       libgnomeui >= 2.10.0-2
53 Requires:       librsvg >= 1:2.9.5
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %description
57 GNOME (GNU Network Object Model Environment) is a user-friendly set of
58 applications and desktop tools to be used in conjunction with a window
59 manager for the X Window System. GNOME is similar in purpose and scope
60 to CDE and KDE, but GNOME is based completely on free software.
61
62 The gnome-panel packages provides the GNOME panel, menus and some
63 basic applets for the panel.
64
65 %description -l pl
66 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
67 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
68 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
69 ca³kowicie na wolnym oprogramowaniu.
70
71 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
72 panelu GNOME2.
73
74 %package devel
75 Summary:        GNOME panel includes, and more
76 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
77 Group:          X11/Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       gtk-doc-common
80 Requires:       libgnomeui-devel >= 2.10.0-2
81
82 %description devel
83 Panel header files for creating GNOME panels.
84
85 %description devel -l pl
86 Pliki nag³ówkowe bibliotek panelu GNOME.
87
88 %package static
89 Summary:        GNOME panel static libraries
90 Summary(pl):    Statyczne biblioteki panelu GNOME
91 Group:          X11/Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 Panel static libraries.
96
97 %description static -l pl
98 Statyczne biblioteki panelu GNOME.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %{?with_menu_stripe:%patch2 -p1}
105 %patch3 -p1
106
107 %build
108 cp /usr/share/gnome-common/data/omf.make .
109 intltoolize --copy --force
110 %{__libtoolize}
111 glib-gettextize --copy --force
112 %{__aclocal}
113 %{__autoheader}
114 %{__autoconf}
115 %{__automake}
116 %configure \
117         --enable-gtk-doc \
118         --with-html-dir=%{_gtkdocdir} \
119         --enable-eds \
120         --disable-schemas-install
121 %{__make}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
130
131 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
132
133 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 mv ChangeLog main-ChangeLog
136 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
137
138 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
139
140 %find_lang %{name} --with-gnome --all-name
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post
146 /sbin/ldconfig
147 scrollkeeper-update
148 %gconf_schema_install
149 %{_bindir}/gconftool-2 --direct \
150         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
151         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
152 %{_bindir}/gconftool-2 --direct \
153         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
154         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
155
156 %postun
157 /sbin/ldconfig
158 scrollkeeper-update
159
160 %files -f %{name}.lang
161 %defattr(644,root,root,755)
162 %doc AUTHORS NEWS README *ChangeLog
163 %config %{_sysconfdir}/gconf/schemas/*
164 %attr(755,root,root) %{_bindir}/*
165 %attr(755,root,root) %{_libdir}/fish-applet-2
166 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
167 %attr(755,root,root) %{_libdir}/clock-applet
168 %attr(755,root,root) %{_libdir}/wnck-applet
169 %attr(755,root,root) %{_libdir}/notification-area-applet
170 %{_libdir}/bonobo/servers/*
171 %{_datadir}/gnome/panel
172 %{_datadir}/gnome-2.0/ui/*
173 %{_datadir}/gnome-panel
174 %{_datadir}/gnome-panelrc
175 %{_datadir}/idl/gnome-panel-2.0
176 %{_pixmapsdir}/*
177 %{_iconsdir}/*/*/apps/*.png
178 %{_omf_dest_dir}/%{name}
179 %{_mandir}/man1/*
180
181 %files devel
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
184 %{_libdir}/*.la
185 %{_gtkdocdir}/panel-applet
186 %{_includedir}/panel-2.0
187 %{_pkgconfigdir}/*.pc
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/lib*.a
This page took 0.043981 seconds and 3 git commands to generate.