]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- added pango epoch to R:/BR:
[packages/gnome-panel.git] / gnome-panel.spec
1 #
2 # Conditional build:
3 %bcond_with     menu_stripe     # build with menu-stripe.patch
4
5 Summary:        The core programs for the GNOME GUI desktop environment
6 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
7 Name:           gnome-panel
8 Version:        2.6.2
9 Release:        5.1
10 License:        LGPL
11 Group:          X11/Applications
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.6/%{name}-%{version}.tar.bz2
13 # Source0-md5:  41318b24e18f497b4418c7d60aaf33f6
14 Source1:        pld-desktop-stripe.png
15 # Source1-md5:  4b8b299a8aa7b95a606e7c4d8debd60c
16 Patch0:         %{name}-no_launchers_on_panel.patch
17 Patch1:         %{name}-finalize-memleak.patch
18 Patch2:         %{name}-locale-names.patch
19 %{?with_menu_stripe:Patch3:             %{name}-menu-stripe.patch}
20 Patch4:         %{name}-notification_area_applet.patch
21 Patch5:         %{name}-applet-categories.patch
22 Patch6:         %{name}-schemas.patch
23 Patch7:         %{name}-desktop.patch
24 URL:            http://www.gnome.org/
25 BuildRequires:  GConf2-devel >= 2.6.2
26 BuildRequires:  ORBit2-devel >= 1:2.10.2
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  evolution-data-server-devel >= 0.0.94
30 BuildRequires:  gnome-common >= 2.4.0
31 BuildRequires:  gnome-desktop-devel >= 2.6.2
32 BuildRequires:  gnome-vfs2-devel >= 2.6.1.1
33 BuildRequires:  gtk+2-devel >= 2:2.4.3
34 BuildRequires:  gtk-doc >= 1.1
35 BuildRequires:  intltool >= 0.29
36 BuildRequires:  libart_lgpl-devel >= 2.3.15
37 BuildRequires:  libglade2-devel >= 1:2.4.0
38 BuildRequires:  libgnomeui-devel >= 2.6.1.1
39 BuildRequires:  libpng-devel >= 1.2.0
40 BuildRequires:  libtool
41 BuildRequires:  libwnck-devel >= 2.6.2
42 BuildRequires:  pango-devel >= 1:1.4.0
43 BuildRequires:  perl-base
44 BuildRequires:  pkgconfig >= 0.15.0
45 BuildRequires:  rpm-build >= 4.1-10
46 BuildRequires:  scrollkeeper >= 0.3.11
47 BuildRequires:  zlib-devel
48 BuildConflicts: GConf-devel < 1.0.9-7
49 Requires(post,postun):  /sbin/ldconfig
50 Requires(post,postun):  scrollkeeper
51 Requires(post): GConf2 >= 2.6.2
52 Requires:       gnome-desktop >= 2.6.2
53 Requires:       gnome-icon-theme >= 1.2.3
54 Requires:       gnome-vfs-menu-module
55 Requires:       libgnomeui >= 2.6.1.1
56 Requires:       librsvg >= 1:2.6.5
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 GNOME (GNU Network Object Model Environment) is a user-friendly set of
61 applications and desktop tools to be used in conjunction with a window
62 manager for the X Window System. GNOME is similar in purpose and scope
63 to CDE and KDE, but GNOME is based completely on free software.
64
65 The gnome-panel packages provides the GNOME panel, menus and some
66 basic applets for the panel.
67
68 %description -l pl
69 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
70 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
71 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
72 ca³kowicie na wolnym oprogramowaniu.
73
74 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
75 panelu GNOME2.
76
77 %package devel
78 Summary:        GNOME panel includes, and more
79 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
80 Group:          X11/Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       gtk-doc-common
83 Requires:       libgnomeui-devel >= 2.6.1.1
84
85 %description devel
86 Panel header files for creating GNOME panels.
87
88 %description devel -l pl
89 Pliki nag³ówkowe bibliotek panelu GNOME.
90
91 %package static
92 Summary:        GNOME panel static libraries
93 Summary(pl):    Statyczne biblioteki panelu GNOME
94 Group:          X11/Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Panel static libraries.
99
100 %description static -l pl
101 Statyczne biblioteki panelu GNOME.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108 %{?with_menu_stripe:%patch3 -p1}
109 %patch4 -p1
110 %patch5 -p1
111 %patch6 -p1
112 %patch7 -p1
113
114 mv po/{no,nb}.po
115
116 %build
117 intltoolize --copy --force
118 %{__libtoolize}
119 glib-gettextize --copy --force
120 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
121 %{__autoheader}
122 %{__autoconf}
123 %{__automake}
124 %configure \
125         --enable-gtk-doc \
126         --with-html-dir=%{_gtkdocdir} \
127         --enable-eds \
128         --disable-schemas-install
129
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT \
137         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
138
139 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
140
141 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
142
143 install -d $RPM_BUILD_ROOT%{_datadir}/gnome/capplets
144 mv $RPM_BUILD_ROOT%{_datadir}/control-center-2.0/capplets/*.desktop $RPM_BUILD_ROOT%{_datadir}/gnome/capplets
145
146 mv ChangeLog main-ChangeLog
147 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
148
149 %find_lang %{name} --with-gnome --all-name
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %post
155 /sbin/ldconfig
156 scrollkeeper-update
157 %gconf_schema_install
158 %{_bindir}/gconftool-2 --direct \
159         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
160         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
161 %{_bindir}/gconftool-2 --direct \
162         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
163         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
164
165 %postun
166 /sbin/ldconfig
167 scrollkeeper-update
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS NEWS README *ChangeLog
172 %config %{_sysconfdir}/gconf/schemas/*
173 %attr(755,root,root) %{_bindir}/*
174 %attr(755,root,root) %{_libdir}/fish-applet-2
175 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
176 %attr(755,root,root) %{_libdir}/clock-applet
177 %attr(755,root,root) %{_libdir}/wnck-applet
178 %attr(755,root,root) %{_libdir}/notification-area-applet
179 %{_libdir}/bonobo/servers/*
180 %{_datadir}/gnome/capplets/*
181 %{_datadir}/gnome/panel
182 %{_datadir}/gnome-2.0/ui/*
183 %{_datadir}/gnome-panel
184 %{_datadir}/gnome-panelrc
185 %{_datadir}/idl/gnome-panel-2.0
186 %{_pixmapsdir}/*
187 %{_omf_dest_dir}/%{name}
188 %{_mandir}/man1/*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
193 %{_libdir}/*.la
194 %{_gtkdocdir}/panel-applet
195 %{_includedir}/panel-2.0
196 %{_pkgconfigdir}/*.pc
197
198 %files static
199 %defattr(644,root,root,755)
200 %{_libdir}/lib*.a
This page took 0.035877 seconds and 3 git commands to generate.