]> git.pld-linux.org Git - packages/gnome-panel.git/blob - gnome-panel.spec
- reversed ldconfig changes
[packages/gnome-panel.git] / gnome-panel.spec
1 #
2 # TODO
3 # - fix menu-stripe patch
4 #
5 # Conditional build:
6 %bcond_with     menu_stripe     # build with menu-stripe.patch
7 #
8 Summary:        The core programs for the GNOME GUI desktop environment
9 Summary(pl):    Podstawowe programy ¶rodowiska graficznego GNOME
10 Name:           gnome-panel
11 Version:        2.10.1
12 Release:        1
13 License:        LGPL
14 Group:          X11/Applications
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/gnome-panel/2.10/%{name}-%{version}.tar.bz2
16 # Source0-md5:  a2719f5c79a9e48bca086f08a77a6889
17 Source1:        pld-desktop-stripe.png
18 # Source1-md5:  4b8b299a8aa7b95a606e7c4d8debd60c
19 Patch0:         %{name}-no_launchers_on_panel.patch
20 Patch1:         %{name}-finalize-memleak.patch
21 %{?with_menu_stripe:Patch2:             %{name}-menu-stripe.patch}
22 Patch3:         %{name}-notification_area_applet.patch
23 Patch4:         %{name}-no_mixer_applet.patch
24 URL:            http://www.gnome.org/
25 BuildRequires:  GConf2-devel >= 2.10.0
26 BuildRequires:  ORBit2-devel >= 1:2.12.1
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  evolution-data-server-devel >= 1.2.0
30 BuildRequires:  gnome-common >= 2.8.0-2
31 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
32 BuildRequires:  gnome-menus-devel >= 2.10.0
33 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
34 BuildRequires:  gtk+2-devel >= 2:2.6.2
35 BuildRequires:  gtk-doc >= 1.1
36 BuildRequires:  intltool >= 0.31
37 BuildRequires:  libart_lgpl-devel >= 2.3.15
38 BuildRequires:  libglade2-devel >= 1:2.5.0
39 BuildRequires:  libgnomeui-devel >= 2.10.0-2
40 BuildRequires:  libtool
41 BuildRequires:  libwnck-devel >= 2.10.0
42 BuildRequires:  pango-devel >= 1:1.8.0
43 BuildRequires:  perl-base
44 BuildRequires:  pkgconfig >= 1:0.15.0
45 BuildRequires:  rpm-build >= 4.1-10
46 BuildRequires:  rpmbuild(macros) >= 1.197
47 BuildRequires:  scrollkeeper >= 0.3.11
48 BuildConflicts: GConf-devel < 1.0.9-7
49 Requires(post,postun):  /sbin/ldconfig
50 Requires(post,preun):   GConf2 >= 2.10.0
51 Requires(post,postun):  scrollkeeper
52 Requires:       gnome-desktop >= 2.10.0-2
53 Requires:       gnome-icon-theme >= 2.10.0
54 Requires:       libgnomeui >= 2.10.0-2
55 Requires:       librsvg >= 1:2.9.5
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 GNOME (GNU Network Object Model Environment) is a user-friendly set of
60 applications and desktop tools to be used in conjunction with a window
61 manager for the X Window System. GNOME is similar in purpose and scope
62 to CDE and KDE, but GNOME is based completely on free software.
63
64 The gnome-panel packages provides the GNOME panel, menus and some
65 basic applets for the panel.
66
67 %description -l pl
68 GNOME (GNU Network Object Model Environment) to zestaw przyjaznych
69 dla u¿ytkownika aplikacji i narzêdzi do u¿ywania w po³±czeniu z
70 zarz±dc± okien pod X. GNOME ma podobny cel jak CDE i KDE, ale bazuje
71 ca³kowicie na wolnym oprogramowaniu.
72
73 Ten pakiet dostarcza panel GNOME2, menu oraz podstawowe aplety dla
74 panelu GNOME2.
75
76 %package devel
77 Summary:        GNOME panel includes, and more
78 Summary(pl):    Pliki nag³ówkowe biblioteki panelu GNOME
79 Group:          X11/Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       gtk-doc-common
82 Requires:       libgnomeui-devel >= 2.10.0-2
83
84 %description devel
85 Panel header files for creating GNOME panels.
86
87 %description devel -l pl
88 Pliki nag³ówkowe bibliotek panelu GNOME.
89
90 %package static
91 Summary:        GNOME panel static libraries
92 Summary(pl):    Statyczne biblioteki panelu GNOME
93 Group:          X11/Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Panel static libraries.
98
99 %description static -l pl
100 Statyczne biblioteki panelu GNOME.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105 %patch1 -p1
106 %{?with_menu_stripe:%patch2 -p1}
107 %patch3 -p1
108 %patch4 -p1
109
110 %build
111 cp /usr/share/gnome-common/data/omf.make .
112 %{__intltoolize}
113 %{__libtoolize}
114 %{__glib_gettextize}
115 %{__aclocal}
116 %{__autoheader}
117 %{__autoconf}
118 %{__automake}
119 %configure \
120         --enable-gtk-doc \
121         --with-html-dir=%{_gtkdocdir} \
122         --enable-eds \
123         --disable-schemas-install
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_datadir}/%{name}}
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT \
132         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
133
134 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
135
136 install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
137
138 mv ChangeLog main-ChangeLog
139 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
140
141 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
142
143 %find_lang %{name} --with-gnome --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post
149 /sbin/ldconfig
150 %scrollkeeper_update_post
151 %gconf_schema_install clock.schemas
152 %gconf_schema_install fish.schemas
153 %gconf_schema_install panel-compatibility.schemas
154 %gconf_schema_install panel-general.schemas
155 %gconf_schema_install panel-global.schemas
156 %gconf_schema_install panel-object.schemas
157 %gconf_schema_install panel-toplevel.schemas
158 %gconf_schema_install window-list.schemas
159 %gconf_schema_install workspace-switcher.schemas
160 %{_bindir}/gconftool-2 --direct \
161         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
162         --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
163 %{_bindir}/gconftool-2 --direct \
164         --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
165         --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
166 %banner %{name} -e << EOF
167 For full functionality, you need to install gnome-utils.
168 EOF
169
170 %preun
171 %gconf_schema_uninstall clock.schemas
172 %gconf_schema_uninstall fish.schemas
173 %gconf_schema_uninstall panel-compatibility.schemas
174 %gconf_schema_uninstall panel-general.schemas
175 %gconf_schema_uninstall panel-global.schemas
176 %gconf_schema_uninstall panel-object.schemas
177 %gconf_schema_uninstall panel-toplevel.schemas
178 %gconf_schema_uninstall window-list.schemas
179 %gconf_schema_uninstall workspace-switcher.schemas
180
181 %postun
182 /sbin/ldconfig
183 %scrollkeeper_update_postun
184
185 %files -f %{name}.lang
186 %defattr(644,root,root,755)
187 %doc AUTHORS NEWS README *ChangeLog
188 %config %{_sysconfdir}/gconf/schemas/*
189 %attr(755,root,root) %{_bindir}/*
190 %attr(755,root,root) %{_libdir}/fish-applet-2
191 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
192 %attr(755,root,root) %{_libdir}/clock-applet
193 %attr(755,root,root) %{_libdir}/wnck-applet
194 %attr(755,root,root) %{_libdir}/notification-area-applet
195 %{_libdir}/bonobo/servers/*
196 %{_datadir}/gnome/panel
197 %{_datadir}/gnome-2.0/ui/*
198 %{_datadir}/gnome-panel
199 %{_datadir}/gnome-panelrc
200 %{_datadir}/idl/gnome-panel-2.0
201 %{_pixmapsdir}/*
202 %{_iconsdir}/*/*/apps/*.png
203 %{_omf_dest_dir}/%{name}
204 %{_mandir}/man1/*
205
206 %files devel
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/libpanel-applet*.so
209 %{_libdir}/*.la
210 %{_gtkdocdir}/panel-applet
211 %{_includedir}/panel-2.0
212 %{_pkgconfigdir}/*.pc
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/lib*.a
This page took 0.038449 seconds and 3 git commands to generate.