]> git.pld-linux.org Git - packages/gnome-keyring.git/blob - gnome-keyring.spec
- updated to 42.1, missing files and broken path issues fixes
[packages/gnome-keyring.git] / gnome-keyring.spec
1 # TODO
2 #  Aug 14 13:19:00 haarber gnome-keyring-daemon[6524]: couldn't list keyrings at: /etc/certs: Error opening directory '/etc/certs': Permission denied
3 #
4 # Conditional build:
5 %bcond_with     p11_tests       # PKCS#11 tests
6 #
7 Summary:        Keep passwords and other user's secrets
8 Summary(pl.UTF-8):      Przechowywanie haseł i innych tajnych danych użytkowników
9 Name:           gnome-keyring
10 Version:        42.1
11 Release:        1
12 License:        LGPL v2+ (library), GPL v2+ (programs)
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/gnome-keyring/42/%{name}-%{version}.tar.xz
15 # Source0-md5:  8728a6d344f29c545d9d31cb5c708f14
16 URL:            https://wiki.gnome.org/Projects/GnomeKeyring
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake >= 1:1.12
19 BuildRequires:  docbook-dtd412-xml
20 BuildRequires:  gcr-devel >= 3.28.0
21 BuildRequires:  gcr-ui-devel >= 3.28.0
22 BuildRequires:  gettext-tools >= 0.19.8
23 BuildRequires:  glib2-devel >= 1:2.44.0
24 BuildRequires:  libcap-ng-devel
25 BuildRequires:  libgcrypt-devel >= 1.2.2
26 BuildRequires:  libselinux-devel
27 # for some test only
28 BuildRequires:  libtasn1-devel >= 0.3.4
29 BuildRequires:  libtool
30 BuildRequires:  libxslt-progs
31 BuildRequires:  p11-kit-devel >= 0.16
32 %{?with_p11_tests:BuildRequires:        p11-tests-devel >= 0.1}
33 BuildRequires:  pam-devel
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.592
36 BuildRequires:  systemd-devel >= 1:209
37 BuildRequires:  tar >= 1:1.22
38 BuildRequires:  xz
39 Requires(post,postun):  glib2 >= 1:2.44.0
40 Requires:       filesystem >= 4.0-28
41 Requires:       gcr >= 3.28.0
42 Requires:       glib2 >= 1:2.44.0
43 Requires:       hicolor-icon-theme
44 Requires:       libgcrypt >= 1.2.2
45 Requires:       p11-kit >= 0.16
46 Conflicts:      rpm < 4.4.2-0.2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 GNOME Keyring is a program that keeps password and other secrets for
51 users. It is run as a daemon in the session, similar to ssh-agent, and
52 other applications can locate it by an environment variable.
53
54 %description -l pl.UTF-8
55 GNOME Keyring to program do przechowywania haseł i innych tajnych
56 danych użytkowników. Działa jako demon w sesji, podobnie do
57 ssh-agenta, a inne aplikacje mogą znaleźć go poprzez zmienną
58 środowiskową.
59
60 %package -n pam-pam_gnome_keyring
61 Summary:        A PAM module for unlocking keyrings at login time
62 Summary(pl.UTF-8):      Moduł PAM do odblokowywania zbiorów kluczy w czasie logowania
63 License:        LGPL v2+
64 Group:          Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Obsoletes:      gnome-keyring-pam < 2.30.1-2
67
68 %description -n pam-pam_gnome_keyring
69 A PAM module that can automatically unlock the "login" keyring when
70 the user logs in and start the keyring daemon.
71
72 %description -n pam-pam_gnome_keyring -l pl.UTF-8
73 Moduł PAM, który może automatycznie odblokowywać zbiór kluczy "login"
74 w czasie logowania użytkownika i uruchamiania demona keyring.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         SSH_ADD="/usr/bin/ssh-add" \
87         SSH_AGENT="/usr/bin/ssh-agent" \
88         --disable-silent-rules \
89         %{!?with_p11_tests:--disable-p11-tests} \
90         --with-pam-dir=/%{_lib}/security
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install install-pam \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 %{__rm} $RPM_BUILD_ROOT/%{_lib}/security/pam_gnome_keyring.la
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pkcs11/gnome-keyring-pkcs11.la
101 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gnome-keyring/devel/*.la
102
103 %find_lang %{name}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post
109 %glib_compile_schemas
110
111 %postun
112 %glib_compile_schemas
113
114 %files -f %{name}.lang
115 %defattr(644,root,root,755)
116 %doc AUTHORS ChangeLog NEWS README
117 %attr(755,root,root) %{_bindir}/gnome-keyring
118 %attr(755,root,root) %{_bindir}/gnome-keyring-3
119 %attr(755,root,root) %{_bindir}/gnome-keyring-daemon
120 %attr(755,root,root) %{_libdir}/pkcs11/gnome-keyring-pkcs11.so
121 %dir %{_libdir}/%{name}
122 %dir %{_libdir}/%{name}/devel
123 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-gnome2-store-standalone.so
124 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-secret-store-standalone.so
125 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-ssh-store-standalone.so
126 %attr(755,root,root) %{_libdir}/%{name}/devel/gkm-xdg-store-standalone.so
127 %{_sysconfdir}/xdg/autostart/gnome-keyring-pkcs11.desktop
128 %{_sysconfdir}/xdg/autostart/gnome-keyring-secrets.desktop
129 %{_sysconfdir}/xdg/autostart/gnome-keyring-ssh.desktop
130 %{_datadir}/GConf/gsettings/org.gnome.crypto.cache.convert
131 %{_datadir}/dbus-1/services/org.freedesktop.impl.portal.Secret.service
132 %{_datadir}/dbus-1/services/org.freedesktop.secrets.service
133 %{_datadir}/dbus-1/services/org.gnome.keyring.service
134 %{_datadir}/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
135 %{_datadir}/p11-kit/modules/gnome-keyring.module
136 %{_datadir}/xdg-desktop-portal/portals/gnome-keyring.portal
137 %{systemduserunitdir}/gnome-keyring-daemon.service
138 %{systemduserunitdir}/gnome-keyring-daemon.socket
139 %{_mandir}/man1/gnome-keyring.1*
140 %{_mandir}/man1/gnome-keyring-3.1*
141 %{_mandir}/man1/gnome-keyring-daemon.1*
142
143 %files -n pam-pam_gnome_keyring
144 %defattr(644,root,root,755)
145 %attr(755,root,root) /%{_lib}/security/pam_gnome_keyring.so
This page took 0.078175 seconds and 3 git commands to generate.