]> git.pld-linux.org Git - packages/gnome-abrt.git/blob - gnome-abrt.spec
- BR: python-pygobject3-devel
[packages/gnome-abrt.git] / gnome-abrt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # "make check" run (some pylint false positive?)
4 #
5 Summary:        A utility for viewing problems that have occurred with the system
6 Summary(pl.UTF-8):      Narzędzie do przeglądania problemów, które wystąpiły w systemie
7 Name:           gnome-abrt
8 Version:        0.3.0
9 Release:        1
10 License:        GPL v2+
11 Group:          Applications/System
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
13 # Source0-md5:  9c9e44a255b1b63f3adc31c834f30b2e
14 Patch0:         %{name}-pylint.patch
15 URL:            https://fedorahosted.org/abrt/
16 BuildRequires:  asciidoc
17 BuildRequires:  gettext-devel >= 0.17
18 BuildRequires:  gtk+3-devel >= 3.0
19 BuildRequires:  intltool >= 0.35.0
20 BuildRequires:  libreport-gtk-devel >= 2.0.20
21 %{?with_tests:BuildRequires:    libreport-python}
22 BuildRequires:  pkgconfig
23 %{?with_tests:BuildRequires:    pylint}
24 BuildRequires:  python-devel >= 1:2.7
25 BuildRequires:  python-pygobject3-devel >= 3.0
26 BuildRequires:  rpmbuild(macros) >= 1.596
27 BuildRequires:  sed >= 4.0
28 BuildRequires:  xmlto
29 Requires(post,postun):  gtk-update-icon-cache
30 Requires:       hicolor-icon-theme
31 Requires:       libreport-python
32 Requires:       python-dbus
33 Requires:       python-inotify
34 Requires:       python-pygobject3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 A GNOME application allows users to browse through detected problems
39 and provides them with convenient way for managing these problems.
40
41 %description -l pl.UTF-8
42 Aplikacja GNOME pozwalająca użytkownikom przeglądać wykryte problemy i
43 zapewniająca wygodny sposób zarządzania tymi problemami.
44
45 %prep
46 %setup -q
47 %patch0 -p1
48
49 %{__sed} -i -e '1s,#!/usr/bin/env python,#!/usr/bin/python,' src/gnome-abrt
50
51 %build
52 %configure \
53         --disable-silent-rules \
54         %{!?with_tests:--with-nopylint}
55
56 %{__make}
57
58 %{?with_tests:%{__make} check}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/gnome_abrt/wrappers/*.la
66 %py_postclean
67
68 # just a copy of cs
69 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/locale/cs_CZ
70
71 %find_lang %{name}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 %update_icon_cache hicolor
78
79 %postun
80 %update_icon_cache hicolor
81
82 %files -f %{name}.lang
83 %defattr(644,root,root,755)
84 %attr(755,root,root) %{_bindir}/gnome-abrt
85 %dir %{py_sitedir}/gnome_abrt
86 %{py_sitedir}/gnome_abrt/*.py[co]
87 %dir %{py_sitedir}/gnome_abrt/url
88 %{py_sitedir}/gnome_abrt/url/*.py[co]
89 %dir %{py_sitedir}/gnome_abrt/wrappers
90 %{py_sitedir}/gnome_abrt/wrappers/__init__.py[co]
91 %attr(755,root,root) %{py_sitedir}/gnome_abrt/wrappers/_wrappers.so
92 %{_datadir}/gnome-abrt
93 %{_desktopdir}/gnome-abrt.desktop
94 %{_iconsdir}/hicolor/*/apps/gnome-abrt.png
95 %{_iconsdir}/hicolor/*/status/gnome-abrt.png
96 %{_mandir}/man1/gnome-abrt.1*
This page took 0.032288 seconds and 4 git commands to generate.