]> git.pld-linux.org Git - packages/glibc.git/blob - glibc.spec
- use int not arpa in resolver
[packages/glibc.git] / glibc.spec
1 #
2 # You can define min_kernel macro by "rpm --define 'min_kernel version'"
3 # default is 2.2.0 (no changes up to 2.3.25)
4
5 %{!?min_kernel:%define          min_kernel      2.2.0}
6
7 Summary:        GNU libc
8 Summary(de):    GNU libc
9 Summary(fr):    GNU libc
10 Summary(pl):    GNU libc
11 Summary(tr):    GNU libc
12 Name:           glibc
13 Version:        2.2.5
14 Release:        1.1
15 Epoch:          6
16 License:        LGPL
17 Group:          Libraries
18 Group(de):      Libraries
19 Group(es):      Bibliotecas
20 Group(fr):      Librairies
21 Group(pl):      Biblioteki
22 Group(pt_BR):   Bibliotecas
23 Group(ru):      âÉÂÌÉÏÔÅËÉ
24 Group(uk):      â¦Â̦ÏÔÅËÉ
25 Source0:        ftp://sources.redhat.com/pub/glibc/releases/%{name}-%{version}.tar.bz2
26 Source1:        ftp://sources.redhat.com/pub/glibc/releases/%{name}-linuxthreads-%{version}.tar.bz2
27 Source2:        nscd.init
28 Source3:        nscd.sysconfig
29 Source4:        nscd.logrotate
30 Source5:        %{name}-man-pages.tar.bz2
31 Source6:        %{name}-non-english-man-pages.tar.bz2
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-versions.awk_fix.patch
34 Patch2:         %{name}-pld.patch
35 Patch3:         %{name}-crypt-blowfish.patch
36 Patch4:         %{name}-string2-pointer-arith.patch
37 Patch5:         %{name}-linuxthreads-lock.patch
38 Patch6:         %{name}-pthread_create-manpage.patch
39 Patch7:         %{name}-sparc-linux-chown.patch
40 Patch8:         %{name}-ldconfig-bklinks.patch
41 Patch9:         %{name}-paths.patch
42 Patch10:        %{name}-vaargs.patch
43 Patch11:        %{name}-getaddrinfo-workaround.patch
44 Patch12:        %{name}-use-int-not-arpa.patch
45 URL:            http://www.gnu.org/software/libc/
46 BuildRequires:  gd-devel >= 2.0.1
47 BuildRequires:  gettext-devel >= 0.10.36
48 BuildRequires:  libpng-devel
49 BuildRequires:  perl
50 BuildRequires:  rpm-build >= 4.0.2-46
51 BuildRequires:  texinfo
52 Provides:       ld.so.2
53 Provides:       ldconfig
54 Provides:       /sbin/ldconfig
55 Obsoletes:      %{name}-common
56 Obsoletes:      %{name}-debug
57 Obsoletes:      ldconfig
58 Autoreq:        false
59 Prereq:         basesystem
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61 Conflicts:      kernel < %{min_kernel}
62 Conflicts:      man-pages < 1.43
63 Conflicts:      ld.so < 1.9.9-9
64
65 %define         debugcflags     -O1 -g
66
67 %description
68 Contains the standard libraries that are used by multiple programs on
69 the system. In order to save disk space and memory, as well as to ease
70 upgrades, common system code is kept in one place and shared between
71 programs. This package contains the most important sets of shared
72 libraries, the standard C library and the standard math library.
73 Without these, a Linux system will not function. It also contains
74 national language (locale) support and timezone databases.
75
76 %description -l de
77 Enthält die Standard-Libraries, die von verschiedenen Programmen im
78 System benutzt werden. Um Festplatten- und Arbeitsspeicher zu sparen
79 und zur Vereinfachung von Upgrades ist der gemeinsame Systemcode an
80 einer einzigen Stelle gespeichert und wird von den Programmen
81 gemeinsam genutzt. Dieses Paket enthält die wichtigsten Sets der
82 shared Libraries, die Standard-C-Library und die
83 Standard-Math-Library, ohne die das Linux-System nicht funktioniert.
84 Ferner enthält es den Support für die verschiedenen Sprachgregionen
85 (locale) und die Zeitzonen-Datenbank.
86
87 %description -l fr
88 Contient les bibliothèques standards utilisées par de nombreux
89 programmes du système. Afin d'économiser l'espace disque et mémoire,
90 et de faciliter les mises à jour, le code commun au système est mis à
91 un endroit et partagé entre les programmes. Ce paquetage contient les
92 bibliothèques partagées les plus importantes, la bibliothèque standard
93 du C et la bibliothèque mathématique standard. Sans celles-ci, un
94 système Linux ne peut fonctionner. Il contient aussi la gestion des
95 langues nationales (locales) et les bases de données des zones
96 horaires.
97
98 %description -l pl
99 W pakiecie znajduj± siê podstawowe biblioteki, u¿ywane przez ró¿ne
100 programy w Twoim systemie. U¿ywanie przez programy bibliotek z tego
101 pakietu oszczêdza miejsce na dysku i pamiêæ. Wiekszo¶æ kodu
102 systemowego jest usytuowane w jednym miejscu i dzielone miêdzy wieloma
103 programami. Pakiet ten zawiera bardzo wa¿ny zbiór bibliotek
104 standardowych, wspó³dzielonych (dynamicznych) bibliotek C i
105 matematycznych. Bez glibc system Linux nie jest w stanie funkcjonowaæ.
106 Znajduj± siê tutaj równie¿ definicje ró¿nych informacji dla wielu
107 jêzyków (locale) oraz definicje stref czasowych.
108
109 %description -l tr
110 Bu paket, birçok programýn kullandýðý standart kitaplýklarý içerir.
111 Disk alaný ve bellek kullanýmýný azaltmak ve ayný zamanda güncelleme
112 iþlemlerini kolaylaþtýrmak için ortak sistem kodlarý tek bir yerde
113 tutulup programlar arasýnda paylaþtýrýlýr. Bu paket en önemli ortak
114 kitaplýklarý, standart C kitaplýðýný ve standart matematik kitaplýðýný
115 içerir. Bu kitaplýklar olmadan Linux sistemi çalýþmayacaktýr. Yerel
116 dil desteði ve zaman dilimi veri tabaný da bu pakette yer alýr.
117
118 %package devel
119 Summary:        Additional libraries required to compile
120 Summary(de):    Weitere Libraries zum Kompilieren
121 Summary(fr):    Librairies supplémentaires nécessaires à la compilation.
122 Summary(pl):    Dodatkowe biblioteki wymagane podczas kompilacji
123 Summary(tr):    Geliþtirme için gerekli diðer kitaplýklar
124 Group:          Development/Libraries
125 Group(de):      Entwicklung/Libraries
126 Group(es):      Desarrollo/Bibliotecas
127 Group(fr):      Development/Librairies
128 Group(pl):      Programowanie/Biblioteki
129 Group(pt_BR):   Desenvolvimento/Bibliotecas
130 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
131 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
132 Requires:       %{name} = %{version}
133
134 %description devel
135 To develop programs which use the standard C libraries (which nearly
136 all programs do), the system needs to have these standard header files
137 and object files available for creating the executables.
138
139 %description devel -l de
140 Bei der Entwicklung von Programmen, die die Standard-C-Libraries
141 verwenden (also fast alle), benötigt das System diese Standard-Header-
142 und Objektdateien zum Erstellen der ausführbaren Programme.
143
144 %description devel -l fr
145 Pour développer des programmes utilisant les bibliothèques standard du
146 C (ce que presque tous les programmes font), le système doit posséder
147 ces fichiers en-têtes et objets standards pour créer les exécutables.
148
149 %description devel -l pl
150 Pakiet ten jest niezbêdny przy tworzeniu w³asnych programów
151 korzystaj±cych ze standardowej biblioteki C. Znajduj± siê tutaj pliki
152 nag³ówkowe oraz pliki objektowe, niezbêdne do kompilacji programów
153 wykonywalnych i innych bibliotek.
154
155 %description devel -l tr
156 C kitaplýðýný kullanan (ki hemen hemen hepsi kullanýyor) programlar
157 geliþtirmek için gereken standart baþlýk dosyalarý ve statik
158 kitaplýklar.
159
160 %package -n nscd
161 Summary:        Name Service Caching Daemon
162 Group:          Networking/Daemons
163 Group(de):      Netzwerkwesen/Server
164 Group(pl):      Sieciowe/Serwery
165 Prereq:         /sbin/chkconfig
166 Prereq:         rc-scripts >= 0.2.0
167 Requires:       %{name} = %{version}
168 Requires(post): fileutils
169
170 %description -n nscd
171 nscd caches name service lookups; it can dramatically improve
172 performance with NIS+, and may help with DNS as well. You cannot use
173 nscd with 2.0 kernels, due to bugs in the kernel-side thread support.
174 nscd happens to hit these bugs particularly hard.
175
176 %description -n nscd -l pl
177 nscd zapmiêtuje zapytania i odpowiedzi NIS oraz DNS. Pozwala
178 drastycznie poprawiæ szybko¶æ dzia³ania NIS+. Nie jest mo¿liwe
179 u¿ywanie nscd z j±drami serii 2.0.x z powodu b³êdów po stronie j±dra w
180 ods³udze w±tków.
181
182 %package -n localedb-src
183 Summary:        locale database source code
184 Summary(pl):    Kod ¼ród³owy bazy locale
185 Group:          Daemons
186 Group(de):      Server
187 Group(pl):      Serwery
188 Requires:       %{name} = %{version}
189
190 %description -n localedb-src
191 This add-on package contains the data needed to build the locale data
192 files to use the internationalization features of the GNU libc. glibc
193 package contains standard set of locale binary database so you need
194 this package only when you want to build some non-standard locale
195 database.
196
197 %description -n localedb-src -l pl
198 Pakiet ten zawiera dane niezbêdne do zbudowania binarnych plików
199 lokalizacyjnych, by móc wykorzystaæ mo¿liwo¶ci oferowane przez GNU
200 libc. glibc zawiera standardowy zestaw binarnych baz lokalizacyjnych,
201 w zwi±zku z czym ten pakiet jest potrzebny tylko w sytuacji budowania
202 jakiej¶ niestandardowej bazy.
203
204 %package -n iconv
205 Summary:        Convert encoding of given files from one encoding to another
206 Summary(pl):    Program do konwersji plików tekstowych z jednego kodowania do innego
207 Group:          Daemons
208 Group(de):      Server
209 Group(pl):      Serwery
210 Requires:       %{name} = %{version}
211
212 %description -n iconv
213 Convert encoding of given files from one encoding to another. You need
214 this package if you want to convert some documet from one encoding to
215 another or if you have installed some programs which use Generic
216 Character Set Conversion Interface.
217
218 %description -n iconv -l pl
219 Program do konwersji plików tekstowych z jednego kodowania do innego.
220 Musisz mieæ zainstalowany ten pakiet je¿eli wykonujesz konwersjê
221 dokumentów z jednego kodowania do innego lub je¿eli masz zainstalowane
222 jakie¶ programy, które korzystaj± z Generic Character Set Conversion
223 Interface w glibc, czyli z zestawu funkcji z tej biblioteki, które
224 umo¿liwiaj± konwersjê kodowania danych z poziomu dowolnego programu.
225
226 %package static
227 Summary:        Static libraries
228 Summary(pl):    Biblioteki statyczne
229 Group:          Development/Libraries
230 Group(de):      Entwicklung/Libraries
231 Group(es):      Desarrollo/Bibliotecas
232 Group(fr):      Development/Librairies
233 Group(pl):      Programowanie/Biblioteki
234 Group(pt_BR):   Desenvolvimento/Bibliotecas
235 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
236 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
237 Requires:       %{name}-devel = %{version}
238
239 %description static
240 GNU libc static libraries.
241
242 %description static -l pl
243 Biblioteki statyczne GNU libc.
244
245 %package profile
246 Summary:        glibc with profiling support
247 Summary(de):    glibc mit Profil-Unterstützung
248 Summary(fr):    glibc avec support pour profiling
249 Summary(pl):    glibc ze wsparciem dla profilowania
250 Summary(tr):    Ölçüm desteði olan glibc
251 Group:          Development/Libraries/Libc
252 Group(de):      Entwicklung/Libraries/Libc
253 Group(pl):      Programowanie/Biblioteki/Libc
254 Obsoletes:      libc-profile
255 Requires:       %{name}-devel = %{version}
256
257 %description profile
258 When programs are being profiled used gprof, they must use these
259 libraries instead of the standard C libraries for gprof to be able to
260 profile them correctly.
261
262 %description profile -l de
263 Damit Programmprofile mit gprof richtig erstellt werden, müssen diese
264 Libraries anstelle der üblichen C-Libraries verwendet werden.
265
266 %description profile -l pl
267 Programy profilowane za pomoc± gprof musz± u¿ywaæ tych bibliotek
268 zamiast standardowych bibliotek C, aby gprof móg³ odpowiednio je
269 wyprofilowaæ.
270
271 %description profile -l tr
272 gprof kullanýlarak ölçülen programlar standart C kitaplýðý yerine bu
273 kitaplýðý kullanmak zorundadýrlar.
274
275 %package pic
276 Summary:        glibc PIC archive
277 Summary(pl):    archiwum PIC glibc
278 Group:          Development/Libraries/Libc
279 Group(de):      Entwicklung/Libraries/Libc
280 Group(pl):      Programowanie/Biblioteki/Libc
281 Requires:       %{name}-devel = %{version}
282
283 %description pic
284 GNU C Library PIC archive contains an archive library (ar file)
285 composed of individual shared objects. This is used for creating a
286 library which is a smaller subset of the standard libc shared library.
287
288 %description pic -l pl
289 Archiwum PIC biblioteki GNU C zawiera archiwaln± bibliotekê (plik ar)
290 z³o¿on± z pojedyñczych obiektów wspó³dzielonych. U¿ywana jest do
291 tworzenia biblioteki bêd±cej mniejszym podzestawem standardowej
292 biblioteki wspó³dzielonej libc.
293
294 %package -n nss_compat
295 Summary:        Old style NYS NSS glibc module
296 Summary(pl):    Stary modu³ NYS NSS glibc
297 Group:          Base
298 Group(de):      Gründsätzlich
299 Group(es):      Base
300 Group(pl):      Podstawowe
301 Group(pt_BR):   Base
302 Requires:       %{name} = %{version}
303
304 %description -n nss_compat
305 Old style NYS NSS glibc module.
306
307 %description -n nss_compat -l pl
308 Stary modu³ NYS NSS glibc.
309
310 %package -n nss_dns
311 Summary:        BIND NSS glibc module
312 Summary(pl):    Modu³ BIND NSS glibc
313 Group:          Base
314 Group(de):      Gründsätzlich
315 Group(es):      Base
316 Group(pl):      Podstawowe
317 Group(pt_BR):   Base
318 Requires:       %{name} = %{version}
319
320 %description -n nss_dns
321 BIND NSS glibc module.
322
323 %description -n nss_dns -l pl
324 Modu³ BIND NSS glibc.
325
326 %package -n nss_files
327 Summary:        Traditional files databases NSS glibc module
328 Summary(pl):    Modu³ tradycyjnych plikowych baz danych NSS glibc
329 Group:          Base
330 Group(de):      Gründsätzlich
331 Group(es):      Base
332 Group(pl):      Podstawowe
333 Group(pt_BR):   Base
334 Requires:       %{name} = %{version}
335
336 %description -n nss_files
337 Traditional files databases NSS glibc module.
338
339 %description -n nss_files -l pl
340 Modu³ tradycyjnych plikowych baz danych NSS glibc.
341
342 %package -n nss_hesiod
343 Summary:        Hesiod NSS glibc module
344 Summary(pl):    Modu³ hesiod NSS glibc
345 Group:          Base
346 Group(de):      Gründsätzlich
347 Group(es):      Base
348 Group(pl):      Podstawowe
349 Group(pt_BR):   Base
350 Requires:       %{name} = %{version}
351
352 %description -n nss_hesiod
353 glibc NSS (Name Service Switch) module for databases access.
354
355 %description -n nss_hesiod -l pl
356 Modu³ glibc NSS (Name Service Switch) dostêpu do baz danych.
357
358 %package -n nss_nis
359 Summary:        NIS(YP) NSS glibc module
360 Summary(pl):    Modu³ NIS(YP) NSS glibc
361 Group:          Base
362 Group(de):      Gründsätzlich
363 Group(es):      Base
364 Group(pl):      Podstawowe
365 Group(pt_BR):   Base
366 Requires:       %{name} = %{version}
367
368 %description -n nss_nis
369 glibc NSS (Name Service Switch) module for NIS(YP) databases access.
370
371 %description -n nss_nis -l pl
372 Modu³ glibc NSS (Name Service Switch) dostêpu do baz danych NIS(YP).
373
374 %package -n nss_nisplus
375 Summary:        NIS+ NSS module
376 Summary(pl):    Modu³ NIS+ NSS
377 Group:          Base
378 Group(de):      Gründsätzlich
379 Group(es):      Base
380 Group(pl):      Podstawowe
381 Group(pt_BR):   Base
382 Requires:       %{name} = %{version}
383
384 %description -n nss_nisplus
385 glibc NSS (Name Service Switch) module for NIS+ databases accesa.
386
387 %description -n nss_nisplus -l pl
388 Modu³ glibc NSS (Name Service Switch) dostêpu do baz danych NIS+.
389
390 %package memusage
391 Summary:        A toy
392 Summary(pl):    Zabawka
393 Group:          Applications
394 Group(de):      Applikationen
395 Group(pl):      Aplikacje
396 Requires:       %{name} = %{version}
397 Requires:       gd
398
399 %description memusage
400 A toy.
401
402 %description memusage -l pl
403 Zabawka.
404
405 %prep
406 %setup -q -a 1
407 %patch0 -p1
408 %patch1 -p1
409 %patch2 -p1
410 %patch3 -p1
411 %patch4 -p1
412 %patch5 -p1
413 %patch6 -p1
414 %patch7 -p1
415 %patch8 -p1
416 %patch9 -p1
417 %patch10 -p1
418 %patch11 -p1
419 %patch12 -p1
420
421 chmod +x scripts/cpp
422
423 %build
424 LDFLAGS=" " ; export LDFLAGS
425 %configure2_13 \
426         --enable-add-ons=linuxthreads \
427         --enable-kernel="%{?kernel:%{kernel}}%{!?kernel:%{min_kernel}}" \
428         --enable-profile \
429         --disable-omitfp
430
431 %{__make}
432
433 %install
434 rm -rf $RPM_BUILD_ROOT
435 install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,rc.d/init.d,sysconfig},%{_mandir}/man{3,8},/var/log}
436
437 env LANGUAGE=C LC_ALL=C \
438 %{__make} install \
439         install_root=$RPM_BUILD_ROOT \
440         infodir=%{_infodir} \
441         mandir=%{_mandir}
442
443 env LANGUAGE=C LC_ALL=C \
444 %{__make} install-locales -C localedata \
445         install_root=$RPM_BUILD_ROOT
446
447 PICFILES="libc_pic.a libc.map
448         math/libm_pic.a libm.map
449         resolv/libresolv_pic.a"
450
451 install $PICFILES                               $RPM_BUILD_ROOT%{_libdir}
452 install elf/soinit.os                           $RPM_BUILD_ROOT%{_libdir}/soinit.o
453 install elf/sofini.os                           $RPM_BUILD_ROOT%{_libdir}/sofini.o
454
455 mv -f $RPM_BUILD_ROOT/lib/libmemusage.so        $RPM_BUILD_ROOT%{_libdir}
456 mv -f $RPM_BUILD_ROOT/lib/libpcprofile.so       $RPM_BUILD_ROOT%{_libdir}
457
458 %{__make} -C linuxthreads/man
459 install linuxthreads/man/*.3thr                 $RPM_BUILD_ROOT%{_mandir}/man3
460
461 rm -rf $RPM_BUILD_ROOT%{_datadir}/zoneinfo/{localtime,posixtime,posixrules}
462
463 ln -sf ../../..%{_sysconfdir}/localtime         $RPM_BUILD_ROOT%{_datadir}/zoneinfo/localtime
464 ln -sf localtime                                $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixtime
465 ln -sf localtime                                $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixrules
466 ln -sf ../..%{_libdir}/libbsd-compat.a          $RPM_BUILD_ROOT%{_libdir}/libbsd.a
467
468 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/localtime
469
470 install %{SOURCE2}              $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
471 install %{SOURCE3}              $RPM_BUILD_ROOT/etc/sysconfig/nscd
472 install %{SOURCE4}              $RPM_BUILD_ROOT/etc/logrotate.d/nscd
473 install nscd/nscd.conf          $RPM_BUILD_ROOT%{_sysconfdir}
474 install nss/nsswitch.conf       $RPM_BUILD_ROOT%{_sysconfdir}
475
476 bzip2 -dc %{SOURCE5} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
477 bzip2 -dc %{SOURCE6} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
478 > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.cache
479 > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf
480 rm -f %{_mandir}/hu/man7/man.7
481
482 :> $RPM_BUILD_ROOT/var/log/nscd
483
484 rm -rf documentation
485 install -d documentation
486
487 cp -f linuxthreads/ChangeLog documentation/ChangeLog.threads
488 cp -f linuxthreads/Changes documentation/Changes.threads
489 cp -f linuxthreads/README documentation/README.threads
490 cp -f crypt/README.ufc-crypt documentation/
491
492 cp -f ChangeLog documentation
493
494 gzip -9nf README NEWS FAQ BUGS NOTES PROJECTS documentation/*
495
496 # strip ld.so with --strip-debug only (other ELFs are stripped by rpm):
497 %{!?debug:strip -g -R .comment -R .note $RPM_BUILD_ROOT/lib/ld-%{version}.so}
498
499 # Collect locale files and mark them with %%lang()
500 rm -f glibc.lang
501 for i in $RPM_BUILD_ROOT%{_datadir}/locale/* $RPM_BUILD_ROOT%{_libdir}/locale/* ; do
502         if [ -d $i ]; then
503                 lang=`echo $i | sed -e 's/.*locale\///' -e 's/\/.*//'`
504                 dir=`echo $i | sed "s#$RPM_BUILD_ROOT##"`
505                 echo "%lang($lang) $dir" >> glibc.lang
506         fi
507 done
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512 %post   -p /sbin/ldconfig
513 %postun -p /sbin/ldconfig
514
515 %post   memusage -p /sbin/ldconfig
516 %postun memusage -p /sbin/ldconfig
517
518 %post devel
519 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
520
521 %postun devel
522 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
523
524 %post -n nscd
525 /sbin/chkconfig --add nscd
526 touch /var/log/nscd && (chmod 000 /var/log/nscd; chown root.root /var/log/nscd; chmod 640 /var/log/nscd)
527 if [ -f /var/lock/subsys/nscd ]; then
528         /etc/rc.d/init.d/nscd restart 1>&2
529 else
530         echo "Run \"/etc/rc.d/init.d/nscd start\" to start nscd daemon." 1>&2
531 fi
532
533 %preun -n nscd
534 if [ "$1" = "0" ]; then
535         if [ -f /var/lock/subsys/nscd ]; then
536                 /etc/rc.d/init.d/nscd stop 1>&2
537         fi
538         /sbin/chkconfig --del nscd
539 fi
540
541 %files -f %{name}.lang
542 %defattr(644,root,root,755)
543 %doc {README,NEWS,FAQ,BUGS}.gz
544
545 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ld.so.conf
546 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/nsswitch.conf
547 %config %{_sysconfdir}/rpc
548 %ghost %{_sysconfdir}/ld.so.cache
549
550 %attr(755,root,root) /sbin/*
551 %attr(755,root,root) %{_bindir}/catchsegv
552 %attr(755,root,root) %{_bindir}/getent
553 %attr(755,root,root) %{_bindir}/glibcbug
554 %attr(755,root,root) %{_bindir}/iconv
555 %attr(755,root,root) %{_bindir}/ldd
556 %ifnarch alpha sparc sparc64 ppc
557 %attr(755,root,root) %{_bindir}/lddlibc4
558 %endif
559 %attr(755,root,root) %{_bindir}/locale
560 %attr(755,root,root) %{_bindir}/rpcgen
561 %attr(755,root,root) %{_bindir}/tzselect
562
563 %attr(755,root,root) %{_sbindir}/rpcinfo
564 %attr(755,root,root) %{_sbindir}/zdump
565 %attr(755,root,root) %{_sbindir}/zic
566
567 %attr(755,root,root) /lib/ld-*
568 %attr(755,root,root) /lib/libdl*
569 %attr(755,root,root) /lib/libnsl*
570 %attr(755,root,root) /lib/lib[BScmprtu]*
571
572 %dir %{_datadir}/locale
573 %{_datadir}/locale/locale.alias
574 %{_datadir}/zoneinfo
575
576 %dir %{_libdir}/locale
577
578 %{_mandir}/man1/[^ls]*
579 %{_mandir}/man1/locale.1*
580 %{_mandir}/man1/ldd.1*
581 %{_mandir}/man5/???[^d]*
582 %{_mandir}/man7/*
583 %{_mandir}/man8/[^n]*
584 %lang(cs) %{_mandir}/cs/man[578]/*
585 %lang(de) %{_mandir}/de/man[578]/*
586 %lang(es) %{_mandir}/es/man[578]/*
587 %lang(fi) %{_mandir}/fi/man1/ldd.1*
588 %lang(fr) %{_mandir}/fr/man1/ldd.1*
589 %lang(fr) %{_mandir}/fr/man[578]/*
590 %lang(hu) %{_mandir}/hu/man1/ldd.1*
591 %lang(hu) %{_mandir}/hu/man[578]/*
592 %lang(it) %{_mandir}/it/man[578]/*
593 %lang(ja) %{_mandir}/ja/man1/[^ls]*
594 %lang(ja) %{_mandir}/ja/man1/ldd.1*
595 %lang(ja) %{_mandir}/ja/man5/???[^d]*
596 %lang(ja) %{_mandir}/ja/man7/*
597 %lang(ja) %{_mandir}/ja/man8/[^n]*
598 %lang(ko) %{_mandir}/ko/man[578]/*
599 # %lang(nl) %{_mandir}/nl/man[578]/*
600 %lang(pl) %{_mandir}/pl/man1/ldd.1*
601 %lang(pl) %{_mandir}/pl/man[578]/*
602 %lang(pt) %{_mandir}/pt/man5/???[^d]*
603 %lang(pt) %{_mandir}/pt/man7/*
604 %lang(pt) %{_mandir}/pt/man8/[^n]*
605 %lang(pt_BR) %{_mandir}/pt_BR/man5/???[^d]*
606 %lang(pt_BR) %{_mandir}/pt_BR/man7/*
607 %lang(pt_BR) %{_mandir}/pt_BR/man8/[^n]*
608 %lang(ru) %{_mandir}/ru/man[578]/*
609
610 #%files -n nss_dns
611 %defattr(644,root,root,755)
612 %attr(755,root,root) /lib/libnss_dns*.so*
613
614 #%files -n nss_files
615 %defattr(644,root,root,755)
616 %attr(755,root,root) /lib/libnss_files*.so*
617
618 %files -n nss_compat
619 %defattr(644,root,root,755)
620 %attr(755,root,root) /lib/libnss_compat*.so*
621
622 %files -n nss_hesiod
623 %defattr(644,root,root,755)
624 %attr(755,root,root) /lib/libnss_hesiod*.so*
625
626 %files -n nss_nis
627 %defattr(644,root,root,755)
628 %attr(755,root,root) /lib/libnss_nis.so.*
629 %attr(755,root,root) /lib/libnss_nis-*.so
630
631 %files -n nss_nisplus
632 %defattr(644,root,root,755)
633 %attr(755,root,root) /lib/libnss_nisplus*.so*
634
635 %files memusage
636 %defattr(644,root,root,755)
637 %attr(755,root,root) %{_bindir}/memusage*
638 %attr(755,root,root) %{_libdir}/libmemusage*
639
640 %files devel
641 %defattr(644,root,root,755)
642 %doc documentation/* {NOTES,PROJECTS}.gz
643 %attr(755,root,root) %{_bindir}/gencat
644 %attr(755,root,root) %{_bindir}/getconf
645 %attr(755,root,root) %{_bindir}/*prof*
646 %attr(755,root,root) %{_bindir}/*trace
647
648 %{_includedir}/*
649
650 %{_infodir}/libc.info*
651
652 %attr(755,root,root) %{_libdir}/lib*.so
653 %attr(755,root,root) %{_libdir}/*crt*.o
654 %{_libdir}/libc_nonshared.a
655
656 %{_mandir}/man1/sprof*
657 %{_mandir}/man3/*
658 %lang(cs) %{_mandir}/cs/man3/*
659 %lang(de) %{_mandir}/de/man3/*
660 %lang(es) %{_mandir}/es/man3/*
661 %lang(fr) %{_mandir}/fr/man3/*
662 %lang(hu) %{_mandir}/hu/man3/*
663 # %lang(it) %{_mandir}/it/man3/*
664 %lang(ja) %{_mandir}/ja/man3/*
665 %lang(ko) %{_mandir}/ko/man3/*
666 %lang(nl) %{_mandir}/nl/man3/*
667 %lang(pl) %{_mandir}/pl/man3/*
668 %lang(pt) %{_mandir}/pt/man3/*
669 %lang(pt_BR) %{_mandir}/pt_BR/man3/*
670 %lang(ru) %{_mandir}/ru/man3/*
671
672 %files -n nscd
673 %defattr(644,root,root,755)
674 %attr(640,root,root) %config %verify(not md5 size mtime) /etc/sysconfig/nscd
675 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/nscd.*
676 %attr(754,root,root) /etc/rc.d/init.d/nscd
677 %attr(755,root,root) %{_sbindir}/nscd*
678 %attr(640,root,root) /etc/logrotate.d/nscd
679 %attr(640,root,root) %ghost /var/log/nscd
680 %{_mandir}/man5/nscd.conf*
681 %{_mandir}/man8/nscd*
682 %lang(ja) %{_mandir}/ja/man5/nscd.conf*
683 %lang(ja) %{_mandir}/ja/man8/nscd*
684 %lang(pt) %{_mandir}/pt/man5/nscd.conf*
685 %lang(pt) %{_mandir}/pt/man8/nscd*
686 %lang(pt_BR) %{_mandir}/pt_BR/man5/nscd.conf*
687 %lang(pt_BR) %{_mandir}/pt_BR/man8/nscd*
688
689 %files -n localedb-src
690 %defattr(644,root,root,755)
691 %attr(755,root,root) %{_bindir}/localedef
692 %{_datadir}/i18n
693 %{_mandir}/man1/localedef*
694
695 %files -n iconv
696 %defattr(644,root,root,755)
697 %dir %{_libdir}/gconv
698 %{_libdir}/gconv/gconv-modules
699 %attr(755,root,root) %{_libdir}/gconv/*.so
700
701 %files static
702 %defattr(644,root,root,755)
703 %{_libdir}/libBrokenLocale.a
704 %{_libdir}/libbsd-compat.a
705 %{_libdir}/libbsd.a
706 %{_libdir}/libc.a
707 %{_libdir}/libcrypt.a
708 %{_libdir}/libdl.a
709 %{_libdir}/libg.a
710 %{_libdir}/libieee.a
711 %{_libdir}/libm.a
712 %{_libdir}/libmcheck.a
713 %{_libdir}/libnsl.a
714 %{_libdir}/libpthread.a
715 %{_libdir}/libresolv.a
716 %{_libdir}/librpcsvc.a
717 %{_libdir}/librt.a
718 %{_libdir}/libutil.a
719
720 %files profile
721 %defattr(644,root,root,755)
722 %{_libdir}/lib*_p.a
723
724 %files pic
725 %defattr(644,root,root,755)
726 %{_libdir}/lib*_pic.a
727 %{_libdir}/lib*.map
728 %{_libdir}/soinit.o
729 %{_libdir}/sofini.o
This page took 0.107337 seconds and 3 git commands to generate.