]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
692bbba5c8c39c7f3cb244164b2f6094096272bf
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.10.0
10 Release:        1
11 License:        GPL v2 and LGPL v2
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.10/%{name}-%{version}.tar.bz2
14 # Source0-md5:  70c61582bdc6e9a852b29f3d172ddd4e
15 URL:            http://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel
19 BuildRequires:  gnome-common
20 BuildRequires:  gnome-doc-utils >= 0.18.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.1
22 BuildRequires:  gtk+3-devel >= 3.0.2
23 BuildRequires:  gtk-doc >= 1.13
24 BuildRequires:  intltool >= 0.41.0
25 BuildRequires:  libtool >= 2:2.2.6
26 BuildRequires:  libxml2-devel >= 1:2.4.0
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-pygobject-devel >= 2.28.0
29 BuildRequires:  rpmbuild(find_lang) >= 1.23
30 BuildRequires:  rpmbuild(macros) >= 1.311
31 Requires(post,postun):  gtk-update-icon-cache
32 Requires:       %{name}-libs = %{version}-%{release}
33 Requires:       hicolor-icon-theme
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Glade is a RAD tool to enable quick & easy development of user
38 interfaces for the GTK+ toolkit and the GNOME desktop environment.
39
40 The user interfaces designed in Glade are saved as XML, and by using
41 the GtkBuilder GTK+ object these can be loaded by applications
42 dynamically as needed.
43
44 By using GtkBuilder, Glade XML files can be used in numerous
45 programming languages including C, C++, C#, Vala, Java, Perl, Python
46 and others.
47
48 %description -l pl.UTF-8
49 Glade jest narzędziem typu RAD (Rapid Application Development) do
50 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
51 bibliotekę GTK+ i środowisko GNOME.
52
53 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
54 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
55 dynamicznie ładowane przez aplikacje.
56
57 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
58 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
59 i inne.
60
61 %package libs
62 Summary:        Glade library
63 Summary(pl.UTF-8):      Biblioteka Glade
64 Group:          X11/Libraries
65 Requires:       gtk+3 >= 3.0.2
66
67 %description libs
68 Glade library.
69
70 %description libs -l pl.UTF-8
71 Biblioteka Glade.
72
73 %package devel
74 Summary:        Header files for Glade library
75 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
76 Group:          X11/Development/Libraries
77 Requires:       %{name}-libs = %{version}-%{release}
78 Requires:       gtk+3-devel >= 3.0.2
79 Requires:       libxml2-devel >= 1:2.4.0
80
81 %description devel
82 Header files for Glade library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki Glade.
86
87 %package static
88 Summary:        Static Glade library
89 Summary(pl.UTF-8):      Statyczna biblioteka Glade
90 Group:          X11/Development/Libraries
91 Requires:       %{name}-devel = %{version}-%{release}
92
93 %description static
94 Static Glade library.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka Glade.
98
99 %package apidocs
100 Summary:        Glade API documentation
101 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
102 Group:          Documentation
103 Requires:       gtk-doc-common
104
105 %description apidocs
106 Glade API documentation.
107
108 %description apidocs -l pl.UTF-8
109 Dokumentacja API biblioteki Glade.
110
111 %prep
112 %setup -q
113
114 %build
115 %{__intltoolize}
116 %{__libtoolize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         --disable-silent-rules \
123         %{__enable_disable apidocs gtk-doc} \
124         %{__enable_disable static_libs static} \
125         --with-html-dir=%{_gtkdocdir}
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 rm $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
137
138 %find_lang %{name} --with-gnome --with-omf
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post
144 %update_icon_cache hicolor
145
146 %postun
147 %update_icon_cache hicolor
148
149 %post libs -p /sbin/ldconfig
150 %postun libs -p /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README TODO
155 %attr(755,root,root) %{_bindir}/glade
156 %attr(755,root,root) %{_bindir}/glade-previewer
157 %dir %{_libdir}/glade
158 %dir %{_libdir}/glade/modules
159 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
160 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
161 %{_datadir}/glade
162 %{_desktopdir}/glade.desktop
163 %{_iconsdir}/hicolor/*/*/*.png
164
165 %files libs
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
168 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.0
169 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libgladeui-2.so
174 %{_datadir}/gir-1.0/Gladeui-2.0.gir
175 %{_includedir}/libgladeui-2.0
176 %{_pkgconfigdir}/gladeui-2.0.pc
177
178 %if %{with static_libs}
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/libgladeui-2.a
182 %endif
183
184 %if %{with apidocs}
185 %files apidocs
186 %defattr(644,root,root,755)
187 %{_gtkdocdir}/gladeui
188 %endif
This page took 0.060795 seconds and 3 git commands to generate.