]> git.pld-linux.org Git - packages/glade.git/blob - glade.spec
- updated to 3.14; new soname
[packages/glade.git] / glade.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        User interface builder for GTK+ and GNOME
7 Summary(pl.UTF-8):      Budowniczy interfejsów użytkownika dla GTK+ i GNOME
8 Name:           glade
9 Version:        3.14.0
10 Release:        1
11 License:        GPL v2 and LGPL v2
12 Group:          X11/Applications
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/glade/3.14/%{name}-%{version}.tar.xz
14 # Source0-md5:  cd73934b7cd0dcb1c99a6d0589c73d48
15 URL:            http://glade.gnome.org/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1:1.11
18 BuildRequires:  gettext-devel
19 BuildRequires:  gnome-common
20 BuildRequires:  gnome-doc-utils >= 0.18.0
21 BuildRequires:  gobject-introspection-devel >= 0.10.1
22 BuildRequires:  gtk+3-devel >= 3.5.17
23 BuildRequires:  intltool >= 0.41.0
24 BuildRequires:  libtool >= 2:2.2.6
25 BuildRequires:  libxml2-devel >= 1:2.4.0
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-pygobject3-devel >= 3.0.0
28 BuildRequires:  rpmbuild(find_lang) >= 1.23
29 BuildRequires:  rpmbuild(macros) >= 1.311
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  yelp-tools
32 BuildRequires:  xz
33 Requires(post,postun):  gtk-update-icon-cache
34 Requires(post,postun):  desktop-file-utils
35 Requires:       %{name}-libs = %{version}-%{release}
36 Requires:       hicolor-icon-theme
37 Conflicts:      glade3 < 3.8.2
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Glade is a RAD tool to enable quick & easy development of user
42 interfaces for the GTK+ toolkit and the GNOME desktop environment.
43
44 The user interfaces designed in Glade are saved as XML, and by using
45 the GtkBuilder GTK+ object these can be loaded by applications
46 dynamically as needed.
47
48 By using GtkBuilder, Glade XML files can be used in numerous
49 programming languages including C, C++, C#, Vala, Java, Perl, Python
50 and others.
51
52 %description -l pl.UTF-8
53 Glade jest narzędziem typu RAD (Rapid Application Development) do
54 szybkiego i wygodnego tworzenia interfejsów użytkownika opartych o
55 bibliotekę GTK+ i środowisko GNOME.
56
57 Interfejsy użytkownika zaprojektowane w Glade są zapisywane w formacie
58 XML i poprzez użycie obiektu GtkBuilder, z biblioteki GTK+, mogą być
59 dynamicznie ładowane przez aplikacje.
60
61 Poprzez użycie GtkBuilder, pliki XML Glade mogą być używane w licznych
62 językach programowania, włączając C, C++, C#, Vala, Java, Perl, Python
63 i inne.
64
65 %package libs
66 Summary:        Glade library
67 Summary(pl.UTF-8):      Biblioteka Glade
68 Group:          X11/Libraries
69 Requires:       gtk+3 >= 3.4.0
70
71 %description libs
72 Glade library.
73
74 %description libs -l pl.UTF-8
75 Biblioteka Glade.
76
77 %package devel
78 Summary:        Header files for Glade library
79 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Glade
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-libs = %{version}-%{release}
82 Requires:       gtk+3-devel >= 3.4.0
83 Requires:       libxml2-devel >= 1:2.4.0
84
85 %description devel
86 Header files for Glade library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki Glade.
90
91 %package static
92 Summary:        Static Glade library
93 Summary(pl.UTF-8):      Statyczna biblioteka Glade
94 Group:          X11/Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static Glade library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka Glade.
102
103 %package apidocs
104 Summary:        Glade API documentation
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki Glade
106 Group:          Documentation
107 Requires:       gtk-doc-common
108
109 %description apidocs
110 Glade API documentation.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API biblioteki Glade.
114
115 %prep
116 %setup -q
117
118 %build
119 %{__intltoolize}
120 %{__libtoolize}
121 %{__aclocal} -I m4
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         --disable-silent-rules \
127         %{__enable_disable apidocs gtk-doc} \
128         %{__enable_disable static_libs static} \
129         --with-html-dir=%{_gtkdocdir}
130 %{__make}
131
132 %install
133 rm -rf $RPM_BUILD_ROOT
134
135 %{__make} install \
136         DESTDIR=$RPM_BUILD_ROOT
137
138 rm $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.{a,la}
139
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
141
142 %find_lang %{name} --with-gnome --with-omf
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %update_icon_cache hicolor
149 %update_desktop_database_post
150
151 %postun
152 %update_icon_cache hicolor
153 %update_desktop_database_postun
154
155 %post libs -p /sbin/ldconfig
156 %postun libs -p /sbin/ldconfig
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS ChangeLog NEWS README TODO
161 %attr(755,root,root) %{_bindir}/glade
162 %attr(755,root,root) %{_bindir}/glade-previewer
163 %dir %{_libdir}/glade
164 %dir %{_libdir}/glade/modules
165 %attr(755,root,root) %{_libdir}/glade/modules/libgladegtk.so
166 %attr(755,root,root) %{_libdir}/glade/modules/libgladepython.so
167 %{_datadir}/glade
168 %{_desktopdir}/glade.desktop
169 %{_iconsdir}/hicolor/*/*/*.png
170
171 %files libs
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libgladeui-2.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libgladeui-2.so.4
175 %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_libdir}/libgladeui-2.so
180 %{_datadir}/gir-1.0/Gladeui-2.0.gir
181 %{_includedir}/libgladeui-2.0
182 %{_pkgconfigdir}/gladeui-2.0.pc
183
184 %if %{with static_libs}
185 %files static
186 %defattr(644,root,root,755)
187 %{_libdir}/libgladeui-2.a
188 %endif
189
190 %if %{with apidocs}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %{_gtkdocdir}/gladeui-2
194 %endif
This page took 0.056797 seconds and 3 git commands to generate.