]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
- updated to 1.58.1
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  sysprof         # sysprof profiling
4 %bcond_without  systemtap       # systemtap/dtrace trace support
5 #
6 Summary:        JavaScript bindings for GNOME
7 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
8 Name:           gjs
9 Version:        1.58.1
10 Release:        1
11 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.58/%{name}-%{version}.tar.xz
14 # Source0-md5:  49ae54cccbf212e2f80fa1726d5f974c
15 URL:            https://wiki.gnome.org/Projects/Gjs
16 BuildRequires:  autoconf >= 2.64
17 BuildRequires:  automake >= 1:1.11.1
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-tools
21 BuildRequires:  glib2-devel >= 1:2.58.0
22 BuildRequires:  gobject-introspection-devel >= 1.41.4
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel >= 6:5.0
25 BuildRequires:  libtool >= 2:2.2.0
26 BuildRequires:  mozjs60-devel >= 60
27 BuildRequires:  pkgconfig
28 BuildRequires:  readline-devel
29 # pkgconfig(sysprof-capture-3)
30 %{?with_sysprof:BuildRequires:  sysprof-devel >= 3.34}
31 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
32 Requires:       glib2 >= 1:2.58.0
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Gjs allows using GNOME libraries from JavaScript. It is mainly based
37 on Spidermonkey JavaScript engine and the GObject introspection
38 framework.
39
40 %description -l pl.UTF-8
41 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
42 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
43
44 %package devel
45 Summary:        Header files for gjs library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       cairo-devel
50 Requires:       cairo-gobject-devel
51 Requires:       glib2-devel >= 1:2.58.0
52 Requires:       gobject-introspection-devel >= 1.41.4
53 Requires:       libffi-devel
54 Requires:       mozjs60-devel >= 60
55
56 %description devel
57 Header files for gjs library.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe biblioteki gjs.
61
62 %package -n systemtap-gjs
63 Summary:        systemtap/dtrace probes for gjs
64 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
65 Group:          Development/Tools
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       systemtap-client
68
69 %description -n systemtap-gjs
70 systemtap/dtrace probes for gjs.
71
72 %description -n systemtap-gjs -l pl.UTF-8
73 Sondy systemtap/dtrace dla gjs.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         --enable-profiler%{!?with_sysprof:=no} \
86         --disable-silent-rules \
87         %{?with_systemtap:--enable-systemtap}
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
93
94 %{__make} -j1 install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 cp -p examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
101 # belongs to installed-tests
102 %{__rm} $RPM_BUILD_ROOT%{_datadir}/glib-2.0/schemas/org.gnome.GjsTest.gschema.xml
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc COPYING NEWS README
113 %attr(755,root,root) %{_bindir}/gjs
114 %attr(755,root,root) %{_bindir}/gjs-console
115 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
117 %dir %{_libdir}/gjs
118 %dir %{_libdir}/gjs/girepository-1.0
119 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
120 %{_datadir}/gjs-1.0
121
122 %files devel
123 %defattr(644,root,root,755)
124 %attr(755,root,root) %{_libdir}/libgjs.so
125 %{_includedir}/gjs-1.0
126 %{_pkgconfigdir}/gjs-1.0.pc
127 %{_examplesdir}/%{name}-%{version}
128
129 %files -n systemtap-gjs
130 %defattr(644,root,root,755)
131 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.086118 seconds and 4 git commands to generate.