]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
- build with systemtap/dtrace support, added systemtap patch (fixes install path)
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  systemtap       # systemtap/dtrace trace support
4 #
5 Summary:        JavaScript bindings for GNOME
6 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
7 Name:           gjs
8 Version:        1.38.1
9 Release:        1
10 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.38/%{name}-%{version}.tar.xz
13 # Source0-md5:  0f3422a114cb69735274e75e325013a3
14 Patch0:         %{name}-systemtap.patch
15 URL:            http://live.gnome.org/Gjs
16 BuildRequires:  autoconf >= 2.61
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.36.0
22 BuildRequires:  gobject-introspection-devel >= 1.38.0
23 BuildRequires:  libffi-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 BuildRequires:  mozjs17-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  readline-devel
29 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
30 Requires:       glib2 >= 1:2.36.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Gjs allows using GNOME libraries from JavaScript. It is mainly based
35 on Spidermonkey JavaScript engine and the GObject introspection
36 framework.
37
38 %description -l pl.UTF-8
39 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
40 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
41
42 %package devel
43 Summary:        Header files for gjs library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       dbus-devel
48 Requires:       glib2-devel >= 1:2.36.0
49 Requires:       gobject-introspection-devel >= 1.38.0
50 Requires:       mozjs17-devel
51
52 %description devel
53 Header files for gjs library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe biblioteki gjs.
57
58 %package -n systemtap-gjs
59 Summary:        systemtap/dtrace probes for gjs
60 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
61 Group:          Development/Tools
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       systemtap-client
64
65 %description -n systemtap-gjs
66 systemtap/dtrace probes for gjs.
67
68 %description -n systemtap-gjs -l pl.UTF-8
69 Sondy systemtap/dtrace dla gjs.
70
71 %prep
72 %setup -q
73 %patch0 -p1
74
75 %build
76 %{__libtoolize}
77 %{__aclocal}
78 %{__autoconf}
79 %{__autoheader}
80 %{__automake}
81 %configure \
82         --disable-silent-rules \
83         %{?with_systemtap:--enable-systemtap}
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
89
90 %{__make} -j1 install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 cp examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc COPYING NEWS README
106 %attr(755,root,root) %{_bindir}/gjs
107 %attr(755,root,root) %{_bindir}/gjs-console
108 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
110 %dir %{_libdir}/gjs
111 %dir %{_libdir}/gjs/girepository-1.0
112 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
113 %{_datadir}/gjs-1.0
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libgjs.so
118 %{_includedir}/gjs-1.0
119 %{_pkgconfigdir}/gjs-1.0.pc
120 %{_pkgconfigdir}/gjs-internals-1.0.pc
121 %{_examplesdir}/%{name}-%{version}
122
123 %files -n systemtap-gjs
124 %defattr(644,root,root,755)
125 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.076496 seconds and 4 git commands to generate.