]> git.pld-linux.org Git - packages/gjs.git/blob - gjs.spec
Update to 1.40.1
[packages/gjs.git] / gjs.spec
1 #
2 # Conditional build:
3 %bcond_without  systemtap       # systemtap/dtrace trace support
4 #
5 Summary:        JavaScript bindings for GNOME
6 Summary(pl.UTF-8):      Wiązania JavaScriptu dla GNOME
7 Name:           gjs
8 Version:        1.40.1
9 Release:        1
10 License:        MIT and (MPL v1.1 or GPL v2+ or LGPL v2+)
11 Group:          Libraries
12 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gjs/1.40/%{name}-%{version}.tar.xz
13 # Source0-md5:  150580858bc40d0dbc9df43741eb2ad3
14 Patch0:         %{name}-systemtap.patch
15 URL:            http://live.gnome.org/Gjs
16 BuildRequires:  autoconf >= 2.61
17 BuildRequires:  automake
18 BuildRequires:  cairo-devel
19 BuildRequires:  cairo-gobject-devel
20 BuildRequires:  gettext-devel
21 BuildRequires:  glib2-devel >= 1:2.36.0
22 BuildRequires:  gobject-introspection-devel >= 1.39.3
23 BuildRequires:  gtk+3-devel
24 BuildRequires:  libffi-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  mozjs24-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  readline-devel
30 %{?with_systemtap:BuildRequires:        systemtap-sdt-devel}
31 Requires:       glib2 >= 1:2.36.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Gjs allows using GNOME libraries from JavaScript. It is mainly based
36 on Spidermonkey JavaScript engine and the GObject introspection
37 framework.
38
39 %description -l pl.UTF-8
40 Gjs pozwala używać bibliotek GNOME z JavaScriptem. Jest oparty głównie
41 na silniku JavaScriptu Spidermonkey i systemie GObject introspection.
42
43 %package devel
44 Summary:        Header files for gjs library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki gjs
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       dbus-devel
49 Requires:       glib2-devel >= 1:2.36.0
50 Requires:       gobject-introspection-devel >= 1.39.3
51 Requires:       mozjs24-devel
52
53 %description devel
54 Header files for gjs library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki gjs.
58
59 %package -n systemtap-gjs
60 Summary:        systemtap/dtrace probes for gjs
61 Summary(pl.UTF-8):      Sondy systemtap/dtrace dla gjs
62 Group:          Development/Tools
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       systemtap-client
65
66 %description -n systemtap-gjs
67 systemtap/dtrace probes for gjs.
68
69 %description -n systemtap-gjs -l pl.UTF-8
70 Sondy systemtap/dtrace dla gjs.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %{__libtoolize}
78 %{__aclocal}
79 %{__autoconf}
80 %{__autoheader}
81 %{__automake}
82 %configure \
83         --disable-silent-rules \
84         %{?with_systemtap:--enable-systemtap}
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 %{__make} -j1 install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 cp examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
95
96 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %files
105 %defattr(644,root,root,755)
106 %doc COPYING NEWS README
107 %attr(755,root,root) %{_bindir}/gjs
108 %attr(755,root,root) %{_bindir}/gjs-console
109 %attr(755,root,root) %{_libdir}/libgjs.so.*.*.*
110 %attr(755,root,root) %ghost %{_libdir}/libgjs.so.0
111 %dir %{_libdir}/gjs
112 %dir %{_libdir}/gjs/girepository-1.0
113 %{_libdir}/gjs/girepository-1.0/GjsPrivate-1.0.typelib
114
115 %files devel
116 %defattr(644,root,root,755)
117 %attr(755,root,root) %{_libdir}/libgjs.so
118 %{_includedir}/gjs-1.0
119 %{_pkgconfigdir}/gjs-1.0.pc
120 %{_pkgconfigdir}/gjs-internals-1.0.pc
121 %{_examplesdir}/%{name}-%{version}
122
123 %files -n systemtap-gjs
124 %defattr(644,root,root,755)
125 %{_datadir}/systemtap/tapset/gjs.stp
This page took 0.037462 seconds and 3 git commands to generate.