]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- git-core requires exact version of perl-Git
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.3.3
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  0430440eeb7c037afd4254bc6fd2cce8
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}-gitweb-lighttpd.conf
20 Source4:        %{name}.sysconfig
21 Source5:        %{name}.inet
22 Source6:        %{name}.init
23 Patch0:         %{name}-tests.patch
24 URL:            http://git-scm.com/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  perl-Error > 0.15
32 BuildRequires:  perl-base
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.264
37 BuildRequires:  zlib-devel
38 %if %{with doc}
39 BuildRequires:  asciidoc >= 7.1.2-3
40 BuildRequires:  docbook-dtd45-xml
41 BuildRequires:  xmlto
42 %endif
43 %if %{with tests}
44 %if %{with tests_cvs}
45 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
46 BuildRequires:  cvs-gnu-client < 1.13
47 BuildRequires:  cvs-gnu-client >= 1.12
48 %endif
49 BuildRequires:  pdksh >= 5.2.14-46
50 %endif
51 Requires:       coreutils
52 Requires:       diffutils
53 Requires:       findutils
54 Requires:       grep
55 Requires:       openssh-clients
56 Requires:       perl-Error
57 Requires:       perl-Git = %{version}-%{release}
58 Requires:       sed
59 Suggests:       git-core-cvs
60 Suggests:       git-core-svn
61 Suggests:       less
62 Suggests:       rsync
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # html docs have links to txt files
66 %define         _noautocompressdoc      *.txt
67
68 %define         webapp          gitweb
69 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
70 %define         appdir          %{_datadir}/%{webapp}
71 %define         cgibindir       %{_prefix}/lib/cgi-bin
72
73 %description
74 "git" can mean anything, depending on your mood.
75
76 - random three-letter combination that is pronounceable, and not
77   actually used by any common UNIX command. The fact that it is a
78   mispronunciation of "get" may or may not be relevant.
79 - stupid. contemptible and despicable. simple. Take your pick from the
80   dictionary of slang.
81 - "global information tracker": you're in a good mood, and it actually
82   works for you. Angels sing, and a light suddenly fills the room.
83 - "goddamn idiotic truckload of sh*t": when it breaks
84
85 This is a stupid (but extremely fast) directory content manager. It
86 doesn't do a whole lot, but what it 'does' do is track directory
87 contents efficiently.
88
89 %description -l pl.UTF-8
90 "git" może oznaczać cokolwiek, w zależności od nastroju.
91
92 - losową kombinację trzech liter, która jest wymawialna i właściwie
93   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
94   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
95 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
96 - "global information tracker" (narzędzie do globalnego śledzenia
97   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
98   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
99 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
100   g*) - kiedy się zepsuje.
101
102 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
103 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
104 katalogu.
105
106 %package doc
107 Summary:        Documentation for git-core
108 Summary(pl.UTF-8):      Dokumentacja do git-core
109 Group:          Documentation
110
111 %description doc
112 Documentation for git-core.
113
114 %description doc -l pl.UTF-8
115 Dokumentacja do git-core.
116
117 %description doc -l fr.UTF-8
118 Javadoc pour git-core.
119
120 %package daemon-inetd
121 Summary:        Files necessary to run git-daemon as an inetd service
122 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
123 Group:          Networking/Daemons
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       setup >= 2.4.11-1
126 Provides:       git-core-daemon
127 Obsoletes:      git-core-daemon
128 Obsoletes:      git-core-daemon-standalone
129
130 %description daemon-inetd
131 Git-daemon is a really simple TCP git daemon that can serve git
132 repositories. This package provides all necessarry files to run
133 git-daemon as an inetd service.
134
135 %description daemon-inetd -l pl.UTF-8
136 Git-daemon to prosty demon git korzystający z protokołu TCP do
137 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
138 do uruchomienia git-demona w trybie usługi inetd.
139
140 %package daemon-standalone
141 Summary:        Files necessary to run git-daemon as a standalone service
142 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
143 Group:          Networking/Daemons
144 Requires:       %{name} = %{version}-%{release}
145 Provides:       git-core-daemon
146 Obsoletes:      git-core-daemon
147 Obsoletes:      git-core-daemon-inetd
148
149 %description daemon-standalone
150 Git-daemon is a really simple TCP git daemon that can serve git
151 repositories. This package provides all necessarry files to run
152 git-daemon as an standalone service.
153
154 %description daemon-standalone -l pl.UTF-8
155 Git-daemon to prosty demon git korzystający z protokołu TCP do
156 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
157 do uruchomienia git-daemona w trybie usługi samodzielnej.
158
159 %package devel
160 Summary:        Header files for git-core
161 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
162 Group:          Development/Libraries
163 Requires:       zlib-devel
164
165 %description devel
166 Header files for git-core.
167
168 %description devel -l pl.UTF-8
169 Pliki nagłówkowe dla git-core.
170
171 %package gitk
172 Summary:        Tcl/Tk interface to the Git version control system
173 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
174 Group:          Development/Tools
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       tk
177
178 %description gitk
179 gitk displays changes in a repository or a selected set of commits.
180 This includes visualizing the commit graph, showing information
181 related to each commit, and the files in the trees of each revision.
182
183 Historically, gitk was the first repository browser. It's written in
184 Tcl/Tk and started off in a separate repository but was later merged
185 into the main git repository.
186
187 %description gitk -l pl.UTF-8
188 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
189 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
190 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
191
192 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
193 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
194 osobnym repozytorium, ale z czasem został włączony do głównego
195 repozytorium gita.
196
197 %package gitweb
198 Summary:        Web frontend to git
199 Summary(pl.UTF-8):      Frontend WWW do gita
200 Group:          Development/Tools
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       webapps
203 Requires:       webserver(alias)
204 Requires:       webserver(cgi)
205
206 %description gitweb
207 This package provides a web interface for browsing git repositories.
208
209 %description gitweb -l pl.UTF-8
210 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
211
212 %package gitview
213 Summary:        A GTK+ based repository browser for git
214 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       python >= 1:2.4
218 Requires:       python-pycairo >= 1.0
219 Requires:       python-pygobject
220 Requires:       python-pygtk-gtk >= 2:2.8
221 Suggests:       python-gnome-desktop-gtksourceview
222
223 %description gitview
224 A GTK+ based repository browser for git.
225
226 %description gitview -l pl.UTF-8
227 Oparta na GTK+ przeglądarka repozytorium gita.
228
229 %package gui
230 Summary:        Tcl/Tk interface to the Git version control system
231 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       tk
235 Requires:       xdg-utils
236 Suggests:       meld
237
238 %description gui
239 Displays changes in a repository or a selected set of commits. This
240 includes visualizing the commit graph, showing information related to
241 each commit, and the files in the trees of each revision.
242
243 Historically, gitk was the first repository browser. It's written in
244 Tcl/Tk and started off in a separate repository but was later merged
245 into the main git repository.
246
247 %description gui -l pl.UTF-8
248 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
249 to wizualizację grafu commitów, wyświetlanie informacji związanych z
250 każdym z commitów oraz listę plików dla każdej rewizji.
251
252 Z punktu widzenia historii, gitk był pierwszą przeglądarką
253 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
254 osobnym repozytorium, ale z czasem został włączony do głównego
255 repozytorium gita.
256
257 %package svn
258 Summary:        Subversion support for Git
259 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
260 Group:          Development/Tools
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       perl-Term-ReadKey
263
264 %description svn
265 Subversion support for Git.
266
267 %description svn -l pl.UTF-8
268 Obsługa Subversion dla Gita.
269
270 %package cvs
271 Summary:        CVS support for Git
272 Summary(pl.UTF-8):      Obsługa CVS dla Gita
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       cvsps >= 2.1-2
276 Requires:       rcs
277
278 %description cvs
279 CVS support for Git.
280
281 %description cvs -l pl.UTF-8
282 Obsługa CVS dla Gita.
283
284 %package arch
285 Summary:        Git tools for importing Arch repositories
286 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       tla
290
291 %description arch
292 Git tools for importing Arch repositories.
293
294 %description arch -l pl.UTF-8
295 Narzędzia Gita do importowania repozytoriów Archa.
296
297 %package email
298 Summary:        Git tools for sending email
299 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302
303 %description email
304 Git tools for sending email.
305
306 %description email -l pl.UTF-8
307 Narzędzia Gita do wysyłania poczty.
308
309 %package -n bash-completion-git
310 Summary:        bash-completion for git
311 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
312 Group:          Applications/Shells
313 Requires:       bash-completion
314
315 %description -n bash-completion-git
316 This package provides bash-completion for git.
317
318 %description -n bash-completion-git -l pl.UTF-8
319 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
320
321 %package -n perl-Git
322 Summary:        Perl interface to the Git version control system
323 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
324 Group:          Development/Languages/Perl
325 Obsoletes:      perl-git-core
326
327 %description -n perl-Git
328 This module provides Perl scripts easy way to interface the Git
329 version control system. The modules have an easy and well-tested way
330 to call arbitrary Git commands; in the future, the interface will also
331 provide specialized methods for doing easily operations which are not
332 totally trivial to do over the generic command interface.
333
334 %description -n perl-Git -l pl.UTF-8
335 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
336 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
337 dowolne polecenia Gita; w przyszłości interfejs udostępni także
338 specjalne metody do łatwego wykonywania operacji nietrywialnych do
339 wykonania przy użyciu ogólnego interfejsu poleceń.
340
341 %package -n python-Git
342 Summary:        Python interface to the Git version control system
343 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
344 Group:          Development/Languages/Python
345
346 %description -n python-Git
347 This module provides Python scripts easy way to interface the Git
348 version control system.
349
350 %description -n python-Git -l pl.UTF-8
351 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
352 wersji Git.
353
354 %package -n vim-syntax-gitcommit
355 Summary:        Vim syntax: gitcommit
356 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
357 Group:          Applications/Editors/Vim
358 # for _vimdatadir existence
359 Requires:       vim-rt >= 4:6.3.058-3
360
361 %description -n vim-syntax-gitcommit
362 This plugin provides syntax highlighting for git's commit messages.
363
364 %description -n vim-syntax-gitcommit -l pl.UTF-8
365 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
366
367 %prep
368 %setup -q -n git-%{version}
369 %patch0 -p1
370
371 %build
372 %{__aclocal}
373 %{__autoconf}
374 %configure \
375         --with-openssl
376
377 echo "BLK_SHA1=1" >> config.mak
378
379 %{__make} \
380         INSTALLDIRS=vendor \
381         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
382         GITWEB_PROJECTROOT="/var/lib/git" \
383         GITWEB_CSS="/gitweb/gitweb.css" \
384         GITWEB_LOGO="/gitweb/git-logo.png" \
385         GITWEB_FAVICON="/gitweb/git-favicon.png" \
386         V=1
387
388 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
389 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
390
391 %if %{with tests}
392 %if %{without tests_cvs}
393 rm t/t*cvs*.sh || :
394 %endif
395 %{__make} test
396 %endif
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
401 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
402 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
403
404 %{__make} install \
405         INSTALLDIRS=vendor \
406         DESTDIR=$RPM_BUILD_ROOT
407
408 %if %{with doc}
409 %{__make} -C Documentation install \
410         DESTDIR=$RPM_BUILD_ROOT
411 %endif
412
413 # header files and lib
414 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
415 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
416 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
417 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
418 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
419
420 # bash completion
421 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
422 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
423
424 # vim syntax
425 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
426 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
427 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
428 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
429 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
430 autocmd BufNewFile,BufRead .msg.[0-9]*
431         \ if getline(1) =~ '^From.*# This line is ignored.$' |
432         \   setf gitsendemail |
433         \ endif
434 autocmd BufNewFile,BufRead *.git/**
435         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
436         \   setf git |
437         \ endif
438 EOF
439
440 # gitweb
441 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
442 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
443 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
444 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
445 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
446
447 # gitview
448 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
449
450 # git-daemon related files
451 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
452 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
453 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
454
455 # paths cleanup
456 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
457 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
458
459 # hardlink
460 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
461 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
462 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
463 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
464
465 # remove unneeded files
466 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
467 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
468 %py_postclean
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %post daemon-inetd
474 %service -q rc-inetd reload
475
476 %postun daemon-inetd
477 if [ "$1" = "0" ]; then
478         %service -q rc-inetd reload
479 fi
480
481 %post daemon-standalone
482 /sbin/chkconfig --add git-daemon
483 %service git-daemon restart "git-daemon"
484
485 %preun daemon-standalone
486 if [ "$1" = "0" ]; then
487         %service git-daemon stop
488         /sbin/chkconfig --del git-daemon
489 fi
490
491 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
492 %webapp_register apache %{webapp}
493
494 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
495 %webapp_unregister apache %{webapp}
496
497 %triggerin gitweb -- apache < 2.2.0, apache-base
498 %webapp_register httpd %{webapp}
499
500 %triggerun gitweb -- apache < 2.2.0, apache-base
501 %webapp_unregister httpd %{webapp}
502
503 %triggerin gitweb -- lighttpd
504 %webapp_register lighttpd %{webapp}
505
506 %triggerun gitweb -- lighttpd
507 %webapp_unregister lighttpd %{webapp}
508
509 %files
510 %defattr(644,root,root,755)
511 %doc README contrib
512 %attr(755,root,root) %{_bindir}/git
513 %attr(755,root,root) %{_bindir}/git-receive-pack
514 %attr(755,root,root) %{_bindir}/git-shell
515 %attr(755,root,root) %{_bindir}/git-upload-archive
516 %attr(755,root,root) %{_bindir}/git-upload-pack
517
518 %if %{with doc}
519 %{_mandir}/man1/git-*.1*
520 %exclude %{_mandir}/man1/git-svn.1*
521 %exclude %{_mandir}/man1/git-cvs*.1*
522 %{_mandir}/man1/git.1*
523 %{_mandir}/man5/gitattributes.5*
524 %{_mandir}/man5/githooks.5*
525 %{_mandir}/man5/gitignore.5*
526 %{_mandir}/man5/gitmodules.5*
527 %{_mandir}/man5/gitrepository-layout.5*
528 %{_mandir}/man7/gitcli.7*
529 %{_mandir}/man7/gitcore-tutorial.7*
530 %{_mandir}/man7/gitdiffcore.7*
531 %{_mandir}/man7/gitglossary.7*
532 %{_mandir}/man7/gitrevisions.7*
533 %{_mandir}/man7/gittutorial-2.7*
534 %{_mandir}/man7/gittutorial.7*
535 %{_mandir}/man7/gitworkflows.7*
536 %endif
537
538 %dir %{_libdir}/%{name}
539 %attr(755,root,root) %{_libdir}/%{name}/*-*
540 %attr(755,root,root) %{_libdir}/%{name}/git
541
542 %exclude %{_libdir}/%{name}/git-gui
543 %exclude %{_libdir}/%{name}/git-svn
544 %exclude %{_libdir}/%{name}/git-archimport
545 %exclude %{_libdir}/%{name}/git-cvs*
546 %exclude %{_libdir}/%{name}/*email*
547
548 %{_datadir}/%{name}
549
550 %{_localstatedir}/lib/git
551
552 %if %{with doc}
553 %files doc
554 %defattr(644,root,root,755)
555 %doc Documentation/RelNotes*
556 %doc Documentation/*.html Documentation/howto Documentation/technical
557 %endif
558
559 %files daemon-inetd
560 %defattr(644,root,root,755)
561 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
562
563 %files daemon-standalone
564 %defattr(644,root,root,755)
565 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
566 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
567
568 %files devel
569 %defattr(644,root,root,755)
570 %{_includedir}/git-core
571 %{_libdir}/libgit.a
572 %{_libdir}/libgit_xdiff.a
573
574 %files gitk
575 %defattr(644,root,root,755)
576 %if %{with doc}
577 %{_mandir}/man1/gitk.1*
578 %endif
579 %attr(755,root,root) %{_bindir}/gitk
580 %dir %{_datadir}/gitk
581 %dir %{_datadir}/gitk/lib
582 %dir %{_datadir}/gitk/lib/msgs
583 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
584 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
585 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
586 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
587 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
588 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
589 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
590 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
591
592 %files gitweb
593 %defattr(644,root,root,755)
594 %doc gitweb/{README,INSTALL}
595 %dir %{webappdir}
596 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
597 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
598 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
599 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
600 %attr(755,root,root) %{cgibindir}/gitweb.cgi
601 %{appdir}
602
603 %files gitview
604 %defattr(644,root,root,755)
605 %doc contrib/gitview/gitview.txt
606 %attr(755,root,root) %{_bindir}/gitview
607
608 %files gui
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/%{name}/git-gui
611 %dir %{_datadir}/git-gui
612 %dir %{_datadir}/git-gui/lib
613 %dir %{_datadir}/git-gui/lib/msgs
614 %{_datadir}/git-gui/lib/git-gui.ico
615 %{_datadir}/git-gui/lib/tclIndex
616 %{_datadir}/git-gui/lib/*.js
617 %{_datadir}/git-gui/lib/*.tcl
618 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
619 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
620 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
621 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
622 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
623 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
624 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
625 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
626 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
627 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
628
629 %files svn
630 %defattr(644,root,root,755)
631 %attr(755,root,root) %{_libdir}/%{name}/git-svn
632 %if %{with doc}
633 %{_mandir}/man1/git-svn.1*
634 %endif
635
636 %files cvs
637 %defattr(644,root,root,755)
638 %attr(755,root,root) %{_bindir}/git-cvsserver
639 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
640 %if %{with doc}
641 %{_mandir}/man1/git-cvs*.1*
642 %{_mandir}/man7/gitcvs-migration.7*
643 %endif
644
645 %files arch
646 %defattr(644,root,root,755)
647 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
648 %if %{with doc}
649 %{_mandir}/man1/git-archimport.1*
650 %endif
651
652 %files email
653 %defattr(644,root,root,755)
654 %attr(755,root,root) %{_libdir}/%{name}/*email*
655 %if %{with doc}
656 %{_mandir}/man1/*email*.1*
657 %endif
658
659 %files -n bash-completion-git
660 %defattr(644,root,root,755)
661 %{_sysconfdir}/bash_completion.d/*
662
663 %files -n perl-Git
664 %defattr(644,root,root,755)
665 %{perl_vendorlib}/Git.pm
666 %{_mandir}/man3/Git.3pm*
667
668 %files -n python-Git
669 %defattr(644,root,root,755)
670 %dir %{py_sitescriptdir}/git_remote_helpers
671 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
672 %dir %{py_sitescriptdir}/git_remote_helpers/git
673 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
674 %if "%{py_ver}" > "2.4"
675 %{py_sitescriptdir}/git_remote_helpers*.egg-info
676 %endif
677
678 %files -n vim-syntax-gitcommit
679 %defattr(644,root,root,755)
680 %doc contrib/vim/README
681 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.072507 seconds and 4 git commands to generate.