]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- gui S: meld
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.1.1
12 Release:        2
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  1b116a3e2ecce46a89e4272abf0de955
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 Patch0:         %{name}-tests.patch
23 Patch1:         %{name}-libcrypto.patch
24 URL:            http://git-scm.com/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  perl-Error > 0.15
32 BuildRequires:  perl-base
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.264
37 BuildRequires:  zlib-devel
38 %if %{with doc}
39 BuildRequires:  asciidoc >= 7.1.2-3
40 BuildRequires:  docbook-dtd45-xml
41 BuildRequires:  xmlto
42 %endif
43 %if %{with tests}
44 %if %{with tests_cvs}
45 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
46 BuildRequires:  cvs-gnu-client < 1.13
47 BuildRequires:  cvs-gnu-client >= 1.12
48 %endif
49 BuildRequires:  pdksh >= 5.2.14-46
50 %endif
51 Requires:       coreutils
52 Requires:       diffutils
53 Requires:       findutils
54 Requires:       grep
55 Requires:       openssh-clients
56 Requires:       perl-Error
57 Requires:       sed
58 Suggests:       git-core-cvs
59 Suggests:       git-core-svn
60 Suggests:       less
61 Suggests:       rsync
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # html docs have links to txt files
65 %define         _noautocompressdoc      *.txt
66
67 %define         webapp          gitweb
68 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
69 %define         appdir          %{_datadir}/%{webapp}
70 %define         cgibindir       %{_prefix}/lib/cgi-bin
71
72 %description
73 "git" can mean anything, depending on your mood.
74
75 - random three-letter combination that is pronounceable, and not
76   actually used by any common UNIX command. The fact that it is a
77   mispronunciation of "get" may or may not be relevant.
78 - stupid. contemptible and despicable. simple. Take your pick from the
79   dictionary of slang.
80 - "global information tracker": you're in a good mood, and it actually
81   works for you. Angels sing, and a light suddenly fills the room.
82 - "goddamn idiotic truckload of sh*t": when it breaks
83
84 This is a stupid (but extremely fast) directory content manager. It
85 doesn't do a whole lot, but what it 'does' do is track directory
86 contents efficiently.
87
88 %description -l pl.UTF-8
89 "git" może oznaczać cokolwiek, w zależności od nastroju.
90
91 - losową kombinację trzech liter, która jest wymawialna i właściwie
92   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
93   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
94 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
95 - "global information tracker" (narzędzie do globalnego śledzenia
96   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
97   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
98 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
99   g*) - kiedy się zepsuje.
100
101 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
102 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
103 katalogu.
104
105 %package doc
106 Summary:        Documentation for git-core
107 Summary(pl.UTF-8):      Dokumentacja do git-core
108 Group:          Documentation
109
110 %description doc
111 Documentation for git-core.
112
113 %description doc -l pl.UTF-8
114 Dokumentacja do git-core.
115
116 %description doc -l fr.UTF-8
117 Javadoc pour git-core.
118
119 %package daemon-inetd
120 Summary:        Files necessary to run git-daemon as an inetd service
121 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
122 Group:          Networking/Daemons
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       setup >= 2.4.11-1
125 Provides:       git-core-daemon
126 Obsoletes:      git-core-daemon
127 Obsoletes:      git-core-daemon-standalone
128
129 %description daemon-inetd
130 Git-daemon is a really simple TCP git daemon that can serve git
131 repositories. This package provides all necessarry files to run
132 git-daemon as an inetd service.
133
134 %description daemon-inetd -l pl.UTF-8
135 Git-daemon to prosty demon git korzystający z protokołu TCP do
136 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
137 do uruchomienia git-demona w trybie usługi inetd.
138
139 %package daemon-standalone
140 Summary:        Files necessary to run git-daemon as a standalone service
141 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
142 Group:          Networking/Daemons
143 Requires:       %{name} = %{version}-%{release}
144 Provides:       git-core-daemon
145 Obsoletes:      git-core-daemon
146 Obsoletes:      git-core-daemon-inetd
147
148 %description daemon-standalone
149 Git-daemon is a really simple TCP git daemon that can serve git
150 repositories. This package provides all necessarry files to run
151 git-daemon as an standalone service.
152
153 %description daemon-standalone -l pl.UTF-8
154 Git-daemon to prosty demon git korzystający z protokołu TCP do
155 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
156 do uruchomienia git-daemona w trybie usługi samodzielnej.
157
158 %package devel
159 Summary:        Header files for git-core
160 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
161 Group:          Development/Libraries
162 Requires:       zlib-devel
163
164 %description devel
165 Header files for git-core.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe dla git-core.
169
170 %package gitk
171 Summary:        Tcl/Tk interface to the Git version control system
172 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
173 Group:          Development/Tools
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       tk
176
177 %description gitk
178 gitk displays changes in a repository or a selected set of commits.
179 This includes visualizing the commit graph, showing information
180 related to each commit, and the files in the trees of each revision.
181
182 Historically, gitk was the first repository browser. It's written in
183 Tcl/Tk and started off in a separate repository but was later merged
184 into the main git repository.
185
186 %description gitk -l pl.UTF-8
187 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
188 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
189 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
190
191 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
192 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
193 osobnym repozytorium, ale z czasem został włączony do głównego
194 repozytorium gita.
195
196 %package gitweb
197 Summary:        Web frontend to git
198 Summary(pl.UTF-8):      Webowy frontend do git
199 Group:          Development/Tools
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       webapps
202
203 %description gitweb
204 This package provides a web interface for browsing git repositories.
205
206 %description gitweb -l pl.UTF-8
207 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
208
209 %package gitview
210 Summary:        A GTK+ based repository browser for git
211 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
212 Group:          Development/Tools
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       python >= 1:2.4
215 Requires:       python-pycairo >= 1.0
216 Requires:       python-pygobject
217 Requires:       python-pygtk-gtk >= 2:2.8
218 Suggests:       python-gnome-desktop-gtksourceview
219
220 %description gitview
221 A GTK+ based repository browser for git.
222
223 %description gitview -l pl.UTF-8
224 Oparta na GTK+ przeglądarka repozytorium gita.
225
226 %package gui
227 Summary:        Tcl/Tk interface to the Git version control system
228 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
229 Group:          Development/Tools
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       tk
232 Suggests:       meld
233
234 %description gui
235 Displays changes in a repository or a selected set of commits. This
236 includes visualizing the commit graph, showing information related to
237 each commit, and the files in the trees of each revision.
238
239 Historically, gitk was the first repository browser. It's written in
240 Tcl/Tk and started off in a separate repository but was later merged
241 into the main git repository.
242
243 %description gui -l pl.UTF-8
244 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
245 to wizualizację grafu commitów, wyświetlanie informacji związanych z
246 każdym z commitów oraz listę plików dla każdej rewizji.
247
248 Z punktu widzenia historii, gitk był pierwszą przeglądarką
249 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
250 osobnym repozytorium, ale z czasem został włączony do głównego
251 repozytorium gita.
252
253 %package svn
254 Summary:        Subversion support for Git
255 Summary(pl.UTF-8):      Obsługa Subversion dla Git
256 Group:          Development/Tools
257 Requires:       %{name} = %{version}-%{release}
258
259 %description svn
260 Subversion support for Git.
261
262 %description svn -l pl.UTF-8
263 Obsługa Subversion dla Git.
264
265 %package cvs
266 Summary:        CVS support for Git
267 Summary(pl.UTF-8):      Obsługa CVS dla Git
268 Group:          Development/Tools
269 Requires:       %{name} = %{version}-%{release}
270 Requires:       cvsps >= 2.1-2
271 Requires:       rcs
272
273 %description cvs
274 CVS support for Git.
275
276 %description cvs -l pl.UTF-8
277 Obsługa CVS dla Git.
278
279 %package arch
280 Summary:        Git tools for importing Arch repositories
281 Group:          Development/Tools
282 Requires:       %{name} = %{version}-%{release}
283 Requires:       tla
284
285 %description arch
286 Git tools for importing Arch repositories.
287
288 %package email
289 Summary:        Git tools for sending email
290 Group:          Development/Tools
291 Requires:       %{name} = %{version}-%{release}
292
293 %description email
294 Git tools for sending email.
295
296 %package -n bash-completion-git
297 Summary:        bash-completion for git
298 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
299 Group:          Applications/Shells
300 Requires:       bash-completion
301
302 %description -n bash-completion-git
303 This package provides bash-completion for git.
304
305 %description -n bash-completion-git -l pl.UTF-8
306 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
307
308 %package -n perl-Git
309 Summary:        Perl interface to the Git version control system
310 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
311 Group:          Development/Languages/Perl
312 Obsoletes:      perl-git-core
313
314 %description -n perl-Git
315 This module provides Perl scripts easy way to interface the Git
316 version control system. The modules have an easy and well-tested way
317 to call arbitrary Git commands; in the future, the interface will also
318 provide specialized methods for doing easily operations which are not
319 totally trivial to do over the generic command interface.
320
321 %description -n perl-Git -l pl.UTF-8
322 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
323 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
324 dowolne polecenia Gita; w przyszłości interfejs udostępni także
325 specjalne metody do łatwego wykonywania operacji nietrywialnych do
326 wykonania przy użyciu ogólnego interfejsu poleceń.
327
328 %package -n python-Git
329 Summary:        Python interface to the Git version control system
330 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
331 Group:          Development/Languages/Python
332
333 %description -n python-Git
334 This module provides Python scripts easy way to interface the Git
335 version control system.
336
337 %description -n python-Git -l pl.UTF-8
338 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
339 wersji Git.
340
341 %package -n vim-syntax-gitcommit
342 Summary:        Vim syntax: gitcommit
343 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
344 Group:          Applications/Editors/Vim
345 # for _vimdatadir existence
346 Requires:       vim-rt >= 4:6.3.058-3
347
348 %description -n vim-syntax-gitcommit
349 This plugin provides syntax highlighting for git's commit messages.
350
351 %description -n vim-syntax-gitcommit -l pl.UTF-8
352 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
353
354 %prep
355 %setup -q -n git-%{version}
356 %patch0 -p1
357 %patch1 -p0
358
359 %build
360 %{__aclocal}
361 %{__autoconf}
362 %configure \
363         --with-openssl
364
365 echo "BLK_SHA1=1" >> config.mak
366
367 %{__make} \
368         INSTALLDIRS=vendor \
369         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
370         GITWEB_PROJECTROOT="/var/lib/git" \
371         GITWEB_CSS="/gitweb/gitweb.css" \
372         GITWEB_LOGO="/gitweb/git-logo.png" \
373         GITWEB_FAVICON="/gitweb/git-favicon.png"
374
375 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
376 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
377
378 %if %{with tests}
379 %if %{without tests_cvs}
380 rm t/t*cvs*.sh || :
381 %endif
382 %{__make} test
383 %endif
384
385 %install
386 rm -rf $RPM_BUILD_ROOT
387 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
388 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
389 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
390
391 %{__make} install \
392         INSTALLDIRS=vendor \
393         DESTDIR=$RPM_BUILD_ROOT
394
395 %if %{with doc}
396 %{__make} -C Documentation install \
397         DESTDIR=$RPM_BUILD_ROOT
398 %endif
399
400 # header files and lib
401 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
402 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
403 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
404 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
405 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
406
407 # bash completion
408 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
409 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
410
411 # vim syntax
412 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
413 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
414 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
415 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
416 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
417 autocmd BufNewFile,BufRead .msg.[0-9]*
418         \ if getline(1) =~ '^From.*# This line is ignored.$' |
419         \   setf gitsendemail |
420         \ endif
421 autocmd BufNewFile,BufRead *.git/**
422         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
423         \   setf git |
424         \ endif
425 EOF
426
427 # gitweb
428 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
429 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
430 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
431 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
432 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
433
434 # gitview
435 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
436
437 # git-daemon related files
438 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
439 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
440 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
441
442 # paths cleanup
443 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
444 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
445
446 # hardlink
447 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
448 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
449 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
450 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
451
452 # remove unneeded files
453 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
454 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
455 %py_postclean
456
457 %clean
458 rm -rf $RPM_BUILD_ROOT
459
460 %post daemon-inetd
461 %service -q rc-inetd reload
462
463 %postun daemon-inetd
464 if [ "$1" = "0" ]; then
465         %service -q rc-inetd reload
466 fi
467
468 %post daemon-standalone
469 /sbin/chkconfig --add git-daemon
470 %service git-daemon restart "git-daemon"
471
472 %preun daemon-standalone
473 if [ "$1" = "0" ]; then
474         %service git-daemon stop
475         /sbin/chkconfig --del git-daemon
476 fi
477
478 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
479 %webapp_register apache %{webapp}
480
481 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
482 %webapp_unregister apache %{webapp}
483
484 %triggerin gitweb -- apache < 2.2.0, apache-base
485 %webapp_register httpd %{webapp}
486
487 %triggerun gitweb -- apache < 2.2.0, apache-base
488 %webapp_unregister httpd %{webapp}
489
490 %files
491 %defattr(644,root,root,755)
492 %doc README contrib
493 %attr(755,root,root) %{_bindir}/git
494 %attr(755,root,root) %{_bindir}/git-receive-pack
495 %attr(755,root,root) %{_bindir}/git-shell
496 %attr(755,root,root) %{_bindir}/git-upload-archive
497 %attr(755,root,root) %{_bindir}/git-upload-pack
498
499 %if %{with doc}
500 %{_mandir}/man1/git-*.1*
501 %exclude %{_mandir}/man1/git-svn.1*
502 %exclude %{_mandir}/man1/git-cvs*.1*
503 %{_mandir}/man1/git.1*
504 %{_mandir}/man5/gitattributes.5*
505 %{_mandir}/man5/githooks.5*
506 %{_mandir}/man5/gitignore.5*
507 %{_mandir}/man5/gitmodules.5*
508 %{_mandir}/man5/gitrepository-layout.5*
509 %{_mandir}/man7/gitcli.7*
510 %{_mandir}/man7/gitcore-tutorial.7*
511 %{_mandir}/man7/gitdiffcore.7*
512 %{_mandir}/man7/gitglossary.7*
513 %{_mandir}/man7/gittutorial-2.7*
514 %{_mandir}/man7/gittutorial.7*
515 %{_mandir}/man7/gitworkflows.7*
516 %endif
517
518 %dir %{_libdir}/%{name}
519 %attr(755,root,root) %{_libdir}/%{name}/*-*
520 %attr(755,root,root) %{_libdir}/%{name}/git
521
522 %exclude %{_libdir}/%{name}/git-gui
523 %exclude %{_libdir}/%{name}/git-svn
524 %exclude %{_libdir}/%{name}/git-archimport
525 %exclude %{_libdir}/%{name}/git-cvs*
526 %exclude %{_libdir}/%{name}/*email*
527
528 %{_datadir}/%{name}
529
530 %{_localstatedir}/lib/git
531
532 %if %{with doc}
533 %files doc
534 %defattr(644,root,root,755)
535 %doc Documentation/RelNotes*
536 %doc Documentation/*.html Documentation/howto Documentation/technical
537 %endif
538
539 %files daemon-inetd
540 %defattr(644,root,root,755)
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
542
543 %files daemon-standalone
544 %defattr(644,root,root,755)
545 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
546 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
547
548 %files devel
549 %defattr(644,root,root,755)
550 %{_includedir}/git-core
551 %{_libdir}/libgit.a
552 %{_libdir}/libgit_xdiff.a
553
554 %files gitk
555 %defattr(644,root,root,755)
556 %if %{with doc}
557 %{_mandir}/man1/gitk.1*
558 %endif
559 %attr(755,root,root) %{_bindir}/gitk
560 %dir %{_datadir}/gitk
561 %dir %{_datadir}/gitk/lib
562 %dir %{_datadir}/gitk/lib/msgs
563 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
564 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
565 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
566 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
567 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
568 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
569 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
570 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
571
572 %files gitweb
573 %defattr(644,root,root,755)
574 %doc gitweb/{README,INSTALL}
575 %dir %{webappdir}
576 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
577 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
578 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
579 %attr(755,root,root) %{cgibindir}/gitweb.cgi
580 %{appdir}
581
582 %files gitview
583 %defattr(644,root,root,755)
584 %doc contrib/gitview/gitview.txt
585 %attr(755,root,root) %{_bindir}/gitview
586
587 %files gui
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_libdir}/%{name}/git-gui
590 %dir %{_datadir}/git-gui
591 %dir %{_datadir}/git-gui/lib
592 %dir %{_datadir}/git-gui/lib/msgs
593 %{_datadir}/git-gui/lib/git-gui.ico
594 %{_datadir}/git-gui/lib/tclIndex
595 %{_datadir}/git-gui/lib/*.js
596 %{_datadir}/git-gui/lib/*.tcl
597 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
598 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
599 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
600 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
601 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
602 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
603 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
604 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
605 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
606 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
607
608 %files svn
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_libdir}/%{name}/git-svn
611 %if %{with doc}
612 %{_mandir}/man1/git-svn.1*
613 %endif
614
615 %files cvs
616 %defattr(644,root,root,755)
617 %attr(755,root,root) %{_bindir}/git-cvsserver
618 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
619 %if %{with doc}
620 %{_mandir}/man1/git-cvs*.1*
621 %{_mandir}/man7/gitcvs-migration.7*
622 %endif
623
624 %files arch
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
627 %if %{with doc}
628 %{_mandir}/man1/git-archimport.1*
629 %endif
630
631 %files email
632 %defattr(644,root,root,755)
633 %attr(755,root,root) %{_libdir}/%{name}/*email*
634 %if %{with doc}
635 %{_mandir}/man1/*email*.1*
636 %endif
637
638 %files -n bash-completion-git
639 %defattr(644,root,root,755)
640 %{_sysconfdir}/bash_completion.d/*
641
642 %files -n perl-Git
643 %defattr(644,root,root,755)
644 %{perl_vendorlib}/Git.pm
645 %{_mandir}/man3/Git.3pm*
646
647 %files -n python-Git
648 %defattr(644,root,root,755)
649 %{py_sitescriptdir}/git_remote_helpers*.egg-info
650 %dir %{py_sitescriptdir}/git_remote_helpers
651 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
652 %dir %{py_sitescriptdir}/git_remote_helpers/git
653 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
654
655 %files -n vim-syntax-gitcommit
656 %defattr(644,root,root,755)
657 %doc contrib/vim/README
658 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.086134 seconds and 4 git commands to generate.