]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.5.1
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The stupid content tracker
6 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
7 Name:           git-core
8 Version:        1.5.1
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
13 # Source0-md5:  d60eb458742b6da332f80f3bba68de8f
14 URL:            http://git.or.cz/
15 BuildRequires:  asciidoc
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  curl-devel
19 BuildRequires:  expat-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  perl-Error
22 BuildRequires:  perl-base
23 BuildRequires:  python
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  xmlto
26 BuildRequires:  zlib-devel
27 Requires:       coreutils
28 Requires:       curl
29 Requires:       diffutils
30 Requires:       findutils
31 Requires:       grep
32 Requires:       openssh-clients
33 Requires:       rcs
34 Requires:       sed
35 Requires:       tk
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 "git" can mean anything, depending on your mood.
40
41  - random three-letter combination that is pronounceable, and not
42    actually used by any common UNIX command. The fact that it is a
43    mispronunciation of "get" may or may not be relevant.
44  - stupid. contemptible and despicable. simple. Take your pick from the
45    dictionary of slang.
46  - "global information tracker": you're in a good mood, and it actually
47    works for you. Angels sing, and a light suddenly fills the room.
48  - "goddamn idiotic truckload of sh*t": when it breaks
49
50 This is a stupid (but extremely fast) directory content manager. It
51 doesn't do a whole lot, but what it 'does' do is track directory
52 contents efficiently.
53
54 %description -l pl.UTF-8
55 "git" może oznaczać cokolwiek, w zależności od nastroju.
56
57 - losową kombinację trzech liter, która jest wymawialna i właściwie
58   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
59   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
60 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
61 - "global information tracker" (narzędzie do globalnego śledzenia
62   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
63   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
64 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
65   g*) - kiedy się zepsuje.
66
67 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
68 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
69 katalogu.
70
71 %package devel
72 Summary:        Header files for git-core
73 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
74 Group:          Development/Libraries
75
76 %description devel
77 Header files for git-core.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe dla git-core.
81
82 %package -n perl-Git
83 Summary:        Perl interface to the Git version control system
84 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
85 Group:          Development/Languages/Perl
86 Requires:       %{name} = %{version}-%{release}
87 Obsoletes:      perl-git-core
88
89 %description -n perl-Git
90 This module provides Perl scripts easy way to interface the Git
91 version control system. The modules have an easy and well-tested way
92 to call arbitrary Git commands; in the future, the interface will also
93 provide specialized methods for doing easily operations which are not
94 totally trivial to do over the generic command interface.
95
96 %description -n perl-Git -l pl.UTF-8
97 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
98 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
99 dowolne polecenia Gita; w przyszłości interfejs udostępni także
100 specjalne metody do łatwego wykonywania operacji nietrywialnych do
101 wykonania przy użyciu ogólnego interfejsu poleceń.
102
103 %prep
104 %setup -q -n git-%{version}
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %configure \
110         --with-openssl
111
112 %{__make} \
113         INSTALLDIRS=vendor
114
115 %{__make} -C Documentation
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
120
121 %{__make} install \
122         INSTALLDIRS=vendor \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__make} -C Documentation install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
129 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
130
131 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
132 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc README Documentation/*.html Documentation/howto Documentation/technical
140 %attr(755,root,root) %{_bindir}/*
141 %{_mandir}/man*/*
142 %dir %{_datadir}/%{name}
143 %{_datadir}/%{name}/*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_includedir}/*
148
149 %files -n perl-Git
150 %defattr(644,root,root,755)
151 %{perl_vendorlib}/Git.pm
152 %{_mandir}/man3/*
This page took 0.053431 seconds and 4 git commands to generate.