]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
TODO: gitweb subpackage
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 %include        /usr/lib/rpm/macros.perl
4 Summary:        The stupid content tracker
5 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
6 Name:           git-core
7 Version:        1.4.4.2
8 Release:        1
9 License:        GPL v2
10 Group:          Development/Tools
11 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
12 # Source0-md5:  c4f72d96f62ae97c6e8d5cdb4afd55ca
13 URL:            http://git.or.cz/
14 BuildRequires:  asciidoc
15 BuildRequires:  curl-devel
16 BuildRequires:  expat-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  perl-Error
19 BuildRequires:  perl-base
20 BuildRequires:  python
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  xmlto
23 BuildRequires:  zlib-devel
24 Requires:       coreutils
25 Requires:       findutils
26 Requires:       grep
27 Requires:       sed
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 "git" can mean anything, depending on your mood.
32
33  - random three-letter combination that is pronounceable, and not
34    actually used by any common UNIX command. The fact that it is a
35    mispronunciation of "get" may or may not be relevant.
36  - stupid. contemptible and despicable. simple. Take your pick from the
37    dictionary of slang.
38  - "global information tracker": you're in a good mood, and it actually
39    works for you. Angels sing, and a light suddenly fills the room.
40  - "goddamn idiotic truckload of sh*t": when it breaks
41
42 This is a stupid (but extremely fast) directory content manager. It
43 doesn't do a whole lot, but what it 'does' do is track directory
44 contents efficiently.
45
46 %description -l pl
47 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
48
49 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
50   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
51   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
52 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
53 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
54   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
55   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
56 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
57   g*) - kiedy siê zepsuje.
58
59 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
60 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
61 katalogu.
62
63 %package devel
64 Summary:        Header files for git-core
65 Summary(pl):    Pliki nag³ówkowe dla git-core
66 Group:          Development/Libraries
67
68 %description devel
69 Header files for git-core.
70
71 %description devel
72 Pliki nag³ówkowe dla git-core.
73
74 %package -n perl-Git
75 Summary:        Perl interface to the Git version control system
76 Summary(pl):    Perlowy interfejs do systemu kontroli wersji Git
77 Group:          Development/Languages/Perl
78 Requires:       %{name} = %{version}-%{release}
79 Obsoletes:      perl-git-core
80
81 %description -n perl-Git
82 This module provides Perl scripts easy way to interface the Git
83 version control system. The modules have an easy and well-tested way
84 to call arbitrary Git commands; in the future, the interface will also
85 provide specialized methods for doing easily operations which are not
86 totally trivial to do over the generic command interface.
87
88 %description -n perl-Git -l pl
89 Ten modu³ umo¿liwia skryptom Perla wspó³pracê z systemem kontroli
90 wersji Git. W ³atwy i dobrze przetestowany sposób pozwala wywo³ywaæ
91 dowolne polecenia Gita; w przysz³o¶ci interfejs udostêpni tak¿e
92 specjalne metody do ³atwego wykonywania operacji nietrywialnych do
93 wykonania przy u¿yciu ogólnego interfejsu poleceñ.
94
95 %prep
96 %setup -q -n git-%{version}
97
98 %build
99 %{__make} \
100         prefix=%{_prefix} \
101         CC="%{__cc}" \
102         CFLAGS="%{rpmcflags}" \
103         LDFLAGS="%{rpmldflags}"
104
105 # once again to get perl paths stright
106 cd perl
107 %{__perl} Makefile.PL \
108         INSTALLDIRS=vendor
109 %{__make}
110 cd ..
111
112 %{__make} -C Documentation
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
117
118 %{__make} install \
119         prefix=%{_prefix} \
120         CFLAGS="%{rpmcflags}" \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %{__make} -C Documentation install \
124         prefix=%{_prefix} \
125         mandir=%{_mandir} \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
129 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
130
131 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
132 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc README Documentation/*.html Documentation/howto Documentation/technical
140 %attr(755,root,root) %{_bindir}/*
141 %{_mandir}/man*/*
142 %dir %{_datadir}/%{name}
143 %{_datadir}/%{name}/*
144
145 %files devel
146 %defattr(644,root,root,755)
147 %{_includedir}/*
148
149 %files -n perl-Git
150 %defattr(644,root,root,755)
151 %{perl_vendorlib}/Git.pm
152 %{_mandir}/man3/*
This page took 0.048844 seconds and 4 git commands to generate.