]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- more R/BR; build/install fixes
[packages/git-core.git] / git-core.spec
1 # TODO:
2 # - gitweb subpackage
3 # - gitk subpackage?
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        The stupid content tracker
6 Summary(pl):    Prymitywne narzêdzie do ¶ledzenia tre¶ci
7 Name:           git-core
8 Version:        1.4.4.2
9 Release:        1
10 License:        GPL v2
11 Group:          Development/Tools
12 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
13 # Source0-md5:  c4f72d96f62ae97c6e8d5cdb4afd55ca
14 URL:            http://git.or.cz/
15 BuildRequires:  asciidoc
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  curl-devel
19 BuildRequires:  expat-devel
20 BuildRequires:  openssl-devel
21 BuildRequires:  perl-Error
22 BuildRequires:  perl-base
23 BuildRequires:  python
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildRequires:  xmlto
26 BuildRequires:  zlib-devel
27 Requires:       coreutils
28 Requires:       curl
29 Requires:       diffutils
30 Requires:       findutils
31 Requires:       grep
32 Requires:       openssh-clients
33 Requires:       rcs
34 Requires:       sed
35 Requires:       tk
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 "git" can mean anything, depending on your mood.
40
41  - random three-letter combination that is pronounceable, and not
42    actually used by any common UNIX command. The fact that it is a
43    mispronunciation of "get" may or may not be relevant.
44  - stupid. contemptible and despicable. simple. Take your pick from the
45    dictionary of slang.
46  - "global information tracker": you're in a good mood, and it actually
47    works for you. Angels sing, and a light suddenly fills the room.
48  - "goddamn idiotic truckload of sh*t": when it breaks
49
50 This is a stupid (but extremely fast) directory content manager. It
51 doesn't do a whole lot, but what it 'does' do is track directory
52 contents efficiently.
53
54 %description -l pl
55 "git" mo¿e oznaczaæ cokolwiek, w zale¿no¶ci od nastroju.
56
57 - losow± kombinacjê trzech liter, która jest wymawialna i w³a¶ciwie
58   nie u¿ywana przez ¿adne popularne polecenie uniksowe. Fakt, ¿e jest to
59   b³êdna pisownia s³owa "get" mo¿e mieæ lub nie mieæ znaczenia.
60 - g³upi, pogardliwy, prosty. Mo¿na wybraæ ze s³ownika slangu.
61 - "global information tracker" (narzêdzie do globalnego ¶ledzenia
62   informacji) - je¶li jeste¶my w dobrym nastroju i git akurat dzia³a.
63   Anio³y ¶piewaj±, a ¶wiat³o niespodziewanie wype³nia pokój.
64 - "goddamn idiotic truckload of sh*t" (przeklêty idiotyczny ³adunek
65   g*) - kiedy siê zepsuje.
66
67 Jest to prymitywny (ale bardzo szybki) zarz±dca tre¶ci s³ownikowej.
68 Nie robi wiele, ale to, co "robi", to wydajne ¶ledzenie zawarto¶ci
69 katalogu.
70
71 %package devel
72 Summary:        Header files for git-core
73 Summary(pl):    Pliki nag³ówkowe dla git-core
74 Group:          Development/Libraries
75
76 %description devel
77 Header files for git-core.
78
79 %description devel
80 Pliki nag³ówkowe dla git-core.
81
82 %package -n perl-Git
83 Summary:        Perl interface to the Git version control system
84 Summary(pl):    Perlowy interfejs do systemu kontroli wersji Git
85 Group:          Development/Languages/Perl
86 Requires:       %{name} = %{version}-%{release}
87 Obsoletes:      perl-git-core
88
89 %description -n perl-Git
90 This module provides Perl scripts easy way to interface the Git
91 version control system. The modules have an easy and well-tested way
92 to call arbitrary Git commands; in the future, the interface will also
93 provide specialized methods for doing easily operations which are not
94 totally trivial to do over the generic command interface.
95
96 %description -n perl-Git -l pl
97 Ten modu³ umo¿liwia skryptom Perla wspó³pracê z systemem kontroli
98 wersji Git. W ³atwy i dobrze przetestowany sposób pozwala wywo³ywaæ
99 dowolne polecenia Gita; w przysz³o¶ci interfejs udostêpni tak¿e
100 specjalne metody do ³atwego wykonywania operacji nietrywialnych do
101 wykonania przy u¿yciu ogólnego interfejsu poleceñ.
102
103 %prep
104 %setup -q -n git-%{version}
105
106 %build
107 %{__aclocal}
108 %{__autoconf}
109 %configure \
110         --with-openssl
111
112 # once again to get perl paths stright
113 cd perl
114 rm -f Makefile
115 %{__perl} Makefile.PL \
116         INSTALLDIRS=vendor
117 %{__make}
118 cd ..
119
120 %{__make} -C Documentation
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %{__make} -C Documentation install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
133 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
134
135 rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
136 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc README Documentation/*.html Documentation/howto Documentation/technical
144 %attr(755,root,root) %{_bindir}/*
145 %{_mandir}/man*/*
146 %dir %{_datadir}/%{name}
147 %{_datadir}/%{name}/*
148
149 %files devel
150 %defattr(644,root,root,755)
151 %{_includedir}/*
152
153 %files -n perl-Git
154 %defattr(644,root,root,755)
155 %{perl_vendorlib}/Git.pm
156 %{_mandir}/man3/*
This page took 0.058035 seconds and 4 git commands to generate.