]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- release 2
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.1.1
12 Release:        2
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  1b116a3e2ecce46a89e4272abf0de955
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 Patch0:         %{name}-tests.patch
23 Patch1:         %{name}-libcrypto.patch
24 URL:            http://git-scm.com/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  perl-Error > 0.15
32 BuildRequires:  perl-base
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.264
37 BuildRequires:  zlib-devel
38 %if %{with doc}
39 BuildRequires:  asciidoc >= 7.1.2-3
40 BuildRequires:  docbook-dtd45-xml
41 BuildRequires:  xmlto
42 %endif
43 %if %{with tests}
44 %if %{with tests_cvs}
45 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
46 BuildRequires:  cvs-gnu-client < 1.13
47 BuildRequires:  cvs-gnu-client >= 1.12
48 %endif
49 BuildRequires:  pdksh >= 5.2.14-46
50 %endif
51 Requires:       coreutils
52 Requires:       diffutils
53 Requires:       findutils
54 Requires:       grep
55 Requires:       openssh-clients
56 Requires:       perl-Error
57 Requires:       sed
58 Suggests:       git-core-cvs
59 Suggests:       git-core-svn
60 Suggests:       less
61 Suggests:       rsync
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # html docs have links to txt files
65 %define         _noautocompressdoc      *.txt
66
67 %define         webapp          gitweb
68 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
69 %define         appdir          %{_datadir}/%{webapp}
70 %define         cgibindir       %{_prefix}/lib/cgi-bin
71
72 %description
73 "git" can mean anything, depending on your mood.
74
75 - random three-letter combination that is pronounceable, and not
76   actually used by any common UNIX command. The fact that it is a
77   mispronunciation of "get" may or may not be relevant.
78 - stupid. contemptible and despicable. simple. Take your pick from the
79   dictionary of slang.
80 - "global information tracker": you're in a good mood, and it actually
81   works for you. Angels sing, and a light suddenly fills the room.
82 - "goddamn idiotic truckload of sh*t": when it breaks
83
84 This is a stupid (but extremely fast) directory content manager. It
85 doesn't do a whole lot, but what it 'does' do is track directory
86 contents efficiently.
87
88 %description -l pl.UTF-8
89 "git" może oznaczać cokolwiek, w zależności od nastroju.
90
91 - losową kombinację trzech liter, która jest wymawialna i właściwie
92   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
93   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
94 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
95 - "global information tracker" (narzędzie do globalnego śledzenia
96   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
97   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
98 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
99   g*) - kiedy się zepsuje.
100
101 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
102 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
103 katalogu.
104
105 %package doc
106 Summary:        Documentation for git-core
107 Summary(pl.UTF-8):      Dokumentacja do git-core
108 Group:          Documentation
109
110 %description doc
111 Documentation for git-core.
112
113 %description doc -l pl.UTF-8
114 Dokumentacja do git-core.
115
116 %description doc -l fr.UTF-8
117 Javadoc pour git-core.
118
119 %package daemon-inetd
120 Summary:        Files necessary to run git-daemon as an inetd service
121 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
122 Group:          Networking/Daemons
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       setup >= 2.4.11-1
125 Provides:       git-core-daemon
126 Obsoletes:      git-core-daemon
127 Obsoletes:      git-core-daemon-standalone
128
129 %description daemon-inetd
130 Git-daemon is a really simple TCP git daemon that can serve git
131 repositories. This package provides all necessarry files to run
132 git-daemon as an inetd service.
133
134 %description daemon-inetd -l pl.UTF-8
135 Git-daemon to prosty demon git korzystający z protokołu TCP do
136 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
137 do uruchomienia git-demona w trybie usługi inetd.
138
139 %package daemon-standalone
140 Summary:        Files necessary to run git-daemon as a standalone service
141 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
142 Group:          Networking/Daemons
143 Requires:       %{name} = %{version}-%{release}
144 Provides:       git-core-daemon
145 Obsoletes:      git-core-daemon
146 Obsoletes:      git-core-daemon-inetd
147
148 %description daemon-standalone
149 Git-daemon is a really simple TCP git daemon that can serve git
150 repositories. This package provides all necessarry files to run
151 git-daemon as an standalone service.
152
153 %description daemon-standalone -l pl.UTF-8
154 Git-daemon to prosty demon git korzystający z protokołu TCP do
155 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
156 do uruchomienia git-daemona w trybie usługi samodzielnej.
157
158 %package devel
159 Summary:        Header files for git-core
160 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
161 Group:          Development/Libraries
162 Requires:       zlib-devel
163
164 %description devel
165 Header files for git-core.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe dla git-core.
169
170 %package gitk
171 Summary:        Tcl/Tk interface to the Git version control system
172 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
173 Group:          Development/Tools
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       tk
176
177 %description gitk
178 gitk displays changes in a repository or a selected set of commits.
179 This includes visualizing the commit graph, showing information
180 related to each commit, and the files in the trees of each revision.
181
182 Historically, gitk was the first repository browser. It's written in
183 Tcl/Tk and started off in a separate repository but was later merged
184 into the main git repository.
185
186 %description gitk -l pl.UTF-8
187 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
188 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
189 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
190
191 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
192 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
193 osobnym repozytorium, ale z czasem został włączony do głównego
194 repozytorium gita.
195
196 %package gitweb
197 Summary:        Web frontend to git
198 Summary(pl.UTF-8):      Webowy frontend do git
199 Group:          Development/Tools
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       webapps
202
203 %description gitweb
204 This package provides a web interface for browsing git repositories.
205
206 %description gitweb -l pl.UTF-8
207 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
208
209 %package gitview
210 Summary:        A GTK+ based repository browser for git
211 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
212 Group:          Development/Tools
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       python >= 1:2.4
215 Requires:       python-pycairo >= 1.0
216 Requires:       python-pygobject
217 Requires:       python-pygtk-gtk >= 2:2.8
218 Suggests:       python-gnome-desktop-gtksourceview
219
220 %description gitview
221 A GTK+ based repository browser for git.
222
223 %description gitview -l pl.UTF-8
224 Oparta na GTK+ przeglądarka repozytorium gita.
225
226 %package gui
227 Summary:        Tcl/Tk interface to the Git version control system
228 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
229 Group:          Development/Tools
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       tk
232
233 %description gui
234 Displays changes in a repository or a selected set of commits. This
235 includes visualizing the commit graph, showing information related to
236 each commit, and the files in the trees of each revision.
237
238 Historically, gitk was the first repository browser. It's written in
239 Tcl/Tk and started off in a separate repository but was later merged
240 into the main git repository.
241
242 %description gui -l pl.UTF-8
243 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
244 to wizualizację grafu commitów, wyświetlanie informacji związanych z
245 każdym z commitów oraz listę plików dla każdej rewizji.
246
247 Z punktu widzenia historii, gitk był pierwszą przeglądarką
248 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
249 osobnym repozytorium, ale z czasem został włączony do głównego
250 repozytorium gita.
251
252 %package svn
253 Summary:        Subversion support for Git
254 Summary(pl.UTF-8):      Obsługa Subversion dla Git
255 Group:          Development/Tools
256 Requires:       %{name} = %{version}-%{release}
257
258 %description svn
259 Subversion support for Git.
260
261 %description svn -l pl.UTF-8
262 Obsługa Subversion dla Git.
263
264 %package cvs
265 Summary:        CVS support for Git
266 Summary(pl.UTF-8):      Obsługa CVS dla Git
267 Group:          Development/Tools
268 Requires:       %{name} = %{version}-%{release}
269 Requires:       cvsps >= 2.1-2
270 Requires:       rcs
271
272 %description cvs
273 CVS support for Git.
274
275 %description cvs -l pl.UTF-8
276 Obsługa CVS dla Git.
277
278 %package arch
279 Summary:        Git tools for importing Arch repositories
280 Group:          Development/Tools
281 Requires:       %{name} = %{version}-%{release}
282 Requires:       tla
283
284 %description arch
285 Git tools for importing Arch repositories.
286
287 %package email
288 Summary:        Git tools for sending email
289 Group:          Development/Tools
290 Requires:       %{name} = %{version}-%{release}
291
292 %description email
293 Git tools for sending email.
294
295 %package -n bash-completion-git
296 Summary:        bash-completion for git
297 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
298 Group:          Applications/Shells
299 Requires:       bash-completion
300
301 %description -n bash-completion-git
302 This package provides bash-completion for git.
303
304 %description -n bash-completion-git -l pl.UTF-8
305 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
306
307 %package -n perl-Git
308 Summary:        Perl interface to the Git version control system
309 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
310 Group:          Development/Languages/Perl
311 Obsoletes:      perl-git-core
312
313 %description -n perl-Git
314 This module provides Perl scripts easy way to interface the Git
315 version control system. The modules have an easy and well-tested way
316 to call arbitrary Git commands; in the future, the interface will also
317 provide specialized methods for doing easily operations which are not
318 totally trivial to do over the generic command interface.
319
320 %description -n perl-Git -l pl.UTF-8
321 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
322 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
323 dowolne polecenia Gita; w przyszłości interfejs udostępni także
324 specjalne metody do łatwego wykonywania operacji nietrywialnych do
325 wykonania przy użyciu ogólnego interfejsu poleceń.
326
327 %package -n python-Git
328 Summary:        Python interface to the Git version control system
329 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
330 Group:          Development/Languages/Python
331
332 %description -n python-Git
333 This module provides Python scripts easy way to interface the Git
334 version control system.
335
336 %description -n python-Git -l pl.UTF-8
337 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
338 wersji Git.
339
340 %package -n vim-syntax-gitcommit
341 Summary:        Vim syntax: gitcommit
342 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
343 Group:          Applications/Editors/Vim
344 # for _vimdatadir existence
345 Requires:       vim-rt >= 4:6.3.058-3
346
347 %description -n vim-syntax-gitcommit
348 This plugin provides syntax highlighting for git's commit messages.
349
350 %description -n vim-syntax-gitcommit -l pl.UTF-8
351 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
352
353 %prep
354 %setup -q -n git-%{version}
355 %patch0 -p1
356 %patch1 -p0
357
358 %build
359 %{__aclocal}
360 %{__autoconf}
361 %configure \
362         --with-openssl
363
364 echo "BLK_SHA1=1" >> config.mak
365
366 %{__make} \
367         INSTALLDIRS=vendor \
368         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
369         GITWEB_PROJECTROOT="/var/lib/git" \
370         GITWEB_CSS="/gitweb/gitweb.css" \
371         GITWEB_LOGO="/gitweb/git-logo.png" \
372         GITWEB_FAVICON="/gitweb/git-favicon.png"
373
374 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
375 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
376
377 %if %{with tests}
378 %if %{without tests_cvs}
379 rm t/t*cvs*.sh || :
380 %endif
381 %{__make} test
382 %endif
383
384 %install
385 rm -rf $RPM_BUILD_ROOT
386 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
387 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
388 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
389
390 %{__make} install \
391         INSTALLDIRS=vendor \
392         DESTDIR=$RPM_BUILD_ROOT
393
394 %if %{with doc}
395 %{__make} -C Documentation install \
396         DESTDIR=$RPM_BUILD_ROOT
397 %endif
398
399 # header files and lib
400 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
401 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
402 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
403 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
404 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
405
406 # bash completion
407 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
408 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
409
410 # vim syntax
411 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
412 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
413 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
414 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
415 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
416 autocmd BufNewFile,BufRead .msg.[0-9]*
417         \ if getline(1) =~ '^From.*# This line is ignored.$' |
418         \   setf gitsendemail |
419         \ endif
420 autocmd BufNewFile,BufRead *.git/**
421         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
422         \   setf git |
423         \ endif
424 EOF
425
426 # gitweb
427 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
428 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
429 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
430 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
431 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
432
433 # gitview
434 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
435
436 # git-daemon related files
437 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
438 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
439 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
440
441 # paths cleanup
442 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
443 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
444
445 # hardlink
446 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
447 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
448 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
449 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
450
451 # remove unneeded files
452 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
453 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
454 %py_postclean
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %post daemon-inetd
460 %service -q rc-inetd reload
461
462 %postun daemon-inetd
463 if [ "$1" = "0" ]; then
464         %service -q rc-inetd reload
465 fi
466
467 %post daemon-standalone
468 /sbin/chkconfig --add git-daemon
469 %service git-daemon restart "git-daemon"
470
471 %preun daemon-standalone
472 if [ "$1" = "0" ]; then
473         %service git-daemon stop
474         /sbin/chkconfig --del git-daemon
475 fi
476
477 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
478 %webapp_register apache %{webapp}
479
480 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
481 %webapp_unregister apache %{webapp}
482
483 %triggerin gitweb -- apache < 2.2.0, apache-base
484 %webapp_register httpd %{webapp}
485
486 %triggerun gitweb -- apache < 2.2.0, apache-base
487 %webapp_unregister httpd %{webapp}
488
489 %files
490 %defattr(644,root,root,755)
491 %doc README contrib
492 %attr(755,root,root) %{_bindir}/git
493 %attr(755,root,root) %{_bindir}/git-receive-pack
494 %attr(755,root,root) %{_bindir}/git-shell
495 %attr(755,root,root) %{_bindir}/git-upload-archive
496 %attr(755,root,root) %{_bindir}/git-upload-pack
497
498 %if %{with doc}
499 %{_mandir}/man1/git-*.1*
500 %exclude %{_mandir}/man1/git-svn.1*
501 %exclude %{_mandir}/man1/git-cvs*.1*
502 %{_mandir}/man1/git.1*
503 %{_mandir}/man5/gitattributes.5*
504 %{_mandir}/man5/githooks.5*
505 %{_mandir}/man5/gitignore.5*
506 %{_mandir}/man5/gitmodules.5*
507 %{_mandir}/man5/gitrepository-layout.5*
508 %{_mandir}/man7/gitcli.7*
509 %{_mandir}/man7/gitcore-tutorial.7*
510 %{_mandir}/man7/gitdiffcore.7*
511 %{_mandir}/man7/gitglossary.7*
512 %{_mandir}/man7/gittutorial-2.7*
513 %{_mandir}/man7/gittutorial.7*
514 %{_mandir}/man7/gitworkflows.7*
515 %endif
516
517 %dir %{_libdir}/%{name}
518 %attr(755,root,root) %{_libdir}/%{name}/*-*
519 %attr(755,root,root) %{_libdir}/%{name}/git
520
521 %exclude %{_libdir}/%{name}/git-gui
522 %exclude %{_libdir}/%{name}/git-svn
523 %exclude %{_libdir}/%{name}/git-archimport
524 %exclude %{_libdir}/%{name}/git-cvs*
525 %exclude %{_libdir}/%{name}/*email*
526
527 %{_datadir}/%{name}
528
529 %{_localstatedir}/lib/git
530
531 %if %{with doc}
532 %files doc
533 %defattr(644,root,root,755)
534 %doc Documentation/RelNotes*
535 %doc Documentation/*.html Documentation/howto Documentation/technical
536 %endif
537
538 %files daemon-inetd
539 %defattr(644,root,root,755)
540 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
541
542 %files daemon-standalone
543 %defattr(644,root,root,755)
544 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
545 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
546
547 %files devel
548 %defattr(644,root,root,755)
549 %{_includedir}/git-core
550 %{_libdir}/libgit.a
551 %{_libdir}/libgit_xdiff.a
552
553 %files gitk
554 %defattr(644,root,root,755)
555 %if %{with doc}
556 %{_mandir}/man1/gitk.1*
557 %endif
558 %attr(755,root,root) %{_bindir}/gitk
559 %dir %{_datadir}/gitk
560 %dir %{_datadir}/gitk/lib
561 %dir %{_datadir}/gitk/lib/msgs
562 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
563 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
564 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
565 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
566 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
567 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
568 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
569 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
570
571 %files gitweb
572 %defattr(644,root,root,755)
573 %doc gitweb/{README,INSTALL}
574 %dir %{webappdir}
575 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
576 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
577 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
578 %attr(755,root,root) %{cgibindir}/gitweb.cgi
579 %{appdir}
580
581 %files gitview
582 %defattr(644,root,root,755)
583 %doc contrib/gitview/gitview.txt
584 %attr(755,root,root) %{_bindir}/gitview
585
586 %files gui
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/%{name}/git-gui
589 %dir %{_datadir}/git-gui
590 %dir %{_datadir}/git-gui/lib
591 %dir %{_datadir}/git-gui/lib/msgs
592 %{_datadir}/git-gui/lib/git-gui.ico
593 %{_datadir}/git-gui/lib/tclIndex
594 %{_datadir}/git-gui/lib/*.js
595 %{_datadir}/git-gui/lib/*.tcl
596 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
597 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
598 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
599 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
600 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
601 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
602 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
603 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
604 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
605 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
606
607 %files svn
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/%{name}/git-svn
610 %if %{with doc}
611 %{_mandir}/man1/git-svn.1*
612 %endif
613
614 %files cvs
615 %defattr(644,root,root,755)
616 %attr(755,root,root) %{_bindir}/git-cvsserver
617 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
618 %if %{with doc}
619 %{_mandir}/man1/git-cvs*.1*
620 %{_mandir}/man7/gitcvs-migration.7*
621 %endif
622
623 %files arch
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
626 %if %{with doc}
627 %{_mandir}/man1/git-archimport.1*
628 %endif
629
630 %files email
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/%{name}/*email*
633 %if %{with doc}
634 %{_mandir}/man1/*email*.1*
635 %endif
636
637 %files -n bash-completion-git
638 %defattr(644,root,root,755)
639 %{_sysconfdir}/bash_completion.d/*
640
641 %files -n perl-Git
642 %defattr(644,root,root,755)
643 %{perl_vendorlib}/Git.pm
644 %{_mandir}/man3/Git.3pm*
645
646 %files -n python-Git
647 %defattr(644,root,root,755)
648 %{py_sitescriptdir}/git_remote_helpers*.egg-info
649 %dir %{py_sitescriptdir}/git_remote_helpers
650 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
651 %dir %{py_sitescriptdir}/git_remote_helpers/git
652 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
653
654 %files -n vim-syntax-gitcommit
655 %defattr(644,root,root,755)
656 %doc contrib/vim/README
657 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.19768 seconds and 3 git commands to generate.