]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- remaining pl
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.3.2
12 Release:        2
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  902f7f07a789fedc0d2ac03656b85969
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}-gitweb-lighttpd.conf
20 Source4:        %{name}.sysconfig
21 Source5:        %{name}.inet
22 Source6:        %{name}.init
23 Patch0:         %{name}-tests.patch
24 Patch1:         %{name}-libcrypto.patch
25 URL:            http://git-scm.com/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  curl-devel
29 BuildRequires:  expat-devel
30 BuildRequires:  gettext-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  perl-Error > 0.15
33 BuildRequires:  perl-base
34 BuildRequires:  python-devel
35 BuildRequires:  rpm-perlprov >= 4.1-13
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.264
38 BuildRequires:  zlib-devel
39 %if %{with doc}
40 BuildRequires:  asciidoc >= 7.1.2-3
41 BuildRequires:  docbook-dtd45-xml
42 BuildRequires:  xmlto
43 %endif
44 %if %{with tests}
45 %if %{with tests_cvs}
46 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
47 BuildRequires:  cvs-gnu-client < 1.13
48 BuildRequires:  cvs-gnu-client >= 1.12
49 %endif
50 BuildRequires:  pdksh >= 5.2.14-46
51 %endif
52 Requires:       coreutils
53 Requires:       diffutils
54 Requires:       findutils
55 Requires:       grep
56 Requires:       openssh-clients
57 Requires:       perl-Error
58 Requires:       sed
59 Suggests:       git-core-cvs
60 Suggests:       git-core-svn
61 Suggests:       less
62 Suggests:       rsync
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 # html docs have links to txt files
66 %define         _noautocompressdoc      *.txt
67
68 %define         webapp          gitweb
69 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
70 %define         appdir          %{_datadir}/%{webapp}
71 %define         cgibindir       %{_prefix}/lib/cgi-bin
72
73 %description
74 "git" can mean anything, depending on your mood.
75
76 - random three-letter combination that is pronounceable, and not
77   actually used by any common UNIX command. The fact that it is a
78   mispronunciation of "get" may or may not be relevant.
79 - stupid. contemptible and despicable. simple. Take your pick from the
80   dictionary of slang.
81 - "global information tracker": you're in a good mood, and it actually
82   works for you. Angels sing, and a light suddenly fills the room.
83 - "goddamn idiotic truckload of sh*t": when it breaks
84
85 This is a stupid (but extremely fast) directory content manager. It
86 doesn't do a whole lot, but what it 'does' do is track directory
87 contents efficiently.
88
89 %description -l pl.UTF-8
90 "git" może oznaczać cokolwiek, w zależności od nastroju.
91
92 - losową kombinację trzech liter, która jest wymawialna i właściwie
93   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
94   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
95 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
96 - "global information tracker" (narzędzie do globalnego śledzenia
97   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
98   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
99 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
100   g*) - kiedy się zepsuje.
101
102 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
103 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
104 katalogu.
105
106 %package doc
107 Summary:        Documentation for git-core
108 Summary(pl.UTF-8):      Dokumentacja do git-core
109 Group:          Documentation
110
111 %description doc
112 Documentation for git-core.
113
114 %description doc -l pl.UTF-8
115 Dokumentacja do git-core.
116
117 %description doc -l fr.UTF-8
118 Javadoc pour git-core.
119
120 %package daemon-inetd
121 Summary:        Files necessary to run git-daemon as an inetd service
122 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
123 Group:          Networking/Daemons
124 Requires:       %{name} = %{version}-%{release}
125 Requires:       setup >= 2.4.11-1
126 Provides:       git-core-daemon
127 Obsoletes:      git-core-daemon
128 Obsoletes:      git-core-daemon-standalone
129
130 %description daemon-inetd
131 Git-daemon is a really simple TCP git daemon that can serve git
132 repositories. This package provides all necessarry files to run
133 git-daemon as an inetd service.
134
135 %description daemon-inetd -l pl.UTF-8
136 Git-daemon to prosty demon git korzystający z protokołu TCP do
137 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
138 do uruchomienia git-demona w trybie usługi inetd.
139
140 %package daemon-standalone
141 Summary:        Files necessary to run git-daemon as a standalone service
142 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
143 Group:          Networking/Daemons
144 Requires:       %{name} = %{version}-%{release}
145 Provides:       git-core-daemon
146 Obsoletes:      git-core-daemon
147 Obsoletes:      git-core-daemon-inetd
148
149 %description daemon-standalone
150 Git-daemon is a really simple TCP git daemon that can serve git
151 repositories. This package provides all necessarry files to run
152 git-daemon as an standalone service.
153
154 %description daemon-standalone -l pl.UTF-8
155 Git-daemon to prosty demon git korzystający z protokołu TCP do
156 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
157 do uruchomienia git-daemona w trybie usługi samodzielnej.
158
159 %package devel
160 Summary:        Header files for git-core
161 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
162 Group:          Development/Libraries
163 Requires:       zlib-devel
164
165 %description devel
166 Header files for git-core.
167
168 %description devel -l pl.UTF-8
169 Pliki nagłówkowe dla git-core.
170
171 %package gitk
172 Summary:        Tcl/Tk interface to the Git version control system
173 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
174 Group:          Development/Tools
175 Requires:       %{name} = %{version}-%{release}
176 Requires:       tk
177
178 %description gitk
179 gitk displays changes in a repository or a selected set of commits.
180 This includes visualizing the commit graph, showing information
181 related to each commit, and the files in the trees of each revision.
182
183 Historically, gitk was the first repository browser. It's written in
184 Tcl/Tk and started off in a separate repository but was later merged
185 into the main git repository.
186
187 %description gitk -l pl.UTF-8
188 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
189 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
190 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
191
192 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
193 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
194 osobnym repozytorium, ale z czasem został włączony do głównego
195 repozytorium gita.
196
197 %package gitweb
198 Summary:        Web frontend to git
199 Summary(pl.UTF-8):      Frontend WWW do gita
200 Group:          Development/Tools
201 Requires:       %{name} = %{version}-%{release}
202 Requires:       webapps
203 Requires:       webserver(alias)
204 Requires:       webserver(cgi)
205
206 %description gitweb
207 This package provides a web interface for browsing git repositories.
208
209 %description gitweb -l pl.UTF-8
210 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
211
212 %package gitview
213 Summary:        A GTK+ based repository browser for git
214 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
215 Group:          Development/Tools
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       python >= 1:2.4
218 Requires:       python-pycairo >= 1.0
219 Requires:       python-pygobject
220 Requires:       python-pygtk-gtk >= 2:2.8
221 Suggests:       python-gnome-desktop-gtksourceview
222
223 %description gitview
224 A GTK+ based repository browser for git.
225
226 %description gitview -l pl.UTF-8
227 Oparta na GTK+ przeglądarka repozytorium gita.
228
229 %package gui
230 Summary:        Tcl/Tk interface to the Git version control system
231 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
232 Group:          Development/Tools
233 Requires:       %{name} = %{version}-%{release}
234 Requires:       tk
235 Requires:       xdg-utils
236 Suggests:       meld
237
238 %description gui
239 Displays changes in a repository or a selected set of commits. This
240 includes visualizing the commit graph, showing information related to
241 each commit, and the files in the trees of each revision.
242
243 Historically, gitk was the first repository browser. It's written in
244 Tcl/Tk and started off in a separate repository but was later merged
245 into the main git repository.
246
247 %description gui -l pl.UTF-8
248 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
249 to wizualizację grafu commitów, wyświetlanie informacji związanych z
250 każdym z commitów oraz listę plików dla każdej rewizji.
251
252 Z punktu widzenia historii, gitk był pierwszą przeglądarką
253 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
254 osobnym repozytorium, ale z czasem został włączony do głównego
255 repozytorium gita.
256
257 %package svn
258 Summary:        Subversion support for Git
259 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
260 Group:          Development/Tools
261 Requires:       %{name} = %{version}-%{release}
262 Requires:       perl-Term-ReadKey
263
264 %description svn
265 Subversion support for Git.
266
267 %description svn -l pl.UTF-8
268 Obsługa Subversion dla Gita.
269
270 %package cvs
271 Summary:        CVS support for Git
272 Summary(pl.UTF-8):      Obsługa CVS dla Gita
273 Group:          Development/Tools
274 Requires:       %{name} = %{version}-%{release}
275 Requires:       cvsps >= 2.1-2
276 Requires:       rcs
277
278 %description cvs
279 CVS support for Git.
280
281 %description cvs -l pl.UTF-8
282 Obsługa CVS dla Gita.
283
284 %package arch
285 Summary:        Git tools for importing Arch repositories
286 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
287 Group:          Development/Tools
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       tla
290
291 %description arch
292 Git tools for importing Arch repositories.
293
294 %description arch -l pl.UTF-8
295 Narzędzia Gita do importowania repozytoriów Archa.
296
297 %package email
298 Summary:        Git tools for sending email
299 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
300 Group:          Development/Tools
301 Requires:       %{name} = %{version}-%{release}
302
303 %description email
304 Git tools for sending email.
305
306 %description email -l pl.UTF-8
307 Narzędzia Gita do wysyłania poczty.
308
309 %package -n bash-completion-git
310 Summary:        bash-completion for git
311 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
312 Group:          Applications/Shells
313 Requires:       bash-completion
314
315 %description -n bash-completion-git
316 This package provides bash-completion for git.
317
318 %description -n bash-completion-git -l pl.UTF-8
319 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
320
321 %package -n perl-Git
322 Summary:        Perl interface to the Git version control system
323 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
324 Group:          Development/Languages/Perl
325 Obsoletes:      perl-git-core
326
327 %description -n perl-Git
328 This module provides Perl scripts easy way to interface the Git
329 version control system. The modules have an easy and well-tested way
330 to call arbitrary Git commands; in the future, the interface will also
331 provide specialized methods for doing easily operations which are not
332 totally trivial to do over the generic command interface.
333
334 %description -n perl-Git -l pl.UTF-8
335 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
336 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
337 dowolne polecenia Gita; w przyszłości interfejs udostępni także
338 specjalne metody do łatwego wykonywania operacji nietrywialnych do
339 wykonania przy użyciu ogólnego interfejsu poleceń.
340
341 %package -n python-Git
342 Summary:        Python interface to the Git version control system
343 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
344 Group:          Development/Languages/Python
345
346 %description -n python-Git
347 This module provides Python scripts easy way to interface the Git
348 version control system.
349
350 %description -n python-Git -l pl.UTF-8
351 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
352 wersji Git.
353
354 %package -n vim-syntax-gitcommit
355 Summary:        Vim syntax: gitcommit
356 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
357 Group:          Applications/Editors/Vim
358 # for _vimdatadir existence
359 Requires:       vim-rt >= 4:6.3.058-3
360
361 %description -n vim-syntax-gitcommit
362 This plugin provides syntax highlighting for git's commit messages.
363
364 %description -n vim-syntax-gitcommit -l pl.UTF-8
365 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
366
367 %prep
368 %setup -q -n git-%{version}
369 %patch0 -p1
370 %patch1 -p0
371
372 %build
373 %{__aclocal}
374 %{__autoconf}
375 %configure \
376         --with-openssl
377
378 echo "BLK_SHA1=1" >> config.mak
379
380 %{__make} \
381         INSTALLDIRS=vendor \
382         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
383         GITWEB_PROJECTROOT="/var/lib/git" \
384         GITWEB_CSS="/gitweb/gitweb.css" \
385         GITWEB_LOGO="/gitweb/git-logo.png" \
386         GITWEB_FAVICON="/gitweb/git-favicon.png" \
387         V=1
388
389 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
390 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
391
392 %if %{with tests}
393 %if %{without tests_cvs}
394 rm t/t*cvs*.sh || :
395 %endif
396 %{__make} test
397 %endif
398
399 %install
400 rm -rf $RPM_BUILD_ROOT
401 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
402 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
403 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
404
405 %{__make} install \
406         INSTALLDIRS=vendor \
407         DESTDIR=$RPM_BUILD_ROOT
408
409 %if %{with doc}
410 %{__make} -C Documentation install \
411         DESTDIR=$RPM_BUILD_ROOT
412 %endif
413
414 # header files and lib
415 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
416 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
417 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
418 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
419 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
420
421 # bash completion
422 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
423 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
424
425 # vim syntax
426 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
427 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
428 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
429 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
430 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
431 autocmd BufNewFile,BufRead .msg.[0-9]*
432         \ if getline(1) =~ '^From.*# This line is ignored.$' |
433         \   setf gitsendemail |
434         \ endif
435 autocmd BufNewFile,BufRead *.git/**
436         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
437         \   setf git |
438         \ endif
439 EOF
440
441 # gitweb
442 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
443 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
444 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
445 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
446 cp -a %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
447
448 # gitview
449 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
450
451 # git-daemon related files
452 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
453 cp -a %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
454 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
455
456 # paths cleanup
457 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
458 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
459
460 # hardlink
461 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
462 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
463 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
464 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
465
466 # remove unneeded files
467 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
468 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
469 %py_postclean
470
471 %clean
472 rm -rf $RPM_BUILD_ROOT
473
474 %post daemon-inetd
475 %service -q rc-inetd reload
476
477 %postun daemon-inetd
478 if [ "$1" = "0" ]; then
479         %service -q rc-inetd reload
480 fi
481
482 %post daemon-standalone
483 /sbin/chkconfig --add git-daemon
484 %service git-daemon restart "git-daemon"
485
486 %preun daemon-standalone
487 if [ "$1" = "0" ]; then
488         %service git-daemon stop
489         /sbin/chkconfig --del git-daemon
490 fi
491
492 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
493 %webapp_register apache %{webapp}
494
495 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
496 %webapp_unregister apache %{webapp}
497
498 %triggerin gitweb -- apache < 2.2.0, apache-base
499 %webapp_register httpd %{webapp}
500
501 %triggerun gitweb -- apache < 2.2.0, apache-base
502 %webapp_unregister httpd %{webapp}
503
504 %triggerin gitweb -- lighttpd
505 %webapp_register lighttpd %{webapp}
506
507 %triggerun gitweb -- lighttpd
508 %webapp_unregister lighttpd %{webapp}
509
510 %files
511 %defattr(644,root,root,755)
512 %doc README contrib
513 %attr(755,root,root) %{_bindir}/git
514 %attr(755,root,root) %{_bindir}/git-receive-pack
515 %attr(755,root,root) %{_bindir}/git-shell
516 %attr(755,root,root) %{_bindir}/git-upload-archive
517 %attr(755,root,root) %{_bindir}/git-upload-pack
518
519 %if %{with doc}
520 %{_mandir}/man1/git-*.1*
521 %exclude %{_mandir}/man1/git-svn.1*
522 %exclude %{_mandir}/man1/git-cvs*.1*
523 %{_mandir}/man1/git.1*
524 %{_mandir}/man5/gitattributes.5*
525 %{_mandir}/man5/githooks.5*
526 %{_mandir}/man5/gitignore.5*
527 %{_mandir}/man5/gitmodules.5*
528 %{_mandir}/man5/gitrepository-layout.5*
529 %{_mandir}/man7/gitcli.7*
530 %{_mandir}/man7/gitcore-tutorial.7*
531 %{_mandir}/man7/gitdiffcore.7*
532 %{_mandir}/man7/gitglossary.7*
533 %{_mandir}/man7/gitrevisions.7*
534 %{_mandir}/man7/gittutorial-2.7*
535 %{_mandir}/man7/gittutorial.7*
536 %{_mandir}/man7/gitworkflows.7*
537 %endif
538
539 %dir %{_libdir}/%{name}
540 %attr(755,root,root) %{_libdir}/%{name}/*-*
541 %attr(755,root,root) %{_libdir}/%{name}/git
542
543 %exclude %{_libdir}/%{name}/git-gui
544 %exclude %{_libdir}/%{name}/git-svn
545 %exclude %{_libdir}/%{name}/git-archimport
546 %exclude %{_libdir}/%{name}/git-cvs*
547 %exclude %{_libdir}/%{name}/*email*
548
549 %{_datadir}/%{name}
550
551 %{_localstatedir}/lib/git
552
553 %if %{with doc}
554 %files doc
555 %defattr(644,root,root,755)
556 %doc Documentation/RelNotes*
557 %doc Documentation/*.html Documentation/howto Documentation/technical
558 %endif
559
560 %files daemon-inetd
561 %defattr(644,root,root,755)
562 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
563
564 %files daemon-standalone
565 %defattr(644,root,root,755)
566 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
567 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
568
569 %files devel
570 %defattr(644,root,root,755)
571 %{_includedir}/git-core
572 %{_libdir}/libgit.a
573 %{_libdir}/libgit_xdiff.a
574
575 %files gitk
576 %defattr(644,root,root,755)
577 %if %{with doc}
578 %{_mandir}/man1/gitk.1*
579 %endif
580 %attr(755,root,root) %{_bindir}/gitk
581 %dir %{_datadir}/gitk
582 %dir %{_datadir}/gitk/lib
583 %dir %{_datadir}/gitk/lib/msgs
584 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
585 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
586 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
587 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
588 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
589 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
590 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
591 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
592
593 %files gitweb
594 %defattr(644,root,root,755)
595 %doc gitweb/{README,INSTALL}
596 %dir %{webappdir}
597 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
598 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
599 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
600 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
601 %attr(755,root,root) %{cgibindir}/gitweb.cgi
602 %{appdir}
603
604 %files gitview
605 %defattr(644,root,root,755)
606 %doc contrib/gitview/gitview.txt
607 %attr(755,root,root) %{_bindir}/gitview
608
609 %files gui
610 %defattr(644,root,root,755)
611 %attr(755,root,root) %{_libdir}/%{name}/git-gui
612 %dir %{_datadir}/git-gui
613 %dir %{_datadir}/git-gui/lib
614 %dir %{_datadir}/git-gui/lib/msgs
615 %{_datadir}/git-gui/lib/git-gui.ico
616 %{_datadir}/git-gui/lib/tclIndex
617 %{_datadir}/git-gui/lib/*.js
618 %{_datadir}/git-gui/lib/*.tcl
619 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
620 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
621 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
622 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
623 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
624 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
625 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
626 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
627 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
628 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
629
630 %files svn
631 %defattr(644,root,root,755)
632 %attr(755,root,root) %{_libdir}/%{name}/git-svn
633 %if %{with doc}
634 %{_mandir}/man1/git-svn.1*
635 %endif
636
637 %files cvs
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/git-cvsserver
640 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
641 %if %{with doc}
642 %{_mandir}/man1/git-cvs*.1*
643 %{_mandir}/man7/gitcvs-migration.7*
644 %endif
645
646 %files arch
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
649 %if %{with doc}
650 %{_mandir}/man1/git-archimport.1*
651 %endif
652
653 %files email
654 %defattr(644,root,root,755)
655 %attr(755,root,root) %{_libdir}/%{name}/*email*
656 %if %{with doc}
657 %{_mandir}/man1/*email*.1*
658 %endif
659
660 %files -n bash-completion-git
661 %defattr(644,root,root,755)
662 %{_sysconfdir}/bash_completion.d/*
663
664 %files -n perl-Git
665 %defattr(644,root,root,755)
666 %{perl_vendorlib}/Git.pm
667 %{_mandir}/man3/Git.3pm*
668
669 %files -n python-Git
670 %defattr(644,root,root,755)
671 %dir %{py_sitescriptdir}/git_remote_helpers
672 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
673 %dir %{py_sitescriptdir}/git_remote_helpers/git
674 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
675 %if "%{py_ver}" > "2.4"
676 %{py_sitescriptdir}/git_remote_helpers*.egg-info
677 %endif
678
679 %files -n vim-syntax-gitcommit
680 %defattr(644,root,root,755)
681 %doc contrib/vim/README
682 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.12465 seconds and 3 git commands to generate.