]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- release: 3 (because of that missing R), STBR
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.1
12 Release:        3
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  3da231dbe82ad103373cb530ae7475d5
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 Patch0:         %{name}-tests.patch
23 URL:            http://git-scm.com/
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  curl-devel
27 BuildRequires:  expat-devel
28 BuildRequires:  gettext-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  perl-Error > 0.15
31 BuildRequires:  perl-base
32 BuildRequires:  python-devel
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.264
36 BuildRequires:  zlib-devel
37 %if %{with doc}
38 BuildRequires:  asciidoc >= 7.1.2-3
39 BuildRequires:  docbook-dtd45-xml
40 BuildRequires:  xmlto
41 %endif
42 %if %{with tests}
43 %if %{with tests_cvs}
44 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
45 BuildRequires:  cvs-gnu-client < 1.13
46 BuildRequires:  cvs-gnu-client >= 1.12
47 %endif
48 BuildRequires:  pdksh >= 5.2.14-46
49 %endif
50 Requires:       coreutils
51 Requires:       diffutils
52 Requires:       findutils
53 Requires:       grep
54 Requires:       openssh-clients
55 Requires:       perl-Error
56 Requires:       sed
57 Suggests:       git-core-cvs
58 Suggests:       git-core-svn
59 Suggests:       less
60 Suggests:       rsync
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # html docs have links to txt files
64 %define         _noautocompressdoc      *.txt
65
66 %define         webapp          gitweb
67 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
68 %define         appdir          %{_datadir}/%{webapp}
69 %define         cgibindir       %{_prefix}/lib/cgi-bin
70
71 %description
72 "git" can mean anything, depending on your mood.
73
74 - random three-letter combination that is pronounceable, and not
75   actually used by any common UNIX command. The fact that it is a
76   mispronunciation of "get" may or may not be relevant.
77 - stupid. contemptible and despicable. simple. Take your pick from the
78   dictionary of slang.
79 - "global information tracker": you're in a good mood, and it actually
80   works for you. Angels sing, and a light suddenly fills the room.
81 - "goddamn idiotic truckload of sh*t": when it breaks
82
83 This is a stupid (but extremely fast) directory content manager. It
84 doesn't do a whole lot, but what it 'does' do is track directory
85 contents efficiently.
86
87 %description -l pl.UTF-8
88 "git" może oznaczać cokolwiek, w zależności od nastroju.
89
90 - losową kombinację trzech liter, która jest wymawialna i właściwie
91   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
92   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
93 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
94 - "global information tracker" (narzędzie do globalnego śledzenia
95   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
96   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
97 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
98   g*) - kiedy się zepsuje.
99
100 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
101 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
102 katalogu.
103
104 %package doc
105 Summary:        Documentation for git-core
106 Summary(pl.UTF-8):      Dokumentacja do git-core
107 Group:          Documentation
108
109 %description doc
110 Documentation for git-core.
111
112 %description doc -l pl.UTF-8
113 Dokumentacja do git-core.
114
115 %description doc -l fr.UTF-8
116 Javadoc pour git-core.
117
118 %package daemon-inetd
119 Summary:        Files necessary to run git-daemon as an inetd service
120 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
121 Group:          Networking/Daemons
122 Requires:       %{name} = %{version}-%{release}
123 Requires:       setup >= 2.4.11-1
124 Provides:       git-core-daemon
125 Obsoletes:      git-core-daemon
126 Obsoletes:      git-core-daemon-standalone
127
128 %description daemon-inetd
129 Git-daemon is a really simple TCP git daemon that can serve git
130 repositories. This package provides all necessarry files to run
131 git-daemon as an inetd service.
132
133 %description daemon-inetd -l pl.UTF-8
134 Git-daemon to prosty demon git korzystający z protokołu TCP do
135 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
136 do uruchomienia git-demona w trybie usługi inetd.
137
138 %package daemon-standalone
139 Summary:        Files necessary to run git-daemon as a standalone service
140 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
141 Group:          Networking/Daemons
142 Requires:       %{name} = %{version}-%{release}
143 Provides:       git-core-daemon
144 Obsoletes:      git-core-daemon
145 Obsoletes:      git-core-daemon-inetd
146
147 %description daemon-standalone
148 Git-daemon is a really simple TCP git daemon that can serve git
149 repositories. This package provides all necessarry files to run
150 git-daemon as an standalone service.
151
152 %description daemon-standalone -l pl.UTF-8
153 Git-daemon to prosty demon git korzystający z protokołu TCP do
154 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
155 do uruchomienia git-daemona w trybie usługi samodzielnej.
156
157 %package devel
158 Summary:        Header files for git-core
159 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
160 Group:          Development/Libraries
161 Requires:       zlib-devel
162
163 %description devel
164 Header files for git-core.
165
166 %description devel -l pl.UTF-8
167 Pliki nagłówkowe dla git-core.
168
169 %package gitk
170 Summary:        Tcl/Tk interface to the Git version control system
171 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
172 Group:          Development/Tools
173 Requires:       %{name} = %{version}-%{release}
174 Requires:       tk
175
176 %description gitk
177 gitk displays changes in a repository or a selected set of commits.
178 This includes visualizing the commit graph, showing information
179 related to each commit, and the files in the trees of each revision.
180
181 Historically, gitk was the first repository browser. It's written in
182 Tcl/Tk and started off in a separate repository but was later merged
183 into the main git repository.
184
185 %description gitk -l pl.UTF-8
186 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
187 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
188 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
189
190 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
191 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
192 osobnym repozytorium, ale z czasem został włączony do głównego
193 repozytorium gita.
194
195 %package gitweb
196 Summary:        Web frontend to git
197 Summary(pl.UTF-8):      Webowy frontend do git
198 Group:          Development/Tools
199 Requires:       %{name} = %{version}-%{release}
200 Requires:       webapps
201
202 %description gitweb
203 This package provides a web interface for browsing git repositories.
204
205 %description gitweb -l pl.UTF-8
206 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
207
208 %package gitview
209 Summary:        A GTK+ based repository browser for git
210 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
211 Group:          Development/Tools
212 Requires:       %{name} = %{version}-%{release}
213 Requires:       python >= 1:2.4
214 Requires:       python-pycairo >= 1.0
215 Requires:       python-pygobject
216 Requires:       python-pygtk-gtk >= 2:2.8
217 Suggests:       python-gnome-desktop-gtksourceview
218
219 %description gitview
220 A GTK+ based repository browser for git.
221
222 %description gitview -l pl.UTF-8
223 Oparta na GTK+ przeglądarka repozytorium gita.
224
225 %package gui
226 Summary:        Tcl/Tk interface to the Git version control system
227 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
228 Group:          Development/Tools
229 Requires:       %{name} = %{version}-%{release}
230 Requires:       tk
231
232 %description gui
233 Displays changes in a repository or a selected set of commits. This
234 includes visualizing the commit graph, showing information related to
235 each commit, and the files in the trees of each revision.
236
237 Historically, gitk was the first repository browser. It's written in
238 Tcl/Tk and started off in a separate repository but was later merged
239 into the main git repository.
240
241 %description gui -l pl.UTF-8
242 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
243 to wizualizację grafu commitów, wyświetlanie informacji związanych z
244 każdym z commitów oraz listę plików dla każdej rewizji.
245
246 Z punktu widzenia historii, gitk był pierwszą przeglądarką
247 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
248 osobnym repozytorium, ale z czasem został włączony do głównego
249 repozytorium gita.
250
251 %package svn
252 Summary:        Subversion support for Git
253 Summary(pl.UTF-8):      Obsługa Subversion dla Git
254 Group:          Development/Tools
255 Requires:       %{name} = %{version}-%{release}
256
257 %description svn
258 Subversion support for Git.
259
260 %description svn -l pl.UTF-8
261 Obsługa Subversion dla Git.
262
263 %package cvs
264 Summary:        CVS support for Git
265 Summary(pl.UTF-8):      Obsługa CVS dla Git
266 Group:          Development/Tools
267 Requires:       %{name} = %{version}-%{release}
268 Requires:       cvsps >= 2.1-2
269 Requires:       rcs
270
271 %description cvs
272 CVS support for Git.
273
274 %description cvs -l pl.UTF-8
275 Obsługa CVS dla Git.
276
277 %package arch
278 Summary:        Git tools for importing Arch repositories
279 Group:          Development/Tools
280 Requires:       %{name} = %{version}-%{release}
281 Requires:       tla
282
283 %description arch
284 Git tools for importing Arch repositories.
285
286 %package email
287 Summary:        Git tools for sending email
288 Group:          Development/Tools
289 Requires:       %{name} = %{version}-%{release}
290
291 %description email
292 Git tools for sending email.
293
294 %package -n bash-completion-git
295 Summary:        bash-completion for git
296 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
297 Group:          Applications/Shells
298 Requires:       bash-completion
299
300 %description -n bash-completion-git
301 This package provides bash-completion for git.
302
303 %description -n bash-completion-git -l pl.UTF-8
304 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
305
306 %package -n perl-Git
307 Summary:        Perl interface to the Git version control system
308 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
309 Group:          Development/Languages/Perl
310 Obsoletes:      perl-git-core
311
312 %description -n perl-Git
313 This module provides Perl scripts easy way to interface the Git
314 version control system. The modules have an easy and well-tested way
315 to call arbitrary Git commands; in the future, the interface will also
316 provide specialized methods for doing easily operations which are not
317 totally trivial to do over the generic command interface.
318
319 %description -n perl-Git -l pl.UTF-8
320 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
321 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
322 dowolne polecenia Gita; w przyszłości interfejs udostępni także
323 specjalne metody do łatwego wykonywania operacji nietrywialnych do
324 wykonania przy użyciu ogólnego interfejsu poleceń.
325
326 %package -n python-Git
327 Summary:        Python interface to the Git version control system
328 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
329 Group:          Development/Languages/Python
330
331 %description -n python-Git
332 This module provides Python scripts easy way to interface the Git
333 version control system.
334
335 %description -n python-Git -l pl.UTF-8
336 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
337 wersji Git.
338
339 %package -n vim-syntax-gitcommit
340 Summary:        Vim syntax: gitcommit
341 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
342 Group:          Applications/Editors/Vim
343 # for _vimdatadir existence
344 Requires:       vim-rt >= 4:6.3.058-3
345
346 %description -n vim-syntax-gitcommit
347 This plugin provides syntax highlighting for git's commit messages.
348
349 %description -n vim-syntax-gitcommit -l pl.UTF-8
350 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
351
352 %prep
353 %setup -q -n git-%{version}
354 %patch0 -p1
355
356 %build
357 %{__aclocal}
358 %{__autoconf}
359 %configure \
360         --with-openssl
361
362 echo "BLK_SHA1=1" >> config.mak
363
364 %{__make} \
365         INSTALLDIRS=vendor \
366         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
367         GITWEB_PROJECTROOT="/var/lib/git" \
368         GITWEB_CSS="/gitweb/gitweb.css" \
369         GITWEB_LOGO="/gitweb/git-logo.png" \
370         GITWEB_FAVICON="/gitweb/git-favicon.png"
371
372 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
373 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
374
375 %if %{with tests}
376 %if %{without tests_cvs}
377 rm t/t*cvs*.sh || :
378 %endif
379 %{__make} test
380 %endif
381
382 %install
383 rm -rf $RPM_BUILD_ROOT
384 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
385 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
386 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
387
388 %{__make} install \
389         INSTALLDIRS=vendor \
390         DESTDIR=$RPM_BUILD_ROOT
391
392 %if %{with doc}
393 %{__make} -C Documentation install \
394         DESTDIR=$RPM_BUILD_ROOT
395 %endif
396
397 # header files and lib
398 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
399 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
400 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
401 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
402 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
403
404 # bash completion
405 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
406 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
407
408 # vim syntax
409 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
410 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
411 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
412 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
413 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
414 autocmd BufNewFile,BufRead .msg.[0-9]*
415         \ if getline(1) =~ '^From.*# This line is ignored.$' |
416         \   setf gitsendemail |
417         \ endif
418 autocmd BufNewFile,BufRead *.git/**
419         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
420         \   setf git |
421         \ endif
422 EOF
423
424 # gitweb
425 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
426 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
427 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
428 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
429 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
430
431 # gitview
432 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
433
434 # git-daemon related files
435 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
436 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
437 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
438
439 # paths cleanup
440 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
441 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
442
443 # hardlink
444 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
445 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
446 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
447 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
448
449 # remove unneeded files
450 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
451 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
452 %py_postclean
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %post daemon-inetd
458 %service -q rc-inetd reload
459
460 %postun daemon-inetd
461 if [ "$1" = "0" ]; then
462         %service -q rc-inetd reload
463 fi
464
465 %post daemon-standalone
466 /sbin/chkconfig --add git-daemon
467 %service git-daemon restart "git-daemon"
468
469 %preun daemon-standalone
470 if [ "$1" = "0" ]; then
471         %service git-daemon stop
472         /sbin/chkconfig --del git-daemon
473 fi
474
475 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
476 %webapp_register apache %{webapp}
477
478 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
479 %webapp_unregister apache %{webapp}
480
481 %triggerin gitweb -- apache < 2.2.0, apache-base
482 %webapp_register httpd %{webapp}
483
484 %triggerun gitweb -- apache < 2.2.0, apache-base
485 %webapp_unregister httpd %{webapp}
486
487 %files
488 %defattr(644,root,root,755)
489 %doc README contrib
490 %attr(755,root,root) %{_bindir}/git
491 %attr(755,root,root) %{_bindir}/git-receive-pack
492 %attr(755,root,root) %{_bindir}/git-shell
493 %attr(755,root,root) %{_bindir}/git-upload-archive
494 %attr(755,root,root) %{_bindir}/git-upload-pack
495
496 %if %{with doc}
497 %{_mandir}/man1/git-*.1*
498 %exclude %{_mandir}/man1/git-svn.1*
499 %exclude %{_mandir}/man1/git-cvs*.1*
500 %{_mandir}/man1/git.1*
501 %{_mandir}/man5/gitattributes.5*
502 %{_mandir}/man5/githooks.5*
503 %{_mandir}/man5/gitignore.5*
504 %{_mandir}/man5/gitmodules.5*
505 %{_mandir}/man5/gitrepository-layout.5*
506 %{_mandir}/man7/gitcli.7*
507 %{_mandir}/man7/gitcore-tutorial.7*
508 %{_mandir}/man7/gitdiffcore.7*
509 %{_mandir}/man7/gitglossary.7*
510 %{_mandir}/man7/gittutorial-2.7*
511 %{_mandir}/man7/gittutorial.7*
512 %{_mandir}/man7/gitworkflows.7*
513 %endif
514
515 %dir %{_libdir}/%{name}
516 %attr(755,root,root) %{_libdir}/%{name}/*-*
517 %attr(755,root,root) %{_libdir}/%{name}/git
518
519 %exclude %{_libdir}/%{name}/git-gui
520 %exclude %{_libdir}/%{name}/git-svn
521 %exclude %{_libdir}/%{name}/git-archimport
522 %exclude %{_libdir}/%{name}/git-cvs*
523 %exclude %{_libdir}/%{name}/*email*
524
525 %{_datadir}/%{name}
526
527 %{_localstatedir}/lib/git
528
529 %if %{with doc}
530 %files doc
531 %defattr(644,root,root,755)
532 %doc Documentation/RelNotes*
533 %doc Documentation/*.html Documentation/howto Documentation/technical
534 %endif
535
536 %files daemon-inetd
537 %defattr(644,root,root,755)
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
539
540 %files daemon-standalone
541 %defattr(644,root,root,755)
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
543 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
544
545 %files devel
546 %defattr(644,root,root,755)
547 %{_includedir}/git-core
548 %{_libdir}/libgit.a
549 %{_libdir}/libgit_xdiff.a
550
551 %files gitk
552 %defattr(644,root,root,755)
553 %if %{with doc}
554 %{_mandir}/man1/gitk.1*
555 %endif
556 %attr(755,root,root) %{_bindir}/gitk
557 %dir %{_datadir}/gitk
558 %dir %{_datadir}/gitk/lib
559 %dir %{_datadir}/gitk/lib/msgs
560 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
561 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
562 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
563 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
564 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
565 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
566 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
567 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
568
569 %files gitweb
570 %defattr(644,root,root,755)
571 %doc gitweb/{README,INSTALL}
572 %dir %{webappdir}
573 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
574 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
575 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
576 %attr(755,root,root) %{cgibindir}/gitweb.cgi
577 %{appdir}
578
579 %files gitview
580 %defattr(644,root,root,755)
581 %doc contrib/gitview/gitview.txt
582 %attr(755,root,root) %{_bindir}/gitview
583
584 %files gui
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/%{name}/git-gui
587 %dir %{_datadir}/git-gui
588 %dir %{_datadir}/git-gui/lib
589 %dir %{_datadir}/git-gui/lib/msgs
590 %{_datadir}/git-gui/lib/git-gui.ico
591 %{_datadir}/git-gui/lib/tclIndex
592 %{_datadir}/git-gui/lib/*.js
593 %{_datadir}/git-gui/lib/*.tcl
594 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
595 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
596 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
597 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
598 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
599 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
600 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
601 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
602 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
603 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
604
605 %files svn
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{_libdir}/%{name}/git-svn
608 %if %{with doc}
609 %{_mandir}/man1/git-svn.1*
610 %endif
611
612 %files cvs
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/git-cvsserver
615 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
616 %if %{with doc}
617 %{_mandir}/man1/git-cvs*.1*
618 %{_mandir}/man7/gitcvs-migration.7*
619 %endif
620
621 %files arch
622 %defattr(644,root,root,755)
623 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
624 %if %{with doc}
625 %{_mandir}/man1/git-archimport.1*
626 %endif
627
628 %files email
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_libdir}/%{name}/*email*
631 %if %{with doc}
632 %{_mandir}/man1/*email*.1*
633 %endif
634
635 %files -n bash-completion-git
636 %defattr(644,root,root,755)
637 %{_sysconfdir}/bash_completion.d/*
638
639 %files -n perl-Git
640 %defattr(644,root,root,755)
641 %{perl_vendorlib}/Git.pm
642 %{_mandir}/man3/Git.3pm*
643
644 %files -n python-Git
645 %defattr(644,root,root,755)
646 %{py_sitescriptdir}/git_remote_helpers*.egg-info
647 %dir %{py_sitescriptdir}/git_remote_helpers
648 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
649 %dir %{py_sitescriptdir}/git_remote_helpers/git
650 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
651
652 %files -n vim-syntax-gitcommit
653 %defattr(644,root,root,755)
654 %doc contrib/vim/README
655 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.118784 seconds and 3 git commands to generate.