]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
printf still needed
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # don't perform make test
4 %bcond_with     tests_cvs       # perform tests which use CVS
5 %bcond_without  tests_svn       # perform tests which use subversion
6 %bcond_without  doc             # skip building/packaging docs/manuals (takes some time)
7 %bcond_without  pcre            # perl-compatible regexes support
8 %bcond_without  gnome_keyring   # build without gnome keyring support
9
10 # for AC: --without doc --without gnome_keyring --without tests
11
12 %include        /usr/lib/rpm/macros.perl
13 Summary:        Distributed version control system focused on speed, effectivity and usability
14 Summary(pl.UTF-8):      Rozproszony system śledzenia treści skupiony na szybkości, wydajności i użyteczności
15 Name:           git-core
16 Version:        1.9.1
17 Release:        1
18 License:        GPL v2
19 Group:          Development/Tools
20 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.gz
21 # Source0-md5:  a71a1ee1418bd61d73182fba62b05fd3
22 Source1:        %{name}-gitweb.conf
23 Source2:        %{name}-gitweb-httpd.conf
24 Source3:        %{name}-gitweb-lighttpd.conf
25 Source4:        %{name}.sysconfig
26 Source5:        %{name}.inet
27 Source6:        %{name}.init
28 Source7:        gitolite.pl
29 Patch0:         %{name}-tests.patch
30 Patch1:         %{name}-key-bindings.patch
31 Patch2:         %{name}-sysconfdir.patch
32 Patch3:         cherry-picked-commitlog.patch
33 Patch4:         %{name}-svn-exit-errors.patch
34 URL:            http://git-scm.com/
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake
37 BuildRequires:  curl-devel
38 BuildRequires:  expat-devel
39 BuildRequires:  gettext-devel
40 %if %{with gnome_keyring}
41 BuildRequires:  libgnome-keyring-devel
42 BuildRequires:  pkgconfig
43 %endif
44 BuildRequires:  openssl-devel
45 %{?with_pcre:BuildRequires:     pcre-devel}
46 BuildRequires:  perl-Error > 0.15
47 BuildRequires:  perl-base
48 BuildRequires:  python-devel
49 BuildRequires:  rpm-perlprov >= 4.1-13
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  rpmbuild(macros) >= 1.673
52 BuildRequires:  tcl
53 BuildRequires:  zlib-devel
54 %if %{with doc}
55 BuildRequires:  asciidoc >= 7.1.2-3
56 BuildRequires:  docbook-dtd45-xml
57 BuildRequires:  xmlto
58 %endif
59 %if %{with tests}
60 %if %{with tests_cvs}
61 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
62 BuildRequires:  cvs-gnu-client < 1.13
63 BuildRequires:  cvs-gnu-client >= 1.12
64 %endif
65 %{?with_tests_svn:BuildRequires:  subversion}
66 Conflicts:      pdksh < 5.2.14-46
67 %endif
68 # git-sh-setup: sane_grep
69 Requires:       grep
70 # git-pull: printf
71 Requires:       coreutils
72 Requires:       openssh-clients
73 Requires:       perl-Error
74 Requires:       perl-Git = %{version}-%{release}
75 Requires:       sed
76 Suggests:       git-core-bzr
77 Suggests:       git-core-cvs
78 Suggests:       git-core-hg
79 Suggests:       git-core-p4
80 Suggests:       git-core-svn
81 Suggests:       less
82 Suggests:       rsync
83 Obsoletes:      python-Git
84 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
86 # html docs have links to txt files
87 %define         _noautocompressdoc      *.txt
88
89 %define         webapp          gitweb
90 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
91 %define         appdir          %{_datadir}/%{webapp}
92 %define         cgibindir       %{_prefix}/lib/cgi-bin
93
94 %description
95 "git" can mean anything, depending on your mood.
96
97 - random three-letter combination that is pronounceable, and not
98   actually used by any common UNIX command. The fact that it is a
99   mispronunciation of "get" may or may not be relevant.
100 - stupid. contemptible and despicable. simple. Take your pick from the
101   dictionary of slang.
102 - "global information tracker": you're in a good mood, and it actually
103   works for you. Angels sing, and a light suddenly fills the room.
104 - "goddamn idiotic truckload of sh*t": when it breaks
105
106 This is a stupid (but extremely fast) directory content manager. It
107 doesn't do a whole lot, but what it 'does' do is track directory
108 contents efficiently.
109
110 %description -l pl.UTF-8
111 "git" może oznaczać cokolwiek, w zależności od nastroju.
112
113 - losową kombinację trzech liter, która jest wymawialna i właściwie
114   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
115   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
116 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
117 - "global information tracker" (narzędzie do globalnego śledzenia
118   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
119   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
120 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
121   g*) - kiedy się zepsuje.
122
123 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
124 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
125 katalogu.
126
127 %package doc
128 Summary:        Documentation for git-core
129 Summary(pl.UTF-8):      Dokumentacja do git-core
130 Group:          Documentation
131
132 %description doc
133 Documentation for git-core.
134
135 %description doc -l pl.UTF-8
136 Dokumentacja do git-core.
137
138 %description doc -l fr.UTF-8
139 Javadoc pour git-core.
140
141 %package daemon-inetd
142 Summary:        Files necessary to run git-daemon as an inetd service
143 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
144 Group:          Networking/Daemons
145 Requires:       %{name} = %{version}-%{release}
146 Requires:       setup >= 2.4.11-1
147 Provides:       git-core-daemon
148 Obsoletes:      git-core-daemon
149 Obsoletes:      git-core-daemon-standalone
150
151 %description daemon-inetd
152 Git-daemon is a really simple TCP git daemon that can serve git
153 repositories. This package provides all necessarry files to run
154 git-daemon as an inetd service.
155
156 %description daemon-inetd -l pl.UTF-8
157 Git-daemon to prosty demon git korzystający z protokołu TCP do
158 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
159 do uruchomienia git-demona w trybie usługi inetd.
160
161 %package daemon-standalone
162 Summary:        Files necessary to run git-daemon as a standalone service
163 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
164 Group:          Networking/Daemons
165 Requires:       %{name} = %{version}-%{release}
166 Provides:       git-core-daemon
167 Obsoletes:      git-core-daemon
168 Obsoletes:      git-core-daemon-inetd
169
170 %description daemon-standalone
171 Git-daemon is a really simple TCP git daemon that can serve git
172 repositories. This package provides all necessarry files to run
173 git-daemon as an standalone service.
174
175 %description daemon-standalone -l pl.UTF-8
176 Git-daemon to prosty demon git korzystający z protokołu TCP do
177 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
178 do uruchomienia git-daemona w trybie usługi samodzielnej.
179
180 %package devel
181 Summary:        Git library with header files
182 Summary(pl.UTF-8):      Biblioteka Gita oraz pliki nagłówkowe
183 Group:          Development/Libraries
184 Requires:       zlib-devel
185
186 %description devel
187 Git library with header files.
188
189 %description devel -l pl.UTF-8
190 Biblioteka Gita oraz pliki nagłówkowe.
191
192 %package gitk
193 Summary:        Tcl/Tk interface to the Git version control system
194 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
195 Group:          Development/Tools
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       tk
198
199 %description gitk
200 gitk displays changes in a repository or a selected set of commits.
201 This includes visualizing the commit graph, showing information
202 related to each commit, and the files in the trees of each revision.
203
204 Historically, gitk was the first repository browser. It's written in
205 Tcl/Tk and started off in a separate repository but was later merged
206 into the main git repository.
207
208 %description gitk -l pl.UTF-8
209 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
210 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
211 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
212
213 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
214 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
215 osobnym repozytorium, ale z czasem został włączony do głównego
216 repozytorium gita.
217
218 %package gitweb
219 Summary:        Web frontend to git
220 Summary(pl.UTF-8):      Frontend WWW do gita
221 Group:          Development/Tools
222 Requires:       %{name} = %{version}-%{release}
223 Requires:       webapps
224 Requires:       webserver(access)
225 Requires:       webserver(alias)
226 Requires:       webserver(cgi)
227 Suggests:       webserver(setenv)
228
229 %description gitweb
230 This package provides a web interface for browsing git repositories.
231
232 %description gitweb -l pl.UTF-8
233 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
234
235 %package gitview
236 Summary:        A GTK+ based repository browser for git
237 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
238 Group:          Development/Tools
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       python >= 1:2.4
241 Requires:       python-pycairo >= 1.0
242 Requires:       python-pygobject
243 Requires:       python-pygtk-gtk >= 2:2.8
244 Suggests:       python-gnome-desktop-gtksourceview
245
246 %description gitview
247 A GTK+ based repository browser for git.
248
249 %description gitview -l pl.UTF-8
250 Oparta na GTK+ przeglądarka repozytorium gita.
251
252 %package gui
253 Summary:        Tcl/Tk interface to the Git version control system
254 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
255 Group:          Development/Tools
256 Requires:       %{name} = %{version}-%{release}
257 Requires:       tk
258 Requires:       xdg-utils
259 Suggests:       meld
260
261 %description gui
262 Displays changes in a repository or a selected set of commits. This
263 includes visualizing the commit graph, showing information related to
264 each commit, and the files in the trees of each revision.
265
266 Historically, gitk was the first repository browser. It's written in
267 Tcl/Tk and started off in a separate repository but was later merged
268 into the main git repository.
269
270 %description gui -l pl.UTF-8
271 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
272 to wizualizację grafu commitów, wyświetlanie informacji związanych z
273 każdym z commitów oraz listę plików dla każdej rewizji.
274
275 Z punktu widzenia historii, gitk był pierwszą przeglądarką
276 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
277 osobnym repozytorium, ale z czasem został włączony do głównego
278 repozytorium gita.
279
280 %package arch
281 Summary:        Git tools for importing Arch repositories
282 Summary(pl.UTF-8):      Narzędzia Gita do importowania repozytoriów Archa
283 Group:          Development/Tools
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       tla
286
287 %description arch
288 Git tools for importing Arch repositories.
289
290 %description arch -l pl.UTF-8
291 Narzędzia Gita do importowania repozytoriów Archa.
292
293 %package bzr
294 Summary:        Git tools for working with bzr repositories
295 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami bzr
296 Group:          Development/Tools
297 Requires:       %{name} = %{version}-%{release}
298 Requires:       bzr
299
300 %description bzr
301 Git tools for working with bzr repositories.
302
303 %description bzr -l pl.UTF-8
304 Narzędzia Gita do pracy z repozytoriami bzr.
305
306 %package cvs
307 Summary:        CVS support for Git
308 Summary(pl.UTF-8):      Obsługa CVS dla Gita
309 Group:          Development/Tools
310 Requires:       %{name} = %{version}-%{release}
311 Requires:       cvsps >= 2.1-2
312 Requires:       rcs
313
314 %description cvs
315 CVS support for Git.
316
317 %description cvs -l pl.UTF-8
318 Obsługa CVS dla Gita.
319
320 %package hg
321 Summary:        Git tools for working with mercurial repositories
322 Summary(pl.UTF-8):      Narzędzia Gita do pracy z repozytoriami mercuriala
323 Group:          Development/Tools
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       mercurial >= 1.8
326
327 %description hg
328 Git tools for working with mercurial repositories.
329
330 %description hg -l pl.UTF-8
331 Narzędzia Gita do pracy z repozytoriami mercuriala.
332
333 %package p4
334 Summary:        Git tools for working with Perforce depots
335 Summary(pl.UTF-8):      Narzędzia Gita do pracy z magazynami Perforce'a
336 Group:          Development/Tools
337 Requires:       %{name} = %{version}-%{release}
338
339 %description p4
340 Git tools for working with Perforce depots.
341
342 %description p4 -l pl.UTF-8
343 Narzędzia Gita do pracy z magazynami Perforce'a.
344
345 %package svn
346 Summary:        Subversion support for Git
347 Summary(pl.UTF-8):      Obsługa Subversion dla Gita
348 Group:          Development/Tools
349 Requires:       %{name} = %{version}-%{release}
350 Requires:       perl-Encode
351 Requires:       perl-Term-ReadKey
352
353 %description svn
354 Subversion support for Git.
355
356 %description svn -l pl.UTF-8
357 Obsługa Subversion dla Gita.
358
359 %package email
360 Summary:        Git tools for sending email
361 Summary(pl.UTF-8):      Narzędzia Gita do wysyłania poczty
362 Group:          Development/Tools
363 Requires:       %{name} = %{version}-%{release}
364
365 %description email
366 Git tools for sending email.
367
368 %description email -l pl.UTF-8
369 Narzędzia Gita do wysyłania poczty.
370
371 %package -n bash-completion-git
372 Summary:        bash-completion for git
373 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
374 Group:          Applications/Shells
375 Requires:       %{name} = %{version}-%{release}
376 Requires:       bash-completion >= 2.0
377 %if "%{_rpmversion}" >= "5"
378 BuildArch:      noarch
379 %endif
380
381 %description -n bash-completion-git
382 This package provides bash-completion for git.
383
384 %description -n bash-completion-git -l pl.UTF-8
385 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
386
387 %package -n perl-Git
388 Summary:        Perl interface to the Git version control system
389 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
390 Group:          Development/Languages/Perl
391 Obsoletes:      perl-git-core
392
393 %description -n perl-Git
394 This module provides Perl scripts easy way to interface the Git
395 version control system. The modules have an easy and well-tested way
396 to call arbitrary Git commands; in the future, the interface will also
397 provide specialized methods for doing easily operations which are not
398 totally trivial to do over the generic command interface.
399
400 %description -n perl-Git -l pl.UTF-8
401 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
402 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
403 dowolne polecenia Gita; w przyszłości interfejs udostępni także
404 specjalne metody do łatwego wykonywania operacji nietrywialnych do
405 wykonania przy użyciu ogólnego interfejsu poleceń.
406
407 %package -n gnome-keyring-git-core
408 Summary:        GNOME Keyring authentication provider for Git
409 Summary(pl.UTF-8):      Moduł uwierzytelniający GNOME Keyring dla Git
410 Group:          X11/Applications
411 Requires:       %{name} = %{version}-%{release}
412
413 %description -n gnome-keyring-git-core
414 Authentication provider module for Git which allows git client to
415 authenticate using GNOME Keyring.
416
417 %description -n gnome-keyring-git-core -l pl.UTF-8
418 Moduł uwierzytelniający dla Subversion pozwalający klientom git
419 uwierzytelniać się przy użyciu mechanizmu GNOME Keyring.
420
421 %prep
422 %setup -q -n git-%{version}
423 %patch0 -p1
424 %patch1 -p0
425 %patch2 -p1
426 %patch3 -p1
427 %patch4 -p1
428
429 %{__rm} {Documentation/technical,contrib/emacs,contrib/credential/gnome-keyring}/.gitignore
430
431 %build
432 %{__aclocal}
433 %{__autoconf}
434 %configure \
435         --sysconfdir=%{_sysconfdir}/git-core \
436         %{?with_pcre:--with-libpcre} \
437         --with-openssl
438
439 echo "BLK_SHA1=1" >> config.mak
440
441 %{__make} \
442         INSTALLDIRS=vendor \
443         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
444         GITWEB_PROJECTROOT="/var/lib/git" \
445         GITWEB_CSS="/gitweb/gitweb.css" \
446         GITWEB_LOGO="/gitweb/git-logo.png" \
447         GITWEB_FAVICON="/gitweb/git-favicon.png" \
448         V=1
449
450 %{__make} -C contrib/subtree
451
452 %if %{with gnome_keyring}
453 %{__make} -C contrib/credential/gnome-keyring
454 %endif
455
456 %if %{with doc}
457 %{__make} -C Documentation \
458         MAN_BASE_URL=file://%{_docdir}/%{name}-doc-%{version}/ \
459         V=1
460 %endif
461
462 %if %{with tests}
463 %if %{without tests_cvs}
464 %{__rm} t/t*cvs*.sh || :
465 %endif
466 %{!?with_tests_svn:GIT_SKIP_TESTS='t91??'} %{__make} test
467 %endif
468
469 %install
470 rm -rf $RPM_BUILD_ROOT
471 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
472 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
473 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
474 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
475 cat << EOF > $RPM_BUILD_ROOT%{_sysconfdir}/git-core/gitconfig
476 [init]
477         templatedir = %{_sysconfdir}/%{name}/templates
478 EOF
479
480 %{__make} install \
481         INSTALLDIRS=vendor \
482         DESTDIR=$RPM_BUILD_ROOT
483
484 %if %{with doc}
485 %{__make} -C Documentation install \
486         DESTDIR=$RPM_BUILD_ROOT
487 %endif
488
489 # copy templates except sample hooks
490 cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/templates $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
491 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/templates/hooks/*.sample
492
493 # header files and lib
494 cp -p *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
495 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
496 cp -p xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
497 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
498 cp -p block-sha1/sha1.h $RPM_BUILD_ROOT%{_includedir}/%{name}/block-sha1
499 cp -p libgit.a $RPM_BUILD_ROOT%{_libdir}
500 cp -p xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
501 cp -p {Makefile,config.mak,config.mak.autogen,config.mak.uname} $RPM_BUILD_ROOT%{_includedir}/%{name}
502
503 %{__make} -C contrib/subtree install \
504         libexecdir=%{_libdir}/%{name} \
505         DESTDIR=$RPM_BUILD_ROOT
506
507 %if %{with doc}
508 %{__make} -C contrib/subtree install-doc \
509         DESTDIR=$RPM_BUILD_ROOT
510 %endif
511
512 %if %{with gnome_keyring}
513 install -p contrib/credential/gnome-keyring/git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libdir}/%{name}
514 # Remove built binary files, otherwise they will be installed in doc
515 %{__make} -C contrib/credential/gnome-keyring clean
516 %endif
517
518 # bash completion
519 install -d $RPM_BUILD_ROOT%{bash_compdir}
520 cp -p contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{bash_compdir}/git
521
522 # Install git-prompt.sh
523 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
524 cp -p contrib/completion/git-prompt.sh $RPM_BUILD_ROOT%{_datadir}/%{name}/contrib/completion
525
526 # Install bzr and hg remote helpers from contrib
527 install -p contrib/remote-helpers/git-remote-{bzr,hg} $RPM_BUILD_ROOT%{_libdir}/%{name}
528
529 # gitweb
530 mv $RPM_BUILD_ROOT{%{appdir},%{cgibindir}}/gitweb.cgi
531 ln -s %{cgibindir}/gitweb.cgi $RPM_BUILD_ROOT%{appdir}/gitweb.cgi
532 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
533 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{webappdir}/gitolite.pl
534 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
535 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
536 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{webappdir}/lighttpd.conf
537
538 # gitview
539 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
540
541 # git-daemon related files
542 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
543 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
544 install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
545
546 # paths cleanup
547 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
548 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
549
550 # hardlink
551 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
552 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
553 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
554 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
555
556 # remove unneeded files
557 %{__rm} $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
558 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
559 %py_postclean
560
561 mv $RPM_BUILD_ROOT%{_localedir}/pt{_PT,}
562 %find_lang git
563
564 %clean
565 rm -rf $RPM_BUILD_ROOT
566
567 %post daemon-inetd
568 %service -q rc-inetd reload
569
570 %postun daemon-inetd
571 if [ "$1" = "0" ]; then
572         %service -q rc-inetd reload
573 fi
574
575 %post daemon-standalone
576 /sbin/chkconfig --add git-daemon
577 %service git-daemon restart "git-daemon"
578
579 %preun daemon-standalone
580 if [ "$1" = "0" ]; then
581         %service git-daemon stop
582         /sbin/chkconfig --del git-daemon
583 fi
584
585 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
586 %webapp_register apache %{webapp}
587
588 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
589 %webapp_unregister apache %{webapp}
590
591 %triggerin gitweb -- apache < 2.2.0, apache-base
592 %webapp_register httpd %{webapp}
593
594 %triggerun gitweb -- apache < 2.2.0, apache-base
595 %webapp_unregister httpd %{webapp}
596
597 %triggerin gitweb -- lighttpd
598 %webapp_register lighttpd %{webapp}
599
600 %triggerun gitweb -- lighttpd
601 %webapp_unregister lighttpd %{webapp}
602
603 %files -f git.lang
604 %defattr(644,root,root,755)
605 %doc README contrib
606 %attr(755,root,root) %{_bindir}/git
607 %attr(755,root,root) %{_bindir}/git-receive-pack
608 %attr(755,root,root) %{_bindir}/git-shell
609 %attr(755,root,root) %{_bindir}/git-upload-archive
610 %attr(755,root,root) %{_bindir}/git-upload-pack
611 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}
612
613 %if %{with doc}
614 %{_mandir}/man1/git-*.1*
615 %exclude %{_mandir}/man1/git-archimport.1*
616 %exclude %{_mandir}/man1/git-svn.1*
617 %exclude %{_mandir}/man1/git-cvs*.1*
618 %exclude %{_mandir}/man1/git-imap-send*.1*
619 %exclude %{_mandir}/man1/*email*.1*
620 %{_mandir}/man1/git.1*
621 %{_mandir}/man1/gitremote-helpers.1*
622 %{_mandir}/man5/gitattributes.5*
623 %{_mandir}/man5/githooks.5*
624 %{_mandir}/man5/gitignore.5*
625 %{_mandir}/man5/gitmodules.5*
626 %{_mandir}/man5/gitrepository-layout.5*
627 %{_mandir}/man7/gitcli.7*
628 %{_mandir}/man7/gitcore-tutorial.7*
629 %{_mandir}/man7/gitcredentials.7*
630 %{_mandir}/man7/gitdiffcore.7*
631 %{_mandir}/man7/gitglossary.7*
632 %{_mandir}/man7/gitnamespaces.7*
633 %{_mandir}/man7/gitrevisions.7*
634 %{_mandir}/man7/gittutorial-2.7*
635 %{_mandir}/man7/gittutorial.7*
636 %{_mandir}/man7/gitworkflows.7*
637 %endif
638
639 %dir %{_libdir}/%{name}
640 %attr(755,root,root) %{_libdir}/%{name}/*-*
641 %attr(755,root,root) %{_libdir}/%{name}/git
642 %dir %{_libdir}/%{name}/mergetools
643 %{_libdir}/%{name}/mergetools/*
644
645 %{_datadir}/%{name}
646 %{_localstatedir}/lib/git
647
648 # subpackages
649 %exclude %{_libdir}/%{name}/*email*
650 %exclude %{_libdir}/%{name}/*p4*
651 %exclude %{_libdir}/%{name}/git-archimport
652 %exclude %{_libdir}/%{name}/git-cvs*
653 %exclude %{_libdir}/%{name}/git-gui
654 %exclude %{_libdir}/%{name}/git-imap-send
655 %exclude %{_libdir}/%{name}/git-instaweb
656 %exclude %{_libdir}/%{name}/git-remote-bzr
657 %exclude %{_libdir}/%{name}/git-remote-hg
658 %exclude %{_libdir}/%{name}/git-remote-testsvn
659 %exclude %{_libdir}/%{name}/git-svn
660 %exclude %{_libdir}/%{name}/mergetools/p4merge
661 %if %{with gnome_keyring}
662 %exclude %{_libdir}/%{name}/git-credential-gnome-keyring
663 %endif
664
665 %if %{with doc}
666 %files doc
667 %defattr(644,root,root,755)
668 %doc Documentation/RelNotes*
669 %doc Documentation/*.html Documentation/howto Documentation/technical
670 %endif
671
672 %files daemon-inetd
673 %defattr(644,root,root,755)
674 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
675
676 %files daemon-standalone
677 %defattr(644,root,root,755)
678 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
679 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
680
681 %files devel
682 %defattr(644,root,root,755)
683 %{_includedir}/%{name}
684 %{_libdir}/libgit.a
685 %{_libdir}/libgit_xdiff.a
686
687 %files gitk
688 %defattr(644,root,root,755)
689 %if %{with doc}
690 %{_mandir}/man1/gitk.1*
691 %endif
692 %attr(755,root,root) %{_bindir}/gitk
693 %dir %{_datadir}/gitk
694 %dir %{_datadir}/gitk/lib
695 %dir %{_datadir}/gitk/lib/msgs
696 %lang(bg) %{_datadir}/gitk/lib/msgs/bg.msg
697 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
698 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
699 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
700 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
701 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
702 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
703 %lang(pt_BR) %{_datadir}/gitk/lib/msgs/pt_br.msg
704 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
705 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
706
707 %files gitweb
708 %defattr(644,root,root,755)
709 %doc gitweb/{README,INSTALL}
710 %dir %{webappdir}
711 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
712 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
713 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/lighttpd.conf
714 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
715 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitolite.pl
716 %attr(755,root,root) %{cgibindir}/gitweb.cgi
717 %{appdir}
718 %attr(755,root,root) %{_libdir}/%{name}/git-instaweb
719 %if %{with doc}
720 %{_mandir}/man1/gitweb.1*
721 %{_mandir}/man5/gitweb.conf.5*
722 %endif
723
724 %files gitview
725 %defattr(644,root,root,755)
726 %doc contrib/gitview/gitview.txt
727 %attr(755,root,root) %{_bindir}/gitview
728
729 %files gui
730 %defattr(644,root,root,755)
731 %attr(755,root,root) %{_libdir}/%{name}/git-gui
732 %dir %{_datadir}/git-gui
733 %dir %{_datadir}/git-gui/lib
734 %dir %{_datadir}/git-gui/lib/msgs
735 %{_datadir}/git-gui/lib/git-gui.ico
736 %{_datadir}/git-gui/lib/tclIndex
737 %{_datadir}/git-gui/lib/*.js
738 %{_datadir}/git-gui/lib/*.tcl
739 %lang(bg) %{_datadir}/git-gui/lib/msgs/bg.msg
740 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
741 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
742 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
743 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
744 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
745 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
746 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
747 %lang(pt_br) %{_datadir}/git-gui/lib/msgs/pt_br.msg
748 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
749 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
750 %lang(zh_CN) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
751
752 %files arch
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
755 %if %{with doc}
756 %{_mandir}/man1/git-archimport.1*
757 %endif
758
759 %files bzr
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_libdir}/%{name}/git-remote-bzr
762
763 %files cvs
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_bindir}/git-cvsserver
766 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
767 %if %{with doc}
768 %{_mandir}/man1/git-cvs*.1*
769 %{_mandir}/man7/gitcvs-migration.7*
770 %endif
771
772 %files hg
773 %defattr(644,root,root,755)
774 %attr(755,root,root) %{_libdir}/%{name}/git-remote-hg
775
776 %files p4
777 %defattr(644,root,root,755)
778 %attr(755,root,root) %{_libdir}/%{name}/git-p4
779 %attr(755,root,root) %{_libdir}/%{name}/mergetools/p4merge
780
781 %files svn
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/%{name}/git-svn
784 %attr(755,root,root) %{_libdir}/%{name}/git-remote-testsvn
785 %{perl_vendorlib}/Git/SVN
786 %{perl_vendorlib}/Git/SVN.pm
787 %if %{with doc}
788 %{_mandir}/man1/git-svn.1*
789 %endif
790
791 %files email
792 %defattr(644,root,root,755)
793 %attr(755,root,root) %{_libdir}/%{name}/git-imap-send
794 %attr(755,root,root) %{_libdir}/%{name}/*email*
795 %if %{with doc}
796 %{_mandir}/man1/*email*.1*
797 %{_mandir}/man1/*imap-send*.1*
798 %endif
799
800 %files -n bash-completion-git
801 %defattr(644,root,root,755)
802 %{bash_compdir}/git
803
804 %files -n perl-Git
805 %defattr(644,root,root,755)
806 %{perl_vendorlib}/Git.pm
807 %dir %{perl_vendorlib}/Git
808 %{perl_vendorlib}/Git/I18N.pm
809 %{perl_vendorlib}/Git/IndexInfo.pm
810 %{_mandir}/man3/Git*.3pm*
811
812 %if %{with gnome_keyring}
813 %files -n gnome-keyring-git-core
814 %defattr(644,root,root,755)
815 %attr(755,root,root) %{_libdir}/%{name}/git-credential-gnome-keyring
816 %endif
This page took 0.115165 seconds and 3 git commands to generate.