]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- up to 1.7.0
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.0
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  c7553b73e2156d187ece6ba936ae30ab
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 URL:            http://git-scm.com/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  curl-devel
26 BuildRequires:  expat-devel
27 BuildRequires:  gettext-devel
28 BuildRequires:  openssl-devel
29 BuildRequires:  perl-Error > 0.15
30 BuildRequires:  perl-base
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.264
34 BuildRequires:  zlib-devel
35 %if %{with doc}
36 BuildRequires:  asciidoc >= 7.1.2-3
37 BuildRequires:  docbook-dtd45-xml
38 BuildRequires:  xmlto
39 %endif
40 %if %{with tests}
41 %if %{with tests_cvs}
42 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
43 BuildRequires:  cvs-gnu-client < 1.13
44 BuildRequires:  cvs-gnu-client >= 1.12
45 %endif
46 BuildRequires:  pdksh >= 5.2.14-46
47 %endif
48 Requires:       coreutils
49 Requires:       diffutils
50 Requires:       findutils
51 Requires:       grep
52 Requires:       openssh-clients
53 Requires:       perl-Error
54 Requires:       sed
55 Suggests:       git-core-cvs
56 Suggests:       git-core-svn
57 Suggests:       less
58 Suggests:       rsync
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # html docs have links to txt files
62 %define         _noautocompressdoc      *.txt
63
64 %define         webapp          gitweb
65 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
66 %define         appdir          %{_datadir}/%{webapp}
67 %define         cgibindir       %{_prefix}/lib/cgi-bin
68
69 %description
70 "git" can mean anything, depending on your mood.
71
72  - random three-letter combination that is pronounceable, and not
73    actually used by any common UNIX command. The fact that it is a
74    mispronunciation of "get" may or may not be relevant.
75  - stupid. contemptible and despicable. simple. Take your pick from the
76    dictionary of slang.
77  - "global information tracker": you're in a good mood, and it actually
78    works for you. Angels sing, and a light suddenly fills the room.
79  - "goddamn idiotic truckload of sh*t": when it breaks
80
81 This is a stupid (but extremely fast) directory content manager. It
82 doesn't do a whole lot, but what it 'does' do is track directory
83 contents efficiently.
84
85 %description -l pl.UTF-8
86 "git" może oznaczać cokolwiek, w zależności od nastroju.
87
88  - losową kombinację trzech liter, która jest wymawialna i właściwie
89    nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
90    błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
91  - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
92  - "global information tracker" (narzędzie do globalnego śledzenia
93    informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
94    Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
95  - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
96    g*) - kiedy się zepsuje.
97
98 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
99 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
100 katalogu.
101
102 %package doc
103 Summary:        Documentation for git-core
104 Summary(pl.UTF-8):      Dokumentacja do git-core
105 Group:          Documentation
106
107 %description doc
108 Documentation for git-core.
109
110 %description doc -l pl.UTF-8
111 Dokumentacja do git-core.
112
113 %description doc -l fr.UTF-8
114 Javadoc pour git-core.
115
116 %package daemon-inetd
117 Summary:        Files necessary to run git-daemon as an inetd service
118 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
119 Group:          Networking/Daemons
120 Requires:       %{name} = %{version}-%{release}
121 Requires:       setup >= 2.4.11-1
122 Provides:       git-core-daemon
123 Obsoletes:      git-core-daemon
124 Obsoletes:      git-core-daemon-standalone
125
126 %description daemon-inetd
127 Git-daemon is a really simple TCP git daemon that can serve git
128 repositories. This package provides all necessarry files to run
129 git-daemon as an inetd service.
130
131 %description daemon-inetd -l pl.UTF-8
132 Git-daemon to prosty demon git korzystający z protokołu TCP do
133 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
134 do uruchomienia git-demona w trybie usługi inetd.
135
136 %package daemon-standalone
137 Summary:        Files necessary to run git-daemon as a standalone service
138 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
139 Group:          Networking/Daemons
140 Requires:       %{name} = %{version}-%{release}
141 Provides:       git-core-daemon
142 Obsoletes:      git-core-daemon
143 Obsoletes:      git-core-daemon-inetd
144
145 %description daemon-standalone
146 Git-daemon is a really simple TCP git daemon that can serve git
147 repositories. This package provides all necessarry files to run
148 git-daemon as an standalone service.
149
150 %description daemon-standalone -l pl.UTF-8
151 Git-daemon to prosty demon git korzystający z protokołu TCP do
152 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
153 do uruchomienia git-daemona w trybie usługi samodzielnej.
154
155 %package devel
156 Summary:        Header files for git-core
157 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
158 Group:          Development/Libraries
159
160 %description devel
161 Header files for git-core.
162
163 %description devel -l pl.UTF-8
164 Pliki nagłówkowe dla git-core.
165
166 %package gitk
167 Summary:        Tcl/Tk interface to the Git version control system
168 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
169 Group:          Development/Tools
170 Requires:       %{name} = %{version}-%{release}
171 Requires:       tk
172
173 %description gitk
174 gitk displays changes in a repository or a selected set of commits.
175 This includes visualizing the commit graph, showing information
176 related to each commit, and the files in the trees of each revision.
177
178 Historically, gitk was the first repository browser. It's written in
179 Tcl/Tk and started off in a separate repository but was later merged
180 into the main git repository.
181
182 %description gitk -l pl.UTF-8
183 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
184 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
185 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
186
187 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
188 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
189 osobnym repozytorium, ale z czasem został włączony do głównego
190 repozytorium gita.
191
192 %package gitweb
193 Summary:        Web frontend to git
194 Summary(pl.UTF-8):      Webowy frontend do git
195 Group:          Development/Tools
196 Requires:       %{name} = %{version}-%{release}
197 Requires:       webapps
198
199 %description gitweb
200 This package provides a web interface for browsing git repositories.
201
202 %description gitweb -l pl.UTF-8
203 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
204
205 %package gitview
206 Summary:        A GTK+ based repository browser for git
207 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
208 Group:          Development/Tools
209 Requires:       %{name} = %{version}-%{release}
210 Requires:       python >= 1:2.4
211 Requires:       python-pycairo >= 1.0
212 Requires:       python-pygobject
213 Requires:       python-pygtk-gtk >= 2:2.8
214 Suggests:       python-gnome-desktop-gtksourceview
215
216 %description gitview
217 A GTK+ based repository browser for git.
218
219 %description gitview -l pl.UTF-8
220 Oparta na GTK+ przeglądarka repozytorium gita.
221
222 %package gui
223 Summary:        Tcl/Tk interface to the Git version control system
224 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
225 Group:          Development/Tools
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       tk
228
229 %description gui
230 Displays changes in a repository or a selected set of commits. This
231 includes visualizing the commit graph, showing information related to
232 each commit, and the files in the trees of each revision.
233
234 Historically, gitk was the first repository browser. It's written in
235 Tcl/Tk and started off in a separate repository but was later merged
236 into the main git repository.
237
238 %description gui -l pl.UTF-8
239 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
240 to wizualizację grafu commitów, wyświetlanie informacji związanych z
241 każdym z commitów oraz listę plików dla każdej rewizji.
242
243 Z punktu widzenia historii, gitk był pierwszą przeglądarką
244 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
245 osobnym repozytorium, ale z czasem został włączony do głównego
246 repozytorium gita.
247
248 %package svn
249 Summary:        Subversion support for Git
250 Summary(pl.UTF-8):      Obsługa Subversion dla Git
251 Group:          Development/Tools
252 Requires:       %{name} = %{version}-%{release}
253
254 %description svn
255 Subversion support for Git.
256
257 %description svn -l pl.UTF-8
258 Obsługa Subversion dla Git.
259
260 %package cvs
261 Summary:        CVS support for Git
262 Summary(pl.UTF-8):      Obsługa CVS dla Git
263 Group:          Development/Tools
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       cvsps >= 2.1-2
266 Requires:       rcs
267
268 %description cvs
269 CVS support for Git.
270
271 %description cvs -l pl.UTF-8
272 Obsługa CVS dla Git.
273
274 %package arch
275 Summary:        Git tools for importing Arch repositories
276 Group:          Development/Tools
277 Requires:       %{name} = %{version}-%{release}
278 Requires:       tla
279
280 %description arch
281 Git tools for importing Arch repositories.
282
283 %package email
284 Summary:        Git tools for sending email
285 Group:          Development/Tools
286 Requires:       %{name} = %{version}-%{release}
287
288 %description email
289 Git tools for sending email.
290
291 %package -n bash-completion-git
292 Summary:        bash-completion for git
293 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
294 Group:          Applications/Shells
295 Requires:       bash-completion
296
297 %description -n bash-completion-git
298 This package provides bash-completion for git.
299
300 %description -n bash-completion-git -l pl.UTF-8
301 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
302
303 %package -n perl-Git
304 Summary:        Perl interface to the Git version control system
305 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
306 Group:          Development/Languages/Perl
307 Obsoletes:      perl-git-core
308
309 %description -n perl-Git
310 This module provides Perl scripts easy way to interface the Git
311 version control system. The modules have an easy and well-tested way
312 to call arbitrary Git commands; in the future, the interface will also
313 provide specialized methods for doing easily operations which are not
314 totally trivial to do over the generic command interface.
315
316 %description -n perl-Git -l pl.UTF-8
317 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
318 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
319 dowolne polecenia Gita; w przyszłości interfejs udostępni także
320 specjalne metody do łatwego wykonywania operacji nietrywialnych do
321 wykonania przy użyciu ogólnego interfejsu poleceń.
322
323 %package -n python-Git
324 Summary:        Python interface to the Git version control system
325 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
326 Group:          Development/Languages/Python
327
328 %description -n python-Git
329 This module provides Python scripts easy way to interface the Git
330 version control system.
331
332 %description -n python-Git -l pl.UTF-8
333 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
334 wersji Git.
335
336 %package -n vim-syntax-gitcommit
337 Summary:        Vim syntax: gitcommit
338 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
339 Group:          Applications/Editors/Vim
340 # for _vimdatadir existence
341 Requires:       vim-rt >= 4:6.3.058-3
342
343 %description -n vim-syntax-gitcommit
344 This plugin provides syntax highlighting for git's commit messages.
345
346 %description -n vim-syntax-gitcommit -l pl.UTF-8
347 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
348
349 %prep
350 %setup -q -n git-%{version}
351
352 %build
353 %{__aclocal}
354 %{__autoconf}
355 %configure \
356         --with-openssl
357
358 %{__make} \
359         BLK_SHA1=1 \
360         INSTALLDIRS=vendor \
361         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
362         GITWEB_PROJECTROOT="/var/lib/git" \
363         GITWEB_CSS="/gitweb/gitweb.css" \
364         GITWEB_LOGO="/gitweb/git-logo.png" \
365         GITWEB_FAVICON="/gitweb/git-favicon.png"
366
367 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
368 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
369
370 %if %{with tests}
371 %if %{without tests_cvs}
372 rm t/t*cvs*.sh
373 %endif
374 %{__make} test
375 %endif
376
377 %install
378 rm -rf $RPM_BUILD_ROOT
379 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
380 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
381 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
382
383 %{__make} install \
384         INSTALLDIRS=vendor \
385         DESTDIR=$RPM_BUILD_ROOT
386
387 %if %{with doc}
388 %{__make} -C Documentation install \
389         DESTDIR=$RPM_BUILD_ROOT
390 %endif
391
392 # header files and lib
393 install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
394 install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
395 install libgit.a $RPM_BUILD_ROOT%{_libdir}
396 install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
397
398 # bash completion
399 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
400 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
401
402 # vim syntax
403 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
404 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
405 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
406 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
407 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
408 autocmd BufNewFile,BufRead .msg.[0-9]*
409         \ if getline(1) =~ '^From.*# This line is ignored.$' |
410         \   setf gitsendemail |
411         \ endif
412 autocmd BufNewFile,BufRead *.git/**
413         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
414         \   setf git |
415         \ endif
416 EOF
417
418 # gitweb
419 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
420 cp -a gitweb/*.css gitweb/*.png $RPM_BUILD_ROOT%{appdir}
421 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
422 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
423 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
424
425 # gitview
426 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
427
428 # git-daemon related files
429 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
430 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
431 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
432
433 # paths cleanup
434 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
435 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
436
437 # hardlink
438 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
439 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
440 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
441 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
442
443 # remove unneeded files
444 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
445 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %post daemon-inetd
451 %service -q rc-inetd reload
452
453 %postun daemon-inetd
454 if [ "$1" = "0" ]; then
455         %service -q rc-inetd reload
456 fi
457
458 %post daemon-standalone
459 /sbin/chkconfig --add git-daemon
460 %service git-daemon restart "git-daemon"
461
462 %preun daemon-standalone
463 if [ "$1" = "0" ]; then
464         %service git-daemon stop
465         /sbin/chkconfig --del git-daemon
466 fi
467
468 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
469 %webapp_register apache %{webapp}
470
471 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
472 %webapp_unregister apache %{webapp}
473
474 %triggerin gitweb -- apache < 2.2.0, apache-base
475 %webapp_register httpd %{webapp}
476
477 %triggerun gitweb -- apache < 2.2.0, apache-base
478 %webapp_unregister httpd %{webapp}
479
480 %files
481 %defattr(644,root,root,755)
482 %doc README contrib
483 %attr(755,root,root) %{_bindir}/git
484 %attr(755,root,root) %{_bindir}/git-*
485
486 %if %{with doc}
487 %{_mandir}/man1/git-*.1*
488 %exclude %{_mandir}/man1/git-svn.1*
489 %exclude %{_mandir}/man1/git-cvs*.1*
490 %{_mandir}/man1/git.1*
491 %{_mandir}/man5/gitattributes.5*
492 %{_mandir}/man5/githooks.5*
493 %{_mandir}/man5/gitignore.5*
494 %{_mandir}/man5/gitmodules.5*
495 %{_mandir}/man5/gitrepository-layout.5*
496 %{_mandir}/man7/gitcli.7*
497 %{_mandir}/man7/gitcore-tutorial.7*
498 %{_mandir}/man7/gitdiffcore.7*
499 %{_mandir}/man7/gitglossary.7*
500 %{_mandir}/man7/gittutorial-2.7*
501 %{_mandir}/man7/gittutorial.7*
502 %{_mandir}/man7/gitworkflows.7*
503 %endif
504
505 %dir %{_libdir}/%{name}
506 %attr(755,root,root) %{_libdir}/%{name}/*-*
507 %attr(755,root,root) %{_libdir}/%{name}/git
508
509 %exclude %{_libdir}/%{name}/git-gui
510 %exclude %{_libdir}/%{name}/git-svn
511 %exclude %{_libdir}/%{name}/git-archimport
512 %exclude %{_libdir}/%{name}/git-cvs*
513 %exclude %{_libdir}/%{name}/*email*
514
515 %{_datadir}/%{name}
516
517 %{_localstatedir}/lib/git
518
519 %if %{with doc}
520 %files doc
521 %defattr(644,root,root,755)
522 %doc Documentation/RelNotes*
523 %doc Documentation/*.html Documentation/howto Documentation/technical
524 %endif
525
526 %files daemon-inetd
527 %defattr(644,root,root,755)
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
529
530 %files daemon-standalone
531 %defattr(644,root,root,755)
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
533 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
534
535 %files devel
536 %defattr(644,root,root,755)
537 %{_includedir}/git-core
538 %{_libdir}/libgit.a
539 %{_libdir}/libgit_xdiff.a
540
541 %files gitk
542 %defattr(644,root,root,755)
543 %if %{with doc}
544 %{_mandir}/man1/gitk.1*
545 %endif
546 %attr(755,root,root) %{_bindir}/gitk
547 %dir %{_datadir}/gitk
548 %dir %{_datadir}/gitk/lib
549 %dir %{_datadir}/gitk/lib/msgs
550 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
551 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
552 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
553 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
554 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
555 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
556 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
557 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
558
559 %files gitweb
560 %defattr(644,root,root,755)
561 %doc gitweb/{README,INSTALL}
562 %dir %{webappdir}
563 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
564 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
565 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
566 %attr(755,root,root) %{cgibindir}/gitweb.cgi
567 %{appdir}
568
569 %files gitview
570 %defattr(644,root,root,755)
571 %doc contrib/gitview/gitview.txt
572 %attr(755,root,root) %{_bindir}/gitview
573
574 %files gui
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/%{name}/git-gui
577 %dir %{_datadir}/git-gui
578 %dir %{_datadir}/git-gui/lib
579 %dir %{_datadir}/git-gui/lib/msgs
580 %{_datadir}/git-gui/lib/git-gui.ico
581 %{_datadir}/git-gui/lib/tclIndex
582 %{_datadir}/git-gui/lib/*.js
583 %{_datadir}/git-gui/lib/*.tcl
584 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
585 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
586 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
587 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
588 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
589 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
590 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
591 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
592 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
593 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
594
595 %files svn
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/%{name}/git-svn
598 %if %{with doc}
599 %{_mandir}/man1/git-svn.1*
600 %endif
601
602 %files cvs
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
605 %if %{with doc}
606 %{_mandir}/man1/git-cvs*.1*
607 %{_mandir}/man7/gitcvs-migration.7*
608 %endif
609
610 %files arch
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
613 %if %{with doc}
614 %{_mandir}/man1/git-archimport.1*
615 %endif
616
617 %files email
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_libdir}/%{name}/*email*
620 %if %{with doc}
621 %{_mandir}/man1/*email*.1*
622 %endif
623
624 %files -n bash-completion-git
625 %defattr(644,root,root,755)
626 %{_sysconfdir}/bash_completion.d/*
627
628 %files -n perl-Git
629 %defattr(644,root,root,755)
630 %{perl_vendorlib}/Git.pm
631 %{_mandir}/man3/Git.3pm*
632
633 %files -n python-Git
634 %defattr(644,root,root,755)
635 %{py_sitescriptdir}/git_remote_helpers*.egg-info
636 %dir %{py_sitescriptdir}/git_remote_helpers
637 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
638 %dir %{py_sitescriptdir}/git_remote_helpers/git
639 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
640
641 %files -n vim-syntax-gitcommit
642 %defattr(644,root,root,755)
643 %doc contrib/vim/README
644 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.0711079999999999 seconds and 3 git commands to generate.