]> git.pld-linux.org Git - packages/git-core.git/blob - git-core.spec
- added Req: perl-Term-ReadKey for svn package (uses it when asking for repo passwd)
[packages/git-core.git] / git-core.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # don't perform make test
4 %bcond_with             tests_cvs
5 %bcond_without  doc     # skip building/packaging docs/manuals (takes some time)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        The stupid content tracker
9 Summary(pl.UTF-8):      Prymitywne narzędzie do śledzenia treści
10 Name:           git-core
11 Version:        1.7.3.1
12 Release:        1
13 License:        GPL v2
14 Group:          Development/Tools
15 Source0:        http://www.kernel.org/pub/software/scm/git/git-%{version}.tar.bz2
16 # Source0-md5:  77e1611498919965fb65fd1f229ee155
17 Source1:        %{name}-gitweb.conf
18 Source2:        %{name}-gitweb-httpd.conf
19 Source3:        %{name}.sysconfig
20 Source4:        %{name}.inet
21 Source5:        %{name}.init
22 Patch0:         %{name}-tests.patch
23 Patch1:         %{name}-libcrypto.patch
24 URL:            http://git-scm.com/
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  curl-devel
28 BuildRequires:  expat-devel
29 BuildRequires:  gettext-devel
30 BuildRequires:  openssl-devel
31 BuildRequires:  perl-Error > 0.15
32 BuildRequires:  perl-base
33 BuildRequires:  python-devel
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 BuildRequires:  rpm-pythonprov
36 BuildRequires:  rpmbuild(macros) >= 1.264
37 BuildRequires:  zlib-devel
38 %if %{with doc}
39 BuildRequires:  asciidoc >= 7.1.2-3
40 BuildRequires:  docbook-dtd45-xml
41 BuildRequires:  xmlto
42 %endif
43 %if %{with tests}
44 %if %{with tests_cvs}
45 # tests failed sometimes when using nserver/cvsnt client so enforce pure cvs here
46 BuildRequires:  cvs-gnu-client < 1.13
47 BuildRequires:  cvs-gnu-client >= 1.12
48 %endif
49 BuildRequires:  pdksh >= 5.2.14-46
50 %endif
51 Requires:       coreutils
52 Requires:       diffutils
53 Requires:       findutils
54 Requires:       grep
55 Requires:       openssh-clients
56 Requires:       perl-Error
57 Requires:       sed
58 Suggests:       git-core-cvs
59 Suggests:       git-core-svn
60 Suggests:       less
61 Suggests:       rsync
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 # html docs have links to txt files
65 %define         _noautocompressdoc      *.txt
66
67 %define         webapp          gitweb
68 %define         webappdir       %{_sysconfdir}/webapps/%{webapp}
69 %define         appdir          %{_datadir}/%{webapp}
70 %define         cgibindir       %{_prefix}/lib/cgi-bin
71
72 %description
73 "git" can mean anything, depending on your mood.
74
75 - random three-letter combination that is pronounceable, and not
76   actually used by any common UNIX command. The fact that it is a
77   mispronunciation of "get" may or may not be relevant.
78 - stupid. contemptible and despicable. simple. Take your pick from the
79   dictionary of slang.
80 - "global information tracker": you're in a good mood, and it actually
81   works for you. Angels sing, and a light suddenly fills the room.
82 - "goddamn idiotic truckload of sh*t": when it breaks
83
84 This is a stupid (but extremely fast) directory content manager. It
85 doesn't do a whole lot, but what it 'does' do is track directory
86 contents efficiently.
87
88 %description -l pl.UTF-8
89 "git" może oznaczać cokolwiek, w zależności od nastroju.
90
91 - losową kombinację trzech liter, która jest wymawialna i właściwie
92   nie używana przez żadne popularne polecenie uniksowe. Fakt, że jest to
93   błędna pisownia słowa "get" może mieć lub nie mieć znaczenia.
94 - głupi, pogardliwy, prosty. Można wybrać ze słownika slangu.
95 - "global information tracker" (narzędzie do globalnego śledzenia
96   informacji) - jeśli jesteśmy w dobrym nastroju i git akurat działa.
97   Anioły śpiewają, a światło niespodziewanie wypełnia pokój.
98 - "goddamn idiotic truckload of sh*t" (przeklęty idiotyczny ładunek
99   g*) - kiedy się zepsuje.
100
101 Jest to prymitywny (ale bardzo szybki) zarządca treści słownikowej.
102 Nie robi wiele, ale to, co "robi", to wydajne śledzenie zawartości
103 katalogu.
104
105 %package doc
106 Summary:        Documentation for git-core
107 Summary(pl.UTF-8):      Dokumentacja do git-core
108 Group:          Documentation
109
110 %description doc
111 Documentation for git-core.
112
113 %description doc -l pl.UTF-8
114 Dokumentacja do git-core.
115
116 %description doc -l fr.UTF-8
117 Javadoc pour git-core.
118
119 %package daemon-inetd
120 Summary:        Files necessary to run git-daemon as an inetd service
121 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi inetd
122 Group:          Networking/Daemons
123 Requires:       %{name} = %{version}-%{release}
124 Requires:       setup >= 2.4.11-1
125 Provides:       git-core-daemon
126 Obsoletes:      git-core-daemon
127 Obsoletes:      git-core-daemon-standalone
128
129 %description daemon-inetd
130 Git-daemon is a really simple TCP git daemon that can serve git
131 repositories. This package provides all necessarry files to run
132 git-daemon as an inetd service.
133
134 %description daemon-inetd -l pl.UTF-8
135 Git-daemon to prosty demon git korzystający z protokołu TCP do
136 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
137 do uruchomienia git-demona w trybie usługi inetd.
138
139 %package daemon-standalone
140 Summary:        Files necessary to run git-daemon as a standalone service
141 Summary(pl.UTF-8):      Pliki niezbędne do uruchomienia git-daemona w trybie usługi samodzielnej
142 Group:          Networking/Daemons
143 Requires:       %{name} = %{version}-%{release}
144 Provides:       git-core-daemon
145 Obsoletes:      git-core-daemon
146 Obsoletes:      git-core-daemon-inetd
147
148 %description daemon-standalone
149 Git-daemon is a really simple TCP git daemon that can serve git
150 repositories. This package provides all necessarry files to run
151 git-daemon as an standalone service.
152
153 %description daemon-standalone -l pl.UTF-8
154 Git-daemon to prosty demon git korzystający z protokołu TCP do
155 udostępniania repozytoriów git. Ten pakiet dostarcza pliki potrzebne
156 do uruchomienia git-daemona w trybie usługi samodzielnej.
157
158 %package devel
159 Summary:        Header files for git-core
160 Summary(pl.UTF-8):      Pliki nagłówkowe dla git-core
161 Group:          Development/Libraries
162 Requires:       zlib-devel
163
164 %description devel
165 Header files for git-core.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe dla git-core.
169
170 %package gitk
171 Summary:        Tcl/Tk interface to the Git version control system
172 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
173 Group:          Development/Tools
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       tk
176
177 %description gitk
178 gitk displays changes in a repository or a selected set of commits.
179 This includes visualizing the commit graph, showing information
180 related to each commit, and the files in the trees of each revision.
181
182 Historically, gitk was the first repository browser. It's written in
183 Tcl/Tk and started off in a separate repository but was later merged
184 into the main git repository.
185
186 %description gitk -l pl.UTF-8
187 gitk wyświetla zmiany w repozytorium lub wybranym zbiorze commitów.
188 Oznacza to wizualizację grafu commitów, wyświetlanie informacji
189 związanych z każdym z commitów oraz listę plików dla każdej rewizji.
190
191 Z historycznego punktu widzenia gitk był pierwszą przeglądarką
192 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
193 osobnym repozytorium, ale z czasem został włączony do głównego
194 repozytorium gita.
195
196 %package gitweb
197 Summary:        Web frontend to git
198 Summary(pl.UTF-8):      Webowy frontend do git
199 Group:          Development/Tools
200 Requires:       %{name} = %{version}-%{release}
201 Requires:       webapps
202
203 %description gitweb
204 This package provides a web interface for browsing git repositories.
205
206 %description gitweb -l pl.UTF-8
207 Pakiet ten dostarcza interfejs WWW do przeglądania repozytoriów gita.
208
209 %package gitview
210 Summary:        A GTK+ based repository browser for git
211 Summary(pl.UTF-8):      Oparta na GTK+ przeglądarka repozytorium gita
212 Group:          Development/Tools
213 Requires:       %{name} = %{version}-%{release}
214 Requires:       python >= 1:2.4
215 Requires:       python-pycairo >= 1.0
216 Requires:       python-pygobject
217 Requires:       python-pygtk-gtk >= 2:2.8
218 Suggests:       python-gnome-desktop-gtksourceview
219
220 %description gitview
221 A GTK+ based repository browser for git.
222
223 %description gitview -l pl.UTF-8
224 Oparta na GTK+ przeglądarka repozytorium gita.
225
226 %package gui
227 Summary:        Tcl/Tk interface to the Git version control system
228 Summary(pl.UTF-8):      Napisany w Tcl/Tk interfejs do systemu kontroli wersji Git
229 Group:          Development/Tools
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       tk
232 Requires:       xdg-utils
233 Suggests:       meld
234
235 %description gui
236 Displays changes in a repository or a selected set of commits. This
237 includes visualizing the commit graph, showing information related to
238 each commit, and the files in the trees of each revision.
239
240 Historically, gitk was the first repository browser. It's written in
241 Tcl/Tk and started off in a separate repository but was later merged
242 into the main git repository.
243
244 %description gui -l pl.UTF-8
245 Wyświetla zmiany w repozytorium lub wybranym zbiorze commitów. Oznacza
246 to wizualizację grafu commitów, wyświetlanie informacji związanych z
247 każdym z commitów oraz listę plików dla każdej rewizji.
248
249 Z punktu widzenia historii, gitk był pierwszą przeglądarką
250 repozytorium git. Napisany jest w Tcl/Tk i początkowo był rozwijany w
251 osobnym repozytorium, ale z czasem został włączony do głównego
252 repozytorium gita.
253
254 %package svn
255 Summary:        Subversion support for Git
256 Summary(pl.UTF-8):      Obsługa Subversion dla Git
257 Group:          Development/Tools
258 Requires:       %{name} = %{version}-%{release}
259 Requires:       perl-Term-ReadKey
260
261 %description svn
262 Subversion support for Git.
263
264 %description svn -l pl.UTF-8
265 Obsługa Subversion dla Git.
266
267 %package cvs
268 Summary:        CVS support for Git
269 Summary(pl.UTF-8):      Obsługa CVS dla Git
270 Group:          Development/Tools
271 Requires:       %{name} = %{version}-%{release}
272 Requires:       cvsps >= 2.1-2
273 Requires:       rcs
274
275 %description cvs
276 CVS support for Git.
277
278 %description cvs -l pl.UTF-8
279 Obsługa CVS dla Git.
280
281 %package arch
282 Summary:        Git tools for importing Arch repositories
283 Group:          Development/Tools
284 Requires:       %{name} = %{version}-%{release}
285 Requires:       tla
286
287 %description arch
288 Git tools for importing Arch repositories.
289
290 %package email
291 Summary:        Git tools for sending email
292 Group:          Development/Tools
293 Requires:       %{name} = %{version}-%{release}
294
295 %description email
296 Git tools for sending email.
297
298 %package -n bash-completion-git
299 Summary:        bash-completion for git
300 Summary(pl.UTF-8):      bashowe uzupełnianie nazw dla gita
301 Group:          Applications/Shells
302 Requires:       bash-completion
303
304 %description -n bash-completion-git
305 This package provides bash-completion for git.
306
307 %description -n bash-completion-git -l pl.UTF-8
308 Pakiet ten dostarcza bashowe uzupełnianie nazw dla gita.
309
310 %package -n perl-Git
311 Summary:        Perl interface to the Git version control system
312 Summary(pl.UTF-8):      Perlowy interfejs do systemu kontroli wersji Git
313 Group:          Development/Languages/Perl
314 Obsoletes:      perl-git-core
315
316 %description -n perl-Git
317 This module provides Perl scripts easy way to interface the Git
318 version control system. The modules have an easy and well-tested way
319 to call arbitrary Git commands; in the future, the interface will also
320 provide specialized methods for doing easily operations which are not
321 totally trivial to do over the generic command interface.
322
323 %description -n perl-Git -l pl.UTF-8
324 Ten moduł umożliwia skryptom Perla współpracę z systemem kontroli
325 wersji Git. W łatwy i dobrze przetestowany sposób pozwala wywoływać
326 dowolne polecenia Gita; w przyszłości interfejs udostępni także
327 specjalne metody do łatwego wykonywania operacji nietrywialnych do
328 wykonania przy użyciu ogólnego interfejsu poleceń.
329
330 %package -n python-Git
331 Summary:        Python interface to the Git version control system
332 Summary(pl.UTF-8):      Pythonowy interfejs do systemu kontroli wersji Git
333 Group:          Development/Languages/Python
334
335 %description -n python-Git
336 This module provides Python scripts easy way to interface the Git
337 version control system.
338
339 %description -n python-Git -l pl.UTF-8
340 Ten moduł umożliwia skryptom Pythonowym współpracę z systemem kontroli
341 wersji Git.
342
343 %package -n vim-syntax-gitcommit
344 Summary:        Vim syntax: gitcommit
345 Summary(pl.UTF-8):      Składnia dla Vima: gitcommit
346 Group:          Applications/Editors/Vim
347 # for _vimdatadir existence
348 Requires:       vim-rt >= 4:6.3.058-3
349
350 %description -n vim-syntax-gitcommit
351 This plugin provides syntax highlighting for git's commit messages.
352
353 %description -n vim-syntax-gitcommit -l pl.UTF-8
354 Ta wtyczka dostarcza podświetlanie składni dla treści commitów gita.
355
356 %prep
357 %setup -q -n git-%{version}
358 %patch0 -p1
359 %patch1 -p0
360
361 %build
362 %{__aclocal}
363 %{__autoconf}
364 %configure \
365         --with-openssl
366
367 echo "BLK_SHA1=1" >> config.mak
368
369 %{__make} \
370         INSTALLDIRS=vendor \
371         GITWEB_CONFIG="%{webappdir}/gitweb.conf" \
372         GITWEB_PROJECTROOT="/var/lib/git" \
373         GITWEB_CSS="/gitweb/gitweb.css" \
374         GITWEB_LOGO="/gitweb/git-logo.png" \
375         GITWEB_FAVICON="/gitweb/git-favicon.png"
376
377 # use DOCBOOK_XSL_172=1 to fix 'the ".ft C" problem' in generated manpages.
378 %{?with_doc:%{__make} -C Documentation V=1 DOCBOOK_XSL_172=1}
379
380 %if %{with tests}
381 %if %{without tests_cvs}
382 rm t/t*cvs*.sh || :
383 %endif
384 %{__make} test
385 %endif
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389 install -d $RPM_BUILD_ROOT{%{_includedir}/%{name}/xdiff,%{_localstatedir}/lib/git}
390 install -d $RPM_BUILD_ROOT{%{appdir},%{cgibindir},%{webappdir}}
391 install -d $RPM_BUILD_ROOT/etc/{sysconfig/rc-inetd,rc.d/init.d}
392
393 %{__make} install \
394         INSTALLDIRS=vendor \
395         DESTDIR=$RPM_BUILD_ROOT
396
397 %if %{with doc}
398 %{__make} -C Documentation install \
399         DESTDIR=$RPM_BUILD_ROOT
400 %endif
401
402 # header files and lib
403 cp -a *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
404 cp -a compat $RPM_BUILD_ROOT%{_includedir}/%{name}
405 cp -a xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
406 cp -a libgit.a $RPM_BUILD_ROOT%{_libdir}
407 cp -a xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
408
409 # bash completion
410 install -d $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
411 cp -a contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
412
413 # vim syntax
414 install -d $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax
415 cat > $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles/syntax/gitcommit.vim << 'EOF'
416 autocmd BufNewFile,BufRead *.git/COMMIT_EDITMSG    setf gitcommit
417 autocmd BufNewFile,BufRead *.git/config,.gitconfig setf gitconfig
418 autocmd BufNewFile,BufRead git-rebase-todo         setf gitrebase
419 autocmd BufNewFile,BufRead .msg.[0-9]*
420         \ if getline(1) =~ '^From.*# This line is ignored.$' |
421         \   setf gitsendemail |
422         \ endif
423 autocmd BufNewFile,BufRead *.git/**
424         \ if getline(1) =~ '^\x\{40\}\>\|^ref: ' |
425         \   setf git |
426         \ endif
427 EOF
428
429 # gitweb
430 install -p gitweb/gitweb.cgi $RPM_BUILD_ROOT%{cgibindir}
431 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{webappdir}/gitweb.conf
432 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/apache.conf
433 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{webappdir}/httpd.conf
434
435 # gitview
436 install -p contrib/gitview/gitview $RPM_BUILD_ROOT%{_bindir}
437
438 # git-daemon related files
439 cp -a %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/git-daemon
440 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
441 install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
442
443 # paths cleanup
444 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/rc.d/init.d/git-daemon
445 sed -e 's,@libdir@,%{_libdir},g' -i $RPM_BUILD_ROOT/etc/sysconfig/rc-inetd/git-daemon
446
447 # hardlink
448 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-receive-pack}
449 ln -f $RPM_BUILD_ROOT%{_bindir}/{git,git-upload-archive}
450 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-shell
451 ln -f $RPM_BUILD_ROOT{%{_libdir}/%{name},%{_bindir}}/git-upload-pack
452
453 # remove unneeded files
454 rm $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
455 rm $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Git/.packlist
456 %py_postclean
457
458 %clean
459 rm -rf $RPM_BUILD_ROOT
460
461 %post daemon-inetd
462 %service -q rc-inetd reload
463
464 %postun daemon-inetd
465 if [ "$1" = "0" ]; then
466         %service -q rc-inetd reload
467 fi
468
469 %post daemon-standalone
470 /sbin/chkconfig --add git-daemon
471 %service git-daemon restart "git-daemon"
472
473 %preun daemon-standalone
474 if [ "$1" = "0" ]; then
475         %service git-daemon stop
476         /sbin/chkconfig --del git-daemon
477 fi
478
479 %triggerin gitweb -- apache1 < 1.3.37-3, apache1-base
480 %webapp_register apache %{webapp}
481
482 %triggerun gitweb -- apache1 < 1.3.37-3, apache1-base
483 %webapp_unregister apache %{webapp}
484
485 %triggerin gitweb -- apache < 2.2.0, apache-base
486 %webapp_register httpd %{webapp}
487
488 %triggerun gitweb -- apache < 2.2.0, apache-base
489 %webapp_unregister httpd %{webapp}
490
491 %files
492 %defattr(644,root,root,755)
493 %doc README contrib
494 %attr(755,root,root) %{_bindir}/git
495 %attr(755,root,root) %{_bindir}/git-receive-pack
496 %attr(755,root,root) %{_bindir}/git-shell
497 %attr(755,root,root) %{_bindir}/git-upload-archive
498 %attr(755,root,root) %{_bindir}/git-upload-pack
499
500 %if %{with doc}
501 %{_mandir}/man1/git-*.1*
502 %exclude %{_mandir}/man1/git-svn.1*
503 %exclude %{_mandir}/man1/git-cvs*.1*
504 %{_mandir}/man1/git.1*
505 %{_mandir}/man5/gitattributes.5*
506 %{_mandir}/man5/githooks.5*
507 %{_mandir}/man5/gitignore.5*
508 %{_mandir}/man5/gitmodules.5*
509 %{_mandir}/man5/gitrepository-layout.5*
510 %{_mandir}/man7/gitcli.7*
511 %{_mandir}/man7/gitcore-tutorial.7*
512 %{_mandir}/man7/gitdiffcore.7*
513 %{_mandir}/man7/gitglossary.7*
514 %{_mandir}/man7/gitrevisions.7*
515 %{_mandir}/man7/gittutorial-2.7*
516 %{_mandir}/man7/gittutorial.7*
517 %{_mandir}/man7/gitworkflows.7*
518 %endif
519
520 %dir %{_libdir}/%{name}
521 %attr(755,root,root) %{_libdir}/%{name}/*-*
522 %attr(755,root,root) %{_libdir}/%{name}/git
523
524 %exclude %{_libdir}/%{name}/git-gui
525 %exclude %{_libdir}/%{name}/git-svn
526 %exclude %{_libdir}/%{name}/git-archimport
527 %exclude %{_libdir}/%{name}/git-cvs*
528 %exclude %{_libdir}/%{name}/*email*
529
530 %{_datadir}/%{name}
531
532 %{_localstatedir}/lib/git
533
534 %if %{with doc}
535 %files doc
536 %defattr(644,root,root,755)
537 %doc Documentation/RelNotes*
538 %doc Documentation/*.html Documentation/howto Documentation/technical
539 %endif
540
541 %files daemon-inetd
542 %defattr(644,root,root,755)
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rc-inetd/git-daemon
544
545 %files daemon-standalone
546 %defattr(644,root,root,755)
547 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/git-daemon
548 %attr(754,root, root) /etc/rc.d/init.d/git-daemon
549
550 %files devel
551 %defattr(644,root,root,755)
552 %{_includedir}/git-core
553 %{_libdir}/libgit.a
554 %{_libdir}/libgit_xdiff.a
555
556 %files gitk
557 %defattr(644,root,root,755)
558 %if %{with doc}
559 %{_mandir}/man1/gitk.1*
560 %endif
561 %attr(755,root,root) %{_bindir}/gitk
562 %dir %{_datadir}/gitk
563 %dir %{_datadir}/gitk/lib
564 %dir %{_datadir}/gitk/lib/msgs
565 %lang(de) %{_datadir}/gitk/lib/msgs/de.msg
566 %lang(es) %{_datadir}/gitk/lib/msgs/es.msg
567 %lang(fr) %{_datadir}/gitk/lib/msgs/fr.msg
568 %lang(hu) %{_datadir}/gitk/lib/msgs/hu.msg
569 %lang(it) %{_datadir}/gitk/lib/msgs/it.msg
570 %lang(ja) %{_datadir}/gitk/lib/msgs/ja.msg
571 %lang(ru) %{_datadir}/gitk/lib/msgs/ru.msg
572 %lang(sv) %{_datadir}/gitk/lib/msgs/sv.msg
573
574 %files gitweb
575 %defattr(644,root,root,755)
576 %doc gitweb/{README,INSTALL}
577 %dir %{webappdir}
578 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,http) %{webappdir}/gitweb.conf
579 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/apache.conf
580 %config(noreplace) %verify(not md5 mtime size) %attr(640,root,root) %{webappdir}/httpd.conf
581 %attr(755,root,root) %{cgibindir}/gitweb.cgi
582 %{appdir}
583
584 %files gitview
585 %defattr(644,root,root,755)
586 %doc contrib/gitview/gitview.txt
587 %attr(755,root,root) %{_bindir}/gitview
588
589 %files gui
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_libdir}/%{name}/git-gui
592 %dir %{_datadir}/git-gui
593 %dir %{_datadir}/git-gui/lib
594 %dir %{_datadir}/git-gui/lib/msgs
595 %{_datadir}/git-gui/lib/git-gui.ico
596 %{_datadir}/git-gui/lib/tclIndex
597 %{_datadir}/git-gui/lib/*.js
598 %{_datadir}/git-gui/lib/*.tcl
599 %lang(de) %{_datadir}/git-gui/lib/msgs/de.msg
600 %lang(el) %{_datadir}/git-gui/lib/msgs/el.msg
601 %lang(fr) %{_datadir}/git-gui/lib/msgs/fr.msg
602 %lang(hu) %{_datadir}/git-gui/lib/msgs/hu.msg
603 %lang(it) %{_datadir}/git-gui/lib/msgs/it.msg
604 %lang(ja) %{_datadir}/git-gui/lib/msgs/ja.msg
605 %lang(nb) %{_datadir}/git-gui/lib/msgs/nb.msg
606 %lang(ru) %{_datadir}/git-gui/lib/msgs/ru.msg
607 %lang(sv) %{_datadir}/git-gui/lib/msgs/sv.msg
608 %lang(zh_cn) %{_datadir}/git-gui/lib/msgs/zh_cn.msg
609
610 %files svn
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/%{name}/git-svn
613 %if %{with doc}
614 %{_mandir}/man1/git-svn.1*
615 %endif
616
617 %files cvs
618 %defattr(644,root,root,755)
619 %attr(755,root,root) %{_bindir}/git-cvsserver
620 %attr(755,root,root) %{_libdir}/%{name}/git-cvs*
621 %if %{with doc}
622 %{_mandir}/man1/git-cvs*.1*
623 %{_mandir}/man7/gitcvs-migration.7*
624 %endif
625
626 %files arch
627 %defattr(644,root,root,755)
628 %attr(755,root,root) %{_libdir}/%{name}/git-archimport
629 %if %{with doc}
630 %{_mandir}/man1/git-archimport.1*
631 %endif
632
633 %files email
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_libdir}/%{name}/*email*
636 %if %{with doc}
637 %{_mandir}/man1/*email*.1*
638 %endif
639
640 %files -n bash-completion-git
641 %defattr(644,root,root,755)
642 %{_sysconfdir}/bash_completion.d/*
643
644 %files -n perl-Git
645 %defattr(644,root,root,755)
646 %{perl_vendorlib}/Git.pm
647 %{_mandir}/man3/Git.3pm*
648
649 %files -n python-Git
650 %defattr(644,root,root,755)
651 %{py_sitescriptdir}/git_remote_helpers*.egg-info
652 %dir %{py_sitescriptdir}/git_remote_helpers
653 %{py_sitescriptdir}/git_remote_helpers/*.py[co]
654 %dir %{py_sitescriptdir}/git_remote_helpers/git
655 %{py_sitescriptdir}/git_remote_helpers/git/*.py[co]
656
657 %files -n vim-syntax-gitcommit
658 %defattr(644,root,root,755)
659 %doc contrib/vim/README
660 %{_datadir}/vim/vimfiles/syntax/*.vim
This page took 0.079908 seconds and 3 git commands to generate.