]> git.pld-linux.org Git - packages/gimp.git/blob - gimp.spec
- fixed installing perl modules (gimp-perlinst.patch),
[packages/gimp.git] / gimp.spec
1 Summary:        The GNU Image Manipulation Program
2 Summary(fr):    Le programme de manipulation d'images de GNU.
3 Summary(de):    Das GNU-Bildbearbeitungs-Programm
4 Summary(pl):    GNU program do manipulacji formatami graficznymi (GIMP)
5 Summary(tr):    Çizim, boyama ve görüntü iþleme programý
6 Name:           gimp
7 Version:        1.1.7
8 Release:        1
9 Copyright:      GPL
10 Group:          X11/Applications/Graphics
11 Group(pl):      X11/Aplikacje/Grafika
12 Source:         ftp://ftp.gimp.org/pub/gimp/unstable/v%{version}/%{name}-%{version}.tar.bz2
13 Patch:          gimp-perlinst.patch
14 URL:            http://www.gimp.org/
15 BuildRequires:  gtk+-devel >= 1.2.0
16 BuildRequires:  glib-devel >= 1.2.0
17 BuildRequires:  perl
18 BuildRequires:  perl-PDL >= 1.9906
19 BuildRequires:  perl-gtk >= 0.5120
20 BuildRequires:  XFree86-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libungif-devel
25 BuildRequires:  xpm-devel
26 BuildRequires:  zlib-devel
27 %requires_eq    perl
28 Requires:       %{perl_sitearch}
29 BuildRoot:      /tmp/%{name}-%{version}-root
30 Obsoletes:      gimp-data-min
31 Obsoletes:      gimp-libgimp
32
33 %define _prefix /usr/X11R6
34 %define _mandir %{_prefix}/man
35
36 %description
37 The GIMP is an image manipulation program suitable for photo retouching,
38 image composition and image authoring.  Many people find it extremely useful
39 in creating logos and other graphics for web pages.  The GIMP has many of the
40 tools and filters you would expect to find in similar commercial offerings,
41 and some interesting extras as well.
42
43 The GIMP provides a large image manipulation toolbox, including channel
44 operations and layers, effects, sub-pixel imaging and anti-aliasing,
45 and conversions, all with multi-level undo.
46
47 This version of The GIMP includes a scripting facility, but many of the
48 included scripts rely on fonts that we cannot distribute.  The GIMP ftp
49 site has a package of fonts that you can install by yourself, which
50 includes all the fonts needed to run the included scripts.  Some of the
51 fonts have unusual licensing requirements; all the licenses are documented
52 in the package. Get ftp://ftp.gimp.org/pub/gimp/fonts/freefonts-0.10.tar.gz
53 and ftp://ftp.gimp.org/pub/gimp/fonts/sharefonts-0.10.tar.gz if you are so
54 inclined. Alternatively, choose fonts which exist on your system before
55 running the scripts.
56
57 %description -l pl
58 Program Gimp jest przeznaczony do obróbki i tworzenia plików w ró¿nych
59 formatach graficznych. Dziêki niemu bêdziesz móg³ stworzyæ grafikê dla 
60 stron WWW, przerobiæ zdjêcia, czy stworzyæ w³asne logo.
61
62 %package devel
63 Summary:        GIMP plugin and extension development kit
64 Summary(fr):    Plugin GIMP et kit de développement d'extensions
65 Summary(de):    GIMP-Plugin und Extension Development Kit
66 Summary(pl):    Dodatkowe moduly i rozszerzenia dla Gimp
67 Summary(tr):    GIMP plugin ve uzantý geliþtirme araçlarý
68 Group:          X11/Applications/Graphics
69 Group(pl):      X11/Aplikacje/Grafika
70 Copyright:      LGPL
71 Requires:       %{name} = %{version}
72 Requires:       gtk+-devel >= 1.2.0
73
74 %description devel
75 Header files for writing GIMP plugins and extensions.
76
77 %description -l de devel
78 Header-Dateien zum Schreiben von GIMP-Plugins und -Erweiterungen
79
80 %descriptions -l pl devel
81 Pliki nag³ówkowe dla GIMP.
82
83 %package static
84 Summary:        GIMP static libraries
85 Summary(pl):    Biblioteki statyczne do GIMPa
86 Group:          Libraries
87 Requires:       %{name}-devel = %{version}
88
89 %description static
90 GIMP static libraries.
91
92 %description -l pl static
93 Biblioteki statyczne do GIMPa.
94
95 %prep
96 %setup -q
97 %patch -p0
98
99 %build
100 CFLAGS="$RPM_OPT_FLAGS -Wall" \
101 LDFLAGS="-s" \
102 ./configure %{_target_platform} \
103         --prefix=%{_prefix} \
104         --without-included-gettext \
105         --without-xdelta 
106 make
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT/{etc/X11,usr/share/aclocal} \
111         $RPM_BUILD_ROOT%{_datadir}/icons \
112         $RPM_BUILD_ROOT%{perl_sitearch} \
113         $RPM_BUILD_ROOT%{_libdir}/gimp/1.1/{modules,plug-ins}
114
115 make install \
116         prefix=$RPM_BUILD_ROOT%{_prefix} \
117         mandir=$RPM_BUILD_ROOT%{_mandir} \
118         INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
119         INSTALLMAN3DIR=$RPM_BUILD_ROOT/usr/share/man/man3 \
120         PREFIX=$RPM_BUILD_ROOT/usr \
121         INSTALLMAN5DIR=$RPM_BUILD_ROOT%{_mandir}/man5
122
123 mv $RPM_BUILD_ROOT%{_datadir}/aclocal/* $RPM_BUILD_ROOT/usr/share/aclocal
124 mv $RPM_BUILD_ROOT/usr/bin/* $RPM_BUILD_ROOT%{_bindir}
125
126 install pixmaps/*.xpm $RPM_BUILD_ROOT%{_datadir}/icons/
127 install plug-ins/*/*.xpm $RPM_BUILD_ROOT%{_datadir}/icons/
128
129 strip $RPM_BUILD_ROOT{%{_bindir}/gimp,%{_libdir}/gimp/*/plug-ins/*} ||: 
130 strip --strip-unneeded \
131         $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* \
132         $RPM_BUILD_ROOT%{perl_sitearch}/auto/Gimp/*.so \
133         $RPM_BUILD_ROOT%{perl_sitearch}/auto/Gimp/{Lib,Net}/*.so
134
135 gzip -9nf $RPM_BUILD_ROOT/usr/share/man/man3/* \
136         $RPM_BUILD_ROOT%{_mandir}/man[135]/* \
137         ChangeLog NEWS README README.i18n README.perl \
138         TODO MAINTAINERS docs/*.txt
139
140 %find_lang %{name}
141 %find_lang %{name}-std-plugins
142
143 cat %{name}-std-plugins.lang >> %{name}.lang
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %files -f %{name}.lang
152 %defattr(644,root,root,755)
153 %doc {ChangeLog,NEWS,README,README.i18n,README.perl,MAINTAINERS}.gz
154 %doc docs/*.gz docs/*README docs/*.eps docs/script-fu.tex 
155 %doc docs/white-paper/gimp-white-paper.tex docs/quick_reference.*
156
157 %attr(755,root,root) %{_bindir}/gimp 
158 %attr(755,root,root) %{_bindir}/gimpdoc 
159
160 %{_mandir}/man1/gimp.1* 
161 %{_mandir}/man5/gimprc.5*
162
163 %attr(755,root,root) %{_libdir}/lib*.so.* 
164 %attr(755,root,root) %{_libdir}/gimp 
165
166 %dir %{_datadir}/gimp
167 %{_datadir}/gimp/brushes
168 %{_datadir}/gimp/gfig
169 %{_datadir}/gimp/gradients
170 %{_datadir}/gimp/palettes
171 %{_datadir}/gimp/patterns
172 %{_datadir}/gimp/scripts
173 %{_datadir}/gimp/fractalexplorer
174 %{_datadir}/gimp/help
175 %{_datadir}/gimp/*.ppm
176
177 %dir %{_datadir}/gimp/tips
178 %{_datadir}/gimp/tips/gimp_tips.txt
179 %lang(fr) %{_datadir}/gimp/tips/gimp_conseils.fr.txt
180 %lang(de) %{_datadir}/gimp/tips/gimp_tips.de.txt
181
182 %config %verify(not md5 mtime) %{_datadir}/gimp/gimprc*
183 %config %{_datadir}/gimp/gtkrc*
184 %config %{_datadir}/gimp/ps-menurc
185 %config %{_datadir}/gimp/unitrc
186
187 %attr(755,root,root) %{_datadir}/gimp/user_install
188
189 %{_datadir}/icons/*.xpm 
190
191 ## perl stuff
192 %{perl_sitearch}/Gimp
193 %{perl_sitearch}/Gimp.pm
194 %dir %{perl_sitearch}/auto/Gimp
195 %dir %{perl_sitearch}/auto/Gimp/Lib
196 %dir %{perl_sitearch}/auto/Gimp/Net
197 %{perl_sitearch}/auto/Gimp/Gimp.bs
198 %{perl_sitearch}/auto/Gimp/Lib/Lib.bs
199 %{perl_sitearch}/auto/Gimp/Net/Net.bs
200 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Lib/Lib.so
201 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Net/Net.so
202 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Gimp.so
203 /usr/share/man/man3/Gimp*
204
205 %files devel
206 %defattr(644,root,root,755)
207
208 %attr(755,root,root) %{_libdir}/lib*.so 
209 %{_libdir}/lib*.la
210
211 %{_includedir}/gck/*.h 
212 %{_includedir}/libgimp/*.h
213 /usr/share/aclocal/gimp.m4
214
215 %attr(755,root,root) %{_bindir}/gimptool
216 %attr(755,root,root) %{_bindir}/scm2*
217
218 %{_mandir}/man1/gimptool.1*
219 %{_mandir}/man1/scm2*.1*
220 %{_mandir}/man3/gpc.3*
221
222 %files static
223 %attr(644,root,root) %{_libdir}/lib*.a
This page took 0.052227 seconds and 4 git commands to generate.