]> git.pld-linux.org Git - packages/gimp.git/blob - gimp.spec
- added %lang macros for gimp tips.
[packages/gimp.git] / gimp.spec
1 Summary:        The GNU Image Manipulation Program
2 Summary(fr):    Le programme de manipulation d'images de GNU.
3 Summary(de):    Das GNU-Bildbearbeitungs-Programm
4 Summary(pl):    GNU program do manipulacji formatami graficznymi (GIMP)
5 Summary(tr):    Çizim, boyama ve görüntü iþleme programý
6 Name:           gimp
7 Version:        1.1.6
8 Release:        2
9 Copyright:      GPL
10 Group:          X11/Applications/Graphics
11 Group(pl):      X11/Aplikacje/Grafika
12 #######         ftp://ftp.gimp.org/pub/gimp/unstable/v1.1.5/
13 Source:         %{name}-%{version}.tar.bz2
14 URL:            http://www.gimp.org/
15 BuildPrereq:    gtk+-devel
16 BuildPrereq:    glib-devel
17 BuildPrereq:    perl
18 BuildPrereq:    XFree86-devel
19 BuildPrereq:    libtiff-devel
20 BuildPrereq:    libjpeg-devel
21 BuildPrereq:    libpng-devel
22 BuildPrereq:    libungif-devel
23 BuildPrereq:    xpm-devel
24 BuildPrereq:    zlib-devel
25 Requires:       gtk+ >= 1.2.0
26 Requires:       glib >= 1.2.0
27 %requires_eq    perl
28 Requires:       %{perl_sitearch}
29 BuildRoot:      /tmp/%{name}-%{version}-root
30 Obsoletes:      gimp-data-min
31 Obsoletes:      gimp-libgimp
32
33 %define _prefix /usr/X11R6
34 %define _mandir %{_prefix}/man
35
36 %description
37 The GIMP is an image manipulation program suitable for photo retouching,
38 image composition and image authoring.  Many people find it extremely useful
39 in creating logos and other graphics for web pages.  The GIMP has many of the
40 tools and filters you would expect to find in similar commercial offerings,
41 and some interesting extras as well.
42
43 The GIMP provides a large image manipulation toolbox, including channel
44 operations and layers, effects, sub-pixel imaging and anti-aliasing,
45 and conversions, all with multi-level undo.
46
47 This version of The GIMP includes a scripting facility, but many of the
48 included scripts rely on fonts that we cannot distribute.  The GIMP ftp
49 site has a package of fonts that you can install by yourself, which
50 includes all the fonts needed to run the included scripts.  Some of the
51 fonts have unusual licensing requirements; all the licenses are documented
52 in the package. Get ftp://ftp.gimp.org/pub/gimp/fonts/freefonts-0.10.tar.gz
53 and ftp://ftp.gimp.org/pub/gimp/fonts/sharefonts-0.10.tar.gz if you are so
54 inclined. Alternatively, choose fonts which exist on your system before
55 running the scripts.
56
57 %description -l pl
58 Program Gimp jest przeznaczony do obróbki i tworzenia plików w ró¿nych
59 formatach graficznych. Dziêki niemu bêdziesz móg³ stworzyæ grafikê dla 
60 stron WWW, przerobiæ zdjêcia, czy stworzyæ w³asne logo.
61
62 %package        devel
63 Summary:        GIMP plugin and extension development kit
64 Summary(fr):    Plugin GIMP et kit de développement d'extensions
65 Summary(de):    GIMP-Plugin und Extension Development Kit
66 Summary(pl):    Dodatkowe moduly i rozszerzenia dla Gimp
67 Summary(tr):    GIMP plugin ve uzantý geliþtirme araçlarý
68 Group:          X11/Applications/Graphics
69 Group(pl):      X11/Aplikacje/Grafika
70 Copyright:      LGPL
71 Requires:       %{name} = %{version}
72 Requires:       gtk+-devel >= 1.2.0
73
74 %description devel
75 Header files for writing GIMP plugins and extensions.
76
77 %description -l de devel
78 Header-Dateien zum Schreiben von GIMP-Plugins und -Erweiterungen
79
80 %descriptions -l pl devel
81 Pliki nag³ówkowe dla GIMP.
82
83 %package static
84 Summary:     GIMP static libraries
85 Summary(pl): Biblioteki statyczne do GIMPa
86 Group:       Libraries
87 Requires:    %{name}-devel = %{version}
88
89 %description static
90 GIMP static libraries
91
92 %description -l pl static
93 Biblioteki statyczne do GIMPa
94
95 %prep
96 %setup -q
97
98 %build
99 CFLAGS="$RPM_OPT_FLAGS -Wall" \
100 LDFLAGS="-s" \
101 ./configure %{_target_platform} \
102         --prefix=%{_prefix} \
103         --without-included-gettext \
104         --without-xdelta 
105 make
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT/{etc/X11,usr/share/aclocal} \
110         $RPM_BUILD_ROOT%{_datadir}/icons \
111         $RPM_BUILD_ROOT%{perl_sitearch} \
112         $RPM_BUILD_ROOT%{_libdir}/gimp/1.1/{modules,plug-ins}
113
114 make install \
115         prefix=$RPM_BUILD_ROOT%{_prefix} \
116         mandir=$RPM_BUILD_ROOT%{_mandir} \
117         INSTALLMAN1DIR=$RPM_BUILD_ROOT%{_mandir}/man1 \
118         INSTALLMAN3DIR=$RPM_BUILD_ROOT/usr/share/man/man3 \
119         PREFIX=$RPM_BUILD_ROOT/usr \
120         INSTALLMAN5DIR=$RPM_BUILD_ROOT%{_mandir}/man5
121
122 mv $RPM_BUILD_ROOT%{_datadir}/aclocal/* $RPM_BUILD_ROOT/usr/share/aclocal
123 mv $RPM_BUILD_ROOT/usr/bin/* $RPM_BUILD_ROOT%{_bindir}
124
125 install pixmaps/*.xpm $RPM_BUILD_ROOT%{_datadir}/icons/
126 install plug-ins/*/*.xpm $RPM_BUILD_ROOT%{_datadir}/icons/
127
128 strip $RPM_BUILD_ROOT{%{_bindir}/gimp,%{_libdir}/gimp/*/plug-ins/*} ||: 
129 strip --strip-unneeded \
130         $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.* \
131         $RPM_BUILD_ROOT%{perl_sitearch}/auto/Gimp/*.so \
132         $RPM_BUILD_ROOT%{perl_sitearch}/auto/Gimp/{Lib,Net}/*.so
133
134 #mv $RPM_BUILD_ROOT/usr/share/aclocal/gimp* $RPM_BUILD_ROOT/%{_datadir}/aclocal
135
136 #mv $RPM_BUILD_ROOT/usr/X11R6/lib/perl5/5.* $RPM_BUILD_ROOT/usr/lib/perl5/
137 #install -d $RPM_BUILD_ROOT/usr/lib/perl5/site_perl/5.005
138 #mv $RPM_BUILD_ROOT/usr/X11R6/lib/perl5/site_perl/5.005/* \
139 #       $RPM_BUILD_ROOT/usr/lib/perl5/site_perl/5.005/
140
141 gzip -9nf $RPM_BUILD_ROOT/usr/share/man/man3/* \
142         $RPM_BUILD_ROOT%{_mandir}/man[135]/* \
143         ChangeLog NEWS README README.i18n README.perl \
144         TODO MAINTAINERS docs/*.txt
145
146 %find_lang %{name}
147 %find_lang %{name}-std-plugins
148
149 %post   -p /sbin/ldconfig
150 %postun -p /sbin/ldconfig
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %files -f %{name}.lang -f %{name}-std-plugins.lang
156 %defattr(644,root,root,755)
157 %doc {ChangeLog,NEWS,README,README.i18n,README.perl,MAINTAINERS}.gz
158 %doc docs/*.gz docs/*README docs/*.eps docs/script-fu.tex 
159 %doc docs/white-paper/gimp-white-paper.tex docs/quick_reference.*
160
161 %attr(755,root,root) %{_bindir}/gimp 
162 %attr(755,root,root) %{_bindir}/gimpdoc 
163
164 %{_mandir}/man1/gimp.1* 
165 %{_mandir}/man5/gimprc.5*
166
167 %attr(755,root,root) %{_libdir}/lib*.so.* 
168 %attr(755,root,root) %{_libdir}/gimp 
169
170 %dir %{_datadir}/gimp
171 %{_datadir}/gimp/brushes
172 %{_datadir}/gimp/gfig
173 %{_datadir}/gimp/gradients
174 %{_datadir}/gimp/palettes
175 %{_datadir}/gimp/patterns
176 %{_datadir}/gimp/scripts
177 %{_datadir}/gimp/*.ppm
178
179 %dir%{_datadir}/gimp/tips
180 %{_datadir}/gimp/tips/gimp_tips.txt
181 %lang(fr) %{_datadir}/gimp/tips/gimp_conseils.fr.txt
182 %lang(de) %{_datadir}/gimp/tips/gimp_tips.de.txt
183
184
185 %config %verify(not md5 mtime) %{_datadir}/gimp/gimprc*
186 %config %{_datadir}/gimp/gtkrc*
187 %config %{_datadir}/gimp/ps-menurc
188
189 %attr(755,root,root) %{_datadir}/gimp/user_install
190
191 %{_datadir}/icons/*.xpm 
192
193 ## perl stuff
194 %{perl_sitearch}/Gimp
195 %dir %{perl_sitearch}/auto/Gimp
196 %dir %{perl_sitearch}/auto/Gimp/Lib
197 %dir %{perl_sitearch}/auto/Gimp/Net
198 %{perl_sitearch}/auto/Gimp/Gimp.bs
199 %{perl_sitearch}/auto/Gimp/Lib/Lib.bs
200 %{perl_sitearch}/auto/Gimp/Net/Net.bs
201 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Lib/Lib.so
202 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Net/Net.so
203 %attr(755,root,root) %{perl_sitearch}/auto/Gimp/Gimp.so
204 /usr/share/man/man3/Gimp*
205
206 %files devel
207 %defattr(644,root,root,755)
208
209 %attr(755,root,root) %{_libdir}/lib*.so 
210 %{_libdir}/lib*.la
211
212 %{_includedir}/gck/*.h 
213 %{_includedir}/libgimp/*.h
214 /usr/share/aclocal/gimp.m4
215
216 %attr(755,root,root) %{_bindir}/gimptool
217 %attr(755,root,root) %{_bindir}/scm2*
218
219 %{_mandir}/man1/gimptool.1*
220 %{_mandir}/man1/scm2*.1*
221 %{_mandir}/man3/gpc.3*
222
223 %files static
224 %attr(644,root,root) %{_libdir}/lib*.a
225
226 %changelog
227 * Tue Jun 15 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
228   [1.1.6-2]
229 - fixed documentation.
230
231 * Mon Jun 14 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
232   [1.1.6-1]
233 - updated to version 1.1.6.
234
235 * Mon May 31 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
236   [1.1.5-1]
237 - updated to 1.1.5,
238 - fixes file locations,
239 - based on gimp.spec from PLD-devel.
This page took 0.055406 seconds and 4 git commands to generate.