]> git.pld-linux.org Git - packages/gfs2.git/blob - gfs2.spec
- up to 2.03.10-1
[packages/gfs2.git] / gfs2.spec
1 #
2 # TODO:
3 #       - update patch0
4 #       - cleanup files section
5 #       - change from gfs2 to cluster 
6 #       - move to cluster-3 (for kernels 2.6.29+)
7 #       - split cluster pkg to gfs2, gfs, fence, dlm, rmanager,
8 #         ccs, cman, group
9 #       - more kernel stuff (gnbd, ...), but gnbd looks dead,
10 #         use iscsi, fc, aoe, nbd or sth instead
11 #       - optflags
12 # INFO:
13 #       - gfs2 and dlm kernel modules are in the kernel package
14 #         (2.6.28.9-3 for example); gfs is the old GFS. 
15 #
16 # Conditional build:
17 %bcond_without  dist_kernel     # without distribution kernel
18 %bcond_with     kernel          # don't build kernel module
19 %bcond_without  userspace       # don't build userspace package
20 %bcond_with     verbose
21
22 %if %{without kernel}
23 %undefine       with_dist_kernel
24 %endif
25 %if "%{_alt_kernel}" != "%{nil}"
26 %undefine       with_userspace
27 %endif
28 %if %{without userspace}
29 # nothing to be placed to debuginfo package
30 %define         _enable_debug_packages  0
31 %endif
32
33 %define         rel     1
34 Summary:        Shared-disk cluster file system
35 Summary(pl.UTF-8):      Klastrowy system plików na współdzielonym dysku
36 Name:           gfs2
37 Version:        2.03.10
38 Release:        %{rel}
39 Epoch:          1
40 License:        GPL v2
41 Group:          Applications/System
42 Source0:        ftp://sources.redhat.com/pub/cluster/releases/cluster-%{version}.tar.gz
43 # Source0-md5:  379b560096e315d4b52e238a5c72ba4a
44 Patch0:         %{name}-install.patch
45 Patch1:         %{name}-kernel-2.6.28.patch
46 URL:            http://sources.redhat.com/cluster/gfs/
47 BuildRequires:  libvolume_id-devel
48 BuildRequires:  linux-libc-headers >= 7:2.6.20
49 BuildRequires:  ncurses-devel
50 BuildRequires:  perl-base
51 BuildRequires:  openais-devel
52 %if %{with dist_kernel}
53 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.27
54 %endif
55
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _sbindir        /sbin
59
60 %description -n gfs2
61 GFS (Global File System) is a cluster file system. It allows a cluster
62 of computers to simultaneously use a block device that is shared
63 between them (with FC, iSCSI, NBD, etc...). GFS reads and writes to
64 the block device like a local filesystem, but also uses a lock module
65 to allow the computers coordinate their I/O so filesystem consistency
66 is maintained. One of the nifty features of GFS is perfect consistency
67 -- changes made to the filesystem on one machine show up immediately
68 on all other machines in the cluster.
69
70 %description -l pl.UTF-8 -n gfs2
71 GFS (Global File System) to klastrowy system plików. Pozwala klastrowi
72 komputerów na jednoczesne korzystanie z urządzenia blokowego
73 dzielonego między nimi (poprzez FC, iSCSI, NBD itp.). GFS odczytuje i
74 zapisuje urządzenie blokowe jak lokalny system plików, ale używa
75 dodatkowo modułu blokującego, aby umożliwić komputerom koordynowanie
76 ich operacji I/O w celu zachowania spójności systemu plików. Jedną z
77 szykownych możliwości GFS-a jest idealna spójność - zmiany wykonane w
78 systemie plików na jednej maszynie natychmiast pokazują się na
79 wszystkich innych maszynach w klastrze.
80
81 %package -n cluster
82 Summary:        Cluster stuff
83 Group:          Applications/System
84
85 %description -n cluster
86 The rest of the cluster stuff. 
87
88 %package -n kernel%{_alt_kernel}-misc-gfs
89 Summary:        gfs kernel module
90 Release:        %{rel}@%{_kernel_ver_str}
91 Group:          Base/Kernel
92 Requires(post,postun):  /sbin/depmod
93 %if %{with dist_kernel}
94 %requires_releq_kernel
95 Requires(postun):       %releq_kernel
96 %endif
97 Provides:       kernel(gfs) = %{version}-%{rel}
98
99 %description -n kernel%{_alt_kernel}-misc-gfs
100 gfs kernel module.
101
102 %package -n kernel%{_alt_kernel}-misc-gnbd
103 Summary:        gnbd kernel module
104 Release:        %{rel}@%{_kernel_ver_str}
105 Group:          Base/Kernel
106 Requires(post,postun):  /sbin/depmod
107 %if %{with dist_kernel}
108 %requires_releq_kernel
109 Requires(postun):       %releq_kernel
110 %endif
111 Provides:       kernel(gnbd) = %{version}-%{rel}
112
113 %description -n kernel%{_alt_kernel}-misc-gnbd
114 gnbd kernel module.
115
116 %prep
117 %setup -q -n cluster-%{version}
118 #patch0 -p1
119 %patch1 -p1
120
121 sed -i -e 's,-Wall,%{rpmcflags} -I/usr/include/ncurses -Wall,' make/defines.mk.input
122 sed -i -e 's/ -ggdb / %{rpmcflags} /' gfs2/libgfs2/Makefile
123 sed -i -e 's/ -O2 -ggdb / %{rpmcflags} /' gfs2/mkfs/Makefile
124 %if %{with kernel}
125 # gfs
126 sed -i -e "s,\.\./\.\./\.\.,$PWD," gfs-kernel/src/gfs/Makefile
127 sed -i -e "s,\$(OBJDIR),$PWD," gfs-kernel/src/gfs/Makefile
128 # gnbd
129 sed -i -e "s,\.\./\.\.,$PWD," gnbd-kernel/src/Makefile
130 sed -i -e "s,\$(OBJDIR),$PWD," gnbd-kernel/src/Makefile
131 %endif
132
133 %build
134 ./configure \
135         --libdir=%{_libdir} \
136         --mandir=%{_mandir} \
137         --prefix=%{_prefix} \
138         --sbindir=%{_sbindir} \
139         --ncursesincdir=%{_includedir}/ncurses \
140         --without_kernel_modules
141
142 %if %{with userspace}
143 %{__make}
144 %endif
145
146 %if %{with kernel}
147 export KBUILD_NOPEDANTIC=1
148 %build_kernel_modules -C gfs-kernel/src/gfs -m gfs
149 #build_kernel_modules -C gnbd-kernel/src -m gnbd
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %if %{with userspace}
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT
158
159 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
160 mv $RPM_BUILD_ROOT/etc/init.d/* $RPM_BUILD_ROOT/etc/rc.d/init.d
161 %endif
162
163 %if %{with kernel}
164 %install_kernel_modules -m gfs-kernel/src/gfs/gfs -d misc
165 #install_kernel_modules -m gnbd-kernel/src/gnbd -d misc
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %if %{with userspace}
172 %files -n gfs2
173 %defattr(644,root,root,755)
174 %attr(755,root,root) %{_sbindir}/*gfs2*
175 %attr(754,root,root) /etc/rc.d/init.d/gfs2
176 %{_mandir}/man?/*gfs2*
177 /usr/share/doc/cluster/gfs2.txt
178
179 %files -n cluster
180 %defattr(644,root,root,755)
181 /etc/rc.d/init.d/cman
182 /etc/rc.d/init.d/gfs
183 /etc/rc.d/init.d/qdiskd
184 /etc/rc.d/init.d/rgmanager
185 /etc/rc.d/init.d/scsi_reserve
186 /etc/udev/rules.d/51-dlm.rules
187 %{_includedir}/ccs.h
188 %{_includedir}/libcman.h
189 %{_includedir}/libdlm.h
190 %{_libdir}/libccs.a
191 %{_libdir}/libcman.a
192 %{_libdir}/libcman.so
193 %{_libdir}/libcman.so.2
194 %{_libdir}/libcman.so.2.3
195 %{_libdir}/libdlm.a
196 %{_libdir}/libdlm.so
197 %{_libdir}/libdlm.so.2
198 %{_libdir}/libdlm.so.2.3
199 %{_libdir}/libdlm_lt.a
200 %{_libdir}/libdlm_lt.so
201 %{_libdir}/libdlm_lt.so.2
202 %{_libdir}/libdlm_lt.so.2.3
203 /usr/libexec/lcrso/service_cman.lcrso
204 /usr/share/cluster/ASEHAagent.sh
205 /usr/share/cluster/SAPDatabase
206 /usr/share/cluster/SAPInstance
207 /usr/share/cluster/apache.metadata
208 /usr/share/cluster/apache.sh
209 /usr/share/cluster/clusterfs.sh
210 /usr/share/cluster/default_event_script.sl
211 /usr/share/cluster/fs.sh
212 /usr/share/cluster/ip.sh
213 /usr/share/cluster/lvm.metadata
214 /usr/share/cluster/lvm.sh
215 /usr/share/cluster/lvm_by_lv.sh
216 /usr/share/cluster/lvm_by_vg.sh
217 /usr/share/cluster/mysql.metadata
218 /usr/share/cluster/mysql.sh
219 /usr/share/cluster/named.metadata
220 /usr/share/cluster/named.sh
221 /usr/share/cluster/netfs.sh
222 /usr/share/cluster/nfsclient.sh
223 /usr/share/cluster/nfsexport.sh
224 /usr/share/cluster/ocf-shellfuncs
225 /usr/share/cluster/openldap.metadata
226 /usr/share/cluster/openldap.sh
227 /usr/share/cluster/oracledb.sh
228 /usr/share/cluster/postgres-8.metadata
229 /usr/share/cluster/postgres-8.sh
230 /usr/share/cluster/samba.metadata
231 /usr/share/cluster/samba.sh
232 /usr/share/cluster/script.sh
233 /usr/share/cluster/service.sh
234 /usr/share/cluster/smb.sh
235 /usr/share/cluster/svclib_nfslock
236 /usr/share/cluster/tomcat-5.metadata
237 /usr/share/cluster/tomcat-5.sh
238 /usr/share/cluster/utils/config-utils.sh
239 /usr/share/cluster/utils/httpd-parse-config.pl
240 /usr/share/cluster/utils/member_util.sh
241 /usr/share/cluster/utils/messages.sh
242 /usr/share/cluster/utils/ra-skelet.sh
243 /usr/share/cluster/utils/tomcat-parse-config.pl
244 /usr/share/cluster/vm.sh
245 /usr/share/doc/cluster/COPYING.applications
246 /usr/share/doc/cluster/COPYING.libraries
247 /usr/share/doc/cluster/COPYRIGHT
248 /usr/share/doc/cluster/README.licence
249 /usr/share/doc/cluster/journaling.txt
250 /usr/share/doc/cluster/min-gfs.txt
251 /usr/share/doc/cluster/usage.txt
252 /usr/share/fence/fencing.py
253 /usr/share/fence/telnet_ssl
254 /usr/share/snmp/mibs/powernet369.mib
255 /sbin/ccs_test
256 /sbin/ccs_tool
257 /sbin/ccsd
258 /sbin/clubufflush
259 /sbin/clufindhostname
260 /sbin/clulog
261 /sbin/clunfslock
262 /sbin/clurgmgrd
263 /sbin/clurmtabd
264 /sbin/clustat
265 /sbin/clusvcadm
266 /sbin/cman_tool
267 /sbin/dlm_controld
268 /sbin/dlm_tool
269 /sbin/fence_ack_manual
270 /sbin/fence_alom
271 /sbin/fence_apc
272 /sbin/fence_apc_snmp
273 /sbin/fence_baytech
274 /sbin/fence_bladecenter
275 /sbin/fence_brocade
276 /sbin/fence_bullpap
277 /sbin/fence_cpint
278 /sbin/fence_drac
279 /sbin/fence_drac5
280 /sbin/fence_egenera
281 /sbin/fence_eps
282 /sbin/fence_gnbd
283 /sbin/fence_ibmblade
284 /sbin/fence_ifmib
285 /sbin/fence_ilo
286 /sbin/fence_ipmilan
287 /sbin/fence_ldom
288 /sbin/fence_lpar
289 /sbin/fence_mcdata
290 /sbin/fence_node
291 /sbin/fence_rackswitch
292 /sbin/fence_rps10
293 /sbin/fence_rsa
294 /sbin/fence_rsb
295 /sbin/fence_sanbox2
296 /sbin/fence_scsi
297 /sbin/fence_scsi_test
298 /sbin/fence_tool
299 /sbin/fence_virsh
300 /sbin/fence_vixel
301 /sbin/fence_vmware
302 /sbin/fence_wti
303 /sbin/fence_xcat
304 /sbin/fence_zvm
305 /sbin/fenced
306 /sbin/fsck.gfs
307 /sbin/gfs_controld
308 /sbin/gfs_debug
309 /sbin/gfs_edit
310 /sbin/gfs_fsck
311 /sbin/gfs_grow
312 /sbin/gfs_jadd
313 /sbin/gfs_mkfs
314 /sbin/gfs_quota
315 /sbin/gfs_tool
316 /sbin/gnbd_clusterd
317 /sbin/gnbd_export
318 /sbin/gnbd_get_uid
319 /sbin/gnbd_import
320 /sbin/gnbd_monitor
321 /sbin/gnbd_recvd
322 /sbin/gnbd_serv
323 /sbin/group_tool
324 /sbin/groupd
325 /sbin/mkfs.gfs
326 /sbin/mkqdisk
327 /sbin/mount.gfs
328 /sbin/qdiskd
329 /sbin/rg_test
330 /sbin/umount.gfs
331 /usr/include/ccs.h
332 /usr/include/libcman.h
333 /usr/include/libdlm.h
334 /usr/lib/libccs.a
335 /usr/lib/libcman.a
336 /usr/lib/libcman.so
337 /usr/lib/libcman.so.2
338 /usr/lib/libcman.so.2.3
339 /usr/lib/libdlm.a
340 /usr/lib/libdlm.so
341 /usr/lib/libdlm.so.2
342 /usr/lib/libdlm.so.2.3
343 /usr/lib/libdlm_lt.a
344 /usr/lib/libdlm_lt.so
345 /usr/lib/libdlm_lt.so.2
346 /usr/lib/libdlm_lt.so.2.3
347 /usr/libexec/lcrso/service_cman.lcrso
348 /usr/share/cluster/ASEHAagent.sh
349 /usr/share/cluster/SAPDatabase
350 /usr/share/cluster/SAPInstance
351 /usr/share/cluster/apache.metadata
352 /usr/share/cluster/apache.sh
353 /usr/share/cluster/clusterfs.sh
354 /usr/share/cluster/default_event_script.sl
355 /usr/share/cluster/fs.sh
356 /usr/share/cluster/ip.sh
357 /usr/share/cluster/lvm.metadata
358 /usr/share/cluster/lvm.sh
359 /usr/share/cluster/lvm_by_lv.sh
360 /usr/share/cluster/lvm_by_vg.sh
361 /usr/share/cluster/mysql.metadata
362 /usr/share/cluster/mysql.sh
363 /usr/share/cluster/named.metadata
364 /usr/share/cluster/named.sh
365 /usr/share/cluster/netfs.sh
366 /usr/share/cluster/nfsclient.sh
367 /usr/share/cluster/nfsexport.sh
368 /usr/share/cluster/ocf-shellfuncs
369 /usr/share/cluster/openldap.metadata
370 /usr/share/cluster/openldap.sh
371 /usr/share/cluster/oracledb.sh
372 /usr/share/cluster/postgres-8.metadata
373 /usr/share/cluster/postgres-8.sh
374 /usr/share/cluster/samba.metadata
375 /usr/share/cluster/samba.sh
376 /usr/share/cluster/script.sh
377 /usr/share/cluster/service.sh
378 /usr/share/cluster/smb.sh
379 /usr/share/cluster/svclib_nfslock
380 /usr/share/cluster/tomcat-5.metadata
381 /usr/share/cluster/tomcat-5.sh
382 /usr/share/cluster/utils/config-utils.sh
383 /usr/share/cluster/utils/httpd-parse-config.pl
384 /usr/share/cluster/utils/member_util.sh
385 /usr/share/cluster/utils/messages.sh
386 /usr/share/cluster/utils/ra-skelet.sh
387 /usr/share/cluster/utils/tomcat-parse-config.pl
388 /usr/share/cluster/vm.sh
389 /usr/share/doc/cluster/COPYING.applications
390 /usr/share/doc/cluster/COPYING.libraries
391 /usr/share/doc/cluster/COPYRIGHT
392 /usr/share/doc/cluster/README.licence
393 /usr/share/doc/cluster/journaling.txt
394 /usr/share/doc/cluster/min-gfs.txt
395 /usr/share/doc/cluster/usage.txt
396 /usr/share/fence/fencing.py
397 /usr/share/fence/telnet_ssl
398 /usr/share/man/man3/dlm_cleanup.3
399 /usr/share/man/man3/dlm_close_lockspace.3
400 /usr/share/man/man3/dlm_create_lockspace.3.gz
401 /usr/share/man/man3/dlm_dispatch.3
402 /usr/share/man/man3/dlm_get_fd.3
403 /usr/share/man/man3/dlm_lock.3.gz
404 /usr/share/man/man3/dlm_lock_wait.3
405 /usr/share/man/man3/dlm_ls_lock.3
406 /usr/share/man/man3/dlm_ls_lock_wait.3
407 /usr/share/man/man3/dlm_ls_lockx.3
408 /usr/share/man/man3/dlm_ls_pthread_init.3
409 /usr/share/man/man3/dlm_ls_unlock.3
410 /usr/share/man/man3/dlm_ls_unlock_wait.3
411 /usr/share/man/man3/dlm_new_lockspace.3
412 /usr/share/man/man3/dlm_open_lockspace.3
413 /usr/share/man/man3/dlm_pthread_init.3
414 /usr/share/man/man3/dlm_release_lockspace.3
415 /usr/share/man/man3/dlm_unlock.3.gz
416 /usr/share/man/man3/dlm_unlock_wait.3
417 /usr/share/man/man3/libdlm.3.gz
418 /usr/share/man/man5/cluster.conf.5.gz
419 /usr/share/man/man5/cman.5.gz
420 /usr/share/man/man5/qdisk.5.gz
421 /usr/share/man/man7/ccs.7.gz
422 /usr/share/man/man8/ccs_test.8.gz
423 /usr/share/man/man8/ccs_tool.8.gz
424 /usr/share/man/man8/ccsd.8.gz
425 /usr/share/man/man8/clubufflush.8.gz
426 /usr/share/man/man8/clufindhostname.8.gz
427 /usr/share/man/man8/clulog.8.gz
428 /usr/share/man/man8/clurgmgrd.8.gz
429 /usr/share/man/man8/clurmtabd.8.gz
430 /usr/share/man/man8/clustat.8.gz
431 /usr/share/man/man8/clusvcadm.8.gz
432 /usr/share/man/man8/cman_tool.8.gz
433 /usr/share/man/man8/dlm_controld.8.gz
434 /usr/share/man/man8/dlm_tool.8.gz
435 /usr/share/man/man8/fence.8.gz
436 /usr/share/man/man8/fence_ack_manual.8.gz
437 /usr/share/man/man8/fence_alom.8.gz
438 /usr/share/man/man8/fence_apc.8.gz
439 /usr/share/man/man8/fence_bladecenter.8.gz
440 /usr/share/man/man8/fence_brocade.8.gz
441 /usr/share/man/man8/fence_bullpap.8.gz
442 /usr/share/man/man8/fence_drac.8.gz
443 /usr/share/man/man8/fence_egenera.8.gz
444 /usr/share/man/man8/fence_eps.8.gz
445 /usr/share/man/man8/fence_gnbd.8.gz
446 /usr/share/man/man8/fence_ifmib.8.gz
447 /usr/share/man/man8/fence_ilo.8.gz
448 /usr/share/man/man8/fence_ipmilan.8.gz
449 /usr/share/man/man8/fence_ldom.8.gz
450 /usr/share/man/man8/fence_manual.8.gz
451 /usr/share/man/man8/fence_mcdata.8.gz
452 /usr/share/man/man8/fence_node.8.gz
453 /usr/share/man/man8/fence_rib.8.gz
454 /usr/share/man/man8/fence_rsa.8.gz
455 /usr/share/man/man8/fence_sanbox2.8.gz
456 /usr/share/man/man8/fence_tool.8.gz
457 /usr/share/man/man8/fence_virsh.8.gz
458 /usr/share/man/man8/fence_vixel.8.gz
459 /usr/share/man/man8/fence_vmware.8.gz
460 /usr/share/man/man8/fence_wti.8.gz
461 /usr/share/man/man8/fence_xvm.8.gz
462 /usr/share/man/man8/fence_xvmd.8.gz
463 /usr/share/man/man8/fenced.8.gz
464 /usr/share/man/man8/gfs.8.gz
465 /usr/share/man/man8/gfs_controld.8.gz
466 /usr/share/man/man8/gfs_edit.8
467 /usr/share/man/man8/gfs_fsck.8.gz
468 /usr/share/man/man8/gfs_grow.8.gz
469 /usr/share/man/man8/gfs_jadd.8.gz
470 /usr/share/man/man8/gfs_mkfs.8.gz
471 /usr/share/man/man8/gfs_mount.8.gz
472 /usr/share/man/man8/gfs_quota.8.gz
473 /usr/share/man/man8/gfs_tool.8.gz
474 /usr/share/man/man8/gnbd.8.gz
475 /usr/share/man/man8/gnbd_export.8.gz
476 /usr/share/man/man8/gnbd_import.8.gz
477 /usr/share/man/man8/gnbd_serv.8.gz
478 /usr/share/man/man8/group_tool.8.gz
479 /usr/share/man/man8/groupd.8.gz
480 /usr/share/man/man8/mkqdisk.8.gz
481 /usr/share/man/man8/qdiskd.8.gz
482 /usr/share/snmp/mibs/powernet369.mib
483 %endif
484
485 %if %{with kernel}
486 %files -n kernel%{_alt_kernel}-misc-gfs
487 /lib/modules/%{_kernel_ver}/misc/gfs.ko*
488 #/lib/modules/%{_kernel_ver}/misc/gnbd.ko*
489 %endif
This page took 0.077829 seconds and 4 git commands to generate.