]> git.pld-linux.org Git - packages/geoclue.git/blob - geoclue.spec
a275f3ccfe657ce608d64630fc4bfaf902602393
[packages/geoclue.git] / geoclue.spec
1 #
2 # Conditional build:
3 %bcond_without  gps     # GPS support via gpsd
4 %bcond_with     conic   # Maemo LibConIC connectivity support
5 %bcond_with     connman # ConnMan connectivity support
6 %bcond_without  nm      # NetworkManager connectivity support
7
8 Summary:        A modular geoinformation service
9 Summary(pl.UTF-8):      Modularna usługa geoinformacyjna
10 Name:           geoclue
11 Version:        0.12.99
12 Release:        7
13 License:        LGPL v2+
14 Group:          Applications
15 Source0:        http://freedesktop.org/~hadess/%{name}-%{version}.tar.gz
16 # Source0-md5:  779245045bfeeec4853da8baaa3a18e6
17 Patch0:         %{name}-libsoup.patch
18 Patch1:         %{name}-gpsd.patch
19 Patch2:         %{name}-format.patch
20 Patch3:         %{name}-nm.patch
21 URL:            http://geoclue.freedesktop.org/
22 BuildRequires:  GConf2-devel >= 2.0
23 %{?with_nm:BuildRequires:       NetworkManager-devel >= 1.0}
24 BuildRequires:  autoconf >= 2.59
25 BuildRequires:  automake >= 1:1.9
26 %{?with_connman:BuildRequires:  connman-devel}
27 BuildRequires:  dbus-glib-devel >= 0.86
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  glib2-devel >= 1:2.26
30 %{?with_gps:BuildRequires:      gpsd-devel >= 3.18}
31 BuildRequires:  gtk+2-devel >= 1:2.0
32 BuildRequires:  gtk-doc >= 1.0
33 BuildRequires:  gypsy-devel >= 0.7.1
34 %{?with_conic:BuildRequires:    libconic-devel}
35 BuildRequires:  libsoup-devel >= 2.4.0
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel >= 2.0
38 BuildRequires:  libxslt-progs
39 BuildRequires:  pkgconfig
40 Requires:       %{name}-libs = %{version}-%{release}
41 Requires:       dbus
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Geoclue is a modular geoinformation service built on top of the D-Bus
46 messaging system. The goal of the Geoclue project is to make creating
47 location-aware applications as simple as possible.
48
49 %description -l pl.UTF-8
50 Geoclue to modularna usługa geoinformacyjna zbudowana w oparciu o
51 system komunikacji D-Bus. Celem projektu jest jak największe
52 ułatwienie tworzenia aplikacji uwzględniających lokalizację.
53
54 %package libs
55 Summary:        Geoclue modular geoinformation service library
56 Summary(pl.UTF-8):      Biblioteka geoclue - modularnej usługi geoinformacyjnej
57 Group:          Libraries
58 Requires:       dbus-glib >= 0.86
59 Requires:       glib2 >= 1:2.26
60 Conflicts:      geoclue < 0.12.0-3
61
62 %description libs
63 geoclue modular geoinformation service library.
64
65 %description libs -l pl.UTF-8
66 Biblioteka geoclue - modularnej usługi geoinformacyjnej.
67
68 %package devel
69 Summary:        Development package for geoclue
70 Summary(pl.UTF-8):      Pakiet programistyczny geoclue
71 Group:          Development/Libraries
72 Requires:       %{name}-libs = %{version}-%{release}
73 Requires:       dbus-glib-devel >= 0.86
74 Requires:       glib2-devel >= 1:2.26
75 Requires:       libxml2-devel >= 2.0
76
77 %description devel
78 Header files for development with geoclue.
79
80 %description devel -l pl.UTF-8
81 Pliki nagłówkowe do programowania z użyciem geoclue.
82
83 %package static
84 Summary:        Static geoclue library
85 Summary(pl.UTF-8):      Statyczna biblioteka geoclue
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}-%{release}
88
89 %description static
90 Static geoclue library.
91
92 %description static -l pl.UTF-8
93 Statyczna biblioteka geoclue.
94
95 %package apidocs
96 Summary:        Developer documentation for geoclue
97 Summary(pl.UTF-8):      Dokumentacja programisty do geoclue
98 Group:          Development/Libraries
99 Requires:       gtk-doc-common
100 %if "%{_rpmversion}" >= "5"
101 BuildArch:      noarch
102 %endif
103
104 %description apidocs
105 Developer documentation for geoclue.
106
107 %description apidocs -l pl.UTF-8
108 Dokumentacja programisty do geoclue.
109
110 %package gpsd
111 Summary:        gpsd provider for geoclue
112 Summary(pl.UTF-8):      Interfejs geoclue do gpsd
113 Group:          Applications
114 Requires:       %{name} = %{version}-%{release}
115 Requires:       gpsd >= 3.18
116
117 %description gpsd
118 A gpsd provider for geoclue.
119
120 %description gpsd -l pl.UTF-8
121 Interfejs geoclue do gpsd.
122
123 %package gypsy
124 Summary:        gypsy provider for geoclue
125 Summary(pl.UTF-8):      Interfejs geoclue do gypsy
126 Group:          Applications
127 Requires:       %{name} = %{version}-%{release}
128 Requires:       gypsy >= 0.7.1
129
130 %description gypsy
131 A gypsy provider for geoclue.
132
133 %description gypsy -l pl.UTF-8
134 Interfejs geoclue do gypsy.
135
136 %prep
137 %setup -q
138 %patch0 -p1
139 %patch1 -p1
140 %patch2 -p1
141 %patch3 -p1
142
143 %build
144 %{__gtkdocize}
145 %{__libtoolize}
146 %{__aclocal}
147 %{__autoconf}
148 %{__autoheader}
149 %{__automake}
150 %configure \
151         --enable-gtk-doc \
152         --enable-conic%{!?with_conic:=no} \
153         --enable-connman%{!?with_connman:=no} \
154         --enable-gpsd%{!?with_gps:=no} \
155         --enable-gypsy \
156         --enable-networkmanager%{!?with_nm:=no} \
157         --disable-silent-rules \
158         --enable-skyhook \
159         --with-html-dir=%{_gtkdocdir}
160
161 %{__make}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         DESTDIR=$RPM_BUILD_ROOT
168
169 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   libs -p /sbin/ldconfig
175 %postun libs -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc AUTHORS README
180 %attr(755,root,root) %{_libexecdir}/geoclue-example
181 %attr(755,root,root) %{_libexecdir}/geoclue-geonames
182 %attr(755,root,root) %{_libexecdir}/geoclue-gsmloc
183 %attr(755,root,root) %{_libexecdir}/geoclue-hostip
184 %attr(755,root,root) %{_libexecdir}/geoclue-localnet
185 %attr(755,root,root) %{_libexecdir}/geoclue-manual
186 %attr(755,root,root) %{_libexecdir}/geoclue-master
187 %attr(755,root,root) %{_libexecdir}/geoclue-nominatim
188 %attr(755,root,root) %{_libexecdir}/geoclue-plazes
189 %attr(755,root,root) %{_libexecdir}/geoclue-skyhook
190 %attr(755,root,root) %{_libexecdir}/geoclue-yahoo
191 %dir %{_datadir}/geoclue-providers
192 %{_datadir}/GConf/gsettings/geoclue
193 %{_datadir}/geoclue-providers/geoclue-example.provider
194 %{_datadir}/geoclue-providers/geoclue-geonames.provider
195 %{_datadir}/geoclue-providers/geoclue-gsmloc.provider
196 %{_datadir}/geoclue-providers/geoclue-hostip.provider
197 %{_datadir}/geoclue-providers/geoclue-localnet.provider
198 %{_datadir}/geoclue-providers/geoclue-manual.provider
199 %{_datadir}/geoclue-providers/geoclue-nominatim.provider
200 %{_datadir}/geoclue-providers/geoclue-plazes.provider
201 %{_datadir}/geoclue-providers/geoclue-skyhook.provider
202 %{_datadir}/geoclue-providers/geoclue-yahoo.provider
203 %{_datadir}/glib-2.0/schemas/org.freedesktop.Geoclue.gschema.xml
204 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Master.service
205 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Example.service
206 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Geonames.service
207 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Gsmloc.service
208 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Hostip.service
209 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Localnet.service
210 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Manual.service
211 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Nominatim.service
212 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Plazes.service
213 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Skyhook.service
214 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Yahoo.service
215
216 %files libs
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libgeoclue.so.*.*.*
219 %attr(755,root,root) %ghost %{_libdir}/libgeoclue.so.0
220
221 %files devel
222 %defattr(644,root,root,755)
223 %attr(755,root,root) %{_libdir}/libgeoclue.so
224 %{_includedir}/geoclue
225 %{_pkgconfigdir}/geoclue.pc
226
227 %files static
228 %defattr(644,root,root,755)
229 %{_libdir}/libgeoclue.a
230
231 %files apidocs
232 %defattr(644,root,root,755)
233 %{_gtkdocdir}/geoclue
234
235 %if %{with gps}
236 %files gpsd
237 %defattr(644,root,root,755)
238 %attr(755,root,root) %{_libexecdir}/geoclue-gpsd
239 %{_datadir}/geoclue-providers/geoclue-gpsd.provider
240 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Gpsd.service
241 %endif
242
243 %files gypsy
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libexecdir}/geoclue-gypsy
246 %{_datadir}/geoclue-providers/geoclue-gypsy.provider
247 %{_datadir}/dbus-1/services/org.freedesktop.Geoclue.Providers.Gypsy.service
This page took 0.056695 seconds and 2 git commands to generate.