]> git.pld-linux.org Git - packages/geany-plugins.git/blob - geany-plugins.spec
940ecf0f0018bea406a420a8ce4bb7ab5beab308
[packages/geany-plugins.git] / geany-plugins.spec
1 #
2 # Conditional build:
3 %bcond_without  cppcheck        # cppcheck to check geany-plugins source code
4
5 Summary:        A collection of different plugins for Geany
6 Summary(pl.UTF-8):      Zbiór różnych wtyczek dla Geany
7 Name:           geany-plugins
8 Version:        2.0
9 Release:        2
10 License:        GPL v2+
11 Group:          Libraries
12 Source0:        https://plugins.geany.org/geany-plugins/%{name}-%{version}.tar.gz
13 # Source0-md5:  87b17a7f3ea2402f2bbd5ca68771aafb
14 URL:            https://plugins.geany.org/
15 BuildRequires:  autoconf >= 2.61
16 BuildRequires:  autoconf-archive
17 BuildRequires:  automake >= 1:1.8
18 BuildRequires:  check-devel
19 %{?with_cppcheck:BuildRequires: cppcheck}
20 BuildRequires:  ctpl-devel >= 0.3
21 BuildRequires:  docutils
22 BuildRequires:  enchant2-devel >= 2.2
23 BuildRequires:  gdk-pixbuf2-devel >= 2.0
24 BuildRequires:  geany-devel >= 2.0
25 BuildRequires:  gettext-tools
26 BuildRequires:  glib2-devel >= 1:2.22
27 BuildRequires:  gpgme-devel >= 0.4.2
28 BuildRequires:  gtk+3-devel >= 3.24
29 #BuildRequires: gtk-webkit3-devel >= 1.1.18
30 BuildRequires:  gtk-webkit4-devel >= 1.1.18
31 BuildRequires:  gtkspell3-devel >= 3.0
32 BuildRequires:  intltool >= 0.35.0
33 BuildRequires:  libgit2-devel >= 0.21
34 BuildRequires:  libmarkdown-devel
35 BuildRequires:  libsoup-devel >= 2.42
36 BuildRequires:  libtool
37 BuildRequires:  libxml2-devel >= 1:2.6.27
38 BuildRequires:  lua51-devel >= 5.1
39 BuildRequires:  pkgconfig
40 BuildRequires:  vala
41 BuildRequires:  vte-devel >= 0.46
42 Requires:       geany >= 2.0
43 Requires:       glib2 >= 1:2.22
44 Obsoletes:      geany-plugins-devhelp < 1.37
45 Obsoletes:      geany-plugins-geanypy < 1.37
46 Obsoletes:      geany-plugins-multiterm < 1.37
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 Geany-Plugins is a collection of different plugins for Geany, a
51 lightweight IDE.
52
53 %description -l pl.UTF-8
54 Geany-Plugins to zbiór różnych wtyczek dla Geany, lekiego IDE
55 używającego GTK+.
56
57 %package addons
58 Summary:        Various small plugins for Geany
59 Summary(pl.UTF-8):      Różne drobne dodatki dla Geany
60 Group:          Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description addons
64 This plugin adds various small addons to Geany which aren't worth an
65 own plugin but might still useful for people.
66
67 %description addons -l pl.UTF-8
68 Ta wtyczka dodaje różne małe dodatki do Geany, które nie zasługują aby
69 mieć własne wtyczki, ale wciąż są użyteczne dla ludzi.
70
71 %package autoclose
72 Summary:        autoclose plugin for Geany
73 Summary(pl.UTF-8):      Wtyczka automatycznego zamykania nawiasów dla Geany
74 Group:          Libraries
75 Requires:       %{name} = %{version}-%{release}
76
77 %description autoclose
78 This plugin enables auto-closing features.
79
80 %description autoclose -l pl.UTF-8
81 Ta wtyczka automatycznie zamyka nawiasy w trakcie pisania kodu.
82
83 %package automark
84 Summary:        automark plugin for Geany
85 Summary(pl.UTF-8):      Wtyczka automark dla Geany
86 Group:          Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description automark
90 This is a simple plugin that highlights all words that match current
91 word under cursor.
92
93 %description automark -l pl.UTF-8
94 Ta wtyczka podświetla wszystkie słowa pasujące do aktualnie
95 znajdującego się pod kursorem.
96
97 %package codenav
98 Summary:        codenav plugin for Geany
99 Summary(pl.UTF-8):      Wtyczka codenav dla Geany
100 Group:          Libraries
101 Requires:       %{name} = %{version}-%{release}
102
103 %description codenav
104 This plugin adds some facilities for navigating in code files.
105
106 %description codenav -l pl.UTF-8
107 Wtyczka ułatwiająca nawigowanie po kodzie.
108
109 %package commander
110 Summary:        commander plugin for Geany
111 Summary(pl.UTF-8):      Wtyczka commander dla Geany
112 Group:          Libraries
113 Requires:       %{name} = %{version}-%{release}
114
115 %description commander
116 Commander is a plugin for Geany that provides a command panel for
117 rapid access to any action.
118
119 %description commander -l pl.UTF-8
120 Commander to wtyczka do Geany, która zapewnia panel poleceń,
121 umożliwiający szybki dostęp do dowolnej akcji.
122
123 %package debugger
124 Summary:        debugger plugin for Geany
125 Summary(pl.UTF-8):      Wtyczka debugger dla Geany
126 Group:          Libraries
127 Requires:       %{name} = %{version}-%{release}
128
129 %description debugger
130 Plugin enables debugging in Geany. Currently supports GDB only, but
131 was developed with multiple debuggers support in mind, so the other
132 backends support is planned as well.
133
134 %description debugger -l pl.UTF-8
135 Wtyczka umożliwia debugowanie w Geany. Obecnie obsługuje tylko GDB,
136 ale została opracowana z myślą o obsłudze wielu debuggerów, więc
137 planowane jest także wsparcie innych backendów.
138
139 %package defineformat
140 Summary:        defineformat plugin for Geany
141 Summary(pl.UTF-8):      Wtyczka defineformat dla Geany
142 Group:          Libraries
143 Requires:       %{name} = %{version}-%{release}
144
145 %description defineformat
146 Defineformat -- on-the-fly #define prettyprinter. This plugin will
147 help you to write multiline defines with aligned backslash.
148
149 %description defineformat -l pl.UTF-8
150 Ta wtyczka pomaga pisać definicje wielowierszowe z wyrównanym
151 odwrotnym ukośnikiem.
152
153 %package geanyctags
154 Summary:        geanyctags plugin for Geany
155 Summary(pl.UTF-8):      Wtyczka geanyctags dla Geany
156 Group:          Libraries
157 Requires:       %{name} = %{version}-%{release}
158 Requires:       ctags
159
160 %description geanyctags
161 GeanyCtags adds a simple support for generating and querying ctags
162 files for a Geany project. It requires that the ctags command is
163 installed in a system path
164
165 %description geanyctags -l pl.UTF-8
166 GeanyCtags dodaje prostą obsługę generowania i sprawdzania plików
167 ctags dla projektu Geany. Wtyczka wymaga zainstalowanego ctags.
168
169 %package geanydoc
170 Summary:        geanydoc plugin for Geany
171 Summary(pl.UTF-8):      Wtyczka geanydoc dla Geany
172 Group:          Libraries
173 Requires:       %{name} = %{version}-%{release}
174
175 %description geanydoc
176 Geanydoc is plugin for Geany IDE that allow execute specified commands
177 on the current word at the cursor position.
178
179 %description geanydoc -l pl.UTF-8
180 Geanydoc to wtyczka dla IDE Geany, która pozwala wykonywać określone
181 polecenia dla aktualnie zaznaczonego słowa.
182
183 %package geanyextrasel
184 Summary:        geanyextrasel plugin for Geany
185 Summary(pl.UTF-8):      Wtyczka geanyextrasel dla Geany
186 Group:          Libraries
187 Requires:       %{name} = %{version}-%{release}
188
189 %description geanyextrasel
190 The Extra Selection plugin adds the following functions to Geany:
191 - Goto matching brace and select (Select to Matching Brace).
192 - Goto line and select (Select to Line).
193 - Toggle the current selection type between stream and rectangular
194   (without changing column mode, can be invoked while drag-selecting).
195 - Ctrl-Shift-Alt-Left/Right/Home/End keys - same as Ctrl-Shift, but
196   for rectangular selection.
197 - Column mode - while active, all (Ctrl)-Shift-movement keys do
198   rectangle selection instead of stream.
199 - Selection with anchor instead of the Shift-movement keys.
200
201 %description geanyextrasel -l pl.UTF-8
202 Wtyczka Extra Selection dodaje do Geany następujące funkcje:
203 - Przejście do pasującego nawiasu klamrowego i zaznaczenie (Zaznacz do
204   pasującego nawiasu klamrowego),
205 - Przejście do linii i zaznaczenie (Zaznacz do linii).
206 - Przełączanie bieżącego rodzaju zaznaczenia między strumieniowym a
207   prostokątnym (bez zmiany trybu kolumnowego, można wywoływać podczas
208   zaznaczania przeciągnięciem).
209 - Ctrl-Shift-Alt-Left / Right / Home / End - tak samo jak Ctrl-Shift,
210   ale dla zaznaczania prostokątnego.
211 - Tryb kolumnowy - gdy aktywny, wszystkie klawisze (Ctrl)-Shift-ruch
212   wykonują zaznaczenie prostokątne zamiast strumieniowego.
213 - Zaznaczanie za pomocą kotwicy zamiast klawiszy Shift-move.
214
215 %package geanygendoc
216 Summary:        geanygendoc plugin for Geany
217 Summary(pl.UTF-8):      Wtyczka geanygendoc dla Geany
218 Group:          Libraries
219 Requires:       %{name} = %{version}-%{release}
220 Requires:       ctpl >= 0.3
221 # rst2html
222 Requires:       docutils
223
224 %description geanygendoc
225 GeanyGenDoc is a plugin for Geany that aims to help code documentation
226 by automatically generating documentation comment basis from the
227 source code.
228
229 %description geanygendoc -l pl.UTF-8
230 GeanyGenDoc to wtyczka Geany wspomagająca dokumentowanie kodu poprzez
231 automatyczne generowanie podstaw komentarzy dokumenujących z kodu
232 źródłowego.
233
234 %package geanyinsertnum
235 Summary:        geanyinsertnum plugin for Geany
236 Summary(pl.UTF-8):      Wtyczka geanyinsertnum dla Geany
237 Group:          Libraries
238 Requires:       %{name} = %{version}-%{release}
239
240 %description geanyinsertnum
241 This plugin replaces a (possibly zero-width) rectangular selection
242 with integer numbers, using start/step/base etc. specified by the
243 user. For practical reasons, the number of lines is limited to 250000.
244 Lines shorter than the current selection are skipped.
245
246 %description geanyinsertnum -l pl.UTF-8
247 Wtyczka ta zastępuje prostokątne zaznaczenie (także o zerowej
248 szerokości) ciągiem liczb całkowitych, określony przez początek, krok,
249 podstawę itp. podane przez użytkownika. Ze względów praktycznych
250 liczba linii jest ograniczona do 250000. Linie krótsze niż bieżące
251 zaznaczenie są pomijane.
252
253 %package geanylua
254 Summary:        geanylua plugin for Geany
255 Summary(pl.UTF-8):      Wtyczka geanylua dla Geany
256 Group:          Libraries
257 Requires:       %{name} = %{version}-%{release}
258
259 %description geanylua
260 This is a plugin for the Geany IDE to provide Lua scripting.
261
262 %description geanylua -l pl.UTF-8
263 Ta wtyczka umożliwia używanie w Geany skryptów LUA.
264
265 %package geanymacro
266 Summary:        geanymacro plugin for Geany
267 Summary(pl.UTF-8):      Wtyczka geanymacro dla Geany
268 Group:          Libraries
269 Requires:       %{name} = %{version}-%{release}
270
271 %description geanymacro
272 Geanymacro is a plugin to provide user defined macros for Geany
273
274 %description geanymacro -l pl.UTF-8
275 Geanymacro to wtyczka pozwalająca użytkownikowi definiować własne
276 makra.
277
278 %package geanyminiscript
279 Summary:        geanyminiscript plugin for Geany
280 Summary(pl.UTF-8):      Wtyczka geanyminiscript dla Geany
281 Group:          Libraries
282 Requires:       %{name} = %{version}-%{release}
283
284 %description geanyminiscript
285 A Geany Mini-Script filter plugin
286
287 %description geanyminiscript -l pl.UTF-8
288 Wtyczka filtra Geany Mini-Script
289
290 %package geanynumberedbookmarks
291 Summary:        geanynumberedbookmarks plugin for Geany
292 Summary(pl.UTF-8):      Wtyczka geanynumberedbookmarks dla Geany
293 Group:          Libraries
294 Requires:       %{name} = %{version}-%{release}
295
296 %description geanynumberedbookmarks
297 Geanynumberedbookmarks is a plugin to provide users with 10 numbered
298 bookmarks (in addition to the usual bookmarks).
299
300 %description geanynumberedbookmarks -l pl.UTF-8
301 Geanynumberedbookmarks to wtyczka zapewniająca użytkownikom 10
302 ponumerowanych zakładek (oprócz zwykłych zakładek).
303
304 %package geanypg
305 Summary:        geanypg plugin for Geany
306 Summary(pl.UTF-8):      Wtyczka geanypg dla Geany
307 Group:          Libraries
308 Requires:       %{name} = %{version}-%{release}
309
310 %description geanypg
311 GeanyPG is a plugin for Geany that allows the user to encrypt, decrypt
312 and verify signatures with GnuPG.
313
314 %description geanypg -l pl.UTF-8
315 GeanyPG to wtyczka dla Geany, która pozwala użytkownikowi szyfrować,
316 odszyfrowywać i weryfikować podpisy za pomocą GnuPG.
317
318 %package geanyprj
319 Summary:        geanyprj plugin for Geany
320 Summary(pl.UTF-8):      Wtyczka geanyprj dla Geany
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description geanyprj
325 Geanyprj is alternative project manager for Geany fast light IDE.
326
327 %description geanyprj -l pl.UTF-8
328 Geanyprj jest alternatywnym zarządcą projektów dla Geany IDE.
329
330 %package geanyvc
331 Summary:        geanyvc plugin for Geany
332 Summary(pl.UTF-8):      Wtyczka geanyvc dla Geany
333 Group:          Libraries
334 Requires:       %{name} = %{version}-%{release}
335
336 %description geanyvc
337 GeanyVC is plugin that provides a uniform way of accessing the
338 different version-control systems inside Geany IDE. Only small subset
339 of vc is implemented, but, hey, you don't need anything besides diff,
340 log, status, revert and commit most time.
341
342 %description geanyvc -l pl.UTF-8
343 GeanyVC to wtyczka, która zapewnia jednolity sposób dostępu do różnych
344 systemów kontroli wersji w IDE Geany. Zaimplementowano tylko niewielki
345 podzbiór funkcji, ale zwykle wystarczają różnice, log zmian, status,
346 wycofywanie i zatwierdzanie zmian.
347
348 %package geniuspaste
349 Summary:        geniuspaste plugin for Geany
350 Summary(pl.UTF-8):      Wtyczka geniuspaste dla Geany
351 Group:          Libraries
352 Requires:       %{name} = %{version}-%{release}
353
354 %description geniuspaste
355 This plugin allows the user to paste code from Geany into a configured
356 pastebin service. At the moment it ships with builtin support these
357 pastebin services, but more can be added:
358 - codepad.org
359 - dpaste.de
360 - fpaste.org
361 - pastebin.geany.org
362 - paste.debian.net
363 - sprunge.us
364
365 GeniusPaste detects automatically the syntax of the code and pastes it
366 with syntax highlighting enabled. It can also display the pasted code
367 opening a new browser tab.
368
369 %description geniuspaste -l pl.UTF-8
370 Ta wtyczka pozwala użytkownikowi wkleić kod z Geany do skonfigurowanej
371 usługi pastebin. W tej chwili ma wbudowaną obsługę poniższych usłg
372 pastebin, ale może być dodane więcej:
373 - codepad.org
374 - dpaste.de
375 - fpaste.org
376 - pastebin.geany.org
377 - paste.debian.net
378 - sprunge.us
379
380 GeniusPaste automatycznie wykrywa składnię kodu i wkleja go z
381 włączonym podświetlaniem składni. Może także wyświetlać wklejony kod,
382 otwierając nową kartę przeglądarki.
383
384 %package git-changebar
385 Summary:        git-changebar plugin for Geany
386 Summary(pl.UTF-8):      Wtyczka git-changebar dla Geany
387 Group:          Libraries
388 Requires:       %{name} = %{version}-%{release}
389
390 %description git-changebar
391 This plugin highlights uncommitted changes to files tracked with Git,
392 allows to navigate through the hunks and undo them.
393
394 %description git-changebar -l pl.UTF-8
395 Ta wtyczka podkreśla niezatwierdzone zmiany w plikach śledzonych za
396 pomocą Gita, pozwala nawigować między zmienionymi blokami i wycofywać
397 zmiany.
398
399 %package keyrecord
400 Summary:        keyrecord plugin for Geany
401 Summary(pl.UTF-8):      Wtyczka keyrecord dla Geany
402 Group:          Libraries
403 Requires:       %{name} = %{version}-%{release}
404
405 %description keyrecord
406 This plugin allows you to record a sequence of keystrokes and to
407 replay it several times.
408
409 %description keyrecord -l pl.UTF-8
410 Ta wtyczka pozwala nagrywać sekwencję naciśnięć klawiszy i odtwarzać
411 ją kilka razy.
412
413 %package latex
414 Summary:        latex plugin for Geany
415 Summary(pl.UTF-8):      Wtyczka latex dla Geany
416 Group:          Libraries
417 Requires:       %{name} = %{version}-%{release}
418
419 %description latex
420 LaTeX is a little plugin to improve support of LaTeX on Geany.
421
422 %description latex -l pl.UTF-8
423 LaTeX to prosta wtyczka rozszerzająca możliwości Geany w tym zakresie.
424
425 %package lineoperations
426 Summary:        lineoperations plugin for Geany
427 Summary(pl.UTF-8):      Wtyczka lineoperations dla Geany
428 Group:          Libraries
429 Requires:       %{name} = %{version}-%{release}
430
431 %description lineoperations
432 Line Operations is an assortment of simple line functions that can be
433 applied to an open file, or selection.
434
435 %description lineoperations -l pl.UTF-8
436 Line Operations to zestaw prostych, operujących na liniach funkcji,
437 które można zastosować do otwartego pliku lub zaznaczenia.
438
439 %package lipsum
440 Summary:        lipsum plugin for Geany
441 Summary(pl.UTF-8):      Wtyczka lipsum dla Geany
442 Group:          Libraries
443 Requires:       %{name} = %{version}-%{release}
444
445 %description lipsum
446 Lipsum is a plugin for Geany that implements a Lorem Ipsum generator
447 to insert placeholder text into your document.
448
449 %description lipsum -l pl.UTF-8
450 Lipsum to wtyczka dla Geany, która implementuje generator Lorem Ipsum
451 do wstawiania tekstu zastępczego do dokumentu.
452
453 %package markdown
454 Summary:        markdown plugin for Geany
455 Summary(pl.UTF-8):      Wtyczka markdown dla Geany
456 Group:          Libraries
457 Requires:       %{name} = %{version}-%{release}
458
459 %description markdown
460 This plugin provides a real-time preview of rendered Markdown, that
461 is, Markdown converted to HTML and inserted into an HTML template and
462 loaded into a WebKit view.
463
464 %description markdown -l pl.UTF-8
465 Ta wtyczka zapewnia podgląd w czasie rzeczywistym renderowanego kodu
466 Markdown, tzn. Markdown jest konwertowany na HTML i wstawiany do
467 szablonu HTML, a następnie ładowany do widoku WebKit.
468
469 %package overview
470 Summary:        overview plugin for Geany
471 Summary(pl.UTF-8):      Wtyczka overview dla Geany
472 Group:          Libraries
473 Requires:       %{name} = %{version}-%{release}
474
475 %description overview
476 The Overview plugin is a small zoomed-out view next to the normal
477 editor view that allows to see and navigate a lot of the file at once.
478 It is similar to the Minimap in SublimeText or such similar feature in
479 numerous other editors.
480
481 %description overview -l pl.UTF-8
482 Wtyczka Overview to mały, pomniejszony widok obok normalnego widoku
483 edytora, który pozwala zobaczyć i nawigować po wielu plikach
484 jednocześnie. Jest podobny do Minimapy w SublimeText lub podobnej
485 funkcji w wielu innych edytorach.
486
487 %package pairtaghighlighter
488 Summary:        pairtaghighlighter plugin for Geany
489 Summary(pl.UTF-8):      Wtyczka pairtaghighlighter dla Geany
490 Group:          Libraries
491 Requires:       %{name} = %{version}-%{release}
492
493 %description pairtaghighlighter
494 Finds and highlights matching opening/closing HTML tag by clicking or
495 moving cursor inside a tag.
496
497 %description pairtaghighlighter -l pl.UTF-8
498 Ta wtyczka znajduje i wyróżnia pasujący otwierający/zamykający
499 znacznik HTML po kliknięciu albo przesunięciu kursora wewnątrz
500 znacznika.
501
502 %package pohelper
503 Summary:        pohelper plugin for Geany
504 Summary(pl.UTF-8):      Wtyczka pohelper dla Geany
505 Group:          Libraries
506 Requires:       %{name} = %{version}-%{release}
507
508 %description pohelper
509 Translation Helper is a plugin for Geany that improves the support for
510 GetText translation files, by providing various features specific to
511 this format and to translators.
512
513 %description pohelper -l pl.UTF-8
514 Translation Helper to wtyczka dla Geany, która usprawnia obsługę
515 plików tłumaczeń GetTexta, zapewniając różne funkcje specyficzne dla
516 tego formatu i dla tłumaczy.
517
518 %package pretty-printer
519 Summary:        pretty-printer plugin for Geany
520 Summary(pl.UTF-8):      Wtyczka pretty-printer dla Geany
521 Group:          Libraries
522 Requires:       %{name} = %{version}-%{release}
523 Requires:       libxml2 >= 1:2.6.27
524
525 %description pretty-printer
526 Formats an XML file and makes it human-readable.
527
528 %description pretty-printer -l pl.UTF-8
529 Formatuje XML i czyni go czytelnym dla ludzi.
530
531 %package projectorganizer
532 Summary:        projectorganizer plugin for Geany
533 Summary(pl.UTF-8):      Wtyczka projectorganizer dla Geany
534 Group:          Libraries
535 Requires:       %{name} = %{version}-%{release}
536
537 %description projectorganizer
538 Project Organizer is an extension of Geany's project management
539 displaying a tree of files belonging to the project in the sidebar.
540
541 %description projectorganizer -l pl.UTF-8
542 Project Organizer to rozszerzenie zarządzania projektami Geany,
543 wyświetlające na pasku bocznym drzewo plików należących do projektu.
544
545 %package scope
546 Summary:        scope plugin for Geany
547 Summary(pl.UTF-8):      Wtyczka scope dla Geany
548 Group:          Libraries
549 Requires:       %{name} = %{version}-%{release}
550
551 %description scope
552 Scope is a graphical GDB front-end with the normal functions you would
553 expect (stepping, breakpoints...), and a few notable features:
554 - The comminication between Scope and gdb is asynchronous.
555 - You can enter any gdb command, at any time (of course, for the
556   command to be executed, gdb must be[come] available).
557 - All gdb I/O (along with some other messages) is displayed in a
558   terminal-like "Debug Console". Whenever you find the GUI lacking,
559   simply switch to that console and work directly with gdb.
560 - 7-bit/Locale/UTF-8 support for values.
561
562 %description scope -l pl.UTF-8
563 Scope jest graficznym interfejsem do GDB ze zwykłymi funkcjami,
564 których można oczekiwać (krokami, punktami przerwania itp.) i kilkoma
565 ważnymi cechami:
566 - Łączność między Scope a gdb jest asynchroniczna.
567 - Można wprowadzić dowolne polecenie gdb w dowolnym momencie
568   (oczywiście, aby polecenie zostało wykonane, gdb musi być dostępne).
569 - Wszystkie wejścia/wyjścia gdb (wraz z kilkoma innymi komunikatami)
570   są wyświetlane w podobnej do terminalu „konsoli debugowania”.
571   Jeżeli czegokolwiek brakuje w GUI, wystarczy przełączyć na tę
572   konsolę i pracować bezpośrednio z gdb.
573 - Obsługa znaków 7-bitowych/zlokalizowanych/UTF-8.
574
575 %package sendmail
576 Summary:        sendmail plugin for Geany
577 Summary(pl.UTF-8):      Wtyczka sendmail dla Geany
578 Group:          Libraries
579 Requires:       %{name} = %{version}-%{release}
580
581 %description sendmail
582 SendMail is a little plugin to send a document as attachment using the
583 preferred mail client from inside Geany. It is similar to the envelope
584 symbol of most office tools and requires a mail client that is
585 supporting remote calls. This is not a direct binding to sendmail,
586 even if it could be used for.
587
588 %description sendmail -l pl.UTF-8
589 SendMail to mała wtyczka do wysyłania dokumentu jako załącznika przy
590 użyciu preferowanego klienta poczty z Geany. Jest podobna do symbolu
591 koperty większości narzędzi biurowych i wymaga klienta poczty
592 obsługującego połączenia zdalne. Nie jest bezpośrednio powiązana z
593 sendmailem, nawet jeśli to sendmail miałby być używany do poczty.
594
595 %package shiftcolumn
596 Summary:        shiftcolumn plugin for Geany
597 Summary(pl.UTF-8):      Wtyczka shiftcolumn dla Geany
598 Group:          Libraries
599 Requires:       %{name} = %{version}-%{release}
600
601 %description shiftcolumn
602 This plugin allows you to move blocks of text horizontally in left or
603 right direction skipping one character at a time.
604
605 %description shiftcolumn -l pl.UTF-8
606 Ta wtyczka umożliwia przenoszenie bloków tekstu poziomo w lewo lub w
607 prawo, przeskakując jeden znak na raz.
608
609 %package spellcheck
610 Summary:        spellcheck plugin for Geany
611 Summary(pl.UTF-8):      Wtyczka spellcheck dla Geany
612 Group:          Libraries
613 Requires:       %{name} = %{version}-%{release}
614 Requires:       enchant2 >= 2.2
615
616 %description spellcheck
617 This plugin checks the content of the current document in Geany with
618 the spell check library Enchant. You can also select a certain text
619 passage, then the plugin will only check the selected text. All lines
620 with misspelled words are highlighted with a red squiggly underline
621 and the wrong words are printed in the messages window at the bottom
622 of Geany together with available suggestions. For the plugin to work
623 at all, you need to have the Enchant library installed together with
624 at least one backend (Aspell, Myspell, Hunspell, ...). The plugin's
625 configure dialog lists all available languages/dictionaries which can
626 be used for the spell check.
627
628 %description spellcheck -l pl.UTF-8
629 Ta wtyczka sprawdza pisownię bieżącego dokumentu w Geany za pomocą
630 biblioteki sprawdzania pisowni Enchant. Można także wybrać określony
631 fragment tekstu, a wtyczka sprawdzi tylko zaznaczony tekst. Wszystkie
632 wiersze z błędnie napisanymi słowami są podświetlone czerwonym
633 zawijasowym podkreśleniem, a nieprawidłowe słowa są wypisywane w oknie
634 wiadomości u dołu Geany wraz z dostępnymi podpowiedziami. Aby wtyczka
635 w ogóle działała, trzeba mieć zainstalowaną bibliotekę Enchant z co
636 najmniej jednym backendem (Aspell, Myspell, Hunspell...). Okno
637 dialogowe konfiguracji wtyczki zawiera listę wszystkich dostępnych
638 języków/słowników, których można użyć do sprawdzania pisowni.
639
640 %package tableconvert
641 Summary:        tableconvert plugin for Geany
642 Summary(pl.UTF-8):      Wtyczka tableconvert dla Geany
643 Group:          Libraries
644 Requires:       %{name} = %{version}-%{release}
645
646 %description tableconvert
647 Tableconvert is a plugin which helps on converting a tabulator
648 separated selection into a table.
649
650 %description tableconvert -l pl.UTF-8
651 Tableconvert to wtyczka, która pomaga w konwertowaniu zaznaczenia
652 porozdzielanego tabulatorami na tabelę.
653
654 %package treebrowser
655 Summary:        treebrowser plugin for Geany
656 Summary(pl.UTF-8):      Wtyczka treebrowser dla Geany
657 Group:          Libraries
658 Requires:       %{name} = %{version}-%{release}
659
660 %description treebrowser
661 The TreeBrowser plugin for Geany provides an alternate way to browse
662 through your files. It displays files and directories in a tree view
663 and has more features than the file browser plugin delivered with
664 Geany itself.
665
666 %description treebrowser -l pl.UTF-8
667 Wtyczka TreeBrowser dla Geany zapewnia alternatywny sposób
668 przeglądania plików. Wyświetla pliki i katalogi w widoku drzewa i ma
669 więcej funkcji niż wtyczka przeglądarki plików dostarczana z samym
670 Geany.
671
672 %package updatechecker
673 Summary:        updatechecker plugin for Geany
674 Summary(pl.UTF-8):      Wtyczka updatechecker dla Geany
675 Group:          Libraries
676 Requires:       %{name} = %{version}-%{release}
677 Requires:       libsoup >= 2.42
678
679 %description updatechecker
680 UpdateChecker is a plugin for Geany, which is able to check whether
681 there is a more recent version of Geany available.
682
683 %description updatechecker -l pl.UTF-8
684 UpdateChecker to wtyczka dla Geany, która może sprawdzić, czy dostępna
685 jest nowsza wersja Geany.
686
687 %package vimode
688 Summary:        vimode plugin for Geany
689 Summary(pl.UTF-8):      Wtyczka vimode dla Geany
690 Group:          Libraries
691 Requires:       %{name} = %{version}-%{release}
692
693 %description vimode
694 Vimode is a Vim-mode plugin for Geany.
695
696 %description vimode -l pl.UTF-8
697 Vimode to wtyczka trybu Vim dla Geany.
698
699 %package webhelper
700 Summary:        webhelper plugin for Geany
701 Summary(pl.UTF-8):      : Wtyczka webhelper dla Geany
702 Group:          Libraries
703 Requires:       %{name} = %{version}-%{release}
704
705 %description webhelper
706 WebHelper is a plugin for Geany that provides some web development
707 facilities, such as a web page preview and some debugging tools (web
708 inspector).
709
710 %description webhelper -l pl.UTF-8
711 WebHelper to wtyczka dla Geany, która zapewnia pewne funkcje
712 programistyczne, takie jak podgląd strony internetowej i niektóre
713 narzędzia diagnostyczne (web inspector).
714
715 %package workbench
716 Summary:        workbench plugin for Geany
717 Summary(pl.UTF-8):      Wtyczka workbench dla Geany
718 Group:          Libraries
719 Requires:       %{name} = %{version}-%{release}
720
721 %description workbench
722 The Workbench plugin is an extension that makes it possible to manage
723 multiple projects in geany. You can add geany projects to a workbench.
724 From there you can add directories to the project to manage the files
725 belonging to the project.
726
727 %description workbench -l pl.UTF-8
728 Wtyczka Workbench jest rozszerzeniem, które umożliwia zarządzanie
729 wieloma projektami w Geany. Pozwala dodawać projekty Geany do "biurka
730 roboczego". Stamtąd można dodawać do projektu katalogi, aby zarządzać
731 plikami należącymi do projektu.
732
733 %package xmlsnippets
734 Summary:        xmlsnippets plugin for Geany
735 Summary(pl.UTF-8):      Wtyczka xmlsnippets dla Geany
736 Group:          Libraries
737 Requires:       %{name} = %{version}-%{release}
738
739 %description xmlsnippets
740 This plugin extends XML/HTML tag autocompletion provided by Geany. It
741 automatically inserts a matching snippet after you type an opening
742 tag.
743
744 %description xmlsnippets -l pl.UTF-8
745 Ta wtyczka rozszerza automatyczne uzupełnianie znaczników XML/HTML
746 dostarczane przez Geany. Automatycznie wstawia pasujący fragment po
747 wpisaniu otwierającego znacznika.
748
749 %prep
750 %setup -q
751 %{__rm} build/bundled/gpgme.m4
752
753 %build
754 %{__intltoolize}
755 %{__libtoolize}
756 %{__aclocal} -I build 
757 %{__autoheader}
758 %{__automake}
759 %{__autoconf}
760 %configure \
761         %{!?with_cppcheck:--disable-cppcheck} \
762         --disable-silent-rules
763
764 %{__make}
765
766 %install
767 rm -rf $RPM_BUILD_ROOT
768
769 %{__make} install \
770         DESTDIR=$RPM_BUILD_ROOT
771
772 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
773 %{__rm} $RPM_BUILD_ROOT%{_libdir}/{,geany/,%{name}/geanylua/}*.la
774 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgeanypluginutils.so
775
776 %find_lang %{name}
777
778 %clean
779 rm -rf $RPM_BUILD_ROOT
780
781 %files -f %{name}.lang
782 %defattr(644,root,root,755)
783 %doc NEWS README
784 %attr(755,root,root) %{_libdir}/libgeanypluginutils.so.*.*.*
785 %attr(755,root,root) %ghost %{_libdir}/libgeanypluginutils.so.0
786 %dir %{_libdir}/%{name}
787 %dir %{_datadir}/%{name}
788
789 %files addons
790 %defattr(644,root,root,755)
791 %doc addons/{AUTHORS,ChangeLog,NEWS,README}
792 %attr(755,root,root) %{_libdir}/geany/addons.so
793
794 %files autoclose
795 %defattr(644,root,root,755)
796 %doc autoclose/{AUTHORS,ChangeLog,NEWS,README}
797 %attr(755,root,root) %{_libdir}/geany/autoclose.so
798
799 %files automark
800 %defattr(644,root,root,755)
801 %doc automark/{AUTHORS,ChangeLog,NEWS,README}
802 %attr(755,root,root) %{_libdir}/geany/automark.so
803
804 %files codenav
805 %defattr(644,root,root,755)
806 %doc codenav/{AUTHORS,ChangeLog,NEWS,README}
807 %attr(755,root,root) %{_libdir}/geany/codenav.so
808
809 %files commander
810 %defattr(644,root,root,755)
811 %doc commander/{AUTHORS,ChangeLog,NEWS,README}
812 %attr(755,root,root) %{_libdir}/geany/commander.so
813
814 %files debugger
815 %defattr(644,root,root,755)
816 %doc commander/{AUTHORS,ChangeLog,NEWS,README}
817 %attr(755,root,root) %{_libdir}/geany/debugger.so
818 %{_datadir}/%{name}/debugger
819
820 %files defineformat
821 %defattr(644,root,root,755)
822 %doc defineformat/{AUTHORS,ChangeLog,NEWS,README}
823 %attr(755,root,root) %{_libdir}/geany/defineformat.so
824
825 %files geanyctags
826 %defattr(644,root,root,755)
827 %doc geanyctags/{AUTHORS,ChangeLog,NEWS,README}
828 %attr(755,root,root) %{_libdir}/geany/geanyctags.so
829
830 %files geanydoc
831 %defattr(644,root,root,755)
832 %doc geanydoc/{AUTHORS,ChangeLog,NEWS,README}
833 %attr(755,root,root) %{_libdir}/geany/geanydoc.so
834
835 %files geanyextrasel
836 %defattr(644,root,root,755)
837 %doc geanyextrasel/{AUTHORS,ChangeLog,NEWS,README}
838 %attr(755,root,root) %{_libdir}/geany/geanyextrasel.so
839
840 %files geanygendoc
841 %defattr(644,root,root,755)
842 %doc geanygendoc/{AUTHORS,ChangeLog,NEWS,README,TODO}
843 %attr(755,root,root) %{_libdir}/geany/geanygendoc.so
844 %{_datadir}/%{name}/geanygendoc
845
846 %files geanyinsertnum
847 %defattr(644,root,root,755)
848 %doc geanyinsertnum/{AUTHORS,ChangeLog,NEWS,README}
849 %attr(755,root,root) %{_libdir}/geany/geanyinsertnum.so
850
851 %files geanylua
852 %defattr(644,root,root,755)
853 %doc geanylua/{AUTHORS,ChangeLog,NEWS,README} geanylua/docs/*.html
854 %attr(755,root,root) %{_libdir}/geany/geanylua.so
855 %dir %{_libdir}/%{name}/geanylua
856 %attr(755,root,root) %{_libdir}/%{name}/geanylua/*.so
857 %{_datadir}/%{name}/geanylua
858
859 %files geanymacro
860 %defattr(644,root,root,755)
861 %doc geanymacro/{AUTHORS,ChangeLog,NEWS,README}
862 %attr(755,root,root) %{_libdir}/geany/geanymacro.so
863
864 %files geanyminiscript
865 %defattr(644,root,root,755)
866 %doc geanyminiscript/{AUTHORS,ChangeLog,NEWS,README}
867 %attr(755,root,root) %{_libdir}/geany/geanyminiscript.so
868
869 %files geanynumberedbookmarks
870 %defattr(644,root,root,755)
871 %doc geanynumberedbookmarks/{AUTHORS,ChangeLog,NEWS,README}
872 %attr(755,root,root) %{_libdir}/geany/geanynumberedbookmarks.so
873
874 %files geanypg
875 %defattr(644,root,root,755)
876 %doc geanypg/{AUTHORS,ChangeLog,NEWS,README}
877 %attr(755,root,root) %{_libdir}/geany/geanypg.so
878
879 %files geanyprj
880 %defattr(644,root,root,755)
881 %doc geanyprj/{AUTHORS,ChangeLog,NEWS,README}
882 %attr(755,root,root) %{_libdir}/geany/geanyprj.so
883
884 %files geanyvc
885 %defattr(644,root,root,755)
886 %doc geanyvc/{AUTHORS,ChangeLog,NEWS,README}
887 %attr(755,root,root) %{_libdir}/geany/geanyvc.so
888
889 %files geniuspaste
890 %defattr(644,root,root,755)
891 %doc geniuspaste/{AUTHORS,ChangeLog,NEWS,README}
892 %attr(755,root,root) %{_libdir}/geany/geniuspaste.so
893 %{_datadir}/%{name}/geniuspaste
894
895 %files git-changebar
896 %defattr(644,root,root,755)
897 %doc git-changebar/{AUTHORS,ChangeLog,NEWS,README}
898 %attr(755,root,root) %{_libdir}/geany/git-changebar.so
899 %{_datadir}/%{name}/git-changebar
900
901 %files keyrecord
902 %defattr(644,root,root,755)
903 %doc keyrecord/{AUTHORS,ChangeLog,NEWS,README}
904 %attr(755,root,root) %{_libdir}/geany/keyrecord.so
905
906 %files latex
907 %defattr(644,root,root,755)
908 %doc latex/{AUTHORS,ChangeLog,NEWS,README} latex/doc/latex.pdf
909 %attr(755,root,root) %{_libdir}/geany/latex.so
910
911 %files lineoperations
912 %defattr(644,root,root,755)
913 %doc lineoperations/{AUTHORS,ChangeLog,NEWS,README}
914 %attr(755,root,root) %{_libdir}/geany/lineoperations.so
915
916 %files lipsum
917 %defattr(644,root,root,755)
918 %doc lipsum/{AUTHORS,ChangeLog,NEWS,README}
919 %attr(755,root,root) %{_libdir}/geany/lipsum.so
920
921 %files markdown
922 %defattr(644,root,root,755)
923 %doc markdown/{AUTHORS,ChangeLog,NEWS,README}
924 %attr(755,root,root) %{_libdir}/geany/markdown.so
925
926 %files overview
927 %defattr(644,root,root,755)
928 %doc overview/{AUTHORS,ChangeLog,NEWS,README}
929 %attr(755,root,root) %{_libdir}/geany/overview.so
930 %{_datadir}/%{name}/overview
931
932 %files pairtaghighlighter
933 %defattr(644,root,root,755)
934 %doc pairtaghighlighter/{AUTHORS,ChangeLog,NEWS,README}
935 %attr(755,root,root) %{_libdir}/geany/pairtaghighlighter.so
936
937 %files pohelper
938 %defattr(644,root,root,755)
939 %doc pohelper/{AUTHORS,ChangeLog,NEWS,README}
940 %attr(755,root,root) %{_libdir}/geany/pohelper.so
941 %{_datadir}/%{name}/pohelper
942
943 %files pretty-printer
944 %defattr(644,root,root,755)
945 %doc pretty-printer/{AUTHORS,NEWS,README}
946 %attr(755,root,root) %{_libdir}/geany/pretty-printer.so
947
948 %files projectorganizer
949 %defattr(644,root,root,755)
950 %doc projectorganizer/{AUTHORS,ChangeLog,NEWS,README}
951 %attr(755,root,root) %{_libdir}/geany/projectorganizer.so
952
953 %files scope
954 %defattr(644,root,root,755)
955 %doc scope/{AUTHORS,ChangeLog,NEWS,README} scope/docs/*.html
956 %attr(755,root,root) %{_libdir}/geany/scope.so
957 %{_datadir}/%{name}/scope
958
959 %files sendmail
960 %defattr(644,root,root,755)
961 %doc sendmail/{AUTHORS,ChangeLog,NEWS,README}
962 %attr(755,root,root) %{_libdir}/geany/sendmail.so
963
964 %files shiftcolumn
965 %defattr(644,root,root,755)
966 %doc shiftcolumn/{AUTHORS,ChangeLog,NEWS,README}
967 %attr(755,root,root) %{_libdir}/geany/shiftcolumn.so
968
969 %files spellcheck
970 %defattr(644,root,root,755)
971 %doc spellcheck/{AUTHORS,ChangeLog,NEWS,README}
972 %attr(755,root,root) %{_libdir}/geany/spellcheck.so
973
974 %files tableconvert
975 %defattr(644,root,root,755)
976 %doc tableconvert/{AUTHORS,ChangeLog,NEWS,README}
977 %attr(755,root,root) %{_libdir}/geany/tableconvert.so
978
979 %files treebrowser
980 %defattr(644,root,root,755)
981 %doc treebrowser/{AUTHORS,ChangeLog,NEWS,README}
982 %attr(755,root,root) %{_libdir}/geany/treebrowser.so
983
984 %files updatechecker
985 %defattr(644,root,root,755)
986 %doc updatechecker/{AUTHORS,ChangeLog,NEWS,README}
987 %attr(755,root,root) %{_libdir}/geany/updatechecker.so
988
989 %files vimode
990 %defattr(644,root,root,755)
991 %doc vimode/{AUTHORS,ChangeLog,NEWS,README}
992 %attr(755,root,root) %{_libdir}/geany/vimode.so
993
994 %files webhelper
995 %defattr(644,root,root,755)
996 %doc webhelper/{AUTHORS,ChangeLog,NEWS,README}
997 %attr(755,root,root) %{_libdir}/geany/webhelper.so
998
999 %files workbench
1000 %defattr(644,root,root,755)
1001 %doc workbench/{AUTHORS,ChangeLog,NEWS,README}
1002 %attr(755,root,root) %{_libdir}/geany/workbench.so
1003
1004 %files xmlsnippets
1005 %defattr(644,root,root,755)
1006 %doc xmlsnippets/{AUTHORS,ChangeLog,NEWS,README}
1007 %attr(755,root,root) %{_libdir}/geany/xmlsnippets.so
This page took 0.132967 seconds and 3 git commands to generate.