]> git.pld-linux.org Git - packages/gdome2.git/blob - gdome2.spec
- cleanup, release 2
[packages/gdome2.git] / gdome2.spec
1 #
2 # Conditional build:
3 %bcond_with     glib1   # use glib 1.2 instead of 2.x
4 #
5 Summary:        DOM level2 library for accessing XML files
6 Summary(pl):    Biblioteka dostêpu do plików XML, DOM poziom 2
7 Name:           gdome2
8 Version:        0.8.1
9 Release:        2
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://gdome2.cs.unibo.it/tarball/%{name}-%{version}.tar.gz
13 # Source0-md5:  bfc114e59eec50cbda8e4ece751ff022
14 URL:            http://gdome2.cs.unibo.it/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 %{?with_glib1:BuildRequires:    glib-devel >= 1.2.10}
18 %{!?with_glib1:BuildRequires:   glib2-devel >= 2.2.0}
19 BuildRequires:  libtool
20 BuildRequires:  libxml2-devel >= 2.4.26
21 %{?with_glib1:Requires: glib >= 1.2.10}
22 %{!?with_glib1:Requires:        glib2 >= 2.2.0}
23 Requires:       libxml2 >= 2.4.26
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 gdome2 is a fast, light and complete DOM level2 implementation based
28 on libxml2. Although it has been written for the GNOME project, it can
29 be used stand-alone.
30
31 A DOM implementation (also called a host implementation) is what makes
32 a parsed XML or HTML document available for processing via the DOM
33 interface.
34
35 gdome2 currently supports the "Core", "XML", "Events" and
36 "MutationEvents" modules from the DOM2 Recommendation (see
37 http://www.w3.org/TR/DOM-Level-2-Core/ and
38 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
39 full implementation of all the DOM Level2 standard.
40
41 Now gdome2 also partially supports the XPath module from the DOM level
42 3 drafts.
43
44 %description -l pl
45 gdome2 jest szybk±, lekk± i kompletn± implementacj± DOM poziom 2
46 opart± o libxml2. Pomimo, ¿e gdome2 zosta³o napisane z my¶l± o
47 projekcie GNOME mo¿e byæ u¿ywane samodzielnie.
48
49 Implementacja DOM (zwana równie¿ implementacj± hosta) udostêpnia
50 przeparsowany dokument XML lub HTML dla dalszego przetwarzania poprzez
51 interfejs DOM.
52
53 gdome2 w chwili obecnej wspiera nastêpuj±ce modu³y rekomendacji DOM2:
54 "Core", "XML", "Events" oraz "MutationEvents" (wiêcej informacji mo¿na
55 uzyskaæ pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
56 http://www.w3.org/TR/DOM-Level-2-Events/), a w przysz³o¶ci ma zostaæ
57 pe³n± implementacj± standardu DOM Poziom 2.
58
59 gdome2 wspiera równie¿ czê¶ciowo DOM Poziom 3, konkretnie XPath.
60
61 %package devel
62 Summary:        Development files for gdome2
63 Summary(pl):    Pliki nag³ówkowe gdome2
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}
66 %{?with_glib1:Requires: glib-devel >= 1.2.10}
67 %{!?with_glib1:Requires:        glib2-devel >= 2.2.0}
68 Requires:       libxml2-devel >= 2.4.26
69
70 %description devel
71 This package contains the header files and configuration scripts for
72 developing with gdome2.
73
74 gdome2 is a fast, light and complete DOM level2 implementation based
75 on libxml2. Although it has been written for the GNOME project, it can
76 be used stand-alone.
77
78 A DOM implementation (also called a host implementation) is what makes
79 a parsed XML or HTML document available for processing via the DOM
80 interface.
81
82 gdome2 currently supports the "Core", "XML", "Events" and
83 "MutationEvents" modules from the DOM2 Recommendation (see
84 http://www.w3.org/TR/DOM-Level-2-Core/ and
85 http://www.w3.org/TR/DOM-Level-2-Events/), and is supposed to become a
86 full implementation of all the DOM Level2 standard.
87
88 Now gdome2 also partially supports the XPath module from the DOM level
89 3 drafts.
90
91 %description devel -l pl
92 Pakiet ten zawiera pliki nag³ówkowe oraz skrypty konfiguracyjne
93 potrzebne do rozwijania oprogramowania opartego o gdome2.
94
95 gdome2 jest szybk±, lekk± i kompletn± implementacj± DOM poziom 2
96 opart± o libxml2. Pomimo, ¿e gdome2 zosta³o napisane z my¶l± o
97 projekcie GNOME mo¿e byæ u¿ywane samodzielnie.
98
99 Implementacja DOM (zwana równie¿ implementacj± hosta) udostêpnia
100 przeparsowany dokument XML lub HTML dla dalszego przetwarzania poprzez
101 interfejs DOM.
102
103 gdome2 w chwili obecnej wspiera nastêpuj±ce modu³y rekomendacji DOM2:
104 "Core", "XML", "Events" oraz "MutationEvents" (wiêcej informacji mo¿na
105 uzyskaæ pod adresem http://www.w3.org/TR/DOM-Level-2-Core/ oraz
106 http://www.w3.org/TR/DOM-Level-2-Events/), a w przysz³o¶ci ma zostaæ
107 pe³n± implementacj± standardu DOM Poziom 2.
108
109 gdome2 wspiera równie¿ czê¶ciowo DOM Poziom 3, konkretnie XPath.
110
111 %package static
112 Summary:        Static libraries for gdome2
113 Summary(pl):    Biblioteki statyczne dla gdome2
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{version}
116
117 %description static
118 This package contains static libraries for developing with gdome2.
119
120 %description static -l pl
121 Pakiet ten zawiera statyczne biblioteki potrzebne do rozwijania
122 oprogramowania opartego o gdome2.
123
124 %prep
125 %setup -q
126
127 %{!?with_glib1:echo 'AM_DEFUN([AM_PATH_GLIB], [$3])' >> acinclude.m4}
128 %{?with_glib1:echo 'AM_DEFUN([AM_PATH_GLIB_2_0], [$3]' >> acinclude.m4}
129
130 %build
131 %{__libtoolize}
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135 %configure \
136         %{!?with_glib1:GLIB_CONFIG="pkg-config glib-2.0"} \
137         %{?with_glib1:--enable-glib-1}
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS MAINTAINERS ChangeLog README
156 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
157
158 %files devel
159 %defattr(644,root,root,755)
160 %doc gtk-doc/html/*.html
161 %attr(755,root,root) %{_bindir}/gdome-config
162 %attr(755,root,root) %{_libdir}/lib*.so
163 %{_libdir}/lib*.la
164 %attr(755,root,root) %{_libdir}/*.sh
165 %{_includedir}/libgdome
166 %{_mandir}/man1/gdome-config.1*
167 %{_aclocaldir}/%{name}.m4
168 %{_pkgconfigdir}/%{name}.pc
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/*.a
This page took 0.107045 seconds and 3 git commands to generate.