]> git.pld-linux.org Git - packages/gdm2.20.git/blob - gdm2.20.spec
- updated for gdm 2.2.2
[packages/gdm2.20.git] / gdm2.20.spec
1 Summary:        GNOME Display Manager
2 Summary(pl):    gdm
3 Name:           gdm
4 Version:        2.2.2
5 Release:        1
6 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/latest/sources/%{name}-%{version}.tar.gz
7 Source1:        %{name}.pamd
8 Source2:        %{name}.init
9 Group:          X11/Applications
10 Group(de):      X11/Applikationen
11 Group(pl):      X11/Aplikacje
12 License:        LGPL/GPL
13 Prereq:         /usr/sbin/groupadd
14 Prereq:         /usr/sbin/groupdel
15 Prereq:         /usr/sbin/useradd
16 Prereq:         /usr/sbin/userdel
17 Prereq:         /sbin/chkconfig
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 BuildRequires:  gnome-libs-devel
20 BuildRequires:  gtk+-devel
21 BuildRequires:  esound-devel
22 Requires:       gnome-libs >= 1.0.0
23 Requires:       which
24 Requires:       /usr/X11R6/bin/sessreg
25 Obsoletes:      xdm kdm wdm
26
27 %define         _prefix         /usr/X11R6
28 %define         _mandir         %{_prefix}/man
29 %define         _sysconfdir     /etc/X11
30
31 %description 
32 gdm manages local and remote displays and provides the user with a
33 graphical login window.
34
35 %description -l pl
36 gdm zarz±dza lokalnymi i zdalnymi X serwerami i udostêpnia
37 u¿ytkownikowi graficzne okienko logowania.
38
39 %prep
40 %setup -q
41
42 %build
43 CFLAGS="%{rpmcflags}" \
44 ./configure %{_target_platform} \
45         --prefix=%{_prefix} \
46         --sysconfdir=%{_sysconfdir} \
47         --localstatedir=/var/lib
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d/
54
55 install -d $RPM_BUILD_ROOT{%{_prefix},/etc/{pam.d,security}}
56 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
57
58 %{__make} install prefix=$RPM_BUILD_ROOT%{_prefix} \
59         sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir} \
60         localstatedir=$RPM_BUILD_ROOT/var/lib
61
62 sed -e "s#$RPM_BUILD_ROOT##g" config/gnomerc >config/gnomerc.X
63 install config/gnomerc.X $RPM_BUILD_ROOT%{_sysconfdir}/gdm/gnomerc
64
65 sed -e "s#$RPM_BUILD_ROOT##g" $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome \
66         > $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome.X
67
68 mv -f $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome.X \
69         $RPM_BUILD_ROOT%{_sysconfdir}/gdm/Sessions/Gnome
70
71 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
72 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
73
74 gzip -9nf AUTHORS ChangeLog NEWS README TODO
75
76 %find_lang gdm
77
78 %pre
79 /usr/sbin/groupadd -g 55 -r -f xdm
80
81 if [ -z "`id -u xdm 2>/dev/null`" ]; then
82         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
83 fi
84
85 %post
86 /sbin/chkconfig --add gdm
87 if [ -f /var/lock/subsys/gdm ]; then
88         /etc/rc.d/init.d/gdm restart >&2
89 else
90         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
91 fi
92
93 %preun
94 if [ -f /var/lock/subsys/gdm ]; then
95                  /etc/rc.d/init.d/gdm stop >&2
96 fi
97 /sbin/chkconfig --del gdm
98
99 %postun
100 if [ "$1" = "0" ]; then
101
102         if [ -n "`id -u xdm 2>/dev/null`" ]; then
103                 /usr/sbin/userdel xdm
104         fi
105         
106         /usr/sbin/groupdel xdm
107
108 fi
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files -f gdm.lang
114 %defattr(644,root,root,755)
115 %doc {AUTHORS,ChangeLog,NEWS,README,TODO}.gz
116 %attr(775,root,xdm) %{_bindir}/gdm
117 %attr(775,root,xdm) %{_bindir}/gdmlogin
118 %attr(775,root,xdm) %{_bindir}/gdmchooser
119 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/Init
120 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/PreSession
121 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/Sessions
122 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/PostSession
123 %attr(775,root,xdm) %config %{_sysconfdir}/gdm/gnomerc
124 %attr(664,root,xdm) %config %{_sysconfdir}/gdm/gdm.conf
125 %attr(664,root,xdm) %config %{_sysconfdir}/gdm/locale.alias
126 %attr(775,root,xdm) %dir %{_sysconfdir}/gdm
127 %attr(640,root,root) %config %verify(not size mtime md5) /etc/pam.d/gdm
128 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
129 %attr(750,xdm,xdm) /var/lib/gdm
130 %attr(754,root,root) /etc/rc.d/init.d/gdm
131 %{_pixmapsdir}/*
This page took 0.068749 seconds and 3 git commands to generate.