]> git.pld-linux.org Git - packages/gdm2.20.git/blob - gdm.spec
- BR: libglade-gnome-devel; new %%doc; more specific Requires
[packages/gdm2.20.git] / gdm.spec
1 Summary:        GNOME Display Manager
2 Summary(es):    Administrador de Entrada del GNOME
3 Summary(pl):    gdm
4 Summary(pt_BR): Gerenciador de Entrada do GNOME
5 Name:           gdm
6 Version:        2.2.5.4
7 Release:        7
8 Epoch:          1
9 License:        LGPL/GPL
10 Group:          X11/Applications
11 Source0:        ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{version}.tar.bz2
12 Source1:        %{name}.pamd
13 Source2:        %{name}.init
14 Source3:        %{name}.conf
15 Source4:        %{name}-pld-logo.png
16 Patch0:         %{name}-xdmcp.patch
17 Patch1:         %{name}-am_fixes.patch
18 Patch2:         %{name}-permissions.patch
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  esound-devel
22 BuildRequires:  gdk-pixbuf-devel
23 BuildRequires:  gettext-devel
24 BuildRequires:  gnome-libs-devel
25 BuildRequires:  gtk+-devel
26 BuildRequires:  libglade-gnome-devel
27 BuildRequires:  libtool
28 BuildRequires:  libxml-devel
29 BuildRequires:  perl-modules
30 BuildRequires:  scrollkeeper
31 BuildRequires:  intltool >= 0.14
32 Requires:       gnome-libs >= 1.0.0
33 Requires:       which
34 Requires:       /usr/X11R6/bin/sessreg
35 Requires(pre):  /bin/id
36 Requires(pre):  /usr/sbin/groupadd
37 Requires(pre):  /usr/sbin/useradd
38 Requires(postun):       /usr/sbin/userdel
39 Requires(postun):       /usr/sbin/groupdel
40 Requires(post,postun):  scrollkeeper
41 Requires(post,preun):   /sbin/chkconfig
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43 Obsoletes:      xdm kdm wdm
44
45 %define         _prefix         /usr/X11R6
46 %define         _bindir         %{_prefix}/bin
47 %define         _datadir        %{_prefix}/share
48 %define         _sbindir        %{_prefix}/sbin
49 %define         _mandir         %{_prefix}/man
50 %define         _localstatedir  /var/lib
51 %define         _sysconfdir     /etc/X11
52 %define         _omf_dest_dir   %(scrollkeeper-config --omfdir)
53
54 %description
55 Gdm (the GNOME Display Manager) is a highly configurable
56 reimplementation of xdm, the X Display Manager. Gdm allows you to log
57 into your system with the X Window System running and supports running
58 several different X sessions on your local machine at the same time.
59
60 %description -l es
61 Administrador de Entrada del GNOME.
62
63 %description -l pl
64 Gdm jest wysokokonfigurowaln± reimplementacj± xdma. Gdm pozwala
65 logowaæ siê do systemu z poziomu X11 i wspiera jednoczesn± pracê kilku
66 ró¿nych Xsesji na lokalnej maszynie.
67
68 %description -l pt_BR
69 Gerenciador de Entrada do GNOME.
70
71 %package Xnest
72 Summary:        Xnest (ie embedded X) server for GDM
73 Summary(pl):    Serwer Xnest dla GDM
74 Group:          X11/Applications
75 Requires:       %{name} = %{version}
76 Requires:       XFree86-Xnest
77
78 %description Xnest
79 This package add support for Xnest server in gdm.
80
81 %description Xnest -l pl
82 Ten pakiet dodaje do gdm wsparcie dla Xnest.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 rm -f missing
92 %{__libtoolize}
93 %{__gettextize}
94 aclocal -I %{_aclocaldir}/gnome
95 %{__autoconf}
96 %{__automake}
97 %configure \
98         --with-xinerama=yes \
99         --with-xdmcp=yes \
100         --with-tcp-wrappers=yes \
101         --disable-console-helper
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,pam.d,security}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         Settingsdir=%{_applnkdir}/Settings/GNOME \
112         Systemdir=%{_applnkdir}/System \
113         omf_dest_dir=%{_omf_dest_dir}/%{name}
114
115 install %{SOURCE1} $RPM_BUILD_ROOT/etc/pam.d/gdm
116 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/gdm
117 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/gdm.conf
118 install %{SOURCE4} $RPM_BUILD_ROOT/usr/X11R6/share/pixmaps
119 touch $RPM_BUILD_ROOT/etc/security/blacklist.gdm
120
121 mv $RPM_BUILD_ROOT%{_applnkdir}/System/gdmconfig.desktop \
122         $RPM_BUILD_ROOT%{_applnkdir}/Settings/GNOME/
123
124 %find_lang %{name} --all-name --with-gnome
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %pre
130 /usr/sbin/groupadd -g 55 -r -f xdm
131
132 if [ -z "`id -u xdm 2>/dev/null`" ]; then
133         /usr/sbin/useradd -u 55 -r -d /dev/null -s /bin/false -c 'X Display Manager' -g xdm xdm 1>&2
134 fi
135
136 %post
137 /sbin/chkconfig --add gdm
138 if [ -f /var/lock/subsys/gdm ]; then
139         echo "Run \"/etc/rc.d/init.d/gdm restart\" to restart gdm." >&2
140 else
141         echo "Run \"/etc/rc.d/init.d/gdm start\" to start gdm." >&2
142 fi
143 /usr/bin/scrollkeeper-update
144
145 %preun
146 if [ "$1" = "0" ]; then
147         if [ -f /var/lock/subsys/gdm ]; then
148                 /etc/rc.d/init.d/gdm stop >&2
149         fi
150         /sbin/chkconfig --del gdm
151 fi
152
153 %postun
154 if [ "$1" = "0" ]; then
155         if [ -n "`id -u xdm 2>/dev/null`" ]; then
156                 /usr/sbin/userdel xdm
157         fi
158         /usr/sbin/groupdel xdm
159 fi
160 /usr/bin/scrollkeeper-update
161
162 %files -f %{name}.lang
163 %defattr(644,root,root,755)
164 %doc AUTHORS ChangeLog NEWS README TODO
165 %attr(755,root,root) %{_bindir}/gdm
166 %attr(755,root,root) %{_bindir}/gdmchooser
167 %attr(755,root,root) %{_bindir}/gdmconfig
168 %attr(755,root,root) %{_bindir}/gdmflexiserver
169 %attr(755,root,root) %{_bindir}/gdmlogin
170 %attr(755,root,root) %{_bindir}/gdmmktemp
171 %attr(755,root,root) %{_bindir}/gdmphotosetup
172 %attr(755,root,root) %{_sbindir}/*
173 %attr(755,root,root) %config %{_sysconfdir}/gdm/Init
174 %attr(755,root,root) %config %{_sysconfdir}/gdm/PreSession
175 %attr(755,root,root) %config %{_sysconfdir}/gdm/Sessions
176 %attr(755,root,root) %config %{_sysconfdir}/gdm/PostSession
177 %attr(755,root,root) %config %{_sysconfdir}/gdm/gnomerc
178 %attr(755,root,root) %config %{_sysconfdir}/gdm/XKeepsCrashing
179 %config %{_sysconfdir}/gdm/factory-gdm.conf
180 %config %{_sysconfdir}/gdm/gdm.conf
181 %config %{_sysconfdir}/gdm/locale.alias
182 %attr(755,root,root) %dir %{_sysconfdir}/gdm
183 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/pam.d/gdm
184 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/security/blacklist.gdm
185 %attr(770,root,xdm) /var/lib/gdm
186 %attr(754,root,root) /etc/rc.d/init.d/gdm
187 %{_pixmapsdir}/*
188 # these lines to devel subpackage?
189 %{_applnkdir}/Settings/GNOME/*
190 %{_applnkdir}/System/gdmflexiserver.desktop
191 %{_datadir}/gdm
192 %{_omf_dest_dir}/%{name}
193
194 %files Xnest
195 %defattr(644,root,root,755)
196 %attr(755,root,root) %{_bindir}/gdmXnestchooser
197 %{_applnkdir}/System/gdmflexiserver-xnest.desktop
This page took 0.062038 seconds and 3 git commands to generate.