]> git.pld-linux.org Git - packages/gdbm.git/blob - gdbm.spec
e410771019cd85a9734e9098ffb40b9c4ed911e8
[packages/gdbm.git] / gdbm.spec
1 Summary:        GNU database library for C
2 Summary(de):    GNU-Datenbank-Library für C
3 Summary(fr):    La librairie GNU de bases de données pout le langage C
4 Summary(pl):    Biblioteka GNU bazy danych dla jêzyka C
5 Name:           gdbm
6 Version:        1.8.0
7 Release:        15
8 License:        GPL
9 Group:          Libraries
10 Source0:        ftp://prep.ai.mit.edu/pub/gnu/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-info.patch
12 Patch1:         %{name}-DESTDIR.patch
13 Patch2:         %{name}-jbj.patch
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  texinfo
18 Obsoletes:      libgdbm1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Gdbm is a GNU database indexing library, including routines which use
23 extensible hashing. Gdbm works in a similar way to standard UNIX dbm
24 routines. Gdbm is useful for developers who write C applications and
25 need access to a simple and efficient database or who are building C
26 applications which will use such a database.
27
28 %description -l de
29 Dies ist eine Datenbank-Index-Library für Programmierer, die
30 C-Anwendungen schreiben und eine einfache und leistungsfähige
31 Datenbank benötigen oder diese in C-Anwendungen einsetzen möchten.
32
33 %description -l fr
34 Une librairie d'indexation de bases de données. Elle est utile pour
35 ceux qui désirent écrivent des applications en C et ont besion
36 d'accéder à une base de données simple et efficace ou de construire
37 une application en C qui l'utilise.
38
39 %description -l pl
40 W pakiecie znajduje siê biblioteka indeksowania bazy danych.
41 Biblioteka ta jest szczególnie u¿yteczna dla ludzi, którzy pisz±
42 oprogramowanie w C i potrzebuj± prostej i szybkiej bazy danych, lub
43 dla tych którzy pisz± programy w C z wykorzystaniem tej biblioteki.
44
45 %description -l tr
46 gdbm bir veri tabaný dizinleme kitaplýðýdýr. C uygulamalarý yazýp
47 basit ve etkin bir þekilde veri tabanýna ulaþmak isteyenler için
48 yararlý olacaktýr.
49
50 %package devel
51 Summary:        development libraries and header files for gdbm
52 Summary(de):    Entwicklungs-Libraries und Header-Dateien für gdbm
53 Summary(fr):    Bibliothèques de développement et en-têtes pour gdbm
54 Summary(pl):    Biblioteki i pliki nag³ówkowe dla gdbm
55 Summary(tr):    gdbm için baþlýk dosyalarý ve geliþtirme kitaplýklarý
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}
58 Obsoletes:      libgdbm1-devel
59
60 %description devel
61 These are the development libraries and header files for gdbm, the GNU
62 database system. These are required if you plan to do development
63 using the gdbm database.
64
65 %description devel -l de
66 Dies sind die Entwicklungs-Libraries und Header-Dateien für gdbm, das
67 GNU-Datenbanksystem. Sie sind darauf angewiesen, wenn Sie vorhaben,
68 die gdbm-Datenbank für Entwicklungsarbeiten zu benutzen.
69
70 %description devel -l fr
71 Ce sont les librairies de développement et les fichiers d'en-tête pour
72 gdbm, le système de base de données GNU. Ceci est nécessaire si vous
73 désirez développer en utilisant la base de données gdbm.
74
75 %description devel -l pl
76 W pakiecie tym znajduj± siê pliki nag³ówkowe i biblioteki dla systemu
77 bazy danych GNU.
78
79 %description devel -l tr
80 GNU veri tabaný sistemi gdbm ile program geliþtirmek için gereken
81 baþlýk dosyalarý ve kitaplýklar.
82
83 %package static
84 Summary:        Static gdbm library
85 Summary(pl):    Biblioteki statyczne gdbm
86 Group:          Development/Libraries
87 Requires:       %{name}-devel = %{version}
88
89 %description static
90 Static gdbm library.
91
92 %description static -l pl
93 Biblioteka statyczna gdbm.
94
95 %prep
96 %setup  -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 libtoolize --copy --force
103 aclocal
104 autoheader
105 autoconf
106 %configure
107
108 %{__make} CFLAGS="%{rpmcflags}"
109
110 makeinfo gdbm.texinfo
111
112 cat .libs/libgdbm.lai|sed -e 's/\/usr\/local\/lib/\/usr\/lib/'>libgdbm.lai.tmp
113 mv libgdbm.lai.tmp .libs/libgdbm.lai
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}} \
118            $RPM_BUILD_ROOT{%{_mandir}/man3,%{_infodir}}
119
120 %{__make} install install-compat \
121         prefix=%{_prefix} \
122         exec_prefix=%{_exec_prefix} \
123         binprefix=%{_exec_prefix} \
124         manprefix=%{_prefix} \
125         libdir=%{_libdir} \
126         includedir=%{_includedir} \
127         infodir=%{_infodir} \
128         man3dir=%{_mandir}/man3 \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post devel
138 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
139
140 %postun devel
141 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
142
143 %files
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_libdir}/lib*.so.*.*
146
147 %files devel
148 %defattr(644,root,root,755)
149 %attr(755,root,root) %{_libdir}/lib*.so
150 %attr(755,root,root) %{_libdir}/lib*.la
151 %{_mandir}/man3/*
152 %{_includedir}/*
153 %{_infodir}/gdbm*
154
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/lib*.a
This page took 0.031792 seconds and 3 git commands to generate.