]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
[4.18-3]
[packages/gdb.git] / gdb.spec
1 Summary:        Symbolic debugger for C and other languages
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny debugger dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        4.18
8 Release:        3
9 Copyright:      GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source:         ftp://sourceware.cygnus.com/pub/gdb/%{name}-%{version}.tar.bz2
13 Patch0:         gdb-info.patch
14 Prereq:         /sbin/install-info
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18 This is a full featured, command driven debugger. It allows you to
19 trace the exectuion of programs and examine their internal state
20 at any time. It works for C and C++ compiled with the GNU C compiler
21 gcc.
22
23 %description -l de
24 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
25 inneren Zustand überprüfen können. Er funktioniert für C und mit 
26 GNU C kompiliertes C++. 
27
28 %description -l fr
29 Débugger complet, piloté par commandes. Permet de tracer l'exécution
30 des programmes et d'examiner à tout moment leur état interne. Fonctionne
31 avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
32
33 %description -l pl
34 Gdb jest rozbudowanym debugerem, pozwalaj±cym ¶ledziæ wykonanie
35 programu i badaæ jego stan wewnêtrzny. gdb umo¿liwia debugowanie
36 programów napisanych w C i C++ i skompilowanych przy pomocy kompilatora
37 C GNU (egcs).
38
39 %description -l tr
40 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
41 ve herhangi bir anda programýn durumunu inceleme olanaðý verir.
42
43 %prep
44 %setup -q
45 #%patch0 -p1
46
47 %build
48 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
49 ./configure \
50         --prefix=%{_prefix} \
51         --target=%{_target_platform} \
52         --host=%{_host_alias}
53 make
54 make info
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_prefix}
59
60 make install install-info \
61         prefix=$RPM_BUILD_ROOT%{_prefix} \
62         infodir=$RPM_BUILD_ROOT%{_infodir} \
63         mandir=$RPM_BUILD_ROOT%{_mandir}
64
65 strip $RPM_BUILD_ROOT%{_bindir}/*
66
67 rm -f $RPM_BUILD_ROOT%{_infodir}{bfd*,history*,readline*,standard*,texinfo*}
68 gzip -fn9 $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
69
70 %post
71 /sbin/install-info %{_infodir}/gdb.info.gz /etc/info-dir
72 /sbin/install-info %{_infodir}/stabs.info.gz /etc/info-dir
73 /sbin/install-info %{_infodir}/gdbint.info.gz /etc/info-dir
74
75 %preun
76 if [ "$1" = 0 ]; then
77         /sbin/install-info --delete %{_infodir}/gdb.info.gz    /etc/info-dir
78         /sbin/install-info --delete %{_infodir}/stabs.info.gz  /etc/info-dir
79         /sbin/install-info --delete %{_infodir}/gdbint.info.gz /etc/info-dir
80 fi
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %files
86 %defattr(644,root,root,755)
87 %attr(755,root,root) %{_bindir}/*
88 %{_mandir}/man1/*
89 %{_infodir}/*info*
90
91 %changelog
92 * Sun May 16 1999 Artur Frysiak <wiget@pld.org.pl>
93   [4.18-3]
94 - configure with --host=%{_host_alias} instead --host=%{_host} to prevent build
95   crosscompiler prefix (eg i586-pc-linux-gdb)
96 - using more rpm macros
97
98 * Fri May 14 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
99   [4.18-2]
100 - now package is FHS 2.0 compliant.
101
102 * Tue Apr 13 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
103   [4.18-1]
104 - standarized {un}registering info pages (added gdb-info.patch).
105 - removed man group from man pages.
106
107 * Mon Apr 12 1999 Marcin Dalecki <dalecki@cs.net.pl>
108   [4.18]
109 - updated to this fresh new release.
110
111 * Sat Oct 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
112   [4.17.0.4-3]
113 - added gdb-readline_ncurses.patch for compiling gdb agains shared
114   libredline and libncurses.
115
116 * Sun Sep 27 1998 Marcin Korzonek <mkorz@shadow.eu.org>
117 - added pl translation.
118
119 * Thu May 07 1998 Prospector System <bugs@redhat.com>
120 - translations modified for de, fr, tr
121
122 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
123 - upgraded to 4.17
124
125 * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
126 - updated to use a buildroot
127 - uses install-info
128
129 * Tue Aug 19 1997 Erik Troan <ewt@redhat.com>
130 - turned off mmalloc() support, which seems to annoy glibc (resulting in
131   a quick core dump inside of getcwd())
132
133 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
134 - built against glibc
This page took 0.047134 seconds and 4 git commands to generate.