]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- BuildRequires: libtool
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        5.0
8 Release:        7
9 License:        GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Group(de):      Entwicklung/Debugger
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.bz2
14 Patch0:         %{name}-gettext.patch
15 Patch1:         %{name}-ncurses.patch
16 Patch2:         %{name}-readline.patch
17 Patch3:         %{name}-info.patch
18 Patch4:         %{name}-procfs.patch
19 BuildRequires:  ncurses-devel >= 5.2
20 BuildRequires:  readline-devel >= 4.2
21 BuildRequires:  XFree86-devel
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  libtool
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Gdb is a full featured, command driven debugger. Gdb allows you to
29 trace the execution of programs and examine their internal state at
30 any time. Gdb works for C and C++ compiled with the GNU C compiler
31 gcc.
32
33 %description -l de
34 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
35 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
36 kompiliertes C++.
37
38 %description -l fr
39 Débugger complet, piloté par commandes. Permet de tracer l'exécution
40 des programmes et d'examiner à tout moment leur état interne.
41 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
42 de GNU, gcc.
43
44 %description -l pl
45 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
46 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
47 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
48 przy pomocy kompilatora GNU (gcc).
49
50 %description -l tr
51 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
52 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
53 verir.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59 %patch2 -p1
60 %patch3 -p1
61 %patch4 -p1
62
63 %build
64 (cd gdb; libtoolize --copy --force; aclocal; autoconf)
65 (cd gdb/doc; autoconf)
66 (cd gdb/testsuite; autoconf)
67 (cd gdb/testsuite/gdb.asm; autoconf)
68 (cd gdb/testsuite/gdb.base; autoconf)
69 (cd gdb/testsuite/gdb.c++; autoconf)
70 (cd gdb/testsuite/gdb.disasm; autoconf)
71 (cd gdb/testsuite/gdb.chill; autoconf)
72 (cd gdb/testsuite/gdb.mi; autoconf)
73 (cd gdb/testsuite/gdb.threads; autoconf)
74 (cd gdb/testsuite/gdb.trace; autoconf)
75 (cd gdb/testsuite/gdb.stabs; autoconf)
76 (cd gdb/gdbserver; autoconf)
77 # !! Don't enable shared here !! 
78 # This will cause serious problems --misiek
79 %configure2_13 \
80         --disable-shared \
81         --enable-nls \
82         --without-included-gettext \
83         --enable-multi-ice \
84         --enable-gdbmi \
85         --enable-netrom \
86         --with-cpu=%{_target_cpu} \
87         --with-x \
88 %ifnarch alpha
89         --with-mmalloc \
90 %endif
91         --with-mmap
92 #       --enable-tui
93
94 # rebuild main Makefile again (due to some bug, Makefile is deleted)
95 %configure2_13 \
96         --norecursion
97                         
98 %{__make}
99 %{__make} info
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_infodir}
104
105 %{__make} install install-info \
106         prefix=$RPM_BUILD_ROOT%{_prefix} \
107         bindir=$RPM_BUILD_ROOT%{_bindir} \
108         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
109         infodir=$RPM_BUILD_ROOT%{_infodir} \
110         includedir=$RPM_BUILD_ROOT%{_includedir} \
111         libdir=$RPM_BUILD_ROOT%{_libdir} \
112         mandir=$RPM_BUILD_ROOT%{_mandir}
113
114 gzip -9nf $RPM_BUILD_ROOT{%{_infodir}/*info*,%{_mandir}/man?/*}
115
116 %post
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %postun
120 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/*
128
129 %{_mandir}/man1/*
130 %{_infodir}/gdb*.info*
131 %{_infodir}/stabs*.info*
This page took 0.041843 seconds and 4 git commands to generate.