]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- added Group(pl)
[packages/gdb.git] / gdb.spec
1 Summary:        Symbolic debugger for C and other languages
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(fr):    Débugger symbolique pour C et d'autres langages
4 Summary(pl):    Symboliczny debugger dla C i innych jêzyków
5 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
6 Name:           gdb
7 Version:        4.18
8 Release:        1
9 Copyright:      GPL
10 Group:          Development/Debuggers
11 Group(pl):      Programowanie/Odpluskwiacze
12 Source:         ftp://sourceware.cygnus.com/pub/gdb/%{name}-4.18.tar.bz2
13 Patch0:         gdb-info.patch
14 Prereq:         /sbin/install-info
15 Buildroot:      /tmp/%{name}-%{version}-root
16
17 %description
18 This is a full featured, command driven debugger. It allows you to
19 trace the exectuion of programs and examine their internal state
20 at any time. It works for C and C++ compiled with the GNU C compiler
21 gcc.
22
23 %description -l de
24 dem Sie die Ausführung von Programmen verfolgen und jederzeit den 
25 inneren Zustand überprüfen können. Er funktioniert für C und mit 
26 GNU C kompiliertes C++. 
27
28 %description -l fr
29 Débugger complet, piloté par commandes. Permet de tracer l'exécution
30 des programmes et d'examiner à tout moment leur état interne. Fonctionne
31 avec les binaires C et C++ compilés avec le compilateur C de GNU, gcc.
32
33 %description -l pl
34 Gdb jest rozbudowanym debugerem, pozwalaj±cym ¶ledziæ wykonanie
35 programu i badaæ jego stan wewnêtrzny. gdb umo¿liwia debugowanie
36 programów napisanych w C i C++ i skompilowanych przy pomocy kompilatora
37 C GNU (egcs).
38
39 %description -l tr
40 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme (trace)
41 ve herhangi bir anda programýn durumunu inceleme olanaðý verir.
42
43 %prep
44 %setup -q
45 #%patch0 -p1
46
47 %build
48 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
49 ./configure %{_target} \
50         --prefix=/usr 
51 make
52 make info
53 # MAKEINFO="makeinfo --force"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT/usr
58
59 make install install-info prefix=$RPM_BUILD_ROOT/usr 
60
61 strip $RPM_BUILD_ROOT/usr/bin/*
62
63 rm -f $RPM_BUILD_ROOT/usr/info/{bfd*,history*,readline*,standard*,texinfo*}
64 gzip -fn9 $RPM_BUILD_ROOT/usr/info/*info*
65
66 %post
67 /sbin/install-info /usr/info/gdb.info.gz /etc/info-dir
68 /sbin/install-info /usr/info/stabs.info.gz /etc/info-dir
69 /sbin/install-info /usr/info/gdbint.info.gz /etc/info-dir
70
71 %preun
72 if [ "$1" = 0 ]; then
73         /sbin/install-info --delete /usr/info/gdb.info.gz /usr/info-dir
74         /sbin/install-info --delete /usr/info/stabs.info.gz /etc/info-dir
75         /sbin/install-info --delete /usr/info/gdbint.info.gz /etc/info-dir
76 fi
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %attr(755,root,root) /usr/bin/*
84 /usr/man/man1/*
85 /usr/info/*info*
86
87 %changelog
88 * Tue Apr 13 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
89   [4.18-1]
90 - standarized {un}registering info pages (added gdb-info.patch).
91 - removed man group from man pages.
92
93 * Mon Apr 12 1999 Marcin Dalecki <dalecki@cs.net.pl>
94   [4.18]
95 - updated to this fresh new release.
96
97 * Sat Oct 17 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
98   [4.17.0.4-3]
99 - added gdb-readline_ncurses.patch for compiling gdb agains shared
100   libredline and libncurses.
101
102 * Sun Sep 27 1998 Marcin Korzonek <mkorz@shadow.eu.org>
103 - added pl translation.
104
105 * Thu May 07 1998 Prospector System <bugs@redhat.com>
106 - translations modified for de, fr, tr
107
108 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
109 - upgraded to 4.17
110
111 * Wed Oct 08 1997 Erik Troan <ewt@redhat.com>
112 - updated to use a buildroot
113 - uses install-info
114
115 * Tue Aug 19 1997 Erik Troan <ewt@redhat.com>
116 - turned off mmalloc() support, which seems to annoy glibc (resulting in
117   a quick core dump inside of getcwd())
118
119 * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
120 - built against glibc
This page took 0.031779 seconds and 4 git commands to generate.