]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
- up to 6.7
[packages/gdb.git] / gdb.spec
1 #
2 # NOTE: Do not remove -lib package, it is required by FPC
3 #
4 Summary:        A GNU source-level debugger for C, C++ and Fortran
5 Summary(de.UTF-8):      Symbolischer Debugger für C und andere Sprachen
6 Summary(es.UTF-8):      Depurador de programas C y otras lenguajes
7 Summary(fr.UTF-8):      Débugger symbolique pour C et d'autres langages
8 Summary(pl.UTF-8):      Symboliczny odpluskwiacz dla C i innych języków
9 Summary(pt_BR.UTF-8):   Depurador de programas C e outras linguagens
10 Summary(ru.UTF-8):      Символический отладчик для C и других языков
11 Summary(tr.UTF-8):      C ve diğer diller için sembolik hata ayıklayıcı
12 Summary(uk.UTF-8):      Символьний відладчик для С та інших мов
13 Summary(zh_CN.UTF-8):   [开发]C和其他语言的调试器
14 Summary(zh_TW.UTF-8):   [.-A開發]C和.$)B其.-A他語.$)B言的調試器
15 Name:           gdb
16 Version:        6.7
17 Release:        1
18 License:        GPL
19 Group:          Development/Debuggers
20 Source0:        ftp://ftp.gnu.org/gnu/gdb/%{name}-%{version}.tar.bz2
21 # Source0-md5:  d6e7c0ad7654bc91a3a457fabb6ad6c6
22 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
23 # Source1-md5:  2e8a48939ae282c12bbacdd54e398247
24 Patch0:         %{name}-readline.patch
25 Patch1:         %{name}-info.patch
26 Patch2:         %{name}-passflags.patch
27 Patch4:         %{name}-gdbinit-stat.patch
28 Patch5:         %{name}-pretty-print-by-default.patch
29 Patch6:         %{name}-absolute-gnu_debuglink-path.patch
30 BuildRequires:  autoconf >= 2.53
31 BuildRequires:  automake
32 BuildRequires:  bison
33 BuildRequires:  flex
34 BuildRequires:  libtool
35 BuildRequires:  ncurses-devel >= 5.2
36 BuildRequires:  readline-devel >= 4.3
37 BuildRequires:  texinfo
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Gdb is a full featured, command driven debugger. Gdb allows you to
42 trace the execution of programs and examine their internal state at
43 any time. Gdb works for C and C++ compiled with the GNU C compiler
44 gcc.
45
46 %description -l de.UTF-8
47 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
48 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
49 kompiliertes C++.
50
51 %description -l es.UTF-8
52 Este es un debugger orientado a comandos repleto de características.
53 Te permite rastrear la ejecución de programas y examinar su estado
54 interno a cualquier momento. Funciona para C y C++ compilado con el
55 compilador GNU C.
56
57 %description -l fr.UTF-8
58 Débugger complet, piloté par commandes. Permet de tracer l'exécution
59 des programmes et d'examiner à tout moment leur état interne.
60 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
61 de GNU, gcc.
62
63 %description -l pl.UTF-8
64 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalającym
65 śledzić wykonywanie programu i badać jego stan wewnętrzny. Gdb
66 umożliwia odpluskwianie programów napisanych w C/C++ i skompilowanych
67 przy pomocy kompilatora GNU (gcc).
68
69 %description -l pt_BR.UTF-8
70 Este é um debugger orientado a comandos repleto de características.
71 Ele permite à você rastrear a execução de programas e examinar o seu
72 estado interno a qualquer momento. Ele funciona para para C e C++
73 compilado com o compilador GNU C.
74
75 %description -l ru.UTF-8
76 Это полноценный отладчик, управляемый командами. Он позволяет
77 трассировать исполнение программ и изучать их внутреннее состояние в
78 любой момент времени. Работает с программами на C и C++,
79 скомпилированными GNU компилятором C (gcc, egcs, pgcc).
80
81 %description -l tr.UTF-8
82 Bir komut arayüzü üzerinden programcıya programını adım adım izleme
83 (trace) ve herhangi bir anda programın durumunu inceleme olanağı
84 verir.
85
86 %description -l uk.UTF-8
87 Це повноцінний відладчик, що керується командами. Він дозволяє
88 трасувати виконання програм та вивчати їх внутрішній стан в довільний
89 момент часу. Працює з програмами на C та C++, зкомпільованими
90 компіляторами GNU C (gcc, egcs, pgcc).
91
92 %package lib
93 Summary:        GDB in the form of a static library
94 Summary(pl.UTF-8):      GDB w postaci biblioteki statycznej
95 Group:          Development/Debuggers
96 #Requires:      binutils-static >= 2.17.50
97
98 %description lib
99 GDB in the form of a static library.
100
101 %description lib -l pl.UTF-8
102 GDB w postaci biblioteki statycznej.
103
104 %prep
105 %setup -q
106 %patch0 -p1
107 %patch1 -p1
108 %patch2 -p1
109 %patch4 -p0
110 %patch5 -p1
111 %patch6 -p1
112
113 %build
114 for dir in `find gdb/ -name 'configure.in'`; do
115         dir=$(dirname "$dir")
116         olddir=$(pwd)
117         cd $dir
118         rm -f aclocal.m4
119         %{__aclocal}
120         %{__autoconf}
121         cd $olddir
122 done
123 cp -f /usr/share/automake/config.* .
124 # !! Don't enable shared here !!
125 # This will cause serious problems.
126 %configure \
127         --disable-gdbtk \
128         --disable-shared \
129         --enable-gdbcli \
130         --enable-gdbmi \
131         --enable-multi-ice \
132         --enable-netrom \
133         --enable-nls \
134         --enable-tui \
135         --with-cpu=%{_target_cpu} \
136         --without-included-gettext \
137         --without-included-regex \
138         --without-x \
139 %ifnarch alpha
140         --with-mmalloc
141 %endif
142
143 %{__make}
144 %{__make} info
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148 install -d $RPM_BUILD_ROOT%{_infodir}
149
150 %{__make} install install-info \
151         prefix=$RPM_BUILD_ROOT%{_prefix} \
152         bindir=$RPM_BUILD_ROOT%{_bindir} \
153         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
154         infodir=$RPM_BUILD_ROOT%{_infodir} \
155         includedir=$RPM_BUILD_ROOT%{_includedir} \
156         libdir=$RPM_BUILD_ROOT%{_libdir} \
157         mandir=$RPM_BUILD_ROOT%{_mandir}
158
159 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
160
161 install gdb/libgdb.a $RPM_BUILD_ROOT%{_libdir}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %post
167 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
168
169 %postun
170 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
171
172 %files
173 %defattr(644,root,root,755)
174 %doc gdb/{ChangeLog,NEWS,PROBLEMS,README}
175 %attr(755,root,root) %{_bindir}/*
176 %{_mandir}/man1/*
177 %lang(es) %{_mandir}/es/man1/*
178 %lang(fr) %{_mandir}/fr/man1/*
179 %lang(hu) %{_mandir}/hu/man1/*
180 %lang(ja) %{_mandir}/ja/man1/*
181 %lang(pl) %{_mandir}/pl/man1/*
182 %{_infodir}/gdb*.info*
183 %{_infodir}/stabs*.info*
184
185 %files lib
186 %defattr(644,root,root,755)
187 %{_libdir}/libgdb.a
This page took 0.036254 seconds and 3 git commands to generate.