]> git.pld-linux.org Git - packages/gdb.git/blob - gdb.spec
22a325449fb9ffb1f59889ffdb906303994eb8b8
[packages/gdb.git] / gdb.spec
1 Summary:        A GNU source-level debugger for C, C++ and Fortran
2 Summary(de):    Symbolischer Debugger für C und andere Sprachen 
3 Summary(es):    Depurador de programas C y otras lenguajes
4 Summary(fr):    Débugger symbolique pour C et d'autres langages
5 Summary(pl):    Symboliczny odpluskwiacz dla C i innych jêzyków
6 Summary(pt_BR): Depurador de programas C e outras linguagens
7 Summary(tr):    C ve diðer diller için sembolik hata ayýklayýcý
8 Name:           gdb
9 Version:        5.1.1
10 Release:        1
11 License:        GPL
12 Group:          Development/Debuggers
13 Group(de):      Entwicklung/Debugger
14 Group(pl):      Programowanie/Odpluskwiacze
15 Source0:        ftp://ftp.gnu.org/pub/gnu/gdb/%{name}-%{version}.tar.gz
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 Patch0:         %{name}-gettext.patch
18 Patch1:         %{name}-ncurses.patch
19 Patch2:         %{name}-readline.patch
20 Patch3:         %{name}-info.patch
21 Patch4:         %{name}-procfs.patch
22 BuildRequires:  ncurses-devel >= 5.2
23 BuildRequires:  readline-devel >= 4.2
24 BuildRequires:  XFree86-devel
25 BuildRequires:  autoconf
26 BuildRequires:  automake
27 BuildRequires:  libtool
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Gdb is a full featured, command driven debugger. Gdb allows you to
32 trace the execution of programs and examine their internal state at
33 any time. Gdb works for C and C++ compiled with the GNU C compiler
34 gcc.
35
36 %description -l de
37 dem Sie die Ausführung von Programmen verfolgen und jederzeit den
38 inneren Zustand überprüfen können. Er funktioniert für C und mit GNU C
39 kompiliertes C++.
40
41 %description -l es
42 Este es un debugger orientado a comandos repleto de características.
43 Te permite rastrear la ejecución de programas y examinar su estado
44 interno a cualquier momento. Funciona para C y C++ compilado con el
45 compilador GNU C.
46
47 %description -l fr
48 Débugger complet, piloté par commandes. Permet de tracer l'exécution
49 des programmes et d'examiner à tout moment leur état interne.
50 Fonctionne avec les binaires C et C++ compilés avec le compilateur C
51 de GNU, gcc.
52
53 %description -l pl
54 Gdb jest rozbudowanym odpluskwiaczem (debuggerem), pozwalaj±cym
55 ¶ledziæ wykonywanie programu i badaæ jego stan wewnêtrzny. Gdb
56 umo¿liwia odpluskwianie programów napisanych w C/C++ i skompilowanych
57 przy pomocy kompilatora GNU (gcc).
58
59 %description -l pt_BR
60 Este é um debugger orientado a comandos repleto de características.
61 Ele permite à você rastrear a execução de programas e examinar o seu
62 estado interno a qualquer momento. Ele funciona para para C e C++
63 compilado com o compilador GNU C.
64
65 %description -l tr
66 Bir komut arayüzü üzerinden programcýya programýný adým adým izleme
67 (trace) ve herhangi bir anda programýn durumunu inceleme olanaðý
68 verir.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77
78 %build
79 (cd gdb; autoconf)
80 #libtoolize --copy --force; aclocal; autoconf)
81 (cd gdb/doc; autoconf)
82 (cd gdb/testsuite; autoconf)
83 (cd gdb/testsuite/gdb.asm; autoconf)
84 (cd gdb/testsuite/gdb.base; autoconf)
85 (cd gdb/testsuite/gdb.c++; autoconf)
86 (cd gdb/testsuite/gdb.chill; autoconf)
87 (cd gdb/testsuite/gdb.disasm; autoconf)
88 (cd gdb/testsuite/gdb.fortran; autoconf)
89 (cd gdb/testsuite/gdb.java; autoconf)
90 (cd gdb/testsuite/gdb.mi; autoconf)
91 (cd gdb/testsuite/gdb.stabs; autoconf)
92 (cd gdb/testsuite/gdb.threads; autoconf)
93 (cd gdb/testsuite/gdb.trace; autoconf)
94 (cd gdb/gdbserver; autoconf)
95 # !! Don't enable shared here !! 
96 # This will cause serious problems --misiek
97 %configure2_13 \
98         --disable-shared \
99         --enable-nls \
100         --without-included-gettext \
101         --enable-multi-ice \
102         --enable-gdbmi \
103         --enable-gdcli \
104         --enable-netrom \
105         --with-cpu=%{_target_cpu} \
106         --with-x \
107         --enable-tui \
108 %ifnarch alpha
109         --with-mmalloc \
110 %endif
111         --with-mmap
112
113 # something is wrong after above - e.g. $exeext=="no" - fix it:
114 (cd gdb
115 %configure
116 )
117
118 %{__make}
119 %{__make} info
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_infodir}
124
125 %{__make} install install-info \
126         prefix=$RPM_BUILD_ROOT%{_prefix} \
127         bindir=$RPM_BUILD_ROOT%{_bindir} \
128         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
129         infodir=$RPM_BUILD_ROOT%{_infodir} \
130         includedir=$RPM_BUILD_ROOT%{_includedir} \
131         libdir=$RPM_BUILD_ROOT%{_libdir} \
132         mandir=$RPM_BUILD_ROOT%{_mandir}
133
134 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
141
142 %postun
143 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_bindir}/*
148
149 %{_mandir}/man1/*
150 %lang(es) %{_mandir}/es/man1/*
151 %lang(fr) %{_mandir}/fr/man1/*
152 %lang(hu) %{_mandir}/hu/man1/*
153 %lang(ja) %{_mandir}/ja/man1/*
154 %lang(pl) %{_mandir}/pl/man1/*
155 %{_infodir}/gdb*.info*
156 %{_infodir}/stabs*.info*
This page took 0.362961 seconds and 3 git commands to generate.