]> git.pld-linux.org Git - packages/gd.git/blob - gd.spec
- Release: 4
[packages/gd.git] / gd.spec
1 Summary:        Library for PNG, JPEG creation
2 Summary(pl):    Biblioteka do tworzenia grafiki w formacie PNG, JPEG
3 Name:           gd
4 Version:        1.8.3
5 Release:        4
6 License:        BSD-style
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Group(fr):      Librairies
10 Source0:        ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-ac_am.patch
12 URL:            http://www.boutell.com/gd/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  zlib-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  freetype-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define shlibver %(echo %{version} | cut -f-2 -d.)
22
23 %description
24 gd library creates PNG, JPEG and WBMP images, not GIF images. This is
25 a good thing. PNG is a more compact format, and full compression is
26 available. JPEG works well with photographic images, and is still more
27 compatible with the major Web browsers than even PNG is. WBMP is
28 intended for wireless devices (not regular web browsers). Existing
29 code will need modification to call or gdImageJpeg instead of
30 gdImageGif.
31
32 This library allows you to easily create and manipulate PNG, JPEG
33 image files from your C programs.
34
35 %description -l pl
36 Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
37 graficznymi w formacie PNG.
38
39 %package devel
40 Summary:        Development part of the GD library
41 Summary(pl):    Czê¶æ biblioteki GD przeznaczona dla developerów
42 Group:          Development/Libraries
43 Group(pl):      Programowanie/Biblioteki
44 Group(fr):      Development/Librairies
45 Requires:       libpng-devel
46 Requires:       zlib-devel
47 Requires:       %{name} = %{version}
48
49 %description devel
50 This package contains the files needed for development of programs
51 linked against GD.
52
53 %description -l pl devel
54 Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
55 z biblioteki GD.
56
57 %package static
58 Summary:        Static GD library
59 Summary(pl):    Statyczna biblioteka GD
60 Group:          Development/Libraries
61 Group(pl):      Programowanie/Biblioteki
62 Group(fr):      Development/Librairies
63 Requires:       %{name} = %{version}
64
65 %description devel
66 This package contains static GD library.
67
68 %description -l pl static
69 Pakiet ten zawiera statyczn± bibliotekê GD.
70
71 %prep
72 %setup -q 
73 %patch0 -p1 
74
75 %build
76 libtoolize --copy --force
77 automake -a -c
78 aclocal
79 autoconf
80 %configure
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
90
91 gzip -9nf readme.txt index.html 
92
93 %clean
94 rm -fr $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc readme.txt.gz
102 %attr(755,root,root) %{_bindir}/*
103 %attr(755,root,root) %{_libdir}/*.so.*.*
104
105 %files devel
106 %defattr(644,root,root,755)
107 %doc index.html.gz 
108 %attr(755,root,root) %{_libdir}/*.so
109 %attr(755,root,root) %{_libdir}/*.la
110 %{_includedir}/*
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/lib*.a
This page took 0.056976 seconds and 4 git commands to generate.