]> git.pld-linux.org Git - packages/gd.git/blob - gd.spec
- removed pld patch and added ac_am patch wit full autoconf/automake suilt
[packages/gd.git] / gd.spec
1 Summary:        Library for PNG, JPEG creation
2 Summary(pl):    Biblioteka do tworzenia grafiki w formacie PNG, JPEG
3 Name:           gd
4 Version:        1.8.3
5 Release:        3
6 License:        BSD-style
7 Group:          Libraries
8 Group(pl):      Biblioteki
9 Group(fr):      Librairies
10 Source0:        ftp://ftp.boutell.com/pub/boutell/gd/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-ac_am.patch
12 URL:            http://www.boutell.com/gd/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  zlib-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  freetype-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define shlibver %(echo %{version} | cut -f-2 -d.)
22
23 %description
24 gd library creates PNG, JPEG and WBMP images, not GIF images. This is
25 a good thing. PNG is a more compact format, and full compression is
26 available. JPEG works well with photographic images, and is still more
27 compatible with the major Web browsers than even PNG is. WBMP is
28 intended for wireless devices (not regular web browsers). Existing
29 code will need modification to call or gdImageJpeg instead of
30 gdImageGif.
31
32 This library allows you to easily create and manipulate PNG, JPEG
33 image files from your C programs.
34
35 %description -l pl
36 Biblioteka pozwalaj±ca na proste tworzenie i manipulowanie plikami
37 graficznymi w formacie PNG.
38
39 %package devel
40 Summary:        Development part of the GD library
41 Summary(pl):    Czê¶æ biblioteki GD przeznaczona dla developerów
42 Group:          Development/Libraries
43 Group(pl):      Programowanie/Biblioteki
44 Group(fr):      Development/Librairies
45 Requires:       %{name} = %{version}
46
47 %description devel
48 This package contains the files needed for development of programs
49 linked against GD.
50
51 %description -l pl devel
52 Pakiet ten zawiera pliki potrzebne do rozwoju programów korzystaj±cych
53 z biblioteki GD.
54
55 %package static
56 Summary:        Static GD library
57 Summary(pl):    Statyczna biblioteka GD
58 Group:          Development/Libraries
59 Group(pl):      Programowanie/Biblioteki
60 Group(fr):      Development/Librairies
61 Requires:       %{name} = %{version}
62
63 %description devel
64 This package contains static GD library.
65
66 %description -l pl static
67 Pakiet ten zawiera statyczn± bibliotekê GD.
68
69 %prep
70 %setup -q 
71 %patch0 -p1 
72
73 %build
74 libtoolize --copy --force
75 automake -a -c
76 aclocal
77 autoconf
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
88
89 gzip -9nf readme.txt index.html 
90
91 %clean
92 rm -fr $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc readme.txt.gz
100 %attr(755,root,root) %{_bindir}/*
101 %attr(755,root,root) %{_libdir}/*.so.*.*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %doc index.html.gz 
106 %attr(755,root,root) %{_libdir}/*.so
107 %{_includedir}/*
108
109 %files static
110 %defattr(644,root,root,755)
111 %{_libdir}/lib*.a
This page took 0.121102 seconds and 4 git commands to generate.