]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- GNU Common Lisp package
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.0
5 Release:        1
6 License:        GPL
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
9 Patch0:         %{name}-make.patch
10 Patch1:         %{name}-OPT.patch
11 URL:            http://www.gnu.org/projects/gcl
12 BuildRequires:  tk-devel
13 BuildRequires:  emacs-leim
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 The GNU Common Lisp system, based on KCL.
18
19 %description -l pl
20 System GNU Common Lis[, bazuj±cy na KCL.
21
22 %package tk
23 Summary:        Tcl/tk bindings for GNU Common Lisp
24 Summary(pl):    Documntation dla GNU Common Lisp w formacie HTML
25 Group:          Development/Languages
26 Requires:       %{name} = %{version}
27
28 %description tk
29 Tcl/tk bindings for GNU Common Lisp
30
31 %description tk -l pl
32 Intefejs Tcl/tk dla GNU Common Lisp
33
34 %package doc-html
35 Summary:        HTML documntation for GNU Common Lisp
36 Summary(pl):    Dokumentacja dla GNU Common Lisp w formacie HTML
37 Group:          Development/Languages
38 Requires:       %{name} = %{version}
39
40 %description doc-html
41 HTML documntation for GNU Common Lisp
42
43 %description doc-html -l pl
44 Dokumentacja dla GNU Common Lisp w formacie HTML
45
46 %prep
47 %setup  -q
48 %patch0 -p1
49 %patch1 -p1
50
51 %build
52 export GCC=%{_cc}
53 %configure2_13 \
54         --enable-notify=no
55 %{__make} OPTFLAGS="%{rpmcflags}"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk}
61 install -d $RPM_BUILD_ROOT{%{_infodir},%{_bindir}}
62 install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
63 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
64 install info/*info*.gz $RPM_BUILD_ROOT%{_infodir}
65 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
66 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
67 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
68         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
69
70 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
71
72 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
73 #!/bin/sh
74 exec %{_libdir}/gcl/unixport/saved_gcl \
75    -dir {_libdir}/gcl/unixport/ \
76    -libdir %{_libdir}/gcl/ \
77    -eval '(setq si::*allow-gzipped-file* t)' \
78      "$@"
79 EOF
80
81 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
82 #!/bin/sh
83 exec %{_libdir}/gcl/unixport/saved_gcl \
84    -dir {_libdir}/gcl/unixport/ \
85    -libdir %{_libdir}/gcl/ \
86    -eval '(setq si::*allow-gzipped-file* t)' \
87    -eval '(setq si::*tk-library* "/usr/lib/tk8.3")' \
88      "$@"
89 EOF
90
91 gzip -9nf readme faq ChangeLog
92
93 %post
94 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
95
96 %postun
97 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
98
99 %post tk
100 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
101
102 %postun tk
103 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc *.gz
111 %attr(755,root,root) %{_bindir}/gcl
112 %attr(755,root,root) %{_bindir}/gcl.exe
113 %{_libdir}/gcl/cmpnew
114 %{_libdir}/gcl/lsp
115 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
116 %{_infodir}/gcl-si.info*.gz
117
118 %files doc-html
119 %doc info/*.html
120
121 %files tk
122 %dir %{_infodir}
123 %attr(755,root,root) %{_bindir}/gcl-tk
124 %{_libdir}/gcl/gcl-tk
125 %{_infodir}/gcl-tk.info*.gz
This page took 0.13125 seconds and 4 git commands to generate.