]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- use new %doc.
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.3
5 Release:        1
6 License:        LGPL v2
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
9 Patch0:         %{name}-make.patch
10 Patch1:         %{name}-OPT.patch
11 Patch2:         %{name}-info.patch
12 Patch3:         %{name}-libgmp.patch
13 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gmp-devel
17 BuildRequires:  tk-devel
18 BuildRequires:  xemacs
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The GNU Common Lisp system, based on KCL.
23
24 %description -l pl
25 System GNU Common Lisp, bazuj±cy na KCL.
26
27 %package tk
28 Summary:        Tcl/tk bindings for GNU Common Lisp
29 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
30 Group:          Development/Languages
31 Requires:       %{name} = %{version}
32
33 %description tk
34 Tcl/tk bindings for GNU Common Lisp.
35
36 %description tk -l pl
37 Intefejs Tcl/tk dla GNU Common Lisp.
38
39 %prep
40 %setup  -q
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44 %patch3 -p1
45
46 %build
47 rm -f missing
48 aclocal
49 %{__autoconf}
50 cp -f /usr/share/automake/config.* .
51 GCC="%{__cc}"; export GCC
52 %configure \
53         --enable-notify=no
54
55 %{__make} OPTFLAGS="%{rpmcflags}" \
56         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
61         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
62         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
63
64 (cd info
65 rm -f *info*
66 makeinfo gcl-si.texi gcl-tk.texi
67 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
68 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
69
70 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
71 install info/*info* $RPM_BUILD_ROOT%{_infodir}
72 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
73 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
74 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
75         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
76
77 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
78
79 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
80 #!/bin/sh
81 exec %{_libdir}/gcl/unixport/saved_gcl \
82         -dir {_libdir}/gcl/unixport/ \
83         -libdir %{_libdir}/gcl/ \
84         -eval '(setq si::*allow-gzipped-file* t)' \
85         "$@"
86 EOF
87
88 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
89 #!/bin/sh
90 exec %{_libdir}/gcl/unixport/saved_gcl \
91         -dir {_libdir}/gcl/unixport/ \
92         -libdir %{_libdir}/gcl/ \
93         -eval '(setq si::*allow-gzipped-file* t)' \
94         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
95         "$@"
96 EOF
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post
102 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
103
104 %postun
105 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
106
107 %post tk
108 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
109
110 %postun tk
111 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
112
113 %files
114 %defattr(644,root,root,755)
115 %doc readme faq ChangeLog
116 %attr(755,root,root) %{_bindir}/gcl
117 %attr(755,root,root) %{_bindir}/gcl.exe
118 %{_libdir}/gcl/cmpnew
119 %{_libdir}/gcl/lsp
120 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
121 %{_infodir}/gcl-si.info*
122 %{_mandir}/man1/*
123
124 %files tk
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/gcl-tk
127 %dir %{_libdir}/gcl/gcl-tk
128 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
129 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
130 %{_libdir}/gcl/gcl-tk/*.o
131 %{_libdir}/gcl/gcl-tk/*.tcl
132 %{_infodir}/gcl-tk.info*
This page took 0.118635 seconds and 4 git commands to generate.