]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- added macro to autogenerate tk-deps
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.4
5 Release:        2
6 License:        LGPL v2
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
9 # Source0-md5:  cd2326647d1cd18ccec088370ebdf58d
10 Patch0:         %{name}-make.patch
11 Patch1:         %{name}-OPT.patch
12 Patch2:         %{name}-info.patch
13 Patch3:         %{name}-libgmp.patch
14 Patch4:         %{name}-bfd.patch
15 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gmp-devel
19 BuildRequires:  sed
20 %define         _tk-line        8.3
21 BuildRequires:  tk-devel >= %{_tk-line}.4-5
22 BuildRequires:  xemacs
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24 ExclusiveArch:  %{ix86} sparc
25
26 %description
27 The GNU Common Lisp system, based on KCL.
28
29 %description -l pl
30 System GNU Common Lisp, bazuj±cy na KCL.
31
32 %package tk
33 Summary:        Tcl/Tk bindings for GNU Common Lisp
34 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
35 Group:          Development/Languages
36 Requires:       %{name} = %{version}
37
38 %description tk
39 Tcl/Tk bindings for GNU Common Lisp.
40
41 %description tk -l pl
42 Intefejs Tcl/Tk dla GNU Common Lisp.
43
44 %prep
45 %setup  -q
46 %patch0 -p1
47 %patch1 -p1
48 %patch2 -p1
49 %patch3 -p1
50 #%patch4 -p1
51
52 %build
53 rm -f missing
54 %{__aclocal}
55 %{__autoconf}
56 cp -f /usr/share/automake/config.* .
57 GCC="%{__cc}"; export GCC
58 # note: full path to xemacs must be passed
59 EMACS=/usr/bin/xemacs; export EMACS
60 %configure \
61         --enable-notify=no
62
63 %{__make} OPTFLAGS="%{rpmcflags}" \
64         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
69         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
70         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
71
72 cd info
73 rm -f *info*
74 makeinfo gcl-si.texi gcl-tk.texi
75 install gcl*info* $RPM_BUILD_ROOT%{_infodir}
76 cd ..
77
78 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
79
80 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
81 install info/*info* $RPM_BUILD_ROOT%{_infodir}
82 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
83 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
84 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
85         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
86
87 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
88
89 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
90 #!/bin/sh
91 exec %{_libdir}/gcl/unixport/saved_gcl \
92         -dir {_libdir}/gcl/unixport/ \
93         -libdir %{_libdir}/gcl/ \
94         -eval '(setq si::*allow-gzipped-file* t)' \
95         "$@"
96 EOF
97
98 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
99 #!/bin/sh
100 exec %{_libdir}/gcl/unixport/saved_gcl \
101         -dir {_libdir}/gcl/unixport/ \
102         -libdir %{_libdir}/gcl/ \
103         -eval '(setq si::*allow-gzipped-file* t)' \
104         -eval '(setq si::*tk-library* "%{_libdir}/tk%{_tk-line}")' \
105         "$@"
106 EOF
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
113
114 %postun
115 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
116
117 %post tk
118 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
119
120 %postun tk
121 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
122
123 %files
124 %defattr(644,root,root,755)
125 %doc readme faq ChangeLog
126 %attr(755,root,root) %{_bindir}/gcl
127 %attr(755,root,root) %{_bindir}/gcl.exe
128 %{_libdir}/gcl/cmpnew
129 %{_libdir}/gcl/lsp
130 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
131 %{_infodir}/gcl-si.info*
132 %{_mandir}/man1/*
133
134 %files tk
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/gcl-tk
137 %dir %{_libdir}/gcl/gcl-tk
138 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
139 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
140 %{_libdir}/gcl/gcl-tk/*.o
141 %{_libdir}/gcl/gcl-tk/*.tcl
142 %{_infodir}/gcl-tk.info*
This page took 0.146864 seconds and 4 git commands to generate.