]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
e7be00039de5da8bf954ed76214ca0759925fbee
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Summary(zh_CN): [¿ª·¢]CºÍÆäËûÓïÑԵĵ÷ÊÔÆ÷
4 Summary(zh_TW): [¶}µo]C©M¨ä¥L»y¨¥ªº½Õ¸Õ¾¹
5 Name:           gcl
6 Version:        2.4.3
7 Release:        1
8 License:        LGPL v2
9 Group:          Development/Languages
10 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
11 Patch0:         %{name}-make.patch
12 Patch1:         %{name}-OPT.patch
13 Patch2:         %{name}-info.patch
14 Patch3:         %{name}-libgmp.patch
15 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gmp-devel
19 BuildRequires:  tk-devel
20 BuildRequires:  xemacs
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22 ExclusiveArch:  %{ix86} sparc
23
24 %description
25 The GNU Common Lisp system, based on KCL.
26
27 %description -l pl
28 System GNU Common Lisp, bazuj±cy na KCL.
29
30 %package tk
31 Summary:        Tcl/tk bindings for GNU Common Lisp
32 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
33 Group:          Development/Languages
34 Requires:       %{name} = %{version}
35
36 %description tk
37 Tcl/tk bindings for GNU Common Lisp.
38
39 %description tk -l pl
40 Intefejs Tcl/tk dla GNU Common Lisp.
41
42 %prep
43 %setup  -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 %patch3 -p1
48
49 %build
50 rm -f missing
51 %{__aclocal}
52 %{__autoconf}
53 cp -f /usr/share/automake/config.* .
54 GCC="%{__cc}"; export GCC
55 # note: full path to xemacs must be passed
56 EMACS=/usr/bin/xemacs; export EMACS
57 %configure \
58         --enable-notify=no
59
60 %{__make} OPTFLAGS="%{rpmcflags}" \
61         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
66         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
67         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
68
69 (cd info
70 rm -f *info*
71 makeinfo gcl-si.texi gcl-tk.texi
72 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
73 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
74
75 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
76 install info/*info* $RPM_BUILD_ROOT%{_infodir}
77 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
78 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
79 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
80         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
81
82 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
83
84 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
85 #!/bin/sh
86 exec %{_libdir}/gcl/unixport/saved_gcl \
87         -dir {_libdir}/gcl/unixport/ \
88         -libdir %{_libdir}/gcl/ \
89         -eval '(setq si::*allow-gzipped-file* t)' \
90         "$@"
91 EOF
92
93 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
94 #!/bin/sh
95 exec %{_libdir}/gcl/unixport/saved_gcl \
96         -dir {_libdir}/gcl/unixport/ \
97         -libdir %{_libdir}/gcl/ \
98         -eval '(setq si::*allow-gzipped-file* t)' \
99         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
100         "$@"
101 EOF
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %postun
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %post tk
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %postun tk
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %files
119 %defattr(644,root,root,755)
120 %doc readme faq ChangeLog
121 %attr(755,root,root) %{_bindir}/gcl
122 %attr(755,root,root) %{_bindir}/gcl.exe
123 %{_libdir}/gcl/cmpnew
124 %{_libdir}/gcl/lsp
125 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
126 %{_infodir}/gcl-si.info*
127 %{_mandir}/man1/*
128
129 %files tk
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/gcl-tk
132 %dir %{_libdir}/gcl/gcl-tk
133 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
134 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
135 %{_libdir}/gcl/gcl-tk/*.o
136 %{_libdir}/gcl/gcl-tk/*.tcl
137 %{_infodir}/gcl-tk.info*
This page took 0.103133 seconds and 3 git commands to generate.