]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
ad5b36180af384247c746f07cdd0a163a68e7054
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.3
5 Release:        1
6 License:        LGPL v2
7 Group:          Development/Languages
8 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
9 Patch0:         %{name}-make.patch
10 Patch1:         %{name}-OPT.patch
11 Patch2:         %{name}-info.patch
12 Patch3:         %{name}-libgmp.patch
13 URL:            http://www.ma.utexas.edu/users/wfs/gcl.html
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gmp-devel
17 BuildRequires:  tk-devel
18 BuildRequires:  xemacs
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 ExclusiveArch:  %{ix86} sparc
21
22 %description
23 The GNU Common Lisp system, based on KCL.
24
25 %description -l pl
26 System GNU Common Lisp, bazuj±cy na KCL.
27
28 %package tk
29 Summary:        Tcl/tk bindings for GNU Common Lisp
30 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
31 Group:          Development/Languages
32 Requires:       %{name} = %{version}
33
34 %description tk
35 Tcl/tk bindings for GNU Common Lisp.
36
37 %description tk -l pl
38 Intefejs Tcl/tk dla GNU Common Lisp.
39
40 %prep
41 %setup  -q
42 %patch0 -p1
43 %patch1 -p1
44 %patch2 -p1
45 %patch3 -p1
46
47 %build
48 rm -f missing
49 aclocal
50 %{__autoconf}
51 cp -f /usr/share/automake/config.* .
52 GCC="%{__cc}"; export GCC
53 %configure \
54         --enable-notify=no
55
56 %{__make} OPTFLAGS="%{rpmcflags}" \
57         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
62         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
63         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
64
65 (cd info
66 rm -f *info*
67 makeinfo gcl-si.texi gcl-tk.texi
68 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
69 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
70
71 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
72 install info/*info* $RPM_BUILD_ROOT%{_infodir}
73 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
74 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
75 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
76         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
77
78 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
79
80 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
81 #!/bin/sh
82 exec %{_libdir}/gcl/unixport/saved_gcl \
83         -dir {_libdir}/gcl/unixport/ \
84         -libdir %{_libdir}/gcl/ \
85         -eval '(setq si::*allow-gzipped-file* t)' \
86         "$@"
87 EOF
88
89 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
90 #!/bin/sh
91 exec %{_libdir}/gcl/unixport/saved_gcl \
92         -dir {_libdir}/gcl/unixport/ \
93         -libdir %{_libdir}/gcl/ \
94         -eval '(setq si::*allow-gzipped-file* t)' \
95         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
96         "$@"
97 EOF
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post
103 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
104
105 %postun
106 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
107
108 %post tk
109 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
110
111 %postun tk
112 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
113
114 %files
115 %defattr(644,root,root,755)
116 %doc readme faq ChangeLog
117 %attr(755,root,root) %{_bindir}/gcl
118 %attr(755,root,root) %{_bindir}/gcl.exe
119 %{_libdir}/gcl/cmpnew
120 %{_libdir}/gcl/lsp
121 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
122 %{_infodir}/gcl-si.info*
123 %{_mandir}/man1/*
124
125 %files tk
126 %defattr(644,root,root,755)
127 %attr(755,root,root) %{_bindir}/gcl-tk
128 %dir %{_libdir}/gcl/gcl-tk
129 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
130 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
131 %{_libdir}/gcl/gcl-tk/*.o
132 %{_libdir}/gcl/gcl-tk/*.tcl
133 %{_infodir}/gcl-tk.info*
This page took 0.167742 seconds and 3 git commands to generate.