]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
8889ccb88ccb1a06852ad91497155a212be7a78b
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.0
5 Release:        3
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
11 Patch0:         %{name}-make.patch
12 Patch1:         %{name}-OPT.patch
13 Patch2:         %{name}-info.patch
14 Patch3:         %{name}-libgmp.patch
15 URL:            http://www.gnu.org/projects/gcl
16 BuildRequires:  tk-devel
17 BuildRequires:  xemacs
18 BuildRequires:  autoconf
19 BuildRequires:  gmp-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The GNU Common Lisp system, based on KCL.
24
25 %description -l pl
26 System GNU Common Lisp, bazuj±cy na KCL.
27
28 %package tk
29 Summary:        Tcl/tk bindings for GNU Common Lisp
30 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
31 Group:          Development/Languages
32 Group(de):      Entwicklung/Sprachen
33 Group(pl):      Programowanie/Jêzyki
34 Requires:       %{name} = %{version}
35
36 %description tk
37 Tcl/tk bindings for GNU Common Lisp.
38
39 %description tk -l pl
40 Intefejs Tcl/tk dla GNU Common Lisp.
41
42 %prep
43 %setup  -q
44 %patch0 -p1
45 %patch1 -p1
46 %patch2 -p1
47 %patch3 -p1
48
49 %build
50 GCC="%{__cc}"; export GCC
51 autoconf
52 %configure \
53         --enable-notify=no
54
55 %{__make} OPTFLAGS="%{rpmcflags}" \
56         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
61         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
62         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
63
64 (cd info
65 rm -f *info*
66 makeinfo gcl-si.texi gcl-tk.texi
67 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
68 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
69
70 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
71 install info/*info* $RPM_BUILD_ROOT%{_infodir}
72 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
73 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
74 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
75         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
76
77 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
78
79 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
80 #!/bin/sh
81 exec %{_libdir}/gcl/unixport/saved_gcl \
82         -dir {_libdir}/gcl/unixport/ \
83         -libdir %{_libdir}/gcl/ \
84         -eval '(setq si::*allow-gzipped-file* t)' \
85         "$@"
86 EOF
87
88 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
89 #!/bin/sh
90 exec %{_libdir}/gcl/unixport/saved_gcl \
91         -dir {_libdir}/gcl/unixport/ \
92         -libdir %{_libdir}/gcl/ \
93         -eval '(setq si::*allow-gzipped-file* t)' \
94         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
95         "$@"
96 EOF
97
98 gzip -9nf readme faq ChangeLog
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post
104 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
105
106 %postun
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %post tk
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %postun tk
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %files
116 %defattr(644,root,root,755)
117 %doc *.gz
118 %attr(755,root,root) %{_bindir}/gcl
119 %attr(755,root,root) %{_bindir}/gcl.exe
120 %{_libdir}/gcl/cmpnew
121 %{_libdir}/gcl/lsp
122 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
123 %{_infodir}/gcl-si.info*
124 %{_mandir}/man1/*
125
126 %files tk
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/gcl-tk
129 %dir %{_libdir}/gcl/gcl-tk
130 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
131 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
132 %{_libdir}/gcl/gcl-tk/*.o
133 %{_libdir}/gcl/gcl-tk/*.tcl
134 %{_infodir}/gcl-tk.info*.gz
This page took 0.128847 seconds and 3 git commands to generate.