]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- use built-in bfd, as does not build with shared one from new binutils
[packages/gcl.git] / gcl.spec
1 #
2 # Conditional build:
3 %bcond_without  builtin_bfd     # use built in bfd instead of system one
4 #               (currently does not build with system one from new binutils)
5 #
6 Summary:        GNU Common Lisp system
7 Summary(pl):    System GNU Common Lisp
8 Name:           gcl
9 Version:        2.6.5
10 Release:        5
11 License:        LGPL v2
12 Group:          Development/Languages
13 Source0:        ftp://ftp.gnu.org/gnu/gcl/%{name}-%{version}.tar.gz
14 # Source0-md5:  e0852318b81c93b76bc7e012f036ec6c
15 Patch0:         %{name}-make.patch
16 Patch1:         %{name}-info.patch
17 # It seems this patch doesn't fix what it should: still doesn't build with
18 # newer binutils
19 #Patch2:                %{name}-binutils.patch
20 URL:            http://www.gnu.org/software/gcl/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gmp-devel >= 4.0
24 BuildRequires:  readline-devel
25 %define _tkline 8.4
26 BuildRequires:  tk-devel >= %{_tkline}
27 BuildRequires:  xemacs
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The GNU Common Lisp system, based on KCL.
32
33 %description -l pl
34 System GNU Common Lisp, bazuj±cy na KCL.
35
36 %package tk
37 Summary:        Tcl/Tk bindings for GNU Common Lisp
38 Summary(pl):    Interfejs Tcl/Tk do GNU Common Lisp
39 Group:          Development/Languages
40 Requires:       %{name} = %{version}-%{release}
41
42 %description tk
43 Tcl/Tk bindings for GNU Common Lisp.
44
45 %description tk -l pl
46 Interfejs Tcl/Tk dla GNU Common Lisp.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52 #%%patch2 -p1
53
54 %build
55 %{__aclocal}
56 %{__autoconf}
57 cp -f /usr/share/automake/config.* .
58 GCC="%{__cc}"; export GCC
59 # note: full path to xemacs must be passed
60 EMACS=/usr/bin/xemacs; export EMACS
61 %configure \
62         --disable-statsysbfd \
63 %if %{with builtin_bfd}
64         --enable-locbfd \
65 %else
66 %ifnarch alpha hppa ia64 mips
67         --enable-dynsysbfd \
68 %endif
69 %endif
70         --enable-dynsysgmp \
71         --enable-notify=no
72
73 %{__make} \
74         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1}
79
80 %{__make} install1 \
81         DESTDIR=$RPM_BUILD_ROOT \
82         INSTALL_LIB_DIR=%{_libdir}/gcl
83
84 mv -f $RPM_BUILD_ROOT%{_libdir}/gcl/info/* $RPM_BUILD_ROOT%{_infodir}
85 rmdir $RPM_BUILD_ROOT%{_libdir}/gcl/info
86
87 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
88
89 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
90
91 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
92 #!/bin/sh
93 exec %{_libdir}/gcl/unixport/saved_gcl \
94         -dir {_libdir}/gcl/unixport/ \
95         -libdir %{_libdir}/gcl/ \
96         -eval '(setq si::*allow-gzipped-file* t)' \
97         "$@"
98 EOF
99
100 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
101 #!/bin/sh
102 exec %{_libdir}/gcl/unixport/saved_gcl \
103         -dir {_libdir}/gcl/unixport/ \
104         -libdir %{_libdir}/gcl/ \
105         -eval '(setq si::*allow-gzipped-file* t)' \
106         -eval '(setq si::*tk-library* "/usr/lib/tk%{_tkline}")' \
107         "$@"
108 EOF
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post
114 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
115
116 %postun
117 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
118
119 %post tk
120 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
121
122 %postun tk
123 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
124
125 %files
126 %defattr(644,root,root,755)
127 %doc readme faq ChangeLog
128 %attr(755,root,root) %{_bindir}/gcl
129 %attr(755,root,root) %{_bindir}/gcl.exe
130 %dir %{_libdir}/gcl
131 %{_libdir}/gcl/clcs
132 %{_libdir}/gcl/cmpnew
133 %{_libdir}/gcl/h
134 %{_libdir}/gcl/lsp
135 %{_libdir}/gcl/pcl
136 %dir %{_libdir}/gcl/unixport
137 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
138 %{_libdir}/gcl/unixport/*.lsp
139 # to -devel?
140 #%{_libdir}/gcl/unixport/*.a
141 %{_infodir}/gcl-si.info*
142 %{_mandir}/man1/*
143
144 %files tk
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/gcl-tk
147 %dir %{_libdir}/gcl/gcl-tk
148 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
149 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
150 %{_libdir}/gcl/gcl-tk/*.o
151 %{_libdir}/gcl/gcl-tk/*.tcl
152 %{_infodir}/gcl-tk.info*
This page took 0.037113 seconds and 3 git commands to generate.