]> git.pld-linux.org Git - packages/gcl.git/blob - gcl.spec
- copy config.sub from automake dir (don't use automake -a -c, it doesn't use am)
[packages/gcl.git] / gcl.spec
1 Summary:        GNU Common Lisp
2 Summary(pl):    GNU Common Lisp
3 Name:           gcl
4 Version:        2.4.0
5 Release:        4
6 License:        GPL
7 Group:          Development/Languages
8 Group(de):      Entwicklung/Sprachen
9 Group(pl):      Programowanie/Jêzyki
10 Source0:        ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tgz
11 Patch0:         %{name}-make.patch
12 Patch1:         %{name}-OPT.patch
13 Patch2:         %{name}-info.patch
14 Patch3:         %{name}-libgmp.patch
15 URL:            http://www.gnu.org/projects/gcl
16 BuildRequires:  tk-devel
17 BuildRequires:  xemacs
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  gmp-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The GNU Common Lisp system, based on KCL.
25
26 %description -l pl
27 System GNU Common Lisp, bazuj±cy na KCL.
28
29 %package tk
30 Summary:        Tcl/tk bindings for GNU Common Lisp
31 Summary(pl):    Interfejs Tcl/tk do GNU Common Lisp
32 Group:          Development/Languages
33 Group(de):      Entwicklung/Sprachen
34 Group(pl):      Programowanie/Jêzyki
35 Requires:       %{name} = %{version}
36
37 %description tk
38 Tcl/tk bindings for GNU Common Lisp.
39
40 %description tk -l pl
41 Intefejs Tcl/tk dla GNU Common Lisp.
42
43 %prep
44 %setup  -q
45 %patch0 -p1
46 %patch1 -p1
47 %patch2 -p1
48 %patch3 -p1
49
50 %build
51 GCC="%{__cc}"; export GCC
52 aclocal
53 autoconf
54 cp -f %{_datadir}/automake/config.sub .
55 %configure \
56         --enable-notify=no
57
58 %{__make} OPTFLAGS="%{rpmcflags}" \
59         EMACS_SITE_LISP=`xemacs -q -batch 2>&1 | sed -e /Loading/d `
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_libdir}/gcl/{cmpnew,unixport,lsp,gcl-tk} \
64         $RPM_BUILD_ROOT{%{_infodir},%{_mandir}/man1,%{_bindir}} \
65         $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
66
67 (cd info
68 rm -f *info*
69 makeinfo gcl-si.texi gcl-tk.texi
70 install gcl*info* $RPM_BUILD_ROOT%{_infodir})
71 install man/man1/gcl.1 $RPM_BUILD_ROOT%{_mandir}/man1
72
73 install unixport/saved_gcl $RPM_BUILD_ROOT%{_libdir}/gcl/unixport
74 install info/*info* $RPM_BUILD_ROOT%{_infodir}
75 install cmpnew/collectfn.o $RPM_BUILD_ROOT%{_libdir}/gcl/cmpnew
76 install lsp/{gprof.lsp,info.o,profile.lsp} $RPM_BUILD_ROOT%{_libdir}/gcl/lsp
77 install gcl-tk/{decode.tcl,gcl.tcl,gcltkaux,gcltksrv,tinfo.o,tkl.o} \
78         $RPM_BUILD_ROOT%{_libdir}/gcl/gcl-tk
79
80 ln -sf %{_libdir}/gcl/unixport/saved_gcl $RPM_BUILD_ROOT%{_bindir}/gcl.exe
81
82 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl
83 #!/bin/sh
84 exec %{_libdir}/gcl/unixport/saved_gcl \
85         -dir {_libdir}/gcl/unixport/ \
86         -libdir %{_libdir}/gcl/ \
87         -eval '(setq si::*allow-gzipped-file* t)' \
88         "$@"
89 EOF
90
91 cat <<EOF > $RPM_BUILD_ROOT%{_bindir}/gcl-tk
92 #!/bin/sh
93 exec %{_libdir}/gcl/unixport/saved_gcl \
94         -dir {_libdir}/gcl/unixport/ \
95         -libdir %{_libdir}/gcl/ \
96         -eval '(setq si::*allow-gzipped-file* t)' \
97         -eval '(setq si::*tk-library* "%{_libdir}/tk8.3")' \
98         "$@"
99 EOF
100
101 gzip -9nf readme faq ChangeLog
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post
107 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
108
109 %postun
110 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
111
112 %post tk
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %postun tk
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %files
119 %defattr(644,root,root,755)
120 %doc *.gz
121 %attr(755,root,root) %{_bindir}/gcl
122 %attr(755,root,root) %{_bindir}/gcl.exe
123 %{_libdir}/gcl/cmpnew
124 %{_libdir}/gcl/lsp
125 %attr(755,root,root) %{_libdir}/gcl/unixport/saved_gcl
126 %{_infodir}/gcl-si.info*
127 %{_mandir}/man1/*
128
129 %files tk
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_bindir}/gcl-tk
132 %dir %{_libdir}/gcl/gcl-tk
133 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltkaux
134 %attr (755,root,root) %{_libdir}/gcl/gcl-tk/gcltksrv
135 %{_libdir}/gcl/gcl-tk/*.o
136 %{_libdir}/gcl/gcl-tk/*.tcl
137 %{_infodir}/gcl-tk.info*.gz
This page took 0.051311 seconds and 3 git commands to generate.